16:00:24 <cmurphy> #startmeeting keystone
16:00:25 <openstack> Meeting started Tue May 14 16:00:24 2019 UTC and is due to finish in 60 minutes.  The chair is cmurphy. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:28 <openstack> The meeting name has been set to 'keystone'
16:00:38 <vishakha> o/
16:00:46 <gagehugo> o/
16:00:53 <kmalloc> o/
16:00:54 <bnemec> Hey, my meeting notification works!
16:01:07 <cmurphy> nice :)
16:01:19 <cmurphy> #link https://etherpad.openstack.org/p/keystone-weekly-meeting agenda
16:01:26 <kmalloc> bnemec: my meeting notification is "oh crap, I'm late... wait it's not tuesday, it's monday today" then I remember on tuesday normally
16:01:43 <cmurphy> sounds very efficient
16:01:58 <kmalloc> it happens every single week. so... sure?
16:02:08 <bnemec> Consistency is key
16:02:44 <cmurphy> #topic announcements
16:03:05 <hrybacki> o/
16:03:49 <cmurphy> we discussed at the PTG about making the office hours more useful by planning them ahead of time, so I created a topic etherpad and will announce the topics beforehand
16:04:04 <cmurphy> #link https://etherpad.openstack.org/p/keystone-office-hours-topics office hours topics
16:04:35 <cmurphy> so the office hour after today's meeting will be about liaison review and/or bug triaging
16:04:48 <lbragstad> nice
16:05:07 <gagehugo> ok
16:05:14 <cmurphy> I also added the hour to the eavesdrop schedule - https://review.opendev.org/658909 I'm not sure if we had already documented it somewhere, lbragstad ?
16:05:45 <lbragstad> oh - i don't think it was documented formally
16:05:52 <lbragstad> that's a good idea
16:06:07 <cmurphy> now there's an ics calendar people can import if they want to
16:06:21 <vishakha> nice
16:06:35 <cmurphy> any questions/comments on this?
16:08:22 <cmurphy> #topic Summit/PTG recap
16:09:11 <cmurphy> First of all we did a cycle retrospective which had some useful outcomes
16:09:21 <cmurphy> #link https://trello.com/b/VCCcnCGd/keystone-stein-retrospective cycle retrospective
16:09:44 <cmurphy> not all of the action items are super actionable but I will try to make a point of checking in on them at meetings
16:10:27 <cmurphy> I wrote a keystone-focused recap, feel free to provide feedback:
16:10:35 <cmurphy> #link http://www.gazlene.net/denver-forum-ptg-2019.html recap
16:10:47 <cmurphy> did anyone else write a recap they want to share?
16:11:00 * lbragstad did not
16:11:16 <ayoung> Nope
16:11:16 <lbragstad> i recapped TC-related things and was about to start on a keystone one, then i read cmurphy's
16:11:38 <ayoung> I'm just working on the doc I promised about Keystone sync
16:13:10 <cmurphy> okay
16:13:40 <cmurphy> we also worked through the roadmap board but it's still a bit of a mess, i'll do my best to organize it in a way that makes sense
16:13:51 <cmurphy> #link https://trello.com/b/ClKW9C8x/keystone-train-roadmap roadmap
16:14:12 <ayoung> That should be a rail map
16:14:29 <cmurphy> haha
16:15:09 <cmurphy> was great to see people that week, was sorry not everyone could join
16:15:13 <knikolla> all aboard the keystone line
16:16:32 <cmurphy> any other comments about the forum or ptg?
16:17:04 <lbragstad> great job organizing things cmurphy
16:17:26 <cmurphy> :)
16:17:46 <gagehugo> ++
16:19:56 <cmurphy> #topic retrospective actions followup
16:20:19 <cmurphy> there were a couple of things from the retrospective that i think are worth following up on already
16:20:38 <cmurphy> #link https://trello.com/c/PaTQKtmC/62-use-fast8-for-local-pep8-testing Use fast8 for local pep8 testing
16:20:47 <cmurphy> I don't think we assigned anyone to this
16:20:56 <cmurphy> anyone want to volunteer?
16:21:33 <vishakha> I can
16:22:19 <bnemec> #link https://github.com/openstack/nova/blob/master/tools/flake8wrap.sh
16:22:20 <cmurphy> awesome thanks vishakha
16:22:49 <vishakha> np cmurphy
16:22:57 <cmurphy> #action vishakha to take on fast8 tooling
16:24:40 <cmurphy> #link https://trello.com/c/QJbxGGb6/53-discuss-the-evolution-of-bug-tags Discuss the evolution of bug tags
16:25:21 <cmurphy> This was about expanding the use of things like the low-hanging-fruit tag to better describe sizing of bugs
16:26:37 <cmurphy> we didn't come up with a specific plan at the time, anyone want to voice thoughts on how this might look?
16:27:18 <gagehugo> hmm
16:27:19 <lbragstad> my knee-jerk reaction was to associate timing to different tags, but i'm not sure if that's a great idea
16:27:57 <lbragstad> for two reasons 1.) timing is different across individuals 2.) do we want a cambrian explosion of tags?
16:29:11 <cmurphy> good points
16:30:00 <gagehugo> sizing as in amount of work required?
16:30:35 <lbragstad> yeah - as an estimate
16:30:57 <cmurphy> i think this came up because we were talking about how to get 20%ers more involved
16:31:25 <cmurphy> so it also has a little bit to do with how much background and context you need to solve the problem
16:31:29 <gagehugo> simplest range I've ever used before was t-shirt sizes (S M L)
16:31:31 <lbragstad> (this was also related to being more diligent about breaking everything down into smaller pieces of work, iirc)
16:31:43 <cmurphy> right
16:35:44 <cmurphy> one issue is we already are inconsistent about when to use the low-hanging-fruit tag so adding other sizes would probably also introduce inconsistency based on who is doing the sizing
16:36:18 <lbragstad> ++
16:37:20 <lbragstad> we could start by defining what exactly we mean by "low hanging fruit"
16:37:33 <lbragstad> (in contributor documentation)
16:37:52 <cmurphy> ++
16:38:05 <cmurphy> want to take a stab at that?
16:38:09 <lbragstad> sure
16:38:16 <cmurphy> cool
16:38:29 <hrybacki> What if there were two types of tags: <scope: s, m l> and <type: lhf, ...> ? And then document what each grouping roughly means
16:41:04 <cmurphy> hrybacki: what would another "type" tag be?
16:41:40 <hrybacki> cmurphy: one could be low-hanging-fruit, lump the rest into 'generic' or something as a catch all
16:41:45 <hrybacki> understand the want to avoid masses of tags
16:42:22 <hrybacki> also leaves you room to expand in the future if needed
16:42:45 <cmurphy> what would the difference be between type:low-hanging-fruit and scope:s ?
16:43:33 <hrybacki> you could have a small scoped bug that isn't necessarily appropriate for someone looking to get into contributing
16:43:51 <hrybacki> think of something kmalloc could fix in 30 minutes that might take someone unfamiliar with the project a few days
16:44:05 * hrybacki is generalizing
16:44:16 <cmurphy> gotcha
16:44:17 <kmalloc> hey, i can't fix anything in 30 minutes :P
16:44:24 <kmalloc> it takes at least a week >.>
16:44:25 <kmalloc> <.<
16:44:29 <kmalloc> /snark
16:44:43 <hrybacki> :P
16:44:48 * kmalloc finishes over estimating timeframes to look like a superhero again.
16:45:14 <kmalloc> ^_^
16:45:46 <kmalloc> <type: oh heck, i don't even know how this works> <scope: s>
16:45:56 <cmurphy> maybe let's start with documenting the use of the low-hanging-fruit tag and circle back to adding sizing options afterward?
16:46:21 <cmurphy> #action lbragstad propose definition of low-hanging-fruit tag in contributor documentation
16:46:36 <hrybacki> +1
16:46:43 <lbragstad> sounds good - i'll try and get that proposed by EOW
16:46:47 <gagehugo> sounds good
16:46:56 <cmurphy> great
16:47:41 <cmurphy> okay, we have 13 minutes left, we could either start doing liaison review (it might only take 5 minutes i'm not really sure) or we could go to open discussion -> break before office hours, preferences?
16:48:11 * lbragstad is indifferent
16:48:34 <kmalloc> move liason review to -keystone in either case
16:48:41 <kmalloc> so we don't need to swap channels.
16:48:48 <cmurphy> good point
16:49:38 <cmurphy> #topic open discussion
16:49:44 <cmurphy> I'll open the floor
16:49:55 * kmalloc dances on the open floor.
16:50:09 <cmurphy> any reviews to highlight?
16:53:21 <cmurphy> okay, I'll close the meeting, back in 7 minutes in #openstack-keystone for office hours
16:53:29 <cmurphy> #endmeeting