18:00:04 <lbragstad> #startmeeting keystone
18:00:08 <openstack> Meeting started Tue Oct 10 18:00:04 2017 UTC and is due to finish in 60 minutes.  The chair is lbragstad. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:12 <openstack> The meeting name has been set to 'keystone'
18:00:13 <hrybacki> o/
18:00:13 <lbragstad> #link https://etherpad.openstack.org/p/keystone-weekly-meeting
18:00:19 <knikolla> o/
18:00:21 <lbragstad> ^ agenda
18:00:22 <spilla> o/
18:00:40 <lbragstad> ayoung, breton, cmurphy, dstanek, edmondsw, gagehugo, henrynash, hrybacki, knikolla, lamt, lbragstad, lwanderley, kmalloc, rderose, rodrigods, samueldmq, spilla, aselius, dpar ping!
18:00:48 <gagehugo> o/
18:00:49 <kmalloc> o/
18:01:03 <cmurphy> o/
18:02:10 <lbragstad> #topic announcements: queens deadline dates
18:02:25 <lbragstad> this is the current schedule for queens
18:02:27 <lbragstad> #link https://releases.openstack.org/queens/schedule.html
18:02:37 <lbragstad> i've proposed a patch to add deadlines for keystone
18:02:44 <samueldmq> o/
18:02:47 <lbragstad> which is pretty much a copy paste of all deadlines we used in pike
18:02:49 <lamt> o/
18:02:54 <lbragstad> #link https://review.openstack.org/#/c/509835/
18:03:17 <lbragstad> one thing to note is that feature proposal freeze happens over the christmas holiday
18:03:55 <lbragstad> i'm curious to get feedback here if we want to bump it a week earlier or later (pending new years, too)
18:04:00 <lbragstad> thoughts?
18:04:03 <hrybacki> is everyone taking holiday/shutdown over that period?
18:04:19 <lbragstad> in my experience, things are pretty quiet that week
18:04:23 <samueldmq> lbragstad: ++
18:04:28 <lbragstad> (i don't plan to take much time off over the holiday though)
18:04:39 <samueldmq> I guess we can do it one week early as proposed now
18:04:44 <hrybacki> lbragstad: aye, then I'd say we push it to the left so we encourage to get stuff done early
18:04:50 <hrybacki> samueldmq+1
18:04:52 <gagehugo> hrybacki ++
18:04:58 <samueldmq> and if we get something that really needs more time, we can do an exception for it
18:05:00 <lbragstad> yeah - and it's feature *proposal* freeze
18:05:05 <lbragstad> not feature freeze
18:05:09 <hrybacki> +1
18:05:19 <samueldmq> exactly. I am fine with that, looks good to me
18:05:23 * cmurphy does not care
18:05:32 <lbragstad> ok - that sounds fair
18:05:43 <lbragstad> i'll wip that patch and propose the deadline a week earlier
18:05:59 <lbragstad> #action lbragstad to bump deadline in https://review.openstack.org/#/c/509835/ to not be christmas week
18:06:23 <lbragstad> other than that, does anyone have suggestions for deadlines?
18:06:39 <lbragstad> or was everyone relatively happy with the deadlines we had for pike
18:06:53 <lbragstad> (if not, please don't hesitate to speak up!)
18:07:06 <gagehugo> the other deadlines looked fine imo
18:08:05 <lbragstad> i think we've had pretty consistent deadline structure for the last few releases, but i want to make sure we have the opportunity to adjust if folks think it's necessary
18:09:03 <lbragstad> if that's the case, leave a comment on the review
18:09:06 <lbragstad> #topic announcement: aws iam policy session planning
18:09:19 <lbragstad> this is mostly advertising
18:09:36 <lbragstad> but i started laying this out for tomorrow so that we can start planning a productive policy session
18:10:15 <lbragstad> the plan is to use the policy meeting tomorrow to organize what we want out of that session
18:10:18 <lbragstad> #link http://eavesdrop.openstack.org/#Keystone_Policy_Meeting
18:10:40 <lbragstad> i've also started another etherpad
18:10:40 <hrybacki> fyi ayoung will be in training and likely off of irc tomorrow
18:11:04 <lbragstad> hrybacki: ack
18:11:27 <lbragstad> hrybacki: i should make a point to followup with him when he's done with training to get his cases in the etherpad
18:11:57 <lbragstad> ideally tomorrow we'll just be figuring out what we want out of the session and organizing resources
18:11:58 <hrybacki> lbragstad: ack. He's in Raleigh for the week so he's probably quite board in the evenings and looking for things to do
18:12:04 * hrybacki nods
18:12:10 <hrybacki> bored*
18:12:27 <lbragstad> cool - that sounds good
18:12:58 <lbragstad> by the end of the policy meeting tomorrow, we should have a couple dates proposed, hangout prepared, action items for an AWS account, etc..
18:13:33 <lbragstad> if you want to see how specific things are done in AWS or GKE - feel free to add them to the etherpad https://etherpad.openstack.org/p/analyzing-other-policy-systems
18:13:35 <lbragstad> #link https://etherpad.openstack.org/p/analyzing-other-policy-systems
18:14:31 <lbragstad> #topic announcement: trello sync
18:14:37 <lbragstad> #link https://trello.com/b/5F0h9Hoe/keystone
18:15:00 <lbragstad> just fyi - i've added another column to the board as a way to show what needs review
18:15:38 <lbragstad> i've also been trying to keep things in sync, if i've missed something you're working on just let me know or go ahead and move it
18:16:00 <lbragstad> s/move it/make the necessary changes/
18:17:16 <lbragstad> other than that - how do people feel about the release so far?
18:18:37 * hrybacki hasn't been able to crawl out from his downstream hole to be of much use tbh
18:18:50 <cmurphy> hrybacki: hi5 o/
18:19:05 * cmurphy will go review some things
18:19:14 <hrybacki> o/\o
18:19:21 <gagehugo> I like the v2 removal
18:19:21 <lbragstad> :)
18:19:26 <samueldmq> ++
18:19:41 <samueldmq> lbragstad: I like trello. helps keeping priorities with the team
18:19:49 <lbragstad> samueldmq: good deal
18:19:50 <gagehugo> samueldmq ++
18:19:52 <samueldmq> visually friendly
18:20:05 <lbragstad> hopefully it's helpful, i've been using it a lot
18:20:20 * gagehugo wishes his work board was more like trello
18:20:28 <samueldmq> yes. seems like people have been doing something similar to that, but with different tools
18:20:30 <samueldmq> in different ways
18:20:49 <samueldmq> I used to have an etherpad. having a shared place is great
18:20:49 <lbragstad> yeah - i'm curious to try storyboard (for real) and see how similar it is, if at all
18:20:53 <cmurphy> iirc storyboard has a similar functionality, if we wanted to move to an all-open platform ;)
18:21:01 <cmurphy> lbragstad: heh
18:21:05 <lbragstad> cmurphy: ++
18:21:10 <lbragstad> january!
18:21:18 <samueldmq> aha, cool. would be nice to try it out
18:21:31 <samueldmq> we have a deployment for it in our ecosystem, right?
18:21:39 <samueldmq> https://storyboard.openstack.org/
18:21:40 <lbragstad> yeah - infra manages one already
18:21:56 <samueldmq> #link https://storyboard.openstack.org/#!/board/list
18:21:59 <lbragstad> but per the discussion at the PTG, they are still in the process of migrating projects to it
18:22:37 <lbragstad> i guess the thing i like most about having something like trello is that it help maintain the context of everything we said we were going to do for a release
18:22:53 <samueldmq> it has both boards and work lists ... seems interesting
18:23:21 <samueldmq> lbragstad: yes, establishing the process/habit of using that for tracking is far more important than the specific tool we use
18:23:23 <samueldmq> imo
18:23:30 <cmurphy> ++
18:23:34 <lbragstad> agreed
18:23:46 * hrybacki nods
18:24:09 <lbragstad> if there's anything i can do to help facilitate upstream involvement, don't hesitate to ask
18:24:26 <lbragstad> or if we need to reshuffle things
18:25:07 <lbragstad> #topic TripleO brekage -- API v2 removal post-mortem
18:25:11 <lbragstad> hrybacki: o/
18:25:14 <hrybacki> o/
18:25:44 <hrybacki> this is just more of an awarenss bit, there was a hiccup within TripleO after the removal that we didn't see in time
18:25:44 <samueldmq> I like the topic name. v2.0 post-mortem
18:25:58 <hrybacki> broke a lot of ci unfortunately (tripleo based)
18:26:08 <samueldmq> hrybacki: did it get all fixed already?
18:26:20 <hrybacki> samueldmq: aye, there were two fixes to instack
18:26:34 <hrybacki> and I submitted ~13 patches against the openstack puppet modules setting defaults
18:26:44 <samueldmq> hrybacki: what is instack?
18:26:48 <hrybacki> some had already ported to v3
18:26:51 <samueldmq> hrybacki: cool, thanks for that.
18:27:04 <hrybacki> samueldmq: it's what prepares the undercloud for a tripleo deployment
18:27:13 * samueldmq nods
18:27:17 <hrybacki> aforementioned change: https://review.openstack.org/#/c/510535/
18:27:34 <hrybacki> https://bugs.launchpad.net/tripleo/+bug/1721366 was the main bug for tracking
18:27:35 <openstack> Launchpad bug 1721366 in tripleo "Keystone v2.0 APIs have been removed, TripleO config is incomplete" [Critical,Fix released] - Assigned to yatin (yatinkarel)
18:27:51 <hrybacki> only question I have is, could we have communicated this change betteR?
18:28:42 <hrybacki> that was all I had lbragstad
18:28:43 <samueldmq> didn't we send ML annoucements? warnings?
18:28:45 <samueldmq> depreaction notices?
18:28:59 <hrybacki> samueldmq: we did. I honestly don't think people believed it would get yanked
18:29:03 <lbragstad> yeah - deprecation notices are standard and usually the first line
18:29:18 <hrybacki> it was deprecated for a long time. <-- might be something to keep in mind
18:29:26 <cmurphy> did we send mailing list announcements though?
18:29:28 <samueldmq> maybe some projects just did not realize how much of a change that was
18:29:37 <samueldmq> and it's a very uncommon change in OpenStack
18:29:50 <lbragstad> i think we sent a ML thread - let me dig it up
18:29:59 <hrybacki> cmurphy: I thought we did. At a minimum I know it was in Lance and others' PTG summary/blogs
18:30:20 <samueldmq> I was not surprised someone got bitten, unfortunately
18:30:28 <hrybacki> cmurphy you have my vote btw -- happy to see your name on email earlier
18:30:41 <cmurphy> hrybacki: haha ty
18:31:01 <hrybacki> samueldmq: same. Lots of moving parts. Was a slap in my face when the RH prod line broke for 36 hours though =/
18:31:51 <lbragstad> i did send this a while ago
18:31:53 <kmalloc> we knew v2 was likely to break things.
18:31:59 <lbragstad> to both operators and -dev
18:32:01 <lbragstad> #link http://lists.openstack.org/pipermail/openstack-dev/2017-March/113166.html
18:32:02 <kmalloc> this is why we telegraphed so far in advance
18:32:19 <kmalloc> the fact that things still broke shows that the community was not paying attention
18:32:33 <kmalloc> it happens
18:32:57 <kmalloc> but some projects def. were not attentive on this front.
18:33:14 <edmondsw> I heard that trove is also still using keystone v2
18:33:15 <cmurphy> lbragstad: that's not a "THIS IS HAPPENING ON $RELEASE" it's a gentle poking that it might happen soon
18:33:46 <kmalloc> the TC acceptance of removal was on a very clear timeline
18:33:49 <edmondsw> the trove guys agreed that they need to move to v3, though, so I hope they are just working on that
18:33:51 <lbragstad> true - digging to see if another one was sent
18:34:20 <samueldmq> the subject should be : "BE PREPARED: REMOVE OF THE V2.0 API!!!!", not "Removal of the v2.0 API"
18:34:32 <samueldmq> REMOVAL* :-)
18:34:38 <cmurphy> it's also not tagged [all]
18:35:06 <lbragstad> yeah - that could have been tagged/messaged better
18:35:09 <cmurphy> i think this is something we can do better at for v4 :)
18:35:10 <samueldmq> cmurphy: ++ those could have been points we could've improved
18:35:40 <samueldmq> I agree. not like the fault is only of our message, but could have been slightly better
18:35:50 <lbragstad> yeah - that's on me
18:35:55 <samueldmq> we did our best
18:36:04 <kmalloc> v3 will not be removed, even if we have v45
18:36:06 <kmalloc> v4*
18:36:07 <cmurphy> lbragstad: s/me/us/
18:36:08 <samueldmq> and communicated early. we've been talking about removing it a lot
18:36:13 <samueldmq> cmurphy: ++
18:36:14 <kmalloc> v2.0 was removed for a lot of reasons.
18:36:21 <hrybacki> lbragstad: that's on the group as a whole :) I know at least once I asked myself if we'd properly informed the community after the fact
18:36:23 <kmalloc> this is not likely to ever happen again
18:36:34 <kmalloc> at least not as long as I expect ot be working on openstack
18:36:56 <lbragstad> but - we could take the same precaution with similar situations (like when we remove the uuid token provider)
18:37:03 <lbragstad> or sql persistence layer
18:37:22 <samueldmq> that's why we talk about it now. let's make sure we do it better next time
18:37:27 <lbragstad> those would be good examples of where we could exercise that level of verbosity
18:37:28 <samueldmq> whenever we need to communicate such a change
18:37:30 <kmalloc> we have done those removals before
18:37:32 <kmalloc> less of an issue
18:37:35 <kmalloc> pki/pkiz/etc
18:37:47 <kmalloc> this was a public facing api, that is a *big* deal
18:38:07 <hrybacki> we aren't doing any harm by being communicative regardless of the impact of a change
18:38:16 <kmalloc> if devstack is configured sanely, and puppet/ansible gets the changes, we are fine
18:38:33 <kmalloc> we communicate it, but honestly, i don't think we could have handled v2.0 better
18:38:58 <kmalloc> it's been telegraphed we are removing this for... years
18:39:20 <lbragstad> i would say that we definitely took measures to stay in touch with defcore/refstack/tc though (thanks kmalloc!)
18:39:29 <samueldmq> ++
18:39:30 <cmurphy> kmalloc: puppet at least was caught off guard for some things, that's what causes the tripleo breakage
18:39:45 <hrybacki> aye, that was probably the problem. We told folks it was happening but should have told them that it /did/ happen
18:39:53 <kmalloc> cmurphy: we cannot expect to personally reach out to ever single team.
18:39:54 <hrybacki> cmurphy: and mistral (ptg fire drill)
18:40:14 <lbragstad> aha - that's right
18:40:31 <kmalloc> we used ML, we used TC, we used deprecation warnings
18:40:41 <kmalloc> we used devstack, etc.
18:41:03 <kmalloc> we used IRC. there is only so far we can go.
18:41:51 <samueldmq> yeah, if we did something wrong, we still did it all 99% right
18:42:12 <samueldmq> so we did a great job, maybe not perfect, but still great
18:42:43 <lbragstad> so - question
18:43:04 <lbragstad> outside of API removals (which are super rare) what classifies as needing verbose ML threads to -dev and -operators
18:43:06 <lbragstad> ?
18:43:40 <hrybacki> a good question
18:43:48 <samueldmq> to operators, change of defaults
18:44:11 <lbragstad> so changing configuration options or policy defaults
18:44:28 <lbragstad> removal of driver support?
18:44:55 <kmalloc> change of defaults, deprecation of features/backends, removal(s)
18:45:19 <samueldmq> yes, like anything that might affect what they may run today upon upgrade
18:45:29 <edmondsw> lbragstad FYI, it already merged but I just added a few more comments on https://review.openstack.org/#/c/500141 that bear consideration
18:45:34 <edmondsw> around exactly this
18:46:31 <lbragstad> edmondsw: thanks!
18:48:43 <lbragstad> sounds like we agreed on the need to be more verbose when advertising removals on mailing lists
18:49:03 <lbragstad> hrybacki: anything else you want to work through?
18:49:10 <hrybacki> nope, thanks all!
18:49:17 <lbragstad> cool
18:49:20 <lbragstad> #topic open discussion
18:49:45 <lbragstad> and the floor is open
18:50:22 <cmurphy> do we have forum topics for sydney?
18:50:32 <gagehugo> cmurphy was just gonna ask that haha
18:50:44 <lbragstad> we do - i submitted at least three proposals
18:50:53 <gagehugo> also do we have a "keystone project update" thing for sydney as well?
18:51:52 <lbragstad> #link https://etherpad.openstack.org/p/SYD-keystone-forum-sessions
18:52:09 <lbragstad> #link http://forumtopics.openstack.org/
18:52:32 <lbragstad> #link http://forumtopics.openstack.org/cfp/details/36
18:52:38 <lbragstad> #link http://forumtopics.openstack.org/cfp/details/37
18:52:48 <lbragstad> #link http://forumtopics.openstack.org/cfp/details/39
18:53:13 <gagehugo> ah still unreviewed
18:53:21 <hrybacki> eek, I take it back. Things are still using the v2 api: https://logs.rdoproject.org/openstack-periodic-4hr/periodic-tripleo-ci-centos-7-ovb-1ctlr_1comp-featureset020-master/28b28c1/undercloud/var/log/nova/nova-compute.log.txt.gz#_2017-10-10_18_07_36_272
18:55:29 <lbragstad> hrybacki: that must be coming up in a job?
18:56:05 <hrybacki> lbragstad: aye it is. But we've already tracked it down to an issue within puppet-nova -- patch en route
18:56:20 <lbragstad> nice
18:57:23 * hrybacki has nothing else
18:58:07 <lbragstad> cool - office hours starting in just a few minutes
18:58:13 <lbragstad> #endmeeting