#openstack-meeting: keystone

Meeting started by stevemar at 17:59:53 UTC (full logs).

Meeting summary

  1. release status (stevemar, 18:03:03)
    1. http://releases.openstack.org/newton/schedule.html (stevemar, 18:03:22)

  2. fix cache invalidation (stevemar, 18:06:57)
    1. https://bugs.launchpad.net/keystone/+bug/1607553 (lbragstad, 18:07:00)
    2. https://review.openstack.org/#/c/349704/ this is dstanek's approach to fixing the problem (lbragstad, 18:10:01)
    3. http://git.openstack.org/cgit/openstack/requirements/tree/global-requirements.txt?h=stable/mitaka#n41 (bknudson, 18:13:04)
    4. https://review.openstack.org/#/c/349704/ (lbragstad, 18:19:39)
    5. https://bitbucket.org/zzzeek/dogpile.cache/issues/38/invalidate-entire-cache (amakarov, 18:19:52)
    6. https://bitbucket.org/zzzeek/dogpile.cache/commits/d521db7eb4eab4ad2bacf5f1f5fd89bd3e43a0fa (lbragstad, 18:22:10)
    7. ACTION: breton, dstanek, lbragstad: check if patch by dstanek works not worse than https://review.openstack.org/#/c/327885/ (breton, 18:24:09)

  3. Validating trust-scoped tokens with v2.0 API (stevemar, 18:25:12)
    1. https://review.openstack.org/#/c/278693/ (lbragstad, 18:27:26)
    2. https://review.openstack.org/#/c/278693/ says you can validate trust with v2 (bknudson, 18:30:41)
    3. https://review.openstack.org/#/c/278693/ says that uuid works (bknudson, 18:32:08)

  4. Rolling upgrades (stevemar, 18:34:28)
  5. MFA (stevemar, 18:40:41)
    1. https://github.com/openstack/keystone/blob/9d54eb33c1d74ff39c947af6ff984ef2e0bf4be4/keystone/token/controllers.py#L63 (stevemar, 18:51:31)


Meeting ended at 18:59:23 UTC (full logs).

Action items

  1. breton, dstanek, lbragstad: check if patch by dstanek works not worse than https://review.openstack.org/#/c/327885/


Action items, by person

  1. breton
    1. breton, dstanek, lbragstad: check if patch by dstanek works not worse than https://review.openstack.org/#/c/327885/
  2. dstanek
    1. breton, dstanek, lbragstad: check if patch by dstanek works not worse than https://review.openstack.org/#/c/327885/
  3. lbragstad
    1. breton, dstanek, lbragstad: check if patch by dstanek works not worse than https://review.openstack.org/#/c/327885/
  4. openstack
    1. breton, dstanek, lbragstad: check if patch by dstanek works not worse than https://review.openstack.org/#/c/327885/


People present (lines said)

  1. stevemar (101)
  2. breton (44)
  3. bknudson (30)
  4. adriant (28)
  5. dstanek (27)
  6. lbragstad (23)
  7. dolphm (18)
  8. henrynash (16)
  9. amakarov (13)
  10. jamielennox (11)
  11. rodrigods (7)
  12. topol (4)
  13. openstack (4)
  14. ayoung (3)
  15. rderose (2)
  16. crinkle (1)
  17. browne (1)
  18. nk2527 (1)
  19. Raildo (1)


Generated by MeetBot 0.1.4.