#openstack-meeting: Keystone

Meeting started by morganfainberg at 18:02:18 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/KeystoneMeeting (morganfainberg, 18:02:26)

  1. Migration path for R/W LDAP spec (morganfainberg, 18:03:50)
    1. https://review.openstack.org/#/c/140175/ (morganfainberg, 18:04:08)
    2. ACTION: joesavak and jorge_munoz to poll deployers on LDAP use-cases (morganfainberg, 18:34:00)
    3. ACTION: morganfainberg to sent ML topics and surveys to determine use of ldap assignment (possible deprecation) (morganfainberg, 18:34:24)
    4. ACTION: morganfainberg to send ML topics and surveys to determine use of read/write identity with LDAP (possible deprecation) (morganfainberg, 18:34:47)
    5. ACTION: ayoung nkinder jorge_munoz joesavak to work offline to look at out-of-tree implementation to cover specific use-cases. (morganfainberg, 18:35:32)

  2. AEToken Specification (morganfainberg, 18:36:49)
    1. https://review.openstack.org/#/c/130050/ (morganfainberg, 18:36:53)
    2. ACTION: *EVERYONE* review revocation events - help to get it in place as the default to replace the revocation list (morganfainberg, 18:45:35)

  3. Assignment split (morganfainberg, 18:46:18)
    1. https://review.openstack.org/#/c/144239/ (morganfainberg, 18:46:45)
    2. https://review.openstack.org/#/q/status:open+project:openstack/keystone+branch:master+topic:bp/pluggable-assignments,n,z (lbragstad, 18:47:10)

  4. Spec Review (morganfainberg, 18:47:39)
  5. BPs / reviews that do not need specs (morganfainberg, 18:48:17)
    1. https://review.openstack.org/#/c/145204/ (marekd, 18:49:16)
    2. VOTE: Voted on "Does the refactor of keystone-all and http/keystone need a spec?" Results are, Abstain: 1, No: 7 (morganfainberg, 18:56:31)
    3. VOTE: Voted on "refactor keystonemiddleware to extract classes need a spec?" Results are, no: 9 (morganfainberg, 19:00:19)


Meeting ended at 19:00:48 UTC (full logs).

Action items

  1. joesavak and jorge_munoz to poll deployers on LDAP use-cases
  2. morganfainberg to sent ML topics and surveys to determine use of ldap assignment (possible deprecation)
  3. morganfainberg to send ML topics and surveys to determine use of read/write identity with LDAP (possible deprecation)
  4. ayoung nkinder jorge_munoz joesavak to work offline to look at out-of-tree implementation to cover specific use-cases.
  5. *EVERYONE* review revocation events - help to get it in place as the default to replace the revocation list


Action items, by person

  1. ayoung
    1. ayoung nkinder jorge_munoz joesavak to work offline to look at out-of-tree implementation to cover specific use-cases.
  2. joesavak
    1. joesavak and jorge_munoz to poll deployers on LDAP use-cases
    2. ayoung nkinder jorge_munoz joesavak to work offline to look at out-of-tree implementation to cover specific use-cases.
  3. jorge_munoz
    1. joesavak and jorge_munoz to poll deployers on LDAP use-cases
    2. ayoung nkinder jorge_munoz joesavak to work offline to look at out-of-tree implementation to cover specific use-cases.
  4. morganfainberg
    1. morganfainberg to sent ML topics and surveys to determine use of ldap assignment (possible deprecation)
    2. morganfainberg to send ML topics and surveys to determine use of read/write identity with LDAP (possible deprecation)
  5. nkinder
    1. ayoung nkinder jorge_munoz joesavak to work offline to look at out-of-tree implementation to cover specific use-cases.


People present (lines said)

  1. morganfainberg (128)
  2. ayoung (64)
  3. bknudson (30)
  4. lbragstad (24)
  5. gyee (18)
  6. joesavak (15)
  7. dolphm (15)
  8. openstack (15)
  9. stevemar (12)
  10. jorge_munoz (10)
  11. topol (8)
  12. marekd (7)
  13. nonameentername (6)
  14. jamielennox (6)
  15. breton (6)
  16. rodrigods (1)
  17. rharwood (1)
  18. nkinder (1)


Generated by MeetBot 0.1.4.