14:00:46 <mgoddard> #startmeeting kayobe
14:00:47 <openstack> Meeting started Mon Jan 21 14:00:46 2019 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:51 <openstack> The meeting name has been set to 'kayobe'
14:01:20 <mgoddard> Welcome to the first Kayobe IRC meeting!
14:01:35 <mgoddard> We'll start with a rollcall
14:01:40 <mgoddard> #topic rollcall
14:01:46 <mgoddard> Please raise your hands
14:01:52 <mgoddard> o/
14:02:11 <jovial[m]> \o/
14:02:24 <yankcrime> o/
14:03:37 <mgoddard> #topic agenda
14:03:52 <mgoddard> * Roll-call
14:03:54 <mgoddard> * Announcements
14:03:56 <mgoddard> * yankcrime leaving core
14:03:58 <mgoddard> * Discussion
14:04:00 <mgoddard> * Meeting format
14:04:02 <mgoddard> * Rocky release (https://etherpad.openstack.org/p/kayobe-rocky-release)
14:04:04 <mgoddard> * Stein release (https://etherpad.openstack.org/p/kayobe-stein-release)
14:04:06 <mgoddard> * Summit CFP
14:04:08 <mgoddard> * Open Discussion
14:04:10 <mgoddard> #topic announcements
14:05:17 <mgoddard> Sorry to start the first meeting on a low note, but yankcrime will be leaving the core group in a few weeks to due a change of role
14:05:30 <yankcrime> ;_;
14:05:49 <mgoddard> Thanks for all your work yankcrime, you've made some good contributions
14:05:52 <jovial[m]> he will very much be missed
14:06:13 <mgoddard> Any other announcements?
14:06:30 <yankcrime> it's been both a pleasure and an honour to work with you all
14:07:02 <mgoddard> Likewise
14:07:11 <mgoddard> #topic meeting format
14:07:59 <mgoddard> Since it's the first time we're doing this, I thought I'd just go over how we expect it to work. It should be familiar for anyone who attends other OpenStack IRC meetings
14:08:37 <mgoddard> Meetings will be at this time (1400 UTC) on every other Monday, even calendar weeks
14:09:04 <mgoddard> Please add anything you'd like to be discussed to the agenda https://wiki.openstack.org/wiki/Meetings/Kayobe
14:09:08 <mgoddard> #link https://wiki.openstack.org/wiki/Meetings/Kayobe
14:09:38 <mgoddard> Ideally prior to the meeting. If not, other things can be brought up in the final 'open discussion'
14:09:57 <mgoddard> Any thoughts/questions?
14:10:12 <jovial[m]> Do you just edit `Agenda for next meeting `?
14:10:19 <mgoddard> Yes
14:10:35 <mgoddard> I'll add some words to the wiki to make that a little clearer
14:10:46 <jovial[m]> What happens to the old agenda?
14:10:48 <mgoddard> #action mgoddard to add some words to the wiki to make that a little clearer
14:10:53 <mgoddard> Getting the hang of this
14:11:03 <mgoddard> Any others?
14:11:11 <priteau> Just a reminder that come end of March, the United Kingdom will be on UTC+1 and that will make the meeting be at 15:00 London Time
14:11:29 <mgoddard> Good point priteau, thanks
14:11:49 <mgoddard> #topic rocky release
14:12:26 <mgoddard> so we're still trailing upstream releases, but are hopefully on track to catch up during Stein
14:12:53 <mgoddard> Next kayobe release will be for Rocky, within the next few weeks if possible
14:13:03 <mgoddard> #link add some words to the wiki to make that a little clearer
14:13:06 <mgoddard> #undo
14:13:07 <openstack> Removing item from minutes: #link add
14:13:16 <mgoddard> #link https://etherpad.openstack.org/p/kayobe-rocky-release
14:13:38 <mgoddard> Please update the above with any features or bugs you think should be in the release
14:14:20 <mgoddard> This will be used more particularly as we get closer to the end, to decide at what point to branch and release, and which features to hold until stein
14:14:57 <mgoddard> Questions/thoughts?
14:16:32 <mgoddard> #topic stein release
14:17:30 <mgoddard> The openstack stein release is planned to be made on 8th - 12th April
14:18:02 <mgoddard> Kolla releases typically trail this by a few weeks, I would expect us to do the same since we depend on kolla
14:18:43 <mgoddard> I don't expect it to be a big release for us, due to the timescale, but hopefully time for a few features
14:19:12 <mgoddard> Again, if there is anything you would particularly like to see in the release, please add it to the release page
14:19:15 <mgoddard> #link https://etherpad.openstack.org/p/kayobe-stein-release
14:19:45 <mgoddard> Anyone have features they'd particularly like to see in Stein?
14:21:26 <mgoddard> I guess we'll take it as we go. Certainly plenty on the backlog
14:21:40 <mgoddard> #topic Summit CFP
14:21:53 <mgoddard> This is more of an announcement really
14:22:32 <mgoddard> OpenStack summit call for presentations is open
14:22:36 <mgoddard> The deadline to submit is Wednesday, January 23 at 11:59pm PT.
14:22:40 <mgoddard> So not long to go
14:23:21 <jovial[m]> Are you thinking of presenting?
14:23:29 <mgoddard> I'd like to submit an 'intro to kayobe' talk
14:24:28 <mgoddard> if anyone else has any ideas for talks related to kayobe, now's the time
14:24:49 <mgoddard> pairing up with others is often well received
14:25:33 <mgoddard> jovial[m]: are you going to submit any?
14:26:04 <jovial[m]> I've got nothing sufficently interesting to talk about - sorry
14:26:22 <mgoddard> I'm sure that's not true!
14:27:06 <mgoddard> #topic open discussion
14:27:14 <jovial[m]> battle stories from kayobe in the field?
14:27:29 <mgoddard> jovial[m]: those kinds of talks are always interesting
14:28:28 <mgoddard> Anyone have anything else they'd like to discuss?
14:31:03 <mgoddard> jovial[m]: how is your pip install work going?
14:32:23 <jovial[m]> Seems to work well enough. I was awaiting to see if anyone had any more feedback.
14:32:56 <jovial[m]> I guess we still need those PBR fixes merged.
14:33:13 <mgoddard> Good. I'd like to pull it down at some point to try to break it :)
14:33:24 <mgoddard> does it depend on the PBR changes?
14:33:39 <jovial[m]> At least the one that fixes the handling of whitespace changes: https://review.openstack.org/#/c/629161/
14:34:18 <jovial[m]> only if you want to use it in the editable install mode
14:34:48 <mgoddard> hmm
14:34:55 <jovial[m]> which could install galaxy dpenedencies into your git checkout
14:35:19 <mgoddard> any workaround possible?
14:35:54 <mgoddard> we know which files cause problems, and they're only necessary for Arch, which we don't support. Could we remove them?
14:36:07 <jovial[m]> manually removing "ansible/roles/yatesr.timezone/templates/timezone-Arch Linux.j2"?
14:36:14 <mgoddard> yeah
14:36:17 <jovial[m]> that is the only file that causes trouble
14:36:35 <mgoddard> would be a shame to get blocked on PBR merge & release, given we're quite close to release
14:36:57 <priteau> Change the control host bootstrap to remove this file?
14:37:14 <mgoddard> we might also have issues with Rocky upper-constraints - they won't get a PBR bump
14:37:40 <mgoddard> we don't normally use UC to install, but might do in CI/tox, can't remember
14:38:20 <jovial[m]> we could manually expand the glob and list everyfile in setup.cfg?
14:38:45 <jovial[m]> without that one :D
14:38:45 <mgoddard> sounds difficult to maintain
14:39:00 <mgoddard> does removing the file not work?
14:39:11 <mgoddard> I know it's a bit gross, but at least it's small and gross :)
14:40:04 <jovial[m]> I think it may be possible to use a hook when the file is packaged. Does anyone know?
14:41:30 <mgoddard> the problem being that we might not get to run e.g. control host bootstrap between pip installs?
14:41:45 <jovial[m]> yeah
14:41:57 <jovial[m]> or we could fork: https://github.com/yatesr/ansible-timezone?
14:42:44 <jovial[m]> at least until we have PBR support
14:42:56 <mgoddard> that might not be the worst option
14:43:57 <mgoddard> I think that is the simplest path forward
14:44:17 <mgoddard> we can always go back once PBR is fixed
14:45:07 <mgoddard> I'll review those PBR patches in the meantime to see if that helps nudge them along
14:45:15 <jovial[m]> OK, sounds good to me.
14:45:18 <mgoddard> ok, thanks jovial[m]
14:45:21 <mgoddard> any others?
14:46:18 <mgoddard> I guess not. Thanks for coming everyone!
14:46:22 <mgoddard> #endmeeting