14:01:06 <vkramskikh> #startmeeting javascript
14:01:07 <openstack> Meeting started Wed Oct 19 14:01:06 2016 UTC and is due to finish in 60 minutes.  The chair is vkramskikh. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:10 <openstack> The meeting name has been set to 'javascript'
14:01:11 <vkramskikh> hey
14:01:14 <vkramskikh> who's here?
14:01:19 <yujunz> hi
14:02:21 <vkramskikh> not so many people :) let's start anyway
14:02:33 <vkramskikh> agenda https://etherpad.openstack.org/p/javascript-meeting-2016-10-19
14:02:35 <larainema> Hello all
14:02:52 <vkramskikh> hi
14:03:11 <vkramskikh> I'll start with my topics
14:03:24 <vkramskikh> #topic vkramskikh to finish keystone patches
14:03:42 <vkramskikh> the patches that I've started to implement are merged
14:04:15 <vkramskikh> https://review.openstack.org/#/c/381608/ https://review.openstack.org/#/c/381713/
14:05:31 <vkramskikh> so I think Keystone client is ready for MVP, probably I'll also try to add v3.6 support - it should be easy
14:05:48 <yujunz> Good news.
14:05:51 <larainema> Cool
14:05:59 <yujunz> If I want to try it out, where should I get started?
14:06:22 <vkramskikh> try Keystone client?
14:06:29 <yujunz> Yes
14:07:04 <yujunz> Not following it closely, but I think I can help to verify it as a new user :-)
14:07:27 <vkramskikh> well, since the library is not published to npm yet you may want to run "npm run build" and include the resulting file in your project with your favorite approach - script tag, webpack, etc
14:08:37 <yujunz> OK, I haven't look at the latest version yet. But there should be some example or document I can follow right?
14:08:51 <vkramskikh> hmm
14:08:59 <vkramskikh> it seems there is no such doc
14:09:45 <vkramskikh> I think if you need help you can ask for it in #openstack-javascript
14:10:06 <yujunz> I see.
14:10:30 <yujunz> I'll try it out and ask for help if needed.
14:10:58 <vkramskikh> thanks, I think your experience could really help for creation of this doc
14:11:15 <yujunz> OK, I can take this action
14:11:25 <vkramskikh> #action someone to create doc about including js-openstack-lib into existing project
14:11:45 <vkramskikh> #undo
14:11:45 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x7fecfa456ad0>
14:11:56 <vkramskikh> #action yujunz to create doc about including js-openstack-lib into existing project
14:12:00 <vkramskikh> awesome, thanks :)
14:12:08 <vkramskikh> let's move on
14:12:17 <vkramskikh> #topic krotscheck's items
14:12:48 <vkramskikh> As krotscheck mentioned yesterday in #openstack-javascript , he's no longer able to help with the development :(
14:13:17 <yujunz> For a moment or?
14:13:31 <vkramskikh> since release doc has been created by cardeois , the only his item is left: Try to unblock nova.
14:14:14 <vkramskikh> I don't know, iI understood it like he is not going to contribute to OpenStack projects at all
14:14:42 <larainema> I saw cardeois update new patch for nova, but didn't pass the functional tests
14:15:10 <vkramskikh> yes, so it's still an action to do
14:15:14 <cardeois> hello
14:15:19 <vkramskikh> #action everyone Try to unblock nova
14:15:23 <cardeois> sorry for that forgot you guys
14:15:37 * cardeois is catching up
14:16:34 <larainema> krotscheck might busy with his daily work, and not have time focus on openstack
14:16:44 <vkramskikh> here is your action item
14:16:48 <vkramskikh> #topic cardeois to figure out how to release js-openstack-lib to npm
14:17:16 <cardeois> Yes so I can try to release today if the doc I copied from eslint-config-openstack works
14:17:29 <cardeois> which version should we release though?
14:17:31 <cardeois> 0.0.1 ?
14:17:42 <cardeois> should I include a "pre" or "beta" ?
14:17:55 <vkramskikh> I'm ok with 0.0.1, it's definitely not shouldn't be 1.0.0 :)
14:18:12 <vkramskikh> I think it should be just 0.0.1 - it has limited functionality but it works
14:18:40 <cardeois> haha right but there is a lot of npmjs packages I used in the past that wasn't 1.0.0 but still prod ready
14:18:47 <cardeois> but ok let's do 0.0.1
14:19:14 <vkramskikh> awesome
14:19:23 <vkramskikh> and one more action item
14:19:28 <vkramskikh> #topic everyone to review https://review.openstack.org/#/c/381929/ and try to help with docs job failure
14:19:45 <vkramskikh> it seems there is no progress here
14:20:11 <cardeois> Yes larainema I saw you did a review for docs on this project, am I right?
14:20:20 <larainema> I have creat a patch to fix it
14:20:40 <cardeois> Oh right it's here https://review.openstack.org/#/c/385777/
14:21:01 <larainema> But need the core reviewers to land it
14:21:08 <vkramskikh> cool!
14:22:00 <cardeois> So which core reviewer can we poke?
14:22:11 <vkramskikh> #action everyone to review https://review.openstack.org/#/c/385777/
14:22:33 <vkramskikh> I know there is a rule to have 5 +1's to land a patch to eslint-config-openstack
14:22:48 <vkramskikh> not sure if it applies to all patches or just changes to eslint rules
14:22:49 <cardeois> oh ok
14:23:08 <yujunz> 5 is a lot
14:23:17 <larainema> krotscheck: and betherly , I think I can ping them
14:23:19 <vkramskikh> AFAIR betherly is a core of eslint-config-openstack
14:23:45 <vkramskikh> great, so let's review this patch and then ask cores to merge it
14:24:02 <vkramskikh> #topic js-openstack-lib first release
14:24:31 <vkramskikh> so as it was mentioned earlier cardeois will try to publish the release according to the doc
14:24:56 <cardeois> And I think we have everything we need for a first release
14:25:01 <cardeois> Like a basic readme
14:25:35 <vkramskikh> great
14:26:11 <vkramskikh> after the release I can include it as a fuel's dependency in package.json and continue with the migration
14:26:49 <cardeois> cool
14:26:58 <vkramskikh> #topic Open discussion
14:27:03 <cardeois> To come back about nova review from krotscheck, I rebased it but didn't fix the nova issue yet. From what I remember the CORS is not working and we need to debug nova to see what's going on
14:27:32 <cardeois> So personnally I won't have time to work on that this week, and I'm going to barcelona next week and taking 2 weeks of after that.
14:27:53 <cardeois> So does anyone has time to help on that?
14:28:56 <larainema> I can try to help but I am not sure where to start
14:29:24 <cardeois> Yeah me neither, I guess the first step is to setup a devstack (with the vagrant file provided) and run functional test
14:29:33 <cardeois> then run a nova by yourself see what's going on
14:30:06 <cardeois> Other topic: what about next meeting while in barcelona? Should we skip it? Meet in person for the ones that are in the summit?
14:30:31 <yujunz> Speaking about Barcelona, I have received contact information from cardeois msmol and vkramskikh
14:30:40 <yujunz> Anybody else going?
14:30:42 <vkramskikh> I think we should skip it
14:30:57 <vkramskikh> and meet in person instead
14:31:01 <larainema> Okay, I will look at ithe nova issue this and next week
14:31:05 <yujunz> Agree to skip and meet in person
14:31:16 <cardeois> Yeah good idea, larainema will you be in barcelona?
14:31:44 <larainema> No, I didn't get budget to make it this time:(
14:32:09 <cardeois> ok no worries, are you alright if we skip next meeting?
14:32:45 <larainema> Sure, enjoy the summit your guys
14:33:00 <vkramskikh> thanks :)
14:33:05 <vkramskikh> any other topics?
14:33:30 <yujunz> Where do you prefer for the meetup in Barcelona?
14:33:40 <cardeois> Mhh yeah where do we meet?
14:34:09 <vkramskikh> I haven't been there, probably we can contact each other on Tue
14:34:13 <cardeois> No idea, I would say in the convention center if it's in during the day, or some place else if it's the evening
14:34:20 <cardeois> agreed
14:34:47 <cardeois> Also I'm not sure but is there any design/work session around javascript in the summit? I didn't check the schedule yet
14:35:01 <cardeois> (One where we should all go)
14:35:15 <vkramskikh> me too, but krotscheck said there is a session for SDK and we should go there
14:35:47 <cardeois> Yeah I forgot the link, if you have it let me know
14:36:14 <vkramskikh> ok
14:36:33 <vkramskikh> any other topics?
14:37:12 <vkramskikh> thanks everyone
14:37:15 <cardeois> nope I'm good. I'm doing the release right now, will let you know on #openstack-javascript
14:37:16 <vkramskikh> #endmeeting