16:00:03 <TheJulia> #startmeeting ironic_bfv
16:00:04 <TheJulia> o/
16:00:08 <openstack> Meeting started Thu Mar 30 16:00:03 2017 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:11 <openstack> The meeting name has been set to 'ironic_bfv'
16:00:37 <hshiina> o/
16:00:48 <TheJulia> Good morning, afternoon, evening everyone!
16:00:57 <TheJulia> Our agenda today has a few discussion items \o/
16:01:09 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic-BFV
16:01:21 <TheJulia> #topic Announcements/Reminders
16:01:52 <TheJulia> I have none at the moment, does anyone have anything they would like to make a note of today?
16:02:28 <hshiina> i have nothing
16:02:39 <TheJulia> Okay then, moving on!
16:02:44 <TheJulia> #topic Current Status
16:03:04 <TheJulia> I see we have a number of notes in the etherpad today \o/
16:03:14 <TheJulia> #link https://etherpad.openstack.org/p/Ironic-BFV
16:04:22 <TheJulia> Looks like the cinder interface has some feedback that might need to be addressed
16:05:04 <TheJulia> And there is some ongoing discussion in https://review.openstack.org/#/c/366197/
16:05:07 <joanna> o/
16:05:09 <joanna> sorry I am late.
16:05:12 <TheJulia> o/ joanna
16:05:40 <TheJulia> No worries, we were just taking a minute to review the etherpad.
16:06:08 <joanna> I'll update the interface patch
16:06:12 <TheJulia> I updated the status on the etherpad for the cinder common code revision, there is feedback on it.
16:06:17 <TheJulia> Awesome, Thank you joanna
16:06:44 <TheJulia> mjturek: I see you've left some notes, can you give us a quick summary?
16:07:03 <joanna> I'm wondering if we should handle this in attach, or rather fail and let the caller call detach
16:08:24 <TheJulia> That might make more sense
16:09:13 <TheJulia> Anyway, I guess mjturek is busy right now, so we can move on.
16:09:35 <mjturek> TheJulia I'm sorry - on a call will be on ASAP
16:09:35 <joanna> or maybe call abort and do the cleanup in abort, se we return in somewhat clean state. I'll think about it :)
16:10:00 <TheJulia> mjturek: no worries!
16:10:09 <TheJulia> #topic Planning/Priorities
16:10:48 <TheJulia> It appears that mjturek has been looking at devstack stuffs, and continues to do so.  That is a relatively high priority for our velocity.
16:11:17 <TheJulia> joanna: Any idea on timing for the interface revision?
16:11:51 <joanna> ~3hours?
16:12:13 <TheJulia> awesome
16:12:20 <joanna> :)
16:12:45 <TheJulia> My one ask is that everyone takes some time out before mid next week to review https://review.openstack.org/#/c/355625/ which is the cinder common code.
16:12:53 <TheJulia> #link https://review.openstack.org/#/c/355625/
16:13:29 <TheJulia> Aside from that, I guess we're good to move into discussion, unless someone has questions relating to priority or planning?
16:14:14 <hshiina> i aggree the plan and have no question
16:14:22 <TheJulia> Excellent
16:14:27 <TheJulia> Moving on then....
16:14:31 <TheJulia> #topic Discussion
16:16:03 * mjturek is back
16:16:20 <TheJulia> Today we have three items, the first is the question of the MAC address to IP lookup.  This is raised from a question hshiina raised on, I believe the cinder common code since it doesn't support that presently, and I believe we need to address that in ironic since we can't in nova. hshiina I see you also mentioned the nova patch and possible solutions to the
16:16:20 <TheJulia> original issue of MAC -> IP lookups?
16:17:15 <hshiina> TheJulia, yes
16:17:32 <mjturek> TheJulia: by cinder common code do you mean os_block?
16:17:40 <mjturek> or is that separate?
16:17:48 <mjturek> os-brick*
16:17:48 <TheJulia> mjturek: the ironic cinder common code
16:17:52 <mjturek> oh!
16:17:56 <mjturek> sorry understood
16:18:01 <TheJulia> mjturek: no worries
16:18:14 <joanna> TheJulia, hshiina: the comments are in the driver patch
16:21:05 <TheJulia> hshiina: Looking at the ironic nova driver comments, I would think the attach could only actually take place after the node the node has been spawned in ironic, or at least in process, which makes me think the best thing to do is still let ironic handle the attachments in it's workflow
16:22:16 <TheJulia> Ahh, I also see the note about it might be difficult to just somehow skip it :\
16:22:31 <TheJulia> So we could possibly need the info in both places. :(
16:22:47 <TheJulia> Well, that kind of renders that discussion pointless until we have more clarity.
16:23:20 <TheJulia> I guess we should move on then?
16:23:34 <joanna> TheJulia: I have a question about mac
16:23:38 <hshiina> TheJulia, yes. i will add some memo to etherpad later
16:23:59 <hshiina> TheJulia, about this issue
16:24:03 <joanna> since spec says it's valid - what is the actual reason behind mac to ip conversion
16:25:08 <TheJulia> if I define a mac to be part of a storage network, I don't know it's IP until I deploy.  It would be a reasonable way to preserve the fact that it is valid in the hardware configuration.
16:25:21 <TheJulia> hshiina: Awesome, thank you
16:26:13 <TheJulia> joanna: does that answer your question?
16:26:48 <TheJulia> Possibly the other context is that the connector intent was to be as generic as possible to provide storage as much connector information as possible.
16:26:58 <joanna> TheJulia: yes. Why does spec include mac support?
16:27:51 <TheJulia> I believe it is more-so you can define "this network card is always part of the storage fabric, lean towards using it" concept, but I honestly don't remember at this point.
16:28:52 <joanna> thanks :)!
16:28:56 <TheJulia> Moving on, the next item is...
16:28:59 <TheJulia> Cinder storage interface should_write_image() logic and deployment skip logic addition
16:30:42 <TheJulia> hshiina pointed out, i believe in the ipxe template patch, that the logic for that had not yet been proposed. I can likely do it fairly quickly in the next week or so. I just think it should be an additional patch on top of the ipxe template change.  If there are no objections, I'll try and put that together before next thursday.
16:31:54 <hshiina> no objection, thanks
16:32:03 <TheJulia> Awesome
16:32:44 <TheJulia> In that case since, our last item is raised by hshiina, wondering if we should split apart the API patches.
16:33:21 <TheJulia> From an ironic review standpoint, it is rather painful to get two independent API changes in in order since each one results in a micro version bump.
16:33:42 <TheJulia> hshiina: Is your reasoning to split it just over review velocity?
16:34:46 <hshiina> TheJulia, yes. I have heard large patch is difficult to review in some other patches.
16:35:06 <joanna> hshiina: what is the proposed split? Volume and VolumeConnector?
16:35:36 <joanna> I think we should push it to the priority list for the next week, this can solve the issue of lack of reviews
16:35:39 <hshiina> joanna, VolumeConnector and VolumeTarget
16:36:17 <TheJulia> I agree with joanna
16:36:39 <mjturek> seems doable
16:37:03 <joanna> I volunteer as a reviewer :) will look at that later today or tomorrow
16:37:18 <TheJulia> That way we get some of the later review/nitpicking out of the way, of course, the changes have functionally been up for a long time.  It just seems like we should be able to review and agree if there is more work required in that patch.
16:37:48 <TheJulia> A single api change will be much easier to land overall, so I don't think we should split them apart.
16:39:14 <TheJulia> #action TheJulia will raise it in the ironic meeting on monday.
16:39:36 <hshiina> TheJulia, thanks
16:39:41 <TheJulia> Anything else on this topic?
16:40:00 <TheJulia> #undo
16:40:00 <openstack> Removing item from minutes: #action TheJulia will raise it in the ironic meeting on monday.
16:40:30 <TheJulia> #action TheJulia will raise the API patch in the ironic meeting on monday for reviews.
16:40:54 * TheJulia hears crickets :)
16:41:12 <TheJulia> #topic Open Discussion
16:41:26 <mjturek> so I can give a summary of devstack investigation
16:41:39 <TheJulia> mjturek: that would be awesome :)
16:42:27 <mjturek> basically I've been looking for anything in virtualbmc or the libvirt guests that we'd need to do differently. I don't forsee any changes there
16:42:31 <joanna> just FYI: I looked at the sequence diagram shown by cinder team, that shows async communication (the one that caused the discussion an -1s on the interface patch). Nova uses the same client, which makes sync REST call, so everything is sync from our perspective
16:42:58 <mjturek> what I think it's going to come down to is just setting the configs for a boot from volume tempest test
16:43:14 <mjturek> I believe all the config changes are in the cinder common code patch?
16:43:47 <joanna> mjturek: yes, the config will include additional fields
16:44:03 <mjturek> anyways, I also linked to the tempest test that nova does which we'll probably want to do
16:44:07 <joanna> do we already have devstack with cinder plugin?
16:44:23 <mjturek> well ironic and cinder stack together fine
16:44:31 <mjturek> but I haven't tried with the patches
16:44:41 <mjturek> hshiina: it seems like you might've already though?
16:45:02 <hshiina> mjturek, i tried devstack with the patches.
16:45:14 <mjturek> cool, and nothing strange there?
16:45:34 <hshiina> mjturek, stack.sh succeeded
16:45:42 <mjturek> nice!
16:46:26 <mjturek> anyway, I want to try that myself this week and see if I can get devstack to be ready to go for something similar to that tempest test
16:46:28 <joanna> hshiina: awesome :)
16:47:22 <TheJulia> mjturek: I think we're just missing one vital piece to the puzzle, but I'll try to get that hammered out (the missing skip deployment check, which shouldn't be difficult to take care of for me in the next few days)
16:47:49 <mjturek> cool cool
16:48:23 <TheJulia> Awesome, sounds like we're on a good path.  Anything else to discuss or shall we all get ten minutes back?
16:48:53 <hshiina> i have nothing to discuss
16:49:04 <mjturek> good for now
16:49:55 <joanna> i'm good
16:50:00 <TheJulia> Awesome!  Thank you everyone, and have a wonderful rest of the day!
16:50:23 <hshiina> thank you
16:50:33 <joanna> thank you, TheJulia, hshiina, mjturek :)
16:50:37 <TheJulia> #endmeeting