16:00:42 <TheJulia> #startmeeting ironic_bfv
16:00:42 <openstack> Meeting started Thu Mar 23 16:00:42 2017 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:45 <TheJulia> o/
16:00:45 <openstack> The meeting name has been set to 'ironic_bfv'
16:00:46 <joanna> o/
16:00:52 <hshiina> o/
16:00:53 <TheJulia> Good morning everyone
16:00:57 <crushil> \o
16:01:45 <TheJulia> Our agenda for this week, which is minimal (You folks know your welcome to edit it right?) :)
16:01:47 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic-BFV
16:01:49 <mjturek> o/
16:02:29 <TheJulia> #topic Announcements/Reminders
16:02:45 <TheJulia> As mentioned last week, I created an etherpad for tracking the items related to BFV.
16:03:07 <TheJulia> #link https://etherpad.openstack.org/p/Ironic-BFV
16:03:28 <TheJulia> Any other items for announcement?
16:03:30 <joanna> thank Julia! it made things easier
16:03:34 <dtantsur> o/
16:04:00 <dtantsur> please make sure the etherpad is linked from the main whiteboard
16:04:41 <TheJulia> #action TheJulia to check/update links for etherpads
16:04:48 <TheJulia> dtantsur: I think I already had, but just in case ^^^ :)
16:04:59 <TheJulia> Moving on....
16:05:23 <TheJulia> #topic Current Status
16:05:53 <joanna> dtantsur, TheJulia : it is in subtem status section under BFV
16:06:21 <TheJulia> Looks like joanna has updated the cinder common interface revision, but hit an unrelated ci failure.
16:06:33 <joanna> Yes, I requested recheck.
16:06:57 <mjturek> haven't had a lot of time this week to investigate devstack this week :( but planning to make time for it this week, so don't have much of a status
16:07:13 <joanna> Depending patches will need to be updated too, probably it will take some time due to similar issue in tests as in cinder api
16:07:14 <TheJulia> mjturek: Awesome, thank you
16:07:34 <TheJulia> joanna: sorry :(
16:08:05 <TheJulia> hshiina: Have you had time to look into moving connection document logic out of nova, due in part to the need for the ip address?
16:08:50 <hshiina> i read nova code. it seems difficult to move all logic to ironic.
16:08:50 <joanna> TheJulia: no problem at all, don't worry
16:09:00 <TheJulia> #info mjturek will try to look at devstack stuffs next week.
16:09:23 <TheJulia> hshiina: Seems like we should take that topic to discussion then.
16:09:51 <hshiina> now, i updated nova patch to get ip address in nova side by calling vif attach API before creating connection information.
16:09:58 <TheJulia> joanna: Are you going to begin updating the dependent patches?  If you already said you were going to, I didn't pick up on it
16:10:10 <joanna> I will :)
16:10:23 <TheJulia> hshiina: That... might... just... work
16:10:35 <joanna> I just wanted to give everyone heads up that it won't be within next couple of hours :)
16:10:46 <TheJulia> #info joanna to continue to update the ironic in-tree revisions.
16:10:50 <TheJulia> joanna: Awesome
16:11:04 <TheJulia> So shall we move on?
16:11:52 <joanna> +
16:12:03 <hshiina> sure
16:12:20 <TheJulia> #topic Planning/Priorities
16:13:03 <TheJulia> I don't think we have anything to really discuss here, so if anyone has anything then awesome, otherwise, I'll just move us onward to discussion
16:14:09 * TheJulia hears crickets
16:14:44 <TheJulia> #topic Discussion
16:15:37 <joanna> I have one item. Mario left a review yesterday with a question on what is a desired/best behavior in attach_volumes if one attachment fails
16:16:25 <TheJulia> joanna: imho, attachment should fail, power-on should be prevented
16:16:37 <joanna> currently it will raise an exception and leave the cleanup responsibility to the caller (which is fine as detach_volumes can take the same list as a param)
16:17:42 <joanna> his concern was, if we're attaching 10 volumes and only 1 fails... I think that it's good to fail, since we shouldn't deliver half-desired outcome
16:17:44 <TheJulia> I think it is fine for the caller to do the clean-up, is the thought to have the common code handle all of the failure cleanup?
16:18:25 <TheJulia> hshiina: It looks like your uploaded patchset doesn't merge, perhaps time to rebase the nova patchset?
16:18:53 <mjturek> TheJulia: you said the move of connection document logic was only in part needed for the IP problem (which if I'm understanding, was solved by hshiina's current solution?). What else was it required for?
16:19:05 <joanna> TheJulia: no, caller already does that in other patch, I answered that to Mario in my reply. The thing was rather about failing all attachments in case of 1 failure
16:19:27 <TheJulia> mjturek: Mac addresses, although I'm not sure that is a hard requirement.
16:19:31 <hshiina> i guess the nova conflict is caused by Depend-on: ironic api patch, which has a conflict.
16:19:32 <joanna> given examples where failing volume is a 1st one and a 10th one. But detach will handle both cases.
16:19:36 <mjturek> ahh
16:19:57 <TheJulia> mjturek: possibly worth digging into the the common cinder drivers to see what they "really" want for their connection parameters
16:20:13 <joanna> TheJulia: It looks like we agree on that. I will leave it as-is, with excepion being raised no matter which volume failed
16:20:17 <mjturek> TheJulia: yeah sounds like a good path
16:20:57 <TheJulia> Anyone want to volunteer to skim the cinder drivers to see if they care about/want a mac address?
16:21:13 <mjturek> o/
16:21:24 <mjturek> sounds interesting to me
16:21:44 <TheJulia> #info mjturek volunteers to skim through the cinder drivers to validate if they want/need mac addresses in their connection information.
16:21:51 <TheJulia> mjturek: awesome
16:21:55 <mjturek> thanks TheJulia
16:22:05 <TheJulia> hshiina: going back to the depends-on, that would do it.
16:22:34 <TheJulia> So there is only one other item in my head right now.  If there are no objections, I'm just going merge discussion/open discussion on the agenda.
16:23:01 <mjturek> yeah sounds good
16:23:11 <hshiina> i agree
16:23:33 <TheJulia> Awesome!
16:23:42 <TheJulia> Anything else this week?
16:24:52 <mjturek> i'm good
16:25:03 <joanna> i'm good too :)
16:25:18 <hshiina> i'm good
16:25:20 <TheJulia> Excellent!  Thank you everyone!
16:25:30 <TheJulia> Have a wonderful rest of the week and talk to you next week!
16:25:39 <TheJulia> #endmeeting