16:00:13 <TheJulia> #startmeeting ironic_bfv
16:00:14 <openstack> Meeting started Thu Mar 16 16:00:13 2017 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:17 <TheJulia> o/
16:00:18 <openstack> The meeting name has been set to 'ironic_bfv'
16:00:18 <joanna> o/
16:00:21 <TheJulia> Good morning everyone!
16:00:27 <joanna> morning TheJulia :)
16:00:37 <hshiina> o/
16:01:12 <TheJulia> Our agenda, actually has just the standard items on it this morning, so I suspect this should be a relatively quick meeting unless we have a long discussion about anything specific.
16:01:15 <mjturek> o/
16:01:17 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic-BFV
16:02:01 <TheJulia> I'm also going to apologize for dropping somewhat off the radar this week as I've been a bit ill as a result of convention plague.
16:02:17 <mjturek> feel better soon TheJulia!
16:02:20 <TheJulia> #topic Announcements/Reminders
16:03:09 <TheJulia> Well, I have no announcements, anyone else?
16:03:35 <joanna> nope
16:03:38 <TheJulia> Moving on..
16:03:45 <TheJulia> #topic Current Status
16:04:17 <joanna> I updated cinder interface patch removed token handling): https://review.openstack.org/#/c/355625/
16:04:26 <TheJulia> #info joanna has been awesome and updating patches
16:04:41 <joanna> cinder driver was also updated, no reviews yet, though: https://review.openstack.org/#/c/366197/
16:05:02 <TheJulia> I've also tried to go through some of the comments and answer some questions, and provide context as necessary.
16:05:15 <joanna> thank you, TheJulia :)
16:05:49 <mjturek> joanna: will review!
16:06:07 <joanna> mjturek: awesome, thank you!
16:06:43 <TheJulia> I think we need to get the rest of the patches in the chain updated, they seem to be in fairly good state.
16:06:46 <joanna> I was wondering if I can update also: https://review.openstack.org/#/c/406290/ ?
16:06:58 <joanna> if you wouldn't mind, TheJulia, ofc
16:07:10 <TheJulia> Works for me :)
16:07:37 <joanna> awesome :)
16:07:59 <TheJulia> The nova patch does need some additional work.
16:08:23 <TheJulia> #info Nova patch needs some work, we should discuss this!
16:08:43 <TheJulia> Anything else in current status?
16:09:04 <hshiina> i sometimes updated api patch. https://review.openstack.org/#/c/214586/
16:09:50 <TheJulia> #info hshiina has been updating the api patch \o/
16:10:03 <joanna> hshiina: what are the topics under which current patches can be found? I know only about bug/1526231 and bug/1559691
16:10:15 <TheJulia> #topic Planning/Priorities
16:10:33 <mjturek> bp/ironic-boot-from-volume looks like another one
16:10:49 <mjturek> but that's just the nova patch
16:11:29 <TheJulia> Different tracking :\
16:11:41 <hshiina> joanna, i also know these 2 patches in ironic
16:11:43 <TheJulia> Would an etherpad help with clarity?
16:11:54 <mjturek> yeaaaah I think that'd be useful
16:12:20 <joanna> ++
16:12:25 <TheJulia> #action TheJulia to create an etherpad for revision/status tracking.
16:14:39 <TheJulia> I think that will help, is there anything else we should discuss here?
16:15:27 <joanna> I'm not sure if it's not to soon to discuss testing, but I'm just wondering if there are any heavy prerequisites for that
16:16:00 <TheJulia> I think the answer to that would be yes
16:16:14 <TheJulia> I'm going to move us to Open Discussion, since we have no specific discussion topic
16:16:18 <TheJulia> #topic Open Discussion
16:16:58 <mjturek> so are there other patches that could use updating? I'd be happy to volunteer
16:17:45 <mjturek> or is reviewing more important at this point?
16:19:01 <TheJulia> So testing and the nova patch mac address lookup are two things I can think of right now that needs to be discussed.
16:19:18 <TheJulia> mjturek: There are a few, I'll try and create an etherpad later and share the URL to everyone.
16:19:23 <mjturek> right right
16:20:16 <TheJulia> As for nova, hshiina you pointed out that the networking changes in ironic with attach_vifs kind of breaks mac address availability.  Any thoughts of just doing it inside of ironic since we can be fully aware of the state the node is in and then lookup/relate the data back.
16:22:31 <hshiina> doing in ironic sounds better
16:22:42 <TheJulia> On the side of testing, since I'm trying to multitask at the moment \o/.  We do need to get devstack configurations to get cinder in place along with ironic/nova.  That plus the patches should make something more functional
16:23:24 <TheJulia> hshiina: That may remove a lot of the information manipulation needs in the ironic-virt driver code.
16:24:16 <hshiina> TheJulia, yes. this works seems diffucult
16:24:54 <hshiina> nova also has some volume manipulation out of virt driver
16:28:00 <TheJulia> I don't remember seeing that, could you pull the urls for this for us at some point in the next day or two?
16:28:51 <hshiina> TheJulia, i will
16:30:03 <mjturek> TheJulia: wrt testing, are there known shortcomings for devstack setting up cinder/ironic/nova or does that need some digging?
16:30:26 <TheJulia> #info hshiina to collect information regarding restructuring the information generation/identification for volume connectors.
16:30:39 <TheJulia> mjturek: It needs investigation, would you be up for it?
16:30:51 <mjturek> TheJulia: sure!
16:31:24 <TheJulia> #info mjturek to look at creating devstack config for cinder/ironic/nova \o/
16:32:41 <TheJulia> With the application of patches, and that config, our velocity and ability to begin testing should be enabled
16:34:56 <mjturek> coooool
16:35:47 <TheJulia> joanna: Does that answer your question/concern?
16:36:05 <joanna> TheJulia, mjturek: yes, thank you \o/
16:36:11 <jlvillal> o/
16:37:01 <TheJulia> Awesome, is there anything else that we need to cover today?
16:39:07 * TheJulia hears crickets
16:39:13 <mjturek> I'm good for now!
16:39:19 <mjturek> I'll post questions to #openstack-ironic
16:39:20 <joanna> me too :)
16:40:02 <TheJulia> Awesome, thank you both!
16:40:03 <hshiina> i have nothing else
16:40:25 <TheJulia> Excellent!  I'll try to get the etherpad posted in the next couple of hours.
16:40:32 <mjturek> thanks TheJulia :)
16:40:43 <TheJulia> Have a wonderful day everyone!
16:40:45 <TheJulia> #endmeeting