15:00:40 <rpittau> #startmeeting ironic
15:00:40 <opendevmeet> Meeting started Mon Jan 29 15:00:40 2024 UTC and is due to finish in 60 minutes.  The chair is rpittau. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:40 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:40 <opendevmeet> The meeting name has been set to 'ironic'
15:00:50 <iurygregory> o/
15:00:52 <rpittau> hello everyone! o/
15:01:02 <dtantsur> o/
15:01:38 <JayF> o/
15:01:38 <rpittau> #topic Announcement/Reminder
15:01:39 <TheJulia> o/
15:01:46 <rpittau> #info Standing reminder to review patches tagged ironic-week-prio and to hashtag any patches ready for review with ironic-week-prio: https://tinyurl.com/ironic-weekly-prio-dash
15:02:30 <rpittau> I don't see any action item from last meeting, so jumping to the next topic
15:02:35 <rpittau> #topic Caracal Release Schedule
15:03:13 <rpittau> it's R-9 week, no actions for us this week
15:03:49 <rpittau> #link https://releases.openstack.org/caracal/schedule.html
15:04:20 <rpittau> mm final release for non client libraries is in 3 weeks
15:04:44 <rpittau> alright, moving on
15:04:53 <rpittau> #topic Potential BM SIG/Ironic meetup at CERN around June 6, 2024
15:05:03 <rpittau> JayF: any news on this? ^
15:06:39 <rpittau> I guess we can circle back to it later
15:06:42 <TheJulia> I've not seen anything this week on Switzerland meetup being posted yet
15:06:50 <rpittau> ok, thanks TheJulia
15:06:51 <TheJulia> It seems to be in early planning and trying to move forward
15:07:17 <JayF> Yeah I am trying very hard and encouraging folks to get stuff down in writing
15:07:22 <TheJulia> likewise
15:07:24 <JayF> I should pull that item out of the agenda until something is nailed down
15:07:32 <rpittau> sounds good
15:08:11 <rpittau> going to move forward then
15:08:13 <rpittau> #topic Review Ironic CI Status
15:08:38 <TheJulia> Python-ironicclient functional tests are currently broken due to the rbac policy default change, it is next on my list
15:09:24 <TheJulia> the functests were written back in the very very early of the first policy stuffs, so the settings are just out of date... hopefully that is it
15:09:34 <rpittau> thanks TheJulia
15:10:20 <TheJulia> A similar fix for networking-baremetal job config has also been posted
15:11:04 <rpittau> JayF: I was wondering about the issue with latest eventlet in inspector docs mentioned last week
15:11:24 <JayF> So eventlet version bumps were rolled back out of requirements and will not be rolled forward again in C
15:11:35 <JayF> It is a problem we'll still have to tacklem
15:11:35 <rpittau> alright
15:11:44 <JayF> I suspect the agenda never got cleared after last meeting if that is still on the agenda
15:12:08 <rpittau> no, it's not, just my curiosity
15:13:03 <rpittau> also I think we'll finally be good with Pillow update thanks to masghar patch https://review.opendev.org/c/openstack/ironic/+/906825
15:13:21 <TheJulia> ++
15:13:51 <rpittau> anything else on CI status ?
15:14:27 <rpittau> moving on!
15:14:29 <rpittau> #topic Bug Deputy
15:14:47 <rpittau> it was me last week, I really don't have a summary as the situation was really calm
15:15:02 <rpittau> nothing to report
15:15:05 <TheJulia> I suspect a group review session might be needed
15:15:33 <TheJulia> I took a look at a couple different items in ironic's back log last week which were marked wishlist, but both were actually already done
15:16:13 <TheJulia> we likely need to perform some sort of systematic review
15:16:17 <JayF> ++
15:16:38 <JayF> The idea originally was that bug deputies were going to do bug triage parties, but I think that was just wishful thinking that we'd have enough time for it
15:16:56 <TheJulia> Well, last week there were no new bugs against ironic
15:17:01 <rpittau> yep
15:17:15 <rpittau> but maybe we can call bug triage parties from time to time :)
15:17:20 <TheJulia> and everything seemingly already triaged means we need to go back and look at the already triaged
15:17:28 <TheJulia> We *really* should
15:18:33 <rpittau> should we do it maybe next Monday after the meeting ?
15:18:44 <TheJulia> That would work for me
15:19:09 <rpittau> we also need a bug deputy volunteer for this week :)
15:19:20 <arne_wiebalck> o/
15:19:56 <TheJulia> I guess I can do it this week, although I suspect I might just craft a spreadsheet for next week to get folks to work from
15:20:08 <rpittau> TheJulia: that's great actually
15:20:11 <rpittau> thanks
15:20:17 <JayF> I think next Monday might be a us holiday
15:20:35 * arne_wiebalck is available for a potential BM SIG / Ironic meetup at CERN discussion
15:20:54 <rpittau> JayF: I don't have anything on my calendar
15:20:57 <TheJulia> o/ arne
15:20:58 <rpittau> hey arne_wiebalck :)
15:21:10 <rpittau> #action TheJulia is the bug deputy for this week
15:21:11 <JayF> arne_wiebalck: my impression is most folks are in a holding pattern, can't get the travel approved without full details figured out
15:21:25 <arne_wiebalck> shall we discuss now or at the end?
15:21:55 * arne_wiebalck didn't mean to disrupt the meeting
15:22:00 <rpittau> we can leave it for the open discussion
15:22:06 <arne_wiebalck> +1
15:22:14 <rpittau> we're almost there :)
15:22:22 <rpittau> #topic RFE Review
15:22:36 <rpittau> I haven't seen any new RFE proposal
15:23:19 <rpittau> so I guess we can skip this
15:23:26 <rpittau> #topic Open Discussion
15:23:40 <rpittau> arne_wiebalck: here we are! :D
15:23:45 <arne_wiebalck> :-D
15:24:07 <arne_wiebalck> the team is organising an OpenStack meetup on June 6
15:24:25 <TheJulia> arne_wiebalck: any idea when there will be some sort of webpage we can point folks to
15:24:26 <TheJulia> ?
15:24:30 <arne_wiebalck> the current plan is to have the morning with tours, some talks in the afternoon
15:24:41 <arne_wiebalck> TheJulia: end of this week
15:24:54 <arne_wiebalck> there is the official announcement on the foundation's pages
15:25:13 <arne_wiebalck> we have some speakers lined up already
15:25:34 <arne_wiebalck> 4-5 presentations, then a social event in the evening
15:25:59 <arne_wiebalck> now, then there is the idea of a BM SIG meeting / Ironic meetup on the 5th
15:26:26 <arne_wiebalck> we can provide a meeting room, just like for the mid-cycle we did here
15:26:54 <arne_wiebalck> we have reached out to some folks to see if they would come one day earlier for this
15:27:35 <arne_wiebalck> JayF has confirmed his availability, StackHPC as well
15:28:10 <JayF> I'm actually probably going to have a day or two to "kill" early in that week (Mon/Tues?) as well in the EU if anyone wants to have a IRL pair session with me in some fun place a train ride away from France :)
15:28:15 <TheJulia> I've started to look at flights to get a general plan together
15:28:17 <rpittau> I am probably going to come no matter what, but of course the more info we have the more the chance to get "sponsored"
15:28:24 <arne_wiebalck> we may reach out to more, like Sylvain,  who would come for the meetup to see if he would be available for Ironic/Nova discussions (if needed)
15:29:04 <arne_wiebalck> we will try to get the page for the 6th up asap
15:29:11 <rpittau> thanks arne_wiebalck
15:29:12 <TheJulia> Awesome, thanks
15:29:14 <arne_wiebalck> this one is confirmed and will happen
15:29:30 <TheJulia> (And I think the idea of cross-pollination between teams in OpenStack is also a good idea
15:29:31 <TheJulia> )
15:29:31 <arne_wiebalck> for the 5th we can do it, if there is interest
15:29:32 <JayF> BM SIG + Ironic hackathon the day before seems appealing
15:29:44 <JayF> if we can nail down a specific time for the SIG to invite operators/external interested parties/etc
15:29:57 <JayF> and then just try to get smart Ironic people physically in a room with internet for earlier in the day
15:30:02 <JayF> if that's logistically possible
15:30:15 <arne_wiebalck> sounds doable, yes
15:30:51 <JayF> if Julia and Riccardo are working on I
15:30:55 <JayF> s/I/it/
15:30:56 <arne_wiebalck> I realise there is some sort of egg and chicken problem
15:30:58 <JayF> that seems like quorum :)
15:31:12 <JayF> me/julia/riccardo/stackhpc is probably enough to make it worth putting on a schedule
15:31:14 <arne_wiebalck> but we're happy to provide the facility
15:31:20 <arne_wiebalck> JayF: ok!
15:31:41 <JayF> and we can push for more EU based Ironic operators to go as well
15:31:50 <JayF> I have several contacts with companies that use Ironic more quietly over there
15:32:00 <JayF> will urge them to get outta the shadows and come to CERN :D
15:32:50 <arne_wiebalck> we can create an item on our conferencing website, this will allow folks to point to it
15:33:07 <rpittau> that sounds perfect
15:33:12 <arne_wiebalck> maybe that is the first step
15:33:18 <JayF> Yeah, if we can get that, then I'll work on writing something up for ironicbaremetal.org / socials
15:33:28 <arne_wiebalck> ok!
15:33:47 <arne_wiebalck> we will need to compile an agenda/topics, but I guess the usual etherpad will do
15:34:00 <arne_wiebalck> and/or our conference tool
15:34:07 <arne_wiebalck> for publicity :)
15:34:27 <arne_wiebalck> ok, let me start with this, then we take it from there!
15:34:29 * JayF is thinking "a recap of 10 years of Ironic features" or something similar as a short presentation
15:35:17 <arne_wiebalck> oh, if you have presentations like this one to attract people, awesome
15:35:33 <TheJulia> I would <3 that, but I also have to speak on something in LA in like 5 weeks
15:35:49 <rpittau> I can probably do something on the metal3 side, if it can be of any interest
15:35:53 <JayF> ++
15:35:57 <arne_wiebalck> rpittau: ++
15:36:01 <JayF> A cavalcade of 15 minute lightning talks
15:36:04 <JayF> on things you didn't know Ironic did
15:36:25 <JayF> I can work with this :D
15:36:30 <rpittau> looks like we have a plan :)
15:36:36 <arne_wiebalck> if we could leave the content to upstream, that would be great
15:36:47 <rpittau> yes, of course that would be better
15:36:58 <arne_wiebalck> since the team also have to prepare the meetup
15:37:00 <JayF> absolutely
15:37:17 <JayF> I'll own that agenda for the sig day
15:37:31 <arne_wiebalck> ok, I will see to get something up on the web this week or so
15:37:33 <JayF> with the understanding the organized time there is not going to be extremely long :)
15:37:38 <arne_wiebalck> thanks JayF
15:37:59 <rpittau> thanks all, sounds promising
15:37:59 <arne_wiebalck> for tours, we would probably refer to the meetup on the 6th
15:38:09 <arne_wiebalck> and not have tours on the 5th as well
15:38:29 <rpittau> ++
15:38:30 <arne_wiebalck> but let's see how that goes
15:38:43 <arne_wiebalck> the visit calendar is already filling up ...
15:38:57 <arne_wiebalck> ok, all good for me for the moment, thanks!
15:39:08 <dtantsur> speaking of meetups, a short heads-up
15:39:24 <dtantsur> Metal3 meetup on Wednesday: https://docs.google.com/document/d/1Exm5k6JB2JlD9_FOaM68R2ASHi7ZsryF_xEqLG1j4zA/edit#heading=h.noz6wdbo32qs
15:39:34 <rpittau> oh yeah, thanks dtantsur
15:39:56 <rpittau> #info Metal3 meetup on Wednesday January 31
15:39:57 <TheJulia> arne_wiebalck: I think tours only on one day makes sense
15:40:03 <rpittau> #link https://docs.google.com/document/d/1Exm5k6JB2JlD9_FOaM68R2ASHi7ZsryF_xEqLG1j4zA/edit#heading=h.noz6wdbo32qs
15:40:06 <arne_wiebalck> TheJulia: ++
15:40:35 <rpittau> I think we're good for now, thank you all again
15:40:54 <rpittau> anything else to discuss?
15:41:34 <rpittau> alright then!
15:41:35 <rpittau> #endmeeting