15:01:20 <JayF> #startmeeting ironic
15:01:20 <opendevmeet> Meeting started Mon Dec  5 15:01:20 2022 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:20 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:20 <opendevmeet> The meeting name has been set to 'ironic'
15:01:25 <TheJulia> o/
15:01:33 <Kirill_> o/
15:01:35 <JayF> Good morning; who all is here today
15:01:40 <ajya> o/
15:02:19 <rloo> o/
15:02:27 <JayF> #topic Announcements/Reminder
15:02:47 <JayF> As always, hashtag patches that need review with #ironic-week-prio and please use our priorty review dashboard to guide your reviewing if you're a core.
15:03:14 <JayF> I'm going to go hashtag the shard key spec; it's getting close and needs to land soon
15:03:40 <rpittau> o/ (a bit alte)
15:03:47 <rpittau> or even late
15:04:00 <JayF> #topic Review action items from last meeting
15:04:02 <JayF> I don't think we had any?
15:04:17 <TheJulia> same
15:04:19 <JayF> Yeah no actions
15:04:33 <JayF> #topic Ironic CI Status + Update
15:04:35 <erbarr> o/
15:04:58 <JayF> Thanks to rpittau and iurygregory who have been looking at the last couple of stable branches to fix for Zuul config errors caused by the queue key.
15:05:14 <JayF> I think we're down to two patches to land to finish it all up?
15:05:25 <JayF> Any other observations about CI for the meeting?
15:05:47 <TheJulia> rpittau did make a comment about wallaby and bifrost earlier
15:05:54 <rpittau> ah yes
15:07:11 <TheJulia> something about it being fubar
15:07:48 <rpittau> so bifrost centos8 jobs are foobar in wallaby
15:08:09 <rpittau> as a consequence the integration job in ironic-prometheus-exporter is also not in a good shape
15:08:36 <TheJulia> Do we know if anyone is consuming i-p-e for wallaby?
15:08:40 <rpittau> wondering if we want to spend time trying to fix them or just make them no-voting and remove it from i-p-e
15:09:01 <TheJulia> I'm +1 to removing from i-p-e
15:09:14 <JayF> Wallaby is EM. I'd suggest removing (don't NV them unless someone is going to fix some day) those jobs if they aren't possible to keep around anymore.
15:09:17 <TheJulia> it is not great, but it is also a very simple plugin
15:09:37 <JayF> We also extremely rarely backport to IPE
15:09:43 <JayF> I don't have a problem asking someone to manually test if we do one
15:09:52 <TheJulia> ++
15:10:14 <iurygregory> o/
15:10:15 <rpittau> sounds good
15:10:25 <JayF> #action rpittau to remove centos8 jobs from bifrost/IPE wallaby
15:10:25 * iurygregory is in two meetings at same time
15:10:35 <rpittau> will do :)
15:10:38 <JayF> Anything else on ci?
15:11:23 <JayF> Moving on...
15:11:33 <JayF> #topic 2023.1 WIP
15:11:47 <JayF> #link https://etherpad.opendev.org/p/IronicWorkstreams2023.1
15:12:04 <JayF> I updated this with something for shards; we really need that spec to land as implemnetation is 50%+ done and nova side implementation is going to be moving soon
15:12:59 <TheJulia> Agreed
15:13:18 <JayF> Please review the WIP etherpad for status and update it if you're working on something
15:13:20 <JayF> moving on
15:13:32 <JayF> #topic Bugfix branch retirement
15:13:42 <TheJulia> We could always count an external review/sanity from a known contributor as positive feedback to move it forward. FWIW
15:14:10 <JayF> TheJulia: there's no acceptable reason why we don't have ironic core reviews on that; folks who are cores need to do the reviews they are signed up to do
15:14:21 <TheJulia> True
15:14:29 <JayF> OK; bugfix release branch retirement
15:14:40 <JayF> talking to releases team; we'll have to get some ACLs added for us to be able tohandle that ourselves
15:14:51 <JayF> this will include ability to del bugfix branches and make new tags
15:15:08 <JayF> I made this topic because I'm thinking; that might need to be a smaller group than ironic-core
15:15:10 <rloo> (might be useful to add links to that IronicWokstreams2023.1 etherpad. I'll try to find time to find the shard thing and review ;) )
15:15:15 <JayF> ack
15:15:36 <JayF> What do folks think about that? Making a smaller group for bugfix branch mangement?
15:16:25 <rloo> are those ACLs on a per-person basis?
15:16:41 <JayF> it'd be on a per-group basis
15:16:49 <JayF> e.g. ironic-core or $new-group-I-am-proposing-now
15:16:55 <rloo> sweet. i think that'll be great.
15:17:14 <rpittau> JayF: sounds like a good idea
15:17:20 <JayF> Objections to me making it a smaller group? Just go logistically there aren't a dozen creds out there which can destroy branches
15:17:30 <JayF> I was going to suggest release liasons for that access? dtantsur rpittau iurygregory and me?
15:17:40 <rpittau> works for me
15:17:43 <dtantsur> makes sense
15:17:57 <TheJulia> Sounds good to me
15:18:02 <JayF> #action Jay to create new ironic-releasers group with him, dtantsur rpittau and iurygregory, and give it the access to manage bugfix releases.
15:18:20 <JayF> That also means I will act on retiring bugfix branches next week ifI get that in
15:18:37 <rloo> btw -- how is that diff from ironic-stable-maint?
15:19:01 <JayF> stable-maint is only for merging in changes to stable branches
15:19:11 <rloo> which, umm, is really old so maybe no one uses that: https://review.opendev.org/admin/groups/950,members
15:19:11 <JayF> this credential will be able to delete old bugfix branches and tag them as EOL
15:19:15 <JayF> directly in git
15:19:20 <JayF> not just gerrit review
15:19:24 <JayF> so it's a pretty big hammer
15:19:36 * iurygregory reading now
15:20:03 <rloo> in that case, makes sense to have a separate one/group.
15:20:05 <TheJulia> stable-maint groups were largely changed to be the whole core group for most (all?) projects a few years back
15:20:56 <rloo> ah, thx TheJulia, it is coming back now!
15:21:01 <dtantsur> yeah, I think it's legacy at this point
15:21:08 <JayF> #action Jay will retire branches listed in here if ACLs get setup properly https://etherpad.opendev.org/p/IronicBugfixBranchCleanup
15:21:24 <JayF> This is what was already mentioned on the list, but please have a look.
15:21:38 <JayF> Moving on if there are no further questions?
15:22:25 <JayF> #topic RFE Review
15:22:37 <JayF> I saw Kirill_ was talking about a new spec
15:22:40 <JayF> this is a good place to plug that
15:22:46 <TheJulia> ++
15:25:10 <JayF> Well, scroll up to just before the meeting if you wanna see it :D
15:25:17 <JayF> #topic Open Discussion
15:25:23 <JayF> anything for open discussion before we call it quits?
15:25:26 <TheJulia> yes
15:25:55 <TheJulia> So, we are fast approaching the end of year, and traditionally, we've shut down meetings from mid-december through like the second week in January as a number of contributors need to use PTO or loose it.
15:26:10 <TheJulia> So generally we've lacked quorum for meetings for a few weeks
15:26:34 <JayF> So maybe cancel 12/26, 1/2 ?  12/19 as well maybe?
15:26:42 <JayF> I wouldn't be here for 12/26 myself anyway :)
15:26:48 <TheJulia> Yeah, likely
15:27:09 <JayF> WDYT about 12/19?
15:27:19 <TheJulia> I might not be around personally
15:27:25 <TheJulia> I don't know about others
15:27:44 <JayF> I'll be here, lets just have one 12/19 worst case I just talk to myself and the bot for 10 minutes and walk through it.
15:28:00 <TheJulia> or just go "well, no quorum, that's all folks!"
15:28:01 <TheJulia> ;)
15:28:12 <JayF> Eh; our meetings are mostly informational and rarely decision-y
15:28:26 <TheJulia> It can vary, but yeah
15:28:34 <JayF> #action JayF to cancel meetings 12/26 and 1/2 so people can worry about PTO and holidays and not Ironic
15:29:08 <rloo> do we have quorum so we can vote for that? ha ha
15:29:17 <TheJulia> lol
15:29:45 <JayF> I think I know personally enough contributors to have quorum that none of them would complain about a cancelled meeting lol
15:29:58 <JayF> like asking a kid on halloween if they want candy :D
15:30:08 <opendevreview> Merged openstack/ironic-inspector bugfix/11.0: Fix compatibility with oslo.db 12.1.0  https://review.opendev.org/c/openstack/ironic-inspector/+/856505
15:30:39 <JayF> Anything else for Open Discussion?
15:31:45 <TheJulia> not from me
15:31:57 <JayF> Aight, thanks for coming all, see you next week o/
15:31:59 <JayF> #endmeeting ironic