15:00:39 <TheJulia> #startmeeting ironic
15:00:40 <openstack> Meeting started Mon Mar 30 15:00:39 2020 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:40 <TheJulia> o/
15:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:44 <openstack> The meeting name has been set to 'ironic'
15:00:53 <kaifeng_> o/
15:00:54 <rpittau> o/
15:00:56 <erbarr> o/
15:00:57 <rpioso> \o
15:00:57 <mgoddard> \o
15:01:01 <arne_wiebalck> o/
15:01:01 <ajya> o/
15:01:04 <iurygregory> o/
15:01:05 <rloo> o/
15:01:13 <cdearborn> o/
15:01:18 <TheJulia> Good morning everyone!
15:01:25 <TheJulia> Our agenda can be found on the wiki as always!
15:01:29 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:01:40 <bdodd> o/
15:01:46 <TheJulia> #topic Announcements / Reminders
15:01:47 <rajinir> o/
15:01:49 <dtantsur> o/
15:02:26 <TheJulia> #info Upcoming breaking changes in pip, and test-requirements.txt not installed anymore in devstack.
15:02:37 <TheJulia> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-March/013642.html
15:02:55 <openstackgerrit> Dmitry Tantsur proposed openstack/ironic master: Bump hacking to 3.0.0  https://review.opendev.org/715602
15:02:56 <openstackgerrit> Dmitry Tantsur proposed openstack/ironic master: Fix the remaining hacking issues  https://review.opendev.org/715907
15:02:59 <rpittau> this might (hopefully not) cause issues in CI
15:03:01 <TheJulia> #info This week is the week of the non-client library release freeze
15:03:05 <accakks> o/
15:03:17 <dtantsur> not installing test-requirements is probably good news
15:03:27 <mgoddard> TheJulia: do we need releases?
15:03:31 <TheJulia> This means sushy and ironic-lib need to be released for the cycle this week.
15:03:36 <dtantsur> and metalsmith if needed
15:03:42 <rpittau> it is, just keep all the possible eyes on the CI for possible breakage
15:03:47 <dtantsur> and does anyone know if sushy-cli is considered a client library?
15:03:49 <TheJulia> mgoddard: I think holding off at the moment, ther eis a patch we want to get in on sushy
15:03:55 <TheJulia> dtantsur: client
15:04:00 <dtantsur> okay, so one more week
15:04:03 <TheJulia> dtantsur: or a tool
15:04:06 <dtantsur> ironic-lib will only need the hacking patch
15:04:12 <TheJulia> ++
15:04:13 <rpittau> dtantsur: client
15:04:16 <dtantsur> metalsmith is likely fine, but needs double-checking
15:04:23 <mgoddard> with a bit of luck, this tells us: https://docs.openstack.org/ironic/latest/contributor/releasing.html
15:04:35 <TheJulia> #info Next week is client libraries!
15:04:35 <mgoddard> ironic-lib, metalsmith, sushy
15:05:00 <rloo> so nice to have documentation :)
15:05:15 <iurygregory> ++
15:05:20 <TheJulia> Also next week, I need to write cycle highlights. :(
15:05:27 <dtantsur> TheJulia: need help with that?
15:05:29 <TheJulia> so merge anything good and noteworthy! :)
15:05:39 <TheJulia> dtantsur: Should be relatively easy. :)
15:05:47 <dtantsur> okay, ping me if anything is needed :)
15:06:25 <TheJulia> Does anyone have anything else to announce or remind us of this week?
15:06:53 <dtantsur> reminder: be nice to yourself and wash your hands
15:06:58 <TheJulia> ++
15:07:07 <iurygregory> it's ptl season on openstack-discuss
15:07:15 <TheJulia> #info Everyone is under stress: Be nice to them, yourself, and wash your hands!
15:07:24 <TheJulia> Yes, nominations close tomorrow I believe
15:08:07 <TheJulia> (I'm still pondering, if anyone is wondering)
15:08:18 <dtantsur> We have been wondering, yes :)
15:08:25 <TheJulia> :)
15:08:25 <iurygregory> yup
15:08:39 <rloo> thx for pondering TheJulia!
15:08:43 <TheJulia> :)
15:08:46 <TheJulia> heh
15:08:49 <TheJulia> we should move on!
15:09:06 <iurygregory> ++
15:09:08 <TheJulia> #topic Review action items from the previous meeting.
15:09:39 <TheJulia> We had two action items, one to send out a doodle for the baremetal sig whitepaper call, and another iurygregory was going to follow-up with HPE ilo CI team.
15:09:49 <TheJulia> I believe both were done
15:09:54 <iurygregory> yup =)
15:10:00 <dtantsur> we need a follow-up for the whitepaper now?
15:10:07 <iurygregory> 3 of 5 jobs at least are reporting logs
15:10:10 <TheJulia> dtantsur: why yes, we do!
15:10:29 <TheJulia> #action We need to meet again this week to re-visit the whitepaper.
15:10:35 <TheJulia> #undo
15:10:36 <openstack> Removing item from minutes: #action We need to meet again this week to re-visit the whitepaper.
15:10:52 <TheJulia> #action TheJulia to send out another doodle for the baremetal whitepaper
15:11:20 <TheJulia> Are we good to proceed to subteam status reports?
15:13:17 <iurygregory> ++
15:13:17 <TheJulia> #topic Review subteam status reportss
15:13:17 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:13:17 <TheJulia> Starting at line 252
15:13:29 <TheJulia> arne_wiebalck: I don't remember, were you or someone from cern going to write something regarding conductor groups performance and all ?
15:13:47 <arne_wiebalck> TheJulia: yes, once we are finished
15:13:54 <TheJulia> k
15:14:02 <arne_wiebalck> TheJulia: we will go with 500 nodes per group
15:14:18 <arne_wiebalck> TheJulia: but we still have to do the split
15:14:37 <arne_wiebalck> TheJulia: I will update the etherpad once we have more datat
15:14:40 <arne_wiebalck> data
15:15:00 <TheJulia> arne_wiebalck: awesome
15:15:13 <TheJulia> dtantsur: How are you feeling w/r/t deploy steps this cycle?
15:15:23 <dtantsur> I'm trying :)
15:15:34 <dtantsur> I feel quite confident we can land the foundational bits
15:15:39 <TheJulia> Awesome
15:15:45 <dtantsur> I'm less sure about the actual final split of the deploy.deploy step
15:16:01 <TheJulia> That is a lot to try and lan right now :\
15:16:03 <TheJulia> land
15:16:14 <dtantsur> exactly
15:16:30 <TheJulia> etingof is out today so no update on dhcp-less deployments but it looks like he has been focusing on rebasing/updating this past week so that is good
15:16:50 <arne_wiebalck> retirement is done I think and can be removed
15:17:01 <TheJulia> ++
15:17:01 <dtantsur> * can be retired!
15:17:05 <arne_wiebalck> lol
15:17:06 <TheJulia> I was just going to ask
15:17:06 <TheJulia> lol
15:17:32 <arne_wiebalck> UEFI s/w RAID needs some more reviews to finally merge
15:17:37 <TheJulia> ++
15:18:29 <TheJulia> Any core reviewers have 20 minutes, please review the UEFI s/w RAID patch. It also conflicts with dtantsur's device selection patch, so the sooner ONE of them merges, the faster we can get the other merged.
15:20:05 <TheJulia> iurygregory, rpioso: anything left on the python3 task list ?
15:20:15 <TheJulia> or should we consider that done for the cycle at line 361
15:20:24 <rpittau> TheJulia: sushy-tools six removal
15:20:31 <iurygregory> I was about to say =)
15:20:35 <rpittau> and tenks
15:20:45 <rpittau> I added a comment on the etherpad
15:20:48 <rpittau> and rechecked the patch
15:21:09 <TheJulia> At this point, I suspect six removal can be punted to next cycle
15:21:12 <rpittau> for sushy-tools we probably can move forward
15:21:14 <rpittau> ok
15:21:26 <TheJulia> yeah, if the review is in place, put it on the patches to review this week
15:21:28 <TheJulia> for sushy-tools
15:21:33 <rpittau> erm s/sushy-tools/tenks
15:21:34 <TheJulia> oh wait
15:21:43 <TheJulia> it is not branched, so that is going to break people
15:21:50 <TheJulia> Next cycle is sounding much better
15:21:51 <rpittau> yeah, I meant tenks :)
15:21:54 <openstackgerrit> Iury Gregory Melo Ferreira proposed openstack/ironic-tempest-plugin master: Split Tempest tests between ipmi and redfish  https://review.opendev.org/712041
15:22:23 <TheJulia> mgoddard: do you feel okay with that moving forward with tenks?
15:23:16 <TheJulia> While waiting, next item is the grenade zuul3 changes. iurygregory Are we still waiting on devstack/grenade changes to merge?
15:23:29 <iurygregory> TheJulia, yes
15:23:38 <TheJulia> *sigh*
15:23:41 <iurygregory> luigi still doing some work on the grenade side
15:23:59 <iurygregory> this will be a goal for V so I assume they will merge in the begin o the V cycle ...
15:24:36 <TheJulia> Thank you everyone for the recent CI improvement patches and bug fixes by the way.
15:25:09 <TheJulia> I'm good, is everyone else good with proceeding?
15:25:13 <mgoddard> TheJulia: sorry, had to step away for parenting
15:25:44 <mgoddard> As tenks is not branched, and we use it in environments without good py3 support I think we should keep six around for now
15:25:52 <mgoddard> Proceed :)
15:27:07 <TheJulia> mgoddard: okay, thanks
15:27:20 <tzumainn> TheJulia, hi! regarding node ownership - I'm having difficulty with the suggested revisions to one of the patches; I was hoping that I'd be able to talk to someone about them at some point... ?
15:27:24 <tzumainn> I left comments on the patch as well
15:27:54 <TheJulia> tzumainn: How about a little later in our meeting?
15:28:07 <TheJulia> or after?
15:28:32 <TheJulia> #topic Deciding on Priorities for the week
15:28:38 <tzumainn> TheJulia, that would be great, thanks!
15:28:42 <tzumainn> after would be fine
15:28:49 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:28:55 <TheJulia> Line 122
15:29:07 <TheJulia> Lots of merged things, so give me a moment to clean those up
15:29:26 <TheJulia> While doing so, could someone check the client libraries for open patches that make sense and add them to the list?
15:30:31 <iurygregory> something like https://review.opendev.org/#/q/status:open+project:openstack/sushy ?
15:30:59 <TheJulia> I was thinking python-ironicclient python-ironic-inspector-client
15:31:10 <TheJulia> I checked sushy and I think we already have the one listed
15:32:31 <TheJulia> please add a little bit of a description to the item when adding links
15:32:59 <TheJulia> dtantsur: any more deploy steps patches for the list?
15:33:00 <iurygregory> ironic-inspector-client has 0 patches open
15:33:11 <dtantsur> TheJulia: everything is WIP atm
15:34:08 <kaifeng_> the inspection scope may need a client patch, but not up yet
15:34:33 <TheJulia> kaifeng_: I thought it didn't....
15:34:40 <TheJulia> but it has been a while since I reviewed that one last
15:34:53 <TheJulia> Looks like we got a lot merged last week
15:35:05 <dtantsur> even I'm not sure, and I wrote most of it :)
15:36:04 <TheJulia> Is everyone good with the list of patches there? Are there any patches we're missing?
15:36:16 <openstackgerrit> Iury Gregory Melo Ferreira proposed openstack/ironic-tempest-plugin master: Split Tempest tests between ipmi and redfish  https://review.opendev.org/712041
15:36:43 <dtantsur> looks ok
15:37:07 <iurygregory> yeah
15:37:52 <TheJulia> cdearborn: rpioso: fyi, https://review.opendev.org/#/c/710327/ is on the list under the idrac driver and it is a sushy-oem-idrac patch, so ironic-core can't approve it to merge.
15:37:53 <patchbot> patch 710327 - x/sushy-oem-idrac - Export System Configuration Added code for exporti... - 1 patch set
15:38:17 <TheJulia> Shall we move on?
15:38:33 <dtantsur> yep
15:38:47 <iurygregory> yes
15:39:10 <TheJulia> Moving on then!
15:39:13 <TheJulia> #topic Discussion
15:39:28 <TheJulia> First and only listed topic of the week on the agenda is I believe rpittau's
15:39:36 * TheJulia hands the microphone to rpittau
15:40:12 <TheJulia> I guess I should do my best rpittau impression!
15:40:17 <iurygregory> package lost...
15:40:54 <TheJulia> So we've long been having an issue with the native OVMF package in bionic where TinyIPA machines freeze/fail to boot.
15:41:00 <TheJulia> #link https://bugs.launchpad.net/ubuntu/+source/edk2/+bug/1821729
15:41:02 <openstack> Launchpad bug 1821729 in edk2 (Ubuntu Cosmic) "UEFI in ovmf package causes kernel panic" [Undecided,Invalid]
15:41:51 <TheJulia> From my understanding, the the belief on the OVMF maintainer is that it is tinycore's kernel that is at fault for the crash
15:42:12 <TheJulia> which means we need to figure out our forward path
15:43:05 <TheJulia> I think rpittau is hoping that going to tinycore 11 will fix this, but I think it is time we discuss as a community what our next step should/could be for UEFI testing
15:43:07 <TheJulia> #link https://review.opendev.org/#/c/711647/
15:43:08 <patchbot> patch 711647 - ironic-python-agent-builder - [WIP] Use tinycore 11 - 4 patch sets
15:43:26 <openstackgerrit> Merged openstack/sushy master: Bump hacking to 3.0.0  https://review.opendev.org/715888
15:43:52 <dtantsur> will it help that we're switching the CI to DIB?
15:43:57 <TheJulia> I'm personally wondering if we just need to move UEFI to dib based...
15:44:06 <TheJulia> dtantsur: likely!
15:44:13 <dtantsur> problem solved? :)
15:44:14 <TheJulia> So it all may become moot in the end
15:44:38 <iurygregory> ++ for dib
15:45:23 <TheJulia> Okay then, well that seems to solve it, if there are no objections I think it is time to move to Open Discussion
15:45:50 <TheJulia> yay for netsplits
15:45:56 <iurygregory> wow
15:45:58 <dtantsur> Oo
15:46:02 <TheJulia> It is a thing
15:46:13 <TheJulia> #topic Open Discussion
15:46:23 <TheJulia> tzumainn: o/
15:46:34 <TheJulia> if you want to discuss the issue your encountering?
15:46:50 <tzumainn> TheJulia, hi! so I'm having issues with the suggested revisions on https://review.opendev.org/#/c/708678/
15:46:51 <patchbot> patch 708678 - ironic - Use auth values from neutron conf when managing Ne... - 2 patch sets
15:46:52 <rpittau> split all the things
15:47:17 <rpittau> did we get to talk about the ovmf issue ?
15:47:25 <iurygregory> rpittau, we did
15:47:38 <TheJulia> rpioso: yeah, we did, the feeling is dib will fix everything
15:47:38 <rpittau> ehm without me? :D
15:47:40 <tzumainn> for context, the suggested changes were to use openstacksdk, and to further split apart the port update operation to limit which fields were being updated through the admin
15:47:41 <iurygregory> the ping probably got lost =D
15:47:45 <TheJulia> rpioso: you netsplit
15:47:50 <iurygregory> rpittau, tldr switch to dib XD
15:48:05 <TheJulia> tzumainn: well, the fact openstacksdk doesn't support updating the mac is problematic and a solid reason to hold off on trying to use it for now
15:48:07 <rpioso> TheJulia: I'm not rpittau :-)
15:48:17 <TheJulia> rpioso: doh!
15:48:30 <rpioso> rpittau: o/
15:49:09 <tzumainn> TheJulia, okay! the second issue makes me wonder if it makes sense to isolate the update_port calls into a common/neutron.py method, and then... somehow checking that the user has the appropriate permissions on the affected network?
15:50:09 <tzumainn> because essentially checking field-by-field, operation-by-operation feels delicate to me, like a single accident could cause unintended exposure
15:50:23 <openstackgerrit> Iury Gregory Melo Ferreira proposed openstack/ironic master: Add ironic-standalone-redfish  https://review.opendev.org/712042
15:53:07 <TheJulia> That does seem problematic. hjensas, you know the neutron stuff really well. Any thoughts here because we don't want to become an engine to permit unauthorized port bindings to networks peopel shouldn't be touching because we need to update just a couple of the fields as an privilged account and then likely should step our access back down for the final requested action
15:54:46 <tzumainn> the reason I think that doing this field-by-field doesn't make sense, is that it looks like some of the update operations only update privileged fields
15:55:46 <TheJulia> I guess I'm sitting here wondering how port binding was working when we passed the context previouslly, but then the mac still required us to do it directly.... or was this a feature that only ever worked with Nova was infront of ironic?
15:55:50 <TheJulia> or the user was an admin user?
16:00:14 <TheJulia> heh, well there goes the hope on that thought
16:00:32 <TheJulia> I guess we're done with the meeting for now, tzumainn I think this discussion is going to continue.
16:00:45 <tzumainn> TheJulia, that's fine, thanks!
16:02:12 <TheJulia> #endmeeting