15:00:19 <dtantsur> #startmeeting ironic
15:00:20 <openstack> Meeting started Mon Jan 13 15:00:19 2020 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:23 <openstack> The meeting name has been set to 'ironic'
15:00:24 <dansmith> okay, that's what I thought
15:00:33 <iurygregory> o/
15:00:36 <jroll> \o
15:00:37 <rpittau> o/
15:00:37 <stendulker> o/
15:00:40 <bdodd> o/
15:00:40 <rpioso> \o
15:00:46 <dtantsur> dansmith: feel free to stay and have a meeting with us :)
15:00:46 <mgoddard> \o
15:00:50 <arne_wiebalck> o/
15:00:57 <dtantsur> welcome everyone!
15:00:58 <dansmith> dtantsur:  :)
15:01:06 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic Our agenda
15:01:09 <dtantsur> #chair TheJulia
15:01:10 <openstack> Current chairs: TheJulia dtantsur
15:01:29 <dtantsur> #topic Announcements / Reminder
15:01:47 <dtantsur> #link https://etherpad.openstack.org/p/ironic-ussuri-midcycle Proposed agenda items for the midcycle
15:01:52 <dtantsur> please add your ideas ^^^
15:02:18 <dtantsur> anybody has anything else to announce?
15:02:35 <rloo> o/
15:02:40 <iurygregory> CI broken yay
15:03:01 <dtantsur> for some definition of "yay" :)
15:03:20 <dtantsur> but yes, all devstack jobs (largely, all jobs that mention python 2 anywhere) are currently brokern
15:03:28 <iurygregory> http://lists.openstack.org/pipermail/openstack-discuss/2020-January/011960.html
15:03:28 <TheJulia> o/ from in-person meeting
15:03:30 <dtantsur> please hold on rechecking
15:04:10 <dtantsur> okay, let's roll on
15:04:11 <iurygregory> dtantsur, the yay is just to avoid put crying face
15:04:16 <dtantsur> heh
15:04:25 <dtantsur> #topic Review action items from previous meeting: http://eavesdrop.openstack.org/meetings/ironic/2020/
15:04:37 <dtantsur> Nothing here, just the updated link with s/2019/2020/
15:04:52 <dtantsur> Anyone had any unrecorded items?
15:05:11 <dtantsur> #topic Review subteam status reports (capped at ten minutes)
15:05:26 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard status start on line 277
15:05:51 <dtantsur> A regular reminder: please don't forget to update statuses before the meeting
15:07:28 <dtantsur> #info The in-band deploy steps spec has been approved
15:07:57 <dtantsur> mgoddard: your WIP patches seem to need a rebase
15:08:22 <dtantsur> tzumainn: hey! for the ownership work, do we have some action items after lessee?
15:08:29 <mgoddard> +1, I should update them for the new step names from the spec
15:08:51 <dtantsur> #info Managed boot for inspection has been completed
15:08:57 <tzumainn> dtantsur, hi! I didn't have anything in mind, aside from implementing lessee if approved
15:09:02 <dtantsur> ack
15:09:10 <tzumainn> dtantsur, if there's anything I might have forgotten just let me know
15:09:24 <rloo> etingof: wrt dhcp-less deployments, around L328, is that the right link for your revised spec?
15:09:25 <dtantsur> tzumainn: we need to try creating an end-to-end demo and see what we're missing
15:09:48 <dtantsur> rloo++ wrong link
15:10:13 <dtantsur> updated
15:10:19 <tzumainn> dtantsur, makes sense!
15:10:41 <dtantsur> tzumainn: do you plan on coming to our midcycle?
15:10:43 <TheJulia> Speaking of demos, we should ponder demoing newer features later this year
15:11:08 <dtantsur> very much ++
15:11:32 <dtantsur> arne_wiebalck: do you have any new status for node retirement?
15:11:58 <arne_wiebalck> dtantsur: no, I am about to start on this, though
15:12:01 <arne_wiebalck> hopefully
15:12:01 <tzumainn> dtantsur, I wasn't planning on it, no
15:12:04 <rloo> (i just updated the link to the story for the wsme-replacement work )
15:12:41 <dtantsur> #info mDNS IPv6 support has been completed
15:12:55 <dtantsur> We'll remove the finished items during the next meeting, I guess?
15:14:42 <rloo> great. and ++
15:14:44 <TheJulia> if striked out, makes sense
15:15:15 <dtantsur> Is everyone done with going through the statuses?
15:16:04 <iurygregory> I'm
15:16:15 * rloo is done
15:16:45 <dtantsur> #topic Deciding on priorities for the coming week
15:16:52 <dtantsur> Let me clean up the list
15:18:50 <dtantsur> FYI I'm moving the bifrost python 3 work to the top
15:18:57 <dtantsur> without it bifrost is outright broken
15:20:02 <dtantsur> Now, is there anything we should add to the list?
15:20:23 <iurygregory> yeah
15:20:30 * dtantsur wonders if mkrai is going to update https://review.opendev.org/#/c/672252/ soon
15:20:31 <patchbot> patch 672252 - ironic-specs - Add support for node reconfigure - 5 patch sets
15:20:35 <iurygregory> I think its ok to add https://review.opendev.org/#/c/696914/
15:20:36 <patchbot> patch 696914 - ironic-python-agent - Avoid grub2-install when on UEFI boot mode - 14 patch sets
15:20:52 <iurygregory> (CI is red because of devstack)
15:21:09 <TheJulia> dtantsur: That seems reasonable to me
15:21:35 <dtantsur> iurygregory: it's there now
15:21:50 <iurygregory> dtantsur, tks
15:21:58 <dtantsur> by the way, I forgot to mention but
15:22:17 <dtantsur> #info The DIB CI jobs are green now and are using CentOS 8. Please keep an eye on them.
15:22:39 <dtantsur> now, how's the priority list looking?
15:23:42 <rpittau> lgtm :)
15:23:53 * dtantsur is looking for a 2nd +2 now
15:25:23 * dtantsur hears fresh new year crickets
15:25:42 <mgoddard> looks like we have enough on there
15:25:44 <dtantsur> #topic Open discussion
15:26:09 <dtantsur> Does anyone have anything else to discuss?
15:26:25 <rloo> before i forget, i put as a note in the whiteboard (L233ish) wrt backports. discussed with julia so it isn't a policy, but decided to backport up to or down to pike.
15:26:35 <rloo> does that make sense to others?
15:27:38 <dtantsur> I'm not sure how possible it is to backport anything to pike at this point..
15:27:41 <dtantsur> but yes, it does
15:27:55 <rpittau> for some things it will be toughand not clean
15:27:57 <rloo> "if backporting, also backport to queens & pike, unless the cherry-pick is too difficult" :D
15:28:09 <rpittau> ^ soudns reasonable :)
15:28:12 <dtantsur> yep, that's a great way to put it
15:28:52 <dtantsur> #agreed If backporting, also backport to queens & pike, unless the cherry-pick is too difficult
15:28:53 <rloo> they are in extended maintenance so I didn't know what / if we should backport and/or review/merge them.
15:29:01 <dtantsur> we should but don't have to
15:29:13 <dtantsur> and if the CI is broken and nobody steps up, we're in our right to abandon a branch
15:29:15 <rloo> exactly. that's why i asked/wondered :)
15:29:28 <rloo> yes to abandoning CI for extended branch
15:29:39 <rloo> extended-maintenance branch
15:30:08 <rloo> is pike CI failing?
15:31:41 <dtantsur> no idea, I don't remember many backports there
15:31:57 <rloo> ok, just wondering. let's move on :)
15:31:59 <dtantsur> my corporate interest end at queens nowadays
15:33:26 <mgoddard> arne_wiebalck: will it be possible to join remotely for the midcycle?
15:33:45 <arne_wiebalck> mgoddard: yes
15:33:51 <mgoddard> arne_wiebalck: great :)
15:34:00 <arne_wiebalck> mgoddard: I'll circle instruction in due time
15:34:12 <rloo> hmm, just saw this link in our whiteboard. do we want/update it? https://etherpad.openstack.org/p/IronicHelpWanted
15:35:02 <dtantsur> rloo: it's mostly up-to-date, only the L3 spec seems to be in a healthy state now
15:36:08 <rloo> dtantsur: ok, i'm going to move it up then, above 'Prior Planning Documents'
15:36:15 <dtantsur> ++
15:37:08 <dtantsur> anything else we should talk about?
15:37:28 <arne_wiebalck> mgoddard: did John bring any feedback from the ops meetup?
15:38:02 <mgoddard> arne_wiebalck: good question. I'll be seeing him on Thursday
15:38:16 <arne_wiebalck> ok, thanks!
15:39:22 <dtantsur> a blog post/ML message is appreciated
15:39:34 <dtantsur> are we ready to wrap up now?
15:40:45 * dtantsur assumes yes
15:40:48 <dtantsur> thank you everyone!
15:40:50 <rloo> ++
15:40:56 <dtantsur> #endmeeting