15:01:43 <dtantsur> #startmeeting ironic
15:01:44 <openstack> Meeting started Mon May 20 15:01:43 2019 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:45 <dtantsur> #chair TheJulia
15:01:47 <openstack> The meeting name has been set to 'ironic'
15:01:47 <etingof> o/
15:01:48 <iurygregory> \o
15:01:49 <openstack> Current chairs: TheJulia dtantsur
15:01:50 <rpioso> \o
15:01:52 <arne_wiebalck> o/
15:01:54 <rpittau> o/
15:01:57 <dtantsur> okay, I could not resist, sorry :)
15:01:57 <openstackgerrit> Julia Kreger proposed openstack/ironic-specs master: Add train priorities  https://review.opendev.org/660145
15:02:03 <TheJulia> o/
15:02:04 <bdodd> o/
15:02:05 <TheJulia> woot!
15:02:05 <dnuka> \o/
15:02:07 <kaifeng> o/
15:02:10 <dtantsur> TheJulia: the mic is yours now :)
15:02:16 <TheJulia> dtantsur: thanks, I was just finishing up the priorities doc
15:02:20 <mgoddard> false start!
15:02:20 <TheJulia> o/ everyoen
15:02:21 <mgoddard> \o
15:02:34 <TheJulia> Sorry sorry!
15:02:39 * jroll sneaks in the back \o
15:02:43 <hjensas> o/
15:02:44 <dtantsur> no worries, last Monday I was 10 mins late :D
15:02:48 <TheJulia> lol
15:02:51 <dtantsur> it's hard to get back in schedule after PTO..
15:03:01 <TheJulia> Yeah, and I literally was on PTO last week
15:03:15 <jungleboyj> :-)
15:03:24 <TheJulia> Our agenda this week can be found on the wiki.
15:03:30 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic
15:03:35 <baha> o/
15:03:49 <TheJulia> #topic Announcements/Reminders
15:04:15 <TheJulia> #info Dmitry has written up notes from the PTG (Thanks Dmitry!) and shared them with the world.
15:04:24 <TheJulia> #link https://dtantsur.github.io/posts/ironic-denver-2019/
15:04:34 <cdearborn> 0/
15:04:57 <TheJulia> #info The Next PTG will be in Shanghai on November 6th through 8th.
15:05:16 <TheJulia> Does anyone have anything to add or remind us of?
15:05:33 <jungleboyj> Wow, look like good notes.
15:06:01 <dtantsur> :)
15:06:44 <TheJulia> I guess not...
15:06:55 <TheJulia> items to raise that is :)
15:07:08 <TheJulia> dtantsur: I'm sorry, I've not had time to look at your notes yet. Hopefully later today :)
15:07:27 <dtantsur> No problem, they will be waiting for you :)
15:07:31 <rpioso> They're awesome!
15:07:31 <TheJulia> \o/
15:07:39 <dtantsur> thx :)
15:07:40 <TheJulia> Moving on then!
15:07:43 <TheJulia> #topic Review action items from previous meeting
15:08:07 <TheJulia> #info We had no formal action items from last week, but I know there was post meeting discussion of someone emailing regarding the baremetal sig.
15:08:20 <TheJulia> Since I've barely even started looking at my email, did that take place?
15:08:27 <dtantsur> arne_wiebalck: I think it was you ^^
15:08:34 <dtantsur> and I think I've seen some email
15:08:40 <arne_wiebalck> I contacted Chris.
15:08:54 <TheJulia> Okay, then I think we can move along then :)
15:08:55 <arne_wiebalck> I don't think he's sent sth out.
15:09:08 <dtantsur> we also had an implicit action item to fix the CI, and we did it (modulo the non-voting multinode grenade job)
15:09:23 <TheJulia> ugh
15:10:46 <TheJulia> It does not look like an email went to a mailing list, at least one that shows in my mailing list mailbox inbox
15:10:56 <TheJulia> #action TheJulia follow-up on baremetal sig communication
15:11:17 <TheJulia> Moving on!
15:11:19 <TheJulia> #topic Review subteam status reports
15:11:39 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:11:45 <TheJulia> Starting around line 217
15:12:28 <TheJulia> Looks like Software raid could use some reviews?
15:12:37 <arne_wiebalck> Yes, please :)
15:13:05 <arne_wiebalck> Some reviews were already done, thanks!
15:13:05 <dtantsur> ++
15:13:07 <TheJulia> I'm going to strike out the bulk of deploy templates, since step decomposition will replace it
15:13:18 <dtantsur> I was going to get there, but $errands
15:13:55 <TheJulia> Has anyone started ropping the py35 tests?
15:13:58 <TheJulia> well, test jobs
15:14:14 <rpittau> yes, I saw at least 2 changes
15:14:18 <dtantsur> I think most of our projects don't have them
15:14:24 <rpittau> https://review.opendev.org/652385
15:14:24 <dtantsur> note that we shouldn't literally drop them
15:14:25 <patchbot> patch 652385 - networking-generic-switch - Dropping the py35 testing - 2 patch sets
15:14:37 <dtantsur> there is a new template in zuul per version
15:14:42 <TheJulia> dtantsur: ++
15:14:54 <dtantsur> I don't recall the name, something like python-train-jobs
15:15:16 <TheJulia> dtantsur: can you investigate and follow-up for our next meeting for that?
15:15:27 <dtantsur> I can try
15:15:32 <TheJulia> Thanks
15:16:25 <TheJulia> fast track... one day I'll write docs :(
15:16:40 <TheJulia> etingof: how is redfish virtual media going?
15:16:58 * dtantsur hides
15:17:02 <dnuka> :)
15:17:04 <etingof> TheJulia, simulation is up and running
15:17:20 * etingof is debugging redfish hw type against the simulator
15:17:30 <TheJulia> awesome
15:17:39 * etingof gets up to the point where VM is [not] booting
15:17:41 <TheJulia> etingof: Could you update the whiteboard in that case?
15:17:45 <etingof> sure
15:17:48 <TheJulia> Thanks!
15:18:17 <TheJulia> The locking item is not on the proposed priority list, but it is stil a nice to have general improvement that we have some consensus behind. Looks like I need to rebase that. hopefully this week.
15:18:26 <dtantsur> ++
15:18:41 <TheJulia> arne_wiebalck: re nova callbacks, is it just power, or is there work in progress for state at this time?
15:19:16 <arne_wiebalck> TheJulia: Not sure I understand the question, sorry.
15:19:53 <TheJulia> arne_wiebalck: I know you've been invovled in some of the power call back discussikons with nova, does that include state callbacks or just power?
15:20:25 <dtantsur> I forgot to announce it, but better late than never: two outreachy interns are joining us for summer!
15:20:25 <arne_wiebalck> Only power.
15:20:38 <jungleboyj> dtantsur:  Nice.
15:21:19 <TheJulia> dtantsur: \o/
15:21:21 <dnuka> \o/
15:21:23 <TheJulia> arne_wiebalck: okay
15:21:39 <rpioso> dtantsur: Great news :)
15:21:43 <dtantsur> one will work on sushy, the other - on ironic-python-agent-builder
15:21:50 <TheJulia> cool
15:23:29 <arne_wiebalck> TheJulia: The power stuff is difficult enough ;)
15:23:35 <TheJulia> The rest of the items on the whiteboard were dropped from Stein. They are, as far as I'm remembering from typing, not in the proposed patchset for train
15:23:42 <TheJulia> arne_wiebalck: Yeah, and it still helps a LOT!
15:24:03 <dtantsur> TheJulia: maybe for Train we can have two sections: 1. Priorities, 2. Things people care about that progress well
15:24:16 <TheJulia> ++
15:24:19 <dtantsur> that's essentially what we had for Stein, but expressed explicitly
15:24:34 <TheJulia> kind of, but I divided that by size of work
15:24:50 <TheJulia> Anyway, the change for the train priorities is up in review
15:24:55 <dtantsur> great!
15:25:07 <TheJulia> #link https://review.opendev.org/#/c/660145/
15:25:08 <patchbot> patch 660145 - ironic-specs - Add train priorities - 1 patch set
15:26:02 <TheJulia> So I guess we're good to proceed onward?
15:27:32 <dtantsur> yep
15:27:33 <rpittau> let's!
15:27:40 <TheJulia> #topic Deciding on priorities for the coming week
15:27:52 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:27:55 <TheJulia> Starting around line 123
15:28:52 <TheJulia> Looks like a few items have merged
15:29:00 <TheJulia> A few items are stable-core reviews
15:29:23 <TheJulia> Speaking of which, tonyb, let us know if the overall policy has been updated as discussed in Denver
15:29:45 <TheJulia> I'm going to remove merged items
15:30:11 <TheJulia> Are tehre any other items that people feel need to be on this list?
15:30:31 <mgoddard> added one for nova
15:30:36 <mgoddard> https://review.opendev.org/659809
15:30:37 <patchbot> patch 659809 - nova - [ironic] Don't remove instance info twice in destroy - 1 patch set
15:31:04 <bdodd> Could use reviews on this sushy patch https://review.opendev.org/#/c/657688/
15:31:04 <patchbot> patch 657688 - sushy - Enhance Storage models to support RAID config - 3 patch sets
15:31:05 <mgoddard> efried has said he will proxy a +1 from an ironic-core
15:31:12 <TheJulia> I've not looked at your patch mgoddard, but why just not ignore it?
15:31:28 <TheJulia> mgoddard: are you thinking from a backport standpoint?
15:31:48 <mgoddard> TheJulia: it requires you to wait for all the retries
15:32:10 <TheJulia> I clearly need more coffee
15:32:11 <kaifeng> I'd like to have some reviews on the spec https://review.opendev.org/#/c/650630/
15:32:12 <patchbot> patch 650630 - ironic-inspector-specs - Introduce etcd for service coordination - 4 patch sets
15:32:23 <dtantsur> oh, this ^^ is a good one
15:32:28 * dtantsur +1 to adding it
15:32:41 * TheJulia adds to the lists
15:32:46 <kaifeng> thanks :)
15:33:01 <bdodd> \o/
15:33:04 <TheJulia> mgoddard: looks like you already got your patch
15:33:34 <TheJulia> Okay, if there is nothing else, I guess we can mov on to Baremetal sig
15:35:43 <TheJulia> #topic Baremetal Sig
15:35:57 <TheJulia> Hmm.. No Chris. :\
15:36:25 <arne_wiebalck> I think the main task for now would be to complete the white paper.
15:36:28 <TheJulia> Okay, Well use case documentation is in the list of goals for train. Has anyone had time to look at or discuss the white paper?
15:36:31 <TheJulia> ++
15:37:00 * TheJulia wonders if "review the whitepaper is a thing we could put on the priorities for the week.
15:37:01 <TheJulia> "
15:37:09 <jungleboyj> I have followed up with Lenovo and have a couple of people that would like to get involved.
15:37:15 <TheJulia> \o/
15:37:19 <TheJulia> jungleboyj: that is awesome news
15:37:38 <jungleboyj> Yeah, not sure if they have joined the meeting.  May need to get them up to speed.
15:38:05 <jungleboyj> I got the feeling at the summit though, that we didn't really know what the next steps for the WhitePaper were though.
15:38:26 <arne_wiebalck> jungleboyj: The work on the document has started.
15:38:29 <TheJulia> Largely it was use cases
15:38:34 <TheJulia> and operator cases
15:38:40 <arne_wiebalck> jungleboyj: More use cases are probably needed
15:38:58 <jungleboyj> Ok.
15:39:28 <TheJulia> #link https://docs.google.com/document/d/1KBhJcmpCTm8hn0BX-jO5MAyBYf2RHM5Jh5ib7GTZogM/edit#heading=h.1jw85s2vpx7q
15:39:51 <TheJulia> Also some context on use, which I think this team can add quite a bit about
15:40:30 <TheJulia> Maybe us engineering types should start on the last page and move forward :)_
15:40:34 <TheJulia> s/_//
15:40:45 <jungleboyj> :-)
15:40:54 <TheJulia> Anyhow, if there is nothing else to discuss re the white paper, we can move along to RFE review
15:41:27 <jungleboyj> I will keep following up with my team.
15:41:44 <TheJulia> jungleboyj: Awesome, thanks
15:41:49 <TheJulia> Moving on to RFE review
15:41:53 <TheJulia> #topic RFE Review
15:42:09 <TheJulia> #link https://review.opendev.org/#/c/656799/4
15:42:10 <patchbot> patch 656799 - ironic-specs - Add support for node retirement - 4 patch sets
15:42:39 <TheJulia> I've not had a chance to read this sadly
15:43:00 <arne_wiebalck> This will probably need to be superseded by a more general proposal.
15:43:36 <arne_wiebalck> I'll try to gather more use cases and make a suggestion.
15:43:37 <TheJulia> I think we're generally open to general proposals and the overall theme is covered by the train priorities... It hink
15:43:39 <TheJulia> think
15:44:07 <dtantsur> I guess the key point is to avoid inventing the same feature under two slightly different flavors
15:44:15 <TheJulia> ++
15:44:15 <dtantsur> i.e. retirement and quarantine
15:44:24 <TheJulia> I suspect we'll need separate workflows
15:44:25 <arne_wiebalck> dtantsur: totally agree
15:44:33 <dtantsur> I remember discussing it last time and... I don't remember anything from then :(
15:44:35 <TheJulia> but overall mechanics under the hood should be similar
15:44:44 <TheJulia> Sounds like we all need coffeee
15:44:46 <TheJulia> \o/ coffee
15:45:04 <TheJulia> I guess we can talk about the next item then. A deployment API
15:45:05 <TheJulia> #link https://storyboard.openstack.org/#!/story/2005737
15:45:17 <rpittau> I know we don't want to overload "maintenance", but quarantine sounds like an extended maintenance ? :)
15:45:32 <arne_wiebalck> One point will be whether or not this need to be a state (or a flag).
15:45:40 <TheJulia> rpittau: but it is still a state of being for for the node.. :\
15:45:44 * arne_wiebalck was surprised to see how ops voted at the ptg
15:45:49 <rpittau> yeah, right
15:45:58 * TheJulia barely remembers that now
15:46:09 <arne_wiebalck> state:4, flag: 0
15:46:36 <arne_wiebalck> flag seems more natural to me tbh
15:46:52 <arne_wiebalck> (and easier :-D)
15:47:06 <dtantsur> a flag it's definitely easier, but also less visible
15:47:13 <arne_wiebalck> dtantsur: true
15:47:23 <TheJulia> dtantsur: re your deployment api.... I think your missing instance_uuid since that needs to match nova's already created DB entry
15:47:53 <TheJulia> a flag also gets us into lots of corner case code that is less visible when we go through the code :\
15:47:54 <dtantsur> TheJulia: instance_uuid is implicit there. it's either set in advance or can be set to deployment UUID
15:48:11 <dtantsur> I will mention it in the spec, if we decide it needs a spec
15:48:40 <TheJulia> dtantsur: I'm not sure a spec is really required, it is fairly clearly a pass-through (in flask maybe?!?)
15:48:53 <arne_wiebalck> but a flag can be carried around while walking the state machine
15:49:01 <TheJulia> POST /v1/deployments/instance_uuid ?
15:49:07 <dtantsur> yeah, it's largely a pass-thru to Node, although it will probably have to have a short record in the database
15:49:24 * arne_wiebalck wonders if we have two discussions at the same time :)
15:49:27 <dtantsur> TheJulia: you mean, make Deployment UUID == Allocation UUID?
15:49:29 <TheJulia> arne_wiebalck: yeah... And I think that is where the two features begin to differ
15:49:30 <dtantsur> arne_wiebalck: we do :)
15:49:50 <arne_wiebalck> ok, let's stop the quarantine one for now
15:49:56 <TheJulia> dtantsur: well, if one was chosen externally, one has to be able to define it
15:50:09 <TheJulia> oh, but I just had a thought :)
15:50:16 <TheJulia> re quarentine :)
15:50:18 * TheJulia stops now
15:50:31 <TheJulia> I seriously need more coffee and we only ahve 10 minutes left
15:50:57 <TheJulia> I'm basically good with the rfe for the API. I do think a quick spec is going to be useful since the proposal is a tl;dr :)
15:51:11 <dtantsur> yeah, I'll probably write something this week
15:52:11 <TheJulia> k
15:52:21 <TheJulia> I guess that leaves us to open discussion!
15:52:26 <TheJulia> #topic Open Discussion
15:52:34 <TheJulia> Does anyone have anything to discuss during the meeting?
15:53:52 * TheJulia hears the army of crickets appear
15:54:42 <dtantsur> :)
15:58:34 <TheJulia> Well everyone, thanks!
15:58:37 <TheJulia> Have a wonderful week!
15:58:55 <jungleboyj> Thank you.
15:58:57 <rpittau> thanks! you too!
15:59:11 <openstackgerrit> Riccardo Pittau proposed openstack/ironic-python-agent stable/rocky: [WIP|DNM] testing coreos jobs  https://review.opendev.org/656507
15:59:14 <kaifeng> Thank you
15:59:29 <arne_wiebalck> Thanks!
15:59:42 <rpioso> Thank you, and welcome back TheJulia.
15:59:54 <dnuka> thank you TheJulia
16:00:11 <TheJulia> #endmeeting