15:00:18 <TheJulia> #startmeeting ironic
15:00:19 <openstack> Meeting started Mon Feb 11 15:00:18 2019 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:20 <dtantsur> o/
15:00:21 <TheJulia> o/
15:00:22 <openstack> The meeting name has been set to 'ironic'
15:00:23 <iurygregory> o/
15:00:24 <rpittau> o/
15:00:25 <dnuka> o/
15:00:26 <rpioso> o/
15:00:29 <etingof> \o/
15:00:36 <bdodd> o/
15:00:42 <TheJulia> In accordance with Universal Greeting Time... Good Morning everyone!
15:00:59 <cdearborn> o/
15:01:02 <tendulke> o/
15:01:09 <TheJulia> Our agenda is a bit long this morning, but luckily most of it is announcements.
15:01:10 <TheJulia> \o/
15:01:13 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:01:25 <TheJulia> #topic Announcements / Reminder
15:01:34 <openstackgerrit> Dmitry Tantsur proposed openstack/ironic-tempest-plugin master: Allocation API: functional tests  https://review.openstack.org/635882
15:01:45 <TheJulia> #info This week is R-8 of the Stein development cycle.
15:01:51 <rajinir> o/
15:01:56 <TheJulia> #info Approximately 2 more weeks are available for non-client libraries
15:02:07 <hjensas> o/
15:02:07 <TheJulia> #info Approximately 3 weeks are available for client libraries
15:02:22 <dtantsur> non-client includes sushy, right?
15:02:25 <TheJulia> It goes without saying, review bandwidth and willingness to revise patches the next couple of weeks is going to be vital
15:02:41 <TheJulia> dtantsur: yes, if we need to change a requirement
15:03:26 <TheJulia> #info TC self nominations should occur this week
15:03:34 <jroll> \o
15:03:40 <rloo> o/
15:03:56 <TheJulia> #info A baremetal sig has been forming, please join in!
15:03:57 <TheJulia> #link  https://etherpad.openstack.org/p/bare-metal-sig
15:04:45 <TheJulia> And our last item for the week (hopefully) is that I have created a brainstorming etherpad for Train. We can use this for the PTG and Forum sessions. Please add any and all ideas. No idea is too crazy!
15:04:47 <TheJulia> #link https://etherpad.openstack.org/p/DEN-train-ironic-brainstorming
15:05:04 <TheJulia> Does anyone else have anything to announce or remind us of?
15:06:04 <TheJulia> I guess that is a no.
15:06:09 <TheJulia> Moving on!
15:06:12 <TheJulia> #topic Review action items from previous meeting
15:06:45 * dtantsur types things into the etherpad
15:06:48 <TheJulia> One action item remains from last week, which I'll be carrying over, which is sending a summary email from the PTG. The etherpad is actually an open browser tab now, just finding time()
15:07:06 <TheJulia> err, midcycle
15:07:17 <TheJulia> #action TheJulia needs to send a mid-cycle calls summary
15:07:37 <TheJulia> Moving on!
15:07:38 <TheJulia> #topic Review subteam status reports
15:07:50 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:08:07 <TheJulia> Starting around line 290!
15:09:05 <TheJulia> rloo: thanks for the update :)
15:09:17 <rloo> TheJulia: yw :D
15:10:32 <rloo> wrt Python3. There's a question there, did anyone answer? L321 'do we want to migrate ironicclient'?
15:10:42 <rloo> L325 and moving :)
15:11:27 <jroll> why wouldn't we want to move the client?
15:11:30 <TheJulia> etingof: re execution improvements, do you feel we're basically done for now. I know your working on the sorting idea
15:11:40 <jroll> everything needs to move, py2 is dead very soon
15:11:42 <rloo> jroll: yeah, that's what i am wondering. maybe the focus was just on ironic?
15:12:02 <jroll> ¯\_(ツ)_/¯
15:12:04 <TheJulia> I believe the patches are already up
15:12:11 <rpittau> I guess ironic got precedence considering the complexity ?
15:12:22 <rloo> jroll: i guess we need someone to go through all the ironic-related projects and make sure we have done them all (or know what hasn't been done)?
15:12:26 <rloo> i will answer yes then :)
15:12:43 <etingof> TheJulia, we can consider it done, though I still have some ideas re having a more efficient IPMI client in ironic. but may be we could work on that separately
15:12:46 <TheJulia> I think those questions are also months old.
15:13:20 <rloo> TheJulia: my bad; I clearly didn't read the status stuff carefully. Should have asked that months ago :-(
15:13:33 <rloo> TheJulia: oh, so should we just delete that line?
15:14:00 <TheJulia> rloo: likely, the whole list needs a good scrub, maybe after this meeting :)
15:14:15 <rloo> TheJulia: ok, will leave it for you/derek. thx!
15:14:27 <TheJulia> jroll:  still end of feburary for IPA<->ironic stuffs?
15:14:49 <TheJulia> I fear we might have to let that slip, but the client is also built into IPA so *shrugs*
15:14:52 <jroll> TheJulia: idk. maybe.
15:14:55 <jroll> same
15:14:57 <TheJulia> ack
15:15:14 <jroll> I imagine review will be long
15:15:19 <rloo> i always forget. ipa is NOT a library, right?
15:16:29 <TheJulia> it is not
15:16:41 <rloo> good
15:16:42 <TheJulia> jroll: likely, so should we just consider it towards next cycle?
15:17:02 <jroll> TheJulia: yeah, hopefully will start before, but don't expect it to land this cycle
15:17:11 <TheJulia> ack ack
15:17:51 <TheJulia> Neutron event processing looks okay, some rebasing needed there.
15:17:59 <TheJulia> Smartnics is also looking great \o/
15:18:17 <TheJulia> I'm done with the list, and I promise I'll do some clean-up on the etherpad today
15:18:31 <TheJulia> Does anyone have any more questions regarding subteam statuses, or are we good to proceed?
15:18:38 * dtantsur is good
15:18:49 <rloo> crickets are moving forward
15:19:08 <TheJulia> #topic Deciding on priorities for the coming week
15:19:26 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:19:28 <rpittau> I have one concern for the graphical console, but can wait to open discussion maybe
15:19:30 <TheJulia> Starting at line 159
15:19:37 * TheJulia removes merged items from the list
15:19:45 <rpittau> and nvm, just saw your comment TheJulia :)
15:19:49 <TheJulia> BTW, we got a number of huge things merged last week, thanks everyone!
15:20:41 <rloo> whee, thx everyone :)
15:20:49 <jroll> nice
15:20:57 <TheJulia> Removing the locking patch due to lack of interest at this time, I'll try to rebase it occassionally.
15:21:55 <TheJulia> I guess the housekeeping stuff makes sense to move into the list
15:22:09 <TheJulia> From below line 217
15:22:20 <arne_wiebalck> o/
15:22:37 <dtantsur> I'd love the JSON RPC thingy to get on the list
15:22:55 <TheJulia> That seems really flashy for those reading the release notes
15:23:11 <TheJulia> So I totally agree
15:24:36 <rloo> is xclarity gone?
15:24:36 <TheJulia> That really just leaves the smartnic work, and they have 3 api related changes outstanding, one for ironic's API. I think we should review that this week and hopefully get it merged
15:25:23 <rloo> I'm going to delete the vendor priority for idrac (L271). looks like the ball is in idrac's court since last year.
15:25:36 <TheJulia> rloo: xclarity has a CI up ... might be failing at the moemnt. It is cisco's CI that is gone it seems.
15:25:59 <rloo> TheJulia: thx.
15:27:50 <TheJulia> Updated the note on the cisco driver
15:28:15 <rloo> thx again TheJulia!
15:28:36 <TheJulia> Everyone good with the growing list? Please keep in mind we merged a number of things that conflict with other patches for silly reasons, we shouldn't be afraid of rebasing anything out there
15:28:45 <TheJulia> (merged last week that was)
15:29:27 <dtantsur> the list is huge, probably a few weeks of work :) but everything seems ready, so why not
15:29:42 <dtantsur> TheJulia: you have smartnic duplicated
15:29:48 <TheJulia> woot!
15:29:51 <dtantsur> 202 and 230
15:29:52 <TheJulia> dtantsur: can you delete the dupe
15:29:55 <dtantsur> k
15:29:58 <TheJulia> thanks
15:30:07 <TheJulia> dtantsur: Do you still want time to discuss json-rpc?
15:30:31 <dtantsur> Well, if nobody disagrees with it, we can just move on and merge :)
15:30:42 <dnuka> :)
15:30:43 <TheJulia> I like that idea
15:30:59 <TheJulia> If that is the case, then we can jump to open discussion :)
15:31:07 <rloo> dtantsur: is the json-rpc thing one of the weekly priorities?
15:31:26 <dtantsur> yep
15:31:51 <rloo> dtantsur: ok
15:32:19 <TheJulia> #topic Open Discussion
15:32:47 <TheJulia> I had one thing I wanted to discuss during open discussion (because I added it late to the agenda)
15:33:16 <dnuka> folks, I could really use some reviews on,
15:33:21 <dnuka> https://review.openstack.org/#/c/608563/ and
15:33:22 <patchbot> patch 608563 - sushy - Add support for the `CompositionService` resource - 18 patch sets
15:33:35 <dnuka> https://review.openstack.org/#/c/613828/
15:33:36 <patchbot> patch 613828 - sushy - Add support for the `UpdateService` resource - 20 patch sets
15:33:39 <dnuka> :)
15:34:00 <TheJulia> The eventing work, I feel like it would make sense to at least get the API in ironic merged, even if it is effectively a noop and/or get the sender merged on networking-baremetal even if we just have it tolerate ironic going "I have no idea what this is" (which it really should anyway)
15:34:12 <etingof> dnuka just got the latter reviewed
15:34:30 <dnuka> etingof, thanks :)
15:35:05 <hjensas> TheJulia: I will rebase them again, looks like the fight for api versions is on-going. :)
15:35:07 <dtantsur> TheJulia: well, given that we have the noop network interface which IS going to ignore events, I think it's fine.
15:35:11 <jroll> TheJulia: so you're saying merge the code as-is?
15:35:29 <jroll> er, the api code
15:35:52 <TheJulia> jroll: Yeah, where it doesn't trigger anything in the conductor, that way we can continue to work on it
15:36:09 <jroll> okay. I don't have a problem with that
15:36:14 <jroll> it's not any worse than today
15:36:20 <TheJulia> I think we're kind of stuck on that work and ultimately hurt upgrade ability paths by trying to work everything from the conductor out
15:36:25 <jroll> then we can get clients hooked up and go from there
15:36:54 <TheJulia> And yeah, the fight for API microversion numbers is a struggle :)
15:37:56 <TheJulia> It feels like there is no real objection and I think we're basically aligned on the idea
15:39:39 <TheJulia> Okay then!
15:39:47 <TheJulia> Does anyone else have anything they would like to discuss?
15:40:03 <TheJulia> The weather? crazy ideas for ironic?
15:40:14 <dtantsur> the weather is dull
15:40:26 <TheJulia> Speaking of crazy ideas, I'm still hacking along on the fast track idea
15:40:28 * iurygregory weather is crazy is Brno =P
15:40:28 <dtantsur> and I have a lot of crazy ideas, but I've put them on the Forum/PTG etherpad
15:40:50 <dtantsur> I even added fast-track for you TheJulia :)
15:40:52 <TheJulia> iurygregory: and I'm still struggling with whatever I picked up there
15:40:55 <TheJulia> <3
15:41:11 <TheJulia> mgoddard: I did start looking at doing the whole path through cleaning too
15:41:15 <iurygregory> TheJulia, get better \o/
15:41:19 <rpittau> just wondering if we should rename console to serial_console
15:41:48 <TheJulia> rpittau: That is.... a very good question
15:41:55 * TheJulia is conflicted
15:42:01 <rpittau> I mean, we have now a field called console_enabled
15:42:06 <rpittau> and well....
15:42:09 <TheJulia> I think we would essentially have to do like a v2 api cut and all
15:42:32 <rpittau> since we're going to introduce a console_type anyway
15:42:36 <TheJulia> but yeah, your right about that, and the real driver for seprating them is people using the ipmi sol/serial console to do logging
15:42:50 <openstackgerrit> Merged openstack/ironic-tempest-plugin master: Enable tempest run -l without credential setting  https://review.openstack.org/634641
15:42:53 <rloo> rpittau: that is a very good question. seems like we thought about it way back when.
15:43:07 <rloo> rpittau: don't recall what/if we decided on anything. might be in the spec?
15:43:07 <dtantsur> renaming in API is quite inconvenient
15:43:22 <TheJulia> rpittau: I think that would definitely be larger community discussion topic at a minimum. I'd <3 to see an email, but as dtantsur points out, it would be hugely painful to do right now
15:43:38 <TheJulia> email to the mailing list that is
15:44:07 <rpittau> no, I know, I'm not saying it should happen now :D
15:44:40 <TheJulia> Understood, but popularizing the idea earlier always helps.
15:44:57 <etingof> pardon my ignorance, but is a non-bool option for console_enabled an option? like console_enabled=serial|graphical
15:45:08 <rpittau> etingof, it's boolean :/
15:45:18 <rpittau> https://github.com/openstack/ironic/blob/master/ironic/db/sqlalchemy/models.py#L174
15:45:30 <dtantsur> etingof: these are not mutually exclusive
15:45:40 <etingof> I mean changing type is as painful as changing name?
15:45:48 <dtantsur> no, it's more painful :)
15:45:53 <etingof> good
15:46:08 <dtantsur> because you'll have a database migration to change all data
15:46:17 <dtantsur> because of rolling upgrades you'll have to do it via a rename :)
15:46:41 <etingof> sounds torturing
15:46:46 <dtantsur> indeed
15:46:47 <rloo> database migration isn't painful. just. is. involved...
15:47:15 * iurygregory database migration reminds me about online data migrations for boot_interface =(
15:47:37 <TheJulia> Yeah, many different directions :(
15:47:55 <TheJulia> Anyway, things to think about
15:48:20 <TheJulia> Does anyone have anything else? Or shall we go back to making ironic take over the world?
15:48:45 <dtantsur> absolute power!!
15:48:58 <iurygregory> \o/
15:49:03 <TheJulia> Excellent!
15:49:14 <TheJulia> Thanks everyone! Have a wonderful day!
15:49:27 <dtantsur> thanks TheJulia
15:49:28 <rpittau> thanks!
15:49:30 <iurygregory> thanks
15:49:32 <jroll> thanks!
15:49:35 <TheJulia> #endmeeting