15:00:07 <TheJulia> #startmeeting ironic
15:00:09 <openstack> Meeting started Mon Oct 22 15:00:07 2018 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:09 <TheJulia> o/
15:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:11 <iurygregory> o/
15:00:12 <openstack> The meeting name has been set to 'ironic'
15:00:12 <TheJulia> Good morning everyone!
15:00:16 <etingof> o/
15:00:17 <jiapei> o/
15:00:17 <stendulker> o/
15:00:20 <bdodd> o/
15:00:23 <jroll> \o
15:00:27 <hshiina> o/
15:00:27 <dtantsur> o/
15:00:32 <rloo> o/
15:00:39 <TheJulia> Our agenda for this week can be found on the wiki.
15:00:40 <kaifeng> o/
15:00:42 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:01:17 <TheJulia> It looks like there is nothing beyond our normal meeting agenda today, so hopefully we'll be able to wrap up this meeting fairly quickly.
15:01:29 <TheJulia> #topic Announcements/Reminders
15:02:20 <TheJulia> #info We're a few weeks out from the summit in Berlin. If there is anything that anyone wishes to have raised during the Project Onboarding, Project Update, or during the feedback session, please let me know.
15:02:34 * dtantsur wishes to raise a pint
15:02:48 <TheJulia> dtantsur: ?
15:02:58 <jroll> heh
15:02:59 * TheJulia is all for a pint, but it is also 9am local :)
15:03:15 <dtantsur> TheJulia: in Berlin, I mean :) Isn't it a great way to onboard people?
15:03:21 <TheJulia> dtantsur: ++++
15:03:27 <iurygregory> lol
15:03:34 <jroll> can leave this for open discussion, but should we put together a meetup?
15:03:35 <hjensas> o/
15:03:43 <dtantsur> jroll: I was about to ask the same
15:03:44 <TheJulia> Anyone have anything else to raise or announce today?
15:03:50 <rloo> ein stein I'm guessing? :)
15:03:50 <dtantsur> but yeah, let's wait for the open discussion
15:04:13 <TheJulia> Okay, moving on!
15:04:19 <stendulker> All iLO 3rd party CI jobs are moved to python3 except for one that would run on python2.
15:04:20 <mjturek> o/
15:04:31 <dtantsur> stendulker: nice!
15:04:37 <rloo> nice stendulker! :)
15:04:38 <TheJulia> stendulker: That is awesome news, could you share an example?
15:05:18 <TheJulia> #topic Review action items from previous meeting
15:05:26 <TheJulia> #info No action items from the last meeting
15:05:34 <TheJulia> #topic Review subteam status reports
15:05:38 <stendulker> TheJulia: https://review.openstack.org/#/c/608868/
15:05:39 <patchbot> patch 608868 - ironic - Passing thread pool size to IPA - 2 patch sets
15:05:45 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:05:58 <TheJulia> Starting around line 172
15:06:20 <rloo> dtantsur: yup, i care about the bug numbers :)
15:06:30 <dtantsur> okay, recorded, I'll keep doing it :)
15:06:50 <rloo> what i don't understand is why so many are untriaged. is it cuz we're still catching up on storyboard?
15:07:04 <dtantsur> are we actively triaging them?
15:07:11 <dtantsur> if no, the growth is expected
15:07:34 <TheJulia> I'm only getting to them a couple times a month, but they don't seem to grow that fast
15:07:58 * etingof reminds to tag those with `ironic-triaged`
15:07:58 <TheJulia> I guess it would likely be good for me to try and compare the counting logic, maybe I've been setting the wrong flags or something
15:08:21 <rloo> who's doing the python3 first stuff? (no name there)
15:08:44 <TheJulia> rloo: I think that is largely falling to the PTL
15:09:06 <rloo> TheJulia: oh :-( Any volunteers for that?
15:09:11 <TheJulia> Derek and myself
15:10:05 <TheJulia> I'm really impressed with just the number of things we've got moving forward right now
15:11:16 <TheJulia> jroll: do you feel that there is any action on our part at this moment for nova supporting conductor grouping in nova-compute processes?
15:11:46 <jroll> TheJulia: no, just the spec back and forth right now
15:11:53 <jroll> I'll pull people in ad hoc if I need eyes :)
15:12:02 <TheJulia> jroll: ack, thanks
15:12:38 <rloo> TheJulia: can we amalgamate/remove some of the stuff under Rocky Priorities (L267) ?
15:13:22 <TheJulia> I believe mgoddard is attempting to play the game and looking at pretty buildings in far away places, so I suspect we should just try and review the updated deploy templates spec this week
15:13:48 <rloo> heh, i think there was a graphical console update from mkrai, under the Rocky part. i didn't catch what it was before it was deleted. probably not a big deal.
15:13:50 <TheJulia> Or so suggests twitter :)
15:14:05 <TheJulia> rloo: It looked outdated to me
15:14:16 <rloo> TheJulia: ok
15:14:56 <TheJulia> hshiina: I think your closer to her timezone and have been reviewing. Would you mind following up with her?
15:16:22 <hshiina> TheJulia, sure
15:16:26 <TheJulia> hshiina: thanks :)
15:17:07 <openstackgerrit> Merged openstack/ironic master: Add version discovery information to the /v1 endpoint  https://review.openstack.org/596671
15:17:18 <dtantsur> mordred: ^^^
15:18:05 <TheJulia> Is everyone good to proceed?
15:18:20 <rloo> ++
15:18:28 <mordred> \o/
15:18:31 * mordred does a little dance
15:18:59 * TheJulia notes it is rare for a dancing mordred in channel
15:19:10 <TheJulia> Moving on to priorities if there are no objections
15:19:26 <TheJulia> #topic Priorities for the next week
15:19:53 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:19:57 <TheJulia> Starting at line 93
15:20:20 <TheJulia> I'd like to remove graphical console for this next week, we have a number of housekeeping and smaller patches that could use eyes this week.
15:20:40 <TheJulia> hjensas: any more inspector grenade fixes?
15:21:12 <hjensas> TheJulia: no, they both merged and the configurable timeout made it in.
15:21:23 <rloo> i was looking at the redfish oob inspection stuff (L270). is there just one patch that is left to do/review?
15:22:00 * TheJulia guesses there are no objections re graphical console for this week?
15:22:16 <TheJulia> rloo: I _think_ so...
15:22:17 <etingof> there were also sushy changes related to OOB, but most of them were merged I think
15:22:23 <mjturek> +1 since we're waiting on revisions anyway right?
15:22:26 <TheJulia> etingof: does it require a sushy release?
15:22:31 <TheJulia> mjturek: yes
15:23:01 * TheJulia removes the items for the week
15:23:04 * TheJulia merges in new things
15:23:29 <etingof> TheJulia, let me take a look re sushy release
15:24:27 <TheJulia> I've added kind of the logical continuation of things, which yes is a lot of small patches
15:24:45 <TheJulia> I feel like the redfish inspect interface would be good for that list as well, which I think is where rloo was going
15:25:10 <rloo> TheJulia: yeah, if it was ready for reviews etc. or wait a week if we need to do a sushy release first.
15:25:55 <rloo> wrt streaming raw images -- did 'we' approve the RFE? I don't see any approval. are the patches waiting for comments only, but not merge?
15:26:05 <rloo> https://storyboard.openstack.org/#!/story/2003809
15:26:06 <dtantsur> I think it was approved..
15:26:24 <jroll> I have a +1 on the story
15:26:24 <TheJulia> jroll +1, just didn't tag it looks like
15:26:29 <openstackgerrit> Markos Chandras (hwoarang) proposed openstack/bifrost master: tests: Always use virtualenv for tests  https://review.openstack.org/611808
15:26:35 <jroll> oops
15:27:12 <jroll> done
15:27:18 <rloo> no worries, just administrivia. thx jroll! :)
15:27:19 <TheJulia> jroll: thanks
15:27:52 <TheJulia> I'm good with the list if everyone else is
15:28:01 * rloo wonders if we need a meeting to discuss step retrieval.
15:28:19 <TheJulia> rloo: maybe, or just during open discussion?
15:28:43 <rloo> well, i think we need a few people to read the spec first...
15:28:48 <TheJulia> ++
15:29:13 <openstackgerrit> Manuel Buil proposed openstack/bifrost stable/rocky: Fix bug in dnsmasq config  https://review.openstack.org/612421
15:29:20 <rloo> TheJulia: we could sched in for another mon meeting
15:29:39 <TheJulia> rloo: I like that idea!
15:29:48 <TheJulia> does anyone have any objections to scheduling for next monday?
15:29:49 <rloo> guess i was thinking a video/audio one might be more productive, but we can try irc first.
15:30:33 <rloo> (who cares about it?)
15:30:35 <TheJulia> rloo: yeah, we've not been able to really reach consensus on this before, but I was kind of hoping minimalist with the new spec so maybe that will help
15:30:39 * TheJulia cares about it
15:30:59 <rloo> it is a tough one wrt api etc.
15:31:11 <dtantsur> yeah, I have some problems with the new one.. ++ for a meeting
15:31:25 <TheJulia> Okay, I'll put it on the agenda for next week.
15:31:44 <rloo> anything else that is a bit contentious?
15:32:17 <rloo> let's try to remove blockers (besides 'we need reviews') :)
15:32:38 <TheJulia> rloo: neutron callbacks, but we need the spec revised first
15:33:43 <rloo> TheJulia: ok, maybe we're good for this week then :)
15:33:51 <TheJulia> I think we're good to move to Open Discussion at this time, any objections?
15:34:09 <TheJulia> Is there anything anyone else wishes to raise regarding the priorities for this next week?
15:35:05 * kaifeng has one
15:35:06 * TheJulia takes silence as agreement to move on
15:35:10 <TheJulia> kaifeng: go ahead
15:35:22 <kaifeng> https://review.openstack.org/590076
15:35:22 <patchbot> patch 590076 - ironic-inspector - Support manipulating iptables filter under IPv6 ne... - 2 patch sets
15:35:41 <kaifeng> this patch has some connection with the ipv6 stuff
15:36:04 <dtantsur> kaifeng: quick ques: does it assume either ipv4 or ipv6 stack but not both?
15:36:12 <dtantsur> I'm not sure it's a blocker, just trying to understand
15:36:31 <kaifeng> dtantsur, not a blocker
15:36:37 <TheJulia> at a glance, it appears we assume one, not both
15:36:49 <kaifeng> yes, ipv4 or ipv6, can't be both
15:37:09 <dtantsur> is it a reasonable limitation?
15:37:30 * dtantsur suspects yes, but has to ask
15:37:45 <TheJulia> we have a hardcoded switch in the conductor code, so I think it is
15:37:58 <kaifeng> is there any way to support both? they use different commands
15:38:15 <TheJulia> kaifeng: I added to the ironic-inspector list
15:38:16 <kaifeng> except we bind multiple interfaces
15:38:25 <TheJulia> Yeah, pondering is required
15:38:47 <kaifeng> TheJulia, thanks!
15:38:55 <TheJulia> Anyway, Open Discussion time!
15:38:59 <TheJulia> #topic Open Discussion
15:39:13 <TheJulia> so, raising steins! :)
15:39:14 <jroll> any reason we couldn't just have the iptables call do calls both for iptables and ip6tables?
15:40:08 <TheJulia> I suspect we don't presently have enough information
15:40:11 * kaifeng thanks TheJulia for bringing inspector api/woker from the ground again ;)
15:40:49 <TheJulia> I guess we might be able to record the socket type the connection came inbound on
15:40:53 <TheJulia> maybe
15:40:56 <TheJulia> _maybe_
15:41:25 <jroll> well
15:41:44 <jroll> just check the dnsmasq interface for v4/v6/both, and issue iptables/ip6tables/both as needed
15:41:58 <jroll> > self.interface = CONF.iptables.dnsmasq_interface
15:42:19 <TheJulia> it is mac based....
15:43:00 <TheJulia> so maybe it should just be a v4, v6, both option
15:43:02 <jroll> I'll just comment on the patch so we can get to happier things :)
15:43:15 <TheJulia> \o/
15:45:18 * TheJulia wonders if she needs to install beer taps in IRC
15:45:41 <iurygregory> ++
15:45:53 <iurygregory> =P
15:45:57 <jroll> so, meetup in berlin?
15:46:27 <dtantsur> who is more or less confirmed to go to Berlin?
15:46:33 <TheJulia> I'll be there, I know of dtantsur. Anyone else?
15:46:37 <jroll> I'm going
15:46:43 <jroll> as is penick
15:46:43 <dtantsur> IIRC sambetts
15:47:00 <dtantsur> etingof: do you have an idea if you're coming or not?
15:47:04 <jroll> yep, sam will be there
15:47:20 <TheJulia> dtantsur: know any place that would be good for us to get dinner?
15:47:47 <etingof> dtantsur, no idea yes, but I hope that I come
15:47:48 <rloo> maybe email, set up etherpad like we do for ptgs. I can't remember what you normally do for summit/forum...?
15:47:51 <etingof> *yet
15:48:07 <dtantsur> TheJulia: I have one idea, not sure what they think about group reservations though
15:48:12 <jroll> probably doodle would be good
15:48:26 <rloo> do they have bier gartens in berlin or is that just south germany?
15:48:27 <dtantsur> yeah
15:48:33 <dtantsur> rloo: they do ;)
15:48:43 <rloo> that might be a good experience then dtantsur!
15:48:56 <dtantsur> but a proper Biergarten will not have much food, and unlikely reservations
15:48:57 <TheJulia> I guess create a doodle and we can go from there. dtantsur do you want to inquire with the location you have in mind?
15:49:06 <dtantsur> I'm looking at a middle ground
15:49:26 <dtantsur> TheJulia: I'll try, given my poor language skills :)
15:49:37 <rloo> German food. hmm.. I suspect the bier is the best thing there...
15:49:58 <TheJulia> Heh
15:50:01 <etingof> aren't those bier gartens typically outdoors...
15:50:09 <dtantsur> depends on your tastes :) sausages, cabbage, schnitzel..
15:50:18 <rloo> some are only outdoors. dunno about what is in berlin.
15:50:28 <rloo> and pickled salads :)
15:50:29 <dtantsur> yeah, that's another issue with a pure beer garden
15:50:47 <rloo> have fun wherever you end up !
15:51:09 <etingof> kartoffelsalat
15:51:10 <dtantsur> I'm thinking about https://www.bier-genuss.berlin/en/lindenbraeu-am-potsdamer-platz
15:51:15 <rloo> if there aren't that many of you, you might be ok w/o a reservation.
15:51:24 * TheJulia suspects we're done with the meeting for today
15:51:49 <dtantsur> right, the place is big
15:51:57 <dtantsur> it has semi-outside seating as well
15:52:08 <jroll> I was hungry enough without all this food talk :P
15:52:11 <TheJulia> Thanks everyone for attending today!
15:52:11 * etingof is aware of a delicious ice cream booth at potsdamer platz
15:52:23 <dtantsur> who is doing the doodle, me?
15:52:33 <jroll> I guess so :P
15:52:34 <iurygregory> prob yes dtantsur
15:52:34 <rloo> action item!
15:52:35 <dtantsur> potsdamer platz is not bad at all :)
15:52:36 <TheJulia> dtantsur: I can, but if you want to :)
15:52:42 <JayF> jroll: as a note, ip6tables rules *can* be created and edited on machines that don't have IPv6 connectivity.
15:52:45 <dtantsur> TheJulia: I'll do it
15:52:53 <TheJulia> dtantsur: thanks
15:53:03 <TheJulia> JayF: Muchas Gracias
15:53:04 <JayF> jroll: I didn't get whole context but saw iptables / ip6tables :P
15:53:08 * dtantsur wonders which keyword was highlighted for JayF this time :)
15:53:14 <dtantsur> ah, these two :)
15:53:20 <JayF> I am at a company retreat... just watching IRC :)
15:53:31 <jroll> JayF: also good point, thanks :)
15:54:49 <TheJulia> #action dtantsur to create a doodle for Summit/Forum gathering.
15:55:03 <dtantsur> send it to the ML then?
15:55:19 <jroll> yeah
15:55:22 <TheJulia> dtantsur: yeah
15:55:30 <dtantsur> cool
15:55:34 <TheJulia> Thanks everyone!
15:55:39 <jroll> thanks :)
15:55:54 <TheJulia> #endmeeting