15:00:09 <TheJulia> #startmeeting ironic
15:00:10 <openstack> Meeting started Mon Aug 20 15:00:09 2018 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:11 <TheJulia> o/
15:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:14 <openstack> The meeting name has been set to 'ironic'
15:00:19 <TheJulia> Good morning everyone!
15:00:20 <mjturek> o/
15:00:21 <etingof> o/
15:00:21 <rpioso> o/
15:00:24 <jroll> \o
15:00:28 <mgoddard> o/
15:00:28 <stendulker> o/
15:00:31 <dtantsur> o/
15:00:35 <cdearborn> \o
15:00:41 <bdodd> o/
15:00:43 <kaifeng> o/
15:00:46 <TheJulia> Our agenda is fairly light today, so hopefully we'll wrap up the meeting quickly, and we can all then go back and make software!
15:00:57 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:01:10 <TheJulia> #topic Announcements/Reminders
15:01:17 <rloo> o/
15:01:34 <jiapei> o?
15:01:38 <jiapei> o/
15:01:54 <TheJulia> #info 22 days until the PTG
15:02:22 <TheJulia> #info Please ensure that you've made your hotel reservation and have registered for the PTG. The hotel room block is expected to sell out.
15:03:00 <TheJulia> #info The deadline for submitting topics/ideas is the 23rd, which is this week.
15:03:03 <TheJulia> #link https://etherpad.openstack.org/p/ironic-stein-ptg
15:03:20 * etingof discovered that the hotel rooms are already sold out as of last Friday
15:03:31 <etingof> (group booking)
15:03:50 <TheJulia> #info Please +1 items that you feel are important, that will help with trying to determine a schedule and priority for items.
15:04:14 <TheJulia> #info etingof informs us that the PTG room block has sold out.
15:04:16 <TheJulia> :(
15:04:49 <TheJulia> I think that is it for announcements/reminders from my point of view. Does anyone have anything to raise?
15:05:00 <mjturek> #info Bug day next Thurs (Aug 28th) https://etherpad.openstack.org/p/ironic-bug-day-august-28-2018
15:05:35 <mjturek> oh wait, it's a tuesday not a thursday
15:05:52 <TheJulia> #info Bug day next Tuesday (Aug 28th)
15:06:01 <TheJulia> #link https://etherpad.openstack.org/p/ironic-bug-day-august-28-2018
15:06:14 <TheJulia> Anything else?
15:06:29 <mjturek> please vote for a time! Seems like it will be the standard 1300 UTC
15:07:10 <TheJulia> That will be 6 AM for me :\
15:07:37 <TheJulia> +1 to >=1400 UTC
15:08:20 <mjturek> ouuuch, yeah that would work for me but please cast vote here https://doodle.com/poll/ef4m9zmacm2ey7ce
15:08:31 <TheJulia> #link https://doodle.com/poll/ef4m9zmacm2ey7ce
15:08:50 <TheJulia> Okay, well I guess we can move on!
15:09:20 <TheJulia> #topic Review action items from previous meeting
15:10:25 <TheJulia> We had one action item from last week which was for me to send an email regarding ironic-staging-drivers discussion to get that going on the mailing list.  Thank you those that have replied. My apologies for not replying but last week was a bit hectic and was never able to finish writing a reply.
15:10:53 <rloo> TheJulia:  no need to apologize. thx for starting the discussion!
15:11:13 * TheJulia still feels bad
15:11:14 <TheJulia> :)
15:11:35 <TheJulia> #topic Review subteam status reports
15:12:39 <TheJulia> I feel like we don't really have anything actionable to discuss regarding subteam status. We're in that end of cycle quiet time right now, although we now will permit stein patches to merge to master.
15:13:56 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:14:37 <rloo> i just deleted deploy steps, BIOS, and conductor groups
15:14:53 <rloo> they were all done.
15:15:05 <rloo> now i don't even remember if it was conductor groups, i've already forgotten what I deleted :)
15:15:31 <TheJulia> lol
15:15:52 <rloo> TheJulia: how are we doing wrt project vision?
15:16:05 <rloo> TheJulia: can we +A it now?
15:16:08 <TheJulia> One thing, following up on vision, we have +2s on all cores for https://review.openstack.org/#/c/587576/ (minus myself, but I wrote it)
15:16:09 <patchbot> patch 587576 - ironic - A vision - 0h 19m 8s spent in CI
15:16:29 * jroll thinks TheJulia should +A that
15:16:42 <dtantsur> ++
15:16:42 <TheJulia> So I think we can +A it, I'd prefer to go ahead and get the follow-up patch posted first so I don't forget
15:16:46 <rloo> line 239 for those that are following :)
15:16:51 <TheJulia> Works for me
15:17:07 <rloo> done
15:17:45 <TheJulia> Awesome
15:17:54 <rloo> dtantsur: classic drivers work is done?!
15:18:04 <dtantsur> unbelievable, yeah?
15:18:08 <TheJulia> rloo: I believe it is
15:18:08 <jroll> \o/
15:18:13 <rloo> whee!
15:18:21 * dtantsur can now safely retire
15:18:31 <TheJulia> dtantsur: your keeping a tally of how many beers we need to provide to you in berlin right?
15:18:33 <rloo> dtantsur now moves onto greater glory
15:18:51 <dtantsur> TheJulia: all of them :)
15:18:57 <TheJulia> \o/
15:19:02 <rloo> All the Steins? :)
15:19:18 <TheJulia> Okay, lets move on to priorities for this coming week, since it is largely specs.
15:19:31 <dtantsur> :)
15:19:42 * rloo deletes classic driver removal from whiteboard
15:20:25 <TheJulia> Are we good to proceed since I think everything else is kind of in spec land?
15:20:31 <cdearborn> I have one
15:20:40 <cdearborn> https://review.openstack.org/#/c/591493/
15:20:41 <patchbot> patch 591493 - puppet-ironic - Correct default number of threads - 3h 11m 37s spent in CI
15:20:50 <cdearborn> can we try to get that landed this week?
15:21:03 <rloo> who owns puppet-ironic?
15:21:14 <dtantsur> I'm core there, but noone else I think
15:21:15 <TheJulia> openstack-puppet I believe
15:21:48 <TheJulia> #topic Deciding on priorities for the coming week
15:22:30 <TheJulia> So regarding that, it looks like the linter was just grumpy friday. I didn't see a reason for the failure, I can recheck it and we can go from there
15:22:44 <cdearborn> Thanks!
15:22:47 <TheJulia> and I can reach out to the puppet-ironic ptl
15:22:47 <dtantsur> ++
15:22:58 <dtantsur> I'll +2 when it passes
15:23:02 <TheJulia> k
15:23:03 <rloo> TheJulia: are there any patches needed for the final Rocky release, that we ought to look at?
15:23:07 <dtantsur> (though they haven't migrated to storyboard yet)
15:24:52 <TheJulia> rloo: I think we're in good shape, I know there is an irmc fix that was backported that we should consider releasing
15:25:34 <dtantsur> TheJulia: it's pending their CI passing
15:25:43 <TheJulia> Yeah, https://review.openstack.org/#/c/592247/
15:25:44 <rloo> ok, so we can take the week off :)
15:25:45 <patchbot> patch 592247 - ironic (stable/rocky) - Fix not exist deploy image within irmc-virtual-med... - 3h 53m 25s spent in CI
15:25:58 <TheJulia> rloo: specs :)
15:26:49 <TheJulia> I'm good with the list as-is, I added the puppet ironic item. I don't think any of the doc changes got traction last week, but I think  they may also need revisions
15:27:09 <openstackgerrit> Merged openstack/ironic master: A vision  https://review.openstack.org/587576
15:29:20 <TheJulia> Shall we move on?
15:30:00 <rloo> +1 movin'
15:30:24 <TheJulia> So I had a discusison item, but I'm going to defer that since we're discussing on the  mailing list, so we'll go direct to open discussion.
15:30:34 <TheJulia> #topic Open Discussion
15:30:38 <TheJulia> Anyone have anything?
15:30:44 <TheJulia> Everyone excited about the PTG?
15:30:54 <rpioso> I have a thing.
15:30:54 <cdearborn> Depends on the trains...
15:31:07 <TheJulia> cdearborn: I swore that was addressed....
15:31:20 <TheJulia> rpioso: sure!
15:31:27 <mjturek> I am! The Renaissance  was a nice spot for it last time
15:31:33 <rpioso> Does defining a new clean/deploy step require an RFE or is it a just do it kind of activity?
15:31:43 <rloo> TheJulia: if the discussion item is the staging drivers, i think we might as well finish the discussion here. can recap or whatever in mail list.
15:31:46 * jroll is totes excited
15:32:11 <rloo> rpioso: requires an RFE.
15:32:13 <dtantsur> rpioso: RFE
15:32:26 <TheJulia> rpioso: I think it would be a new RFE, we woudl need to better understand exactly what your attempting to achieve and if there is already the same elsewhere.
15:32:37 <rpioso> Ack
15:33:05 <rpioso> afaiu, it's entirely new.
15:33:14 <TheJulia> Okay, then definitely RFE
15:34:46 <TheJulia> rloo: So it is, I guess my other concern is the lottery factor for pas-ha and the other folks which would leave it entirely pure ironic-core folks if we get ironic-core added
15:35:15 <rloo> not sure what you mean by lottery factor.
15:35:23 <TheJulia> rloo: ever heard of the bus factor?
15:35:29 <rloo> nope
15:35:31 <TheJulia> oh my
15:35:33 <rloo> is that an american thing?
15:35:51 <TheJulia> Think "someone won the lottery, and they are gone forever"
15:35:58 <rloo> oh, got it
15:36:25 <rpioso> Has a new version of sushy been released? I'm under the impression it's needed to fix the gate.
15:36:30 <rloo> so you are concerned if we add ironic-cores as cores to ironic-stging-drivers, that ... ironic cores will end up reviewing only?
15:36:33 <jroll> bus factor being the more generally understood but more morbid thing, where it's someone hit by a bus instead of winning the lottery
15:36:53 <rloo> https://en.wikipedia.org/wiki/Bus_factor
15:36:55 <TheJulia> I can go either way, I didn't see pas-ha reply to the thread, and I feel like he would be the authoritative person at this point.
15:36:58 <jroll> TheJulia: I don't think where the repo lives in governance affects bus factor, right?
15:37:12 <rloo> my thoughts exactly.
15:37:24 <rloo> the bus factor will be an issue regardless
15:37:31 <TheJulia> I guess takeover/line of succession wise
15:37:36 <rpioso> TheJulia: ^^^
15:37:42 <TheJulia> but if we're in agreement that we can add ironic-core, then I think that is good
15:37:46 <rloo> are we concerned with patches not being reviewed in ironic-staging-drivers, or are we concerned with something else?
15:37:53 <TheJulia> Similarlly we should consideer adding cores to sub-projects
15:38:08 <rloo> i thought we were already adding cores to sub-projects?
15:38:15 <TheJulia> rloo: my brain is focused on long term health/survivability
15:38:30 <TheJulia> rloo: we have on a case by case basis, just we've not done it for a while afaik
15:38:47 <TheJulia> rpioso: I or dtantsur need to put htat request in
15:39:07 <TheJulia> rpioso: stable/pike correct?
15:39:11 <rloo> i thought we had decided awhile ago, that ironic-cores were on each subproject and that was done. i don't think we've added any subprojects recently? or maybe we missed/forgot to add cores to them.
15:39:36 <jroll> yeah, when we re-organized governance around jroll-ptl time we made ironic-core the only cores on all projects in our umbrella
15:39:38 <TheJulia> we've kind of missed/forgotten to elevate people actively reviewing only on subprojects
15:39:40 <rpioso> dtantsur, TheJulia: Yes, stable/pike, please.
15:39:44 <rloo> anyway, i'm already worried about long term health/survivability of existing projects under ironic governance.
15:40:12 <TheJulia> Anyway, elevating peoples seems like it is something I should spend time slices on soon()
15:40:14 <rloo> survivability of ironic-staging-drivers is less importnat to me that the other projects
15:40:21 <jroll> I think sushy is probably the first project with non-cores reviewing more there than in ironic
15:40:25 <TheJulia> I guess we can alway scome back ot it
15:40:37 <TheJulia> jroll: I feel like your reading my mind :)
15:40:50 <TheJulia> s/ot/to/
15:41:02 <jroll> :)
15:41:05 <rloo> oh, is that what we're talking about? yeah, each subproject should be promoting folks to cores as warranted.
15:41:28 <TheJulia> so re; ironic-staging-drivers, lets get ironic-core added if the other cores are agreeable. That at least maintains access survivability and gives us the ability to sanity check review/approve
15:41:56 <rloo> (do we need to vote on that? glee)
15:42:24 <jroll> I don't mind ironic-core having access on that project, but don't take that as a commitment to care about it :)
15:42:31 <rloo> are there other cores here besides dtantsur, jroll, myself?
15:42:32 <TheJulia> I'm not really sure, there is nothing preventing someone from adding ironic-core to it today
15:42:57 <jroll> mgoddard is here
15:43:06 <rloo> ok, let's just ask the existing cores in ironic-staging-drivers if they want to add ironic-cores to it.
15:43:20 <TheJulia> rloo: I'll take that as an action item
15:43:29 <rloo> thx TheJulia!
15:43:32 <jroll> we don't manage ironic-staging-drivers, they can add whatever cores they want ;D
15:43:55 <rloo> jroll: true. we can't add us, we have to ask them to add us :)
15:44:00 <TheJulia> #action TheJulia to follow-up with ironic-staging-drivers cores regarding adding to the group of reviewers
15:44:20 <rloo> (if they want us, if they don't, i'm fine with that too)
15:44:21 <TheJulia> Also, I think I need I might as well add an action item to review sushy review traffic and peform some outreach
15:44:44 <etingof> please ^
15:44:50 <TheJulia> :)
15:44:51 <dtantsur> +++
15:45:10 <TheJulia> #action TheJulia to review stats and perform some outreach for subprojects this week.
15:45:29 <TheJulia> Do we have anything else to discuss?
15:45:37 * TheJulia feels like this has been really productive
15:45:45 <jroll> so did we just agree not to bring i-s-d under our wing?
15:45:53 * TheJulia aslways hopes for like a 20 minute meeting
15:46:17 <TheJulia> jroll: I believe we did agree not to, but that we can re-evaluate later.
15:46:20 <jroll> (or not yet anyway)
15:46:27 <jroll> yay, decisions :)
15:46:31 <rloo> yes, we did NOT agree to bring it into govenance :)
15:46:34 <jroll> who is going to summarize on the list?
15:47:17 <rloo> I can do that if no one else wants to :)
15:47:27 <mgoddard> seems like a reasonable decision on i-s-d
15:47:39 <TheJulia> rloo: please :)
15:47:51 <rloo> ok. i'll do it :)
15:48:01 <jroll> thanks rloo!
15:49:05 <TheJulia> thanks rloo!
15:49:17 <TheJulia> so, I guess we should now all return to the software mines?
15:49:22 <cdearborn> Can we discuss 2 RFEs that I just entered?
15:49:32 <cdearborn> not sure of the process
15:49:43 <TheJulia> cdearborn: I don't see why not, what do you have?
15:49:49 <cdearborn> https://storyboard.openstack.org/#!/story/2003495
15:50:16 <dtantsur> I think these RFEs get automatic approve as part of consistency between drivers
15:50:16 <cdearborn> https://storyboard.openstack.org/#!/story/2003494
15:50:34 <TheJulia> yeah, it is pretty much an automatic approval from my point of view since it is parity work
15:50:41 <dtantsur> the second one needs details (in the story or a spec)
15:50:43 * TheJulia loads the second one
15:50:49 <cdearborn> ok - so no spec necessary for 2003495?
15:51:24 <TheJulia> cdearborn: no, we have the method calls on management interfaces
15:51:30 <dtantsur> cdearborn: no. marked it rfe-approved based on the above.
15:51:38 <cdearborn> ok, great, thx!
15:51:43 <TheJulia> so unless there is something super special we're unaware of....
15:52:04 <openstackgerrit> Paul Belanger proposed openstack/bifrost master: WIP: Remove legacy playbooks  https://review.openstack.org/593677
15:52:04 * dtantsur hopes no
15:52:05 <cdearborn> no - nothing super special on that one - should be very straight forward
15:52:06 <TheJulia> The second, the ilo folks have some prior art of sorts in cleaning steps, but I'm leaning towards spec
15:52:36 <dtantsur> yeah, especially since the story does not talk about iDrac specifically
15:52:44 <cdearborn> ok, so the next step will be to come up with a spec for firmware upgrade then
15:53:07 <TheJulia> yeah, need to completely understand the problem and desired outcome too, might be slightly different or have a different take that could really change things up
15:53:32 <cdearborn> ok.  is it ok to add it to the list of possible sessions for the PTG?
15:53:57 <TheJulia> I think so  yeah, it is a common ask so I don't think we can avoid discussing firmware management
15:54:21 <cdearborn> ok, great!  thx very much all
15:54:31 <rloo> we talked ab it about firmware mgt in last PTG.
15:54:46 <cdearborn> will review that material
15:54:54 <rloo> weren't we going to try to get hw vendor agreement on some consistent something?
15:55:11 <openstackgerrit> Paul Belanger proposed openstack/bifrost master: WIP: Remove legacy playbooks  https://review.openstack.org/593677
15:55:52 <TheJulia> rloo: yeah, and that didn't go anywhere I think. I did talk to the folks that are doing firmware updates for EFI stuffs and they have gotten some traction, but they've run into similar roadblocks/hurdles with vendors
15:56:31 <TheJulia> I kind of feel like eventually we could adopt their stuff as an optional cleaning step
15:56:46 <rloo> TheJulia: ok. it would be good to be focussed on what we are going to talke about wrt firmware upgrades, so we don't say the same thing as in last PTG :)
15:56:51 <TheJulia> but they were just getting itno server hardware as of spring
15:57:07 <TheJulia> well, Dell folks being interested might help traction there.
15:57:24 <TheJulia> rloo: ++++
15:57:27 <cdearborn> we're definitely interested!
15:57:48 <rloo> perhaps Dell could be a leader then; prepare/let us know how you do/propose to do firmware upgrades.
15:58:11 <cdearborn> ok, i can definitely come up with something for the PTG
15:58:39 <TheJulia> ++
15:58:41 <openstackgerrit> Paul Belanger proposed openstack/bifrost master: WIP: Remove legacy playbooks  https://review.openstack.org/593677
15:58:47 <TheJulia> Anyway, one minute left. Anyone have anything else?
16:00:15 * jroll throws an extra cricket into the channel
16:00:19 <NobodyCam> Good morning Ironic'ers
16:00:21 <NobodyCam> :p
16:00:28 <TheJulia> Thanks everyone!
16:00:49 <TheJulia> jroll: we need schematics to be able to print that with a 3d printer....
16:00:55 <TheJulia> deploy the crickets! :)
16:01:04 <TheJulia> Anyway have a wonderful day everyone!
16:01:12 <jroll> TheJulia: heh, I have enough real ones in the yard for everyone
16:01:15 <cdearborn> u2 - thx!
16:01:24 <rpioso> Cheers
16:01:28 <TheJulia> #endmeeting