15:00:03 <TheJulia> #startmeeting ironic
15:00:04 <openstack> Meeting started Mon May 14 15:00:03 2018 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:06 <TheJulia> o/
15:00:08 <openstack> The meeting name has been set to 'ironic'
15:00:10 <mraineri> o/
15:00:11 <TheJulia> Good morning everyone!
15:00:15 <vdrok> o/
15:00:16 <rpioso> o/
15:00:19 <jroll> \o
15:00:26 <rloo> o/
15:00:27 <hshiina> o/
15:00:46 <jiapei> o/
15:00:54 <TheJulia> It is time for our weekly ironic meeting! (Our project name is never going to get old....) :)
15:01:10 <stendulker> o/
15:01:11 <TheJulia> Our agenda is on the wiki.
15:01:14 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic
15:01:18 <mjturek> \o
15:01:37 <jroll> nice and light :)
15:01:42 <TheJulia> indeed!
15:01:52 <TheJulia> #topic Announcements / Reminders
15:02:06 <dtantsur> o/
15:02:09 <TheJulia> #info Our meeting is cancelled next week due to the Summit.
15:02:44 <hjensas> o/
15:03:03 <TheJulia> That is all I have right now for announcements/reminders. Does anyone else have anything they would like to raise?
15:03:50 <rloo> the rocky-2 milestone is coming up (sort of) June 7th week
15:03:56 <rloo> that is nova-spec freeze
15:04:08 <rloo> are there any from us, that we need to help ?
15:04:12 <TheJulia> #info Rocky-2 milestone approaching - June 7th
15:05:08 <TheJulia> rloo: We should follow up on rescue I believe. I think that is the only thing we need to worry about right now.
15:05:34 <rloo> TheJulia: ok. (or any other non-ironic project specs. i guess i shouldn't just focus on nova.)
15:05:50 <hshiina> bp for rescue was approved for rocky
15:05:54 <hshiina> in nova
15:06:04 <rloo> hshiina: awesome!
15:06:19 <rloo> so we're good for now :)
15:06:21 <TheJulia> Anyway, if there is nothing else, we can proceed to reviewing action items.
15:06:28 <TheJulia> hshiina: excellent to hear
15:07:05 <TheJulia> #topic Reviewing action items from last week
15:07:33 <TheJulia> #link http://eavesdrop.openstack.org/meetings/ironic/2018/ironic.2018-05-07-15.00.txt
15:08:24 <TheJulia> I was super busy last week and fell down on the action items some last week. I did clean-up the whiteboard some, I forgot to send out an email w/r/t cancelling the meeting next week, and I didn't get a chance to look through what other projects are doing re prioritization in storyboard.
15:08:32 <rloo> Congrats to TheJulia for having the most (and all) action items!
15:08:53 <TheJulia> i know! I should throw a party!
15:09:14 <TheJulia> #action TheJulia to send meeting re-meeting cancellation for next week.
15:09:42 <TheJulia> Re: priorities in storyboard, I think I'll try and get with folks in vancouver and wrap my brain around it then.
15:10:25 <TheJulia> One last item, the status update email discussion is ongoing on the list, I know etingof replied if memory serves, but I've not had a chance to read it.
15:10:59 <TheJulia> With that being said, if there are no objections, we can move on.
15:11:59 <TheJulia> #topic Review subteam status reports
15:12:04 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:12:23 <TheJulia> Starting around line 89
15:12:27 <TheJulia> err
15:12:37 <TheJulia> Line 131!
15:12:55 <TheJulia> err
15:12:59 <TheJulia> Line 145
15:13:03 <TheJulia> Clearly I need lots of coffee
15:13:07 <TheJulia> and a vacation.
15:13:12 <jroll> +1000
15:13:46 <openstackgerrit> Dmitry Tantsur proposed openstack/sushy-tools master: Clean up templates from items that cannot be implemented for libvirt  https://review.openstack.org/538268
15:13:47 <jroll> oh my, bios is close \o/
15:14:26 <openstackgerrit> Dmitry Tantsur proposed openstack/sushy-tools master: Support EthernetInterface resource in the emulator  https://review.openstack.org/538338
15:14:27 <dtantsur> yep :)
15:14:36 <TheJulia> Very very close \o/
15:14:36 <rpioso> Awesome
15:15:20 <jroll> classic driver removal also nearing the finish line
15:15:24 <TheJulia> I'm going to put a few specs that relate to items that are outstanding on this list on the priorities for this week
15:15:52 <jroll> sounds like a good idea to me
15:16:00 <TheJulia> That way we get some eyes on them
15:16:06 <rloo> dtantsur: wrt the classic driver removal. are you OK if I delete the stuff that has already been done? hard to see what is left to do
15:16:14 <dtantsur> rloo: yes please
15:16:25 <dtantsur> I did not update the list, because IIRC TheJulia planned to move it to storyboard
15:16:32 <dtantsur> or maybe I should do it? :)
15:16:49 <TheJulia> dtantsur: you know it better and I've been crazy busy recently
15:16:57 <dtantsur> actually, it's a good question: should we track it on the whiteboard or storyboard?
15:17:21 <rloo> dtantsur: in the classic driver removal, there is a question @ L244ish
15:17:36 <rloo> dtantsur: kill it :)
15:17:40 <TheJulia> The preference we seem to have as a community is to track efforts on etherpads, changing to just using storyboard for that might feel a bit painful
15:17:51 <dtantsur> rloo: I think I even did it already :)
15:18:04 <jroll> I'd prefer storyboard, with whiteboard as the "what got done last week / needs help this week"
15:18:05 <rloo> dtantsur: please update the whiteboard then :D
15:18:09 <jroll> but open to whatever
15:18:15 <TheJulia> I remember dtantsur lightly singed the wiki
15:18:27 <TheJulia> There may have been some smoldering afterwards :)
15:18:38 <rloo> ++ if we are using storyboard, we might want to use it for what it was meant/good at.
15:19:25 <rloo> dtantsur: 'fake' -> 'fake_hardware' hardware type? :)
15:19:37 <TheJulia> Which is the effort tracking, I've personally been trying to break things up and use multiple tasks which is the way it was intended, but yeah...  One step at a time
15:20:06 <dtantsur> rloo: yep, unfortunately this is MUCH harder than just sed
15:20:07 <TheJulia> Is everyone good to move on to priorities?
15:20:41 <dtantsur> yep
15:20:53 <rloo> + good
15:20:57 <jiapei> ++
15:21:25 <TheJulia> #topic Priorities for the next week
15:21:30 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:21:35 <TheJulia> Line 92
15:21:39 <rloo> what about adding this to priorities: https://review.openstack.org/#/c/507067
15:21:40 <patchbot> patch 507067 - ironic - [devstack] Switch ironic to uWSGI
15:21:51 <TheJulia> rloo: I actually have that on the list I was about to paste in....
15:21:59 <rloo> TheJulia: :)
15:23:08 <TheJulia> dtantsur: is the hw-types topic unblocked?
15:23:25 <TheJulia> dtantsur: or are there more api-jobs that need changing?
15:23:30 <olivierb-> TheJulia & all, I made the changes in ironic-lib and ironic-python-agent code in my own repos ? what is the (best) way to take this into account ? Just git clone/checkout properly on bifrost master or change some of the requirements.txt files. Sorry for the freshman developper questions ;-)
15:23:36 <dtantsur> yep, but no patches open right this second
15:23:40 <dtantsur> I mean, yes, unblocked
15:24:25 <rloo> olivierb-: we're in the weekly ironic meeting now (you're welcome to join). Shoudl be done in 30-ish minutes.
15:24:26 <olivierb-> will head back to home/gym and will connect later to read your advices, cheers
15:25:15 <TheJulia> 30-ish minutes if my cat does not find the router, and swipe it from the edge of the earth into the universe.... (so far during the meeting five things have been swiped onto the floor....)
15:25:51 <dtantsur> ENEEDATREAT
15:26:03 <rpioso> TheJulia: Sounds like your cat doesn't like meetings :-)
15:26:08 <TheJulia> pretty much....
15:26:38 <jroll> good cat
15:27:20 <TheJulia> Anyway, I've added the power fault stuff to the list since it is in solid shape as far as I've seen thus far and does improve things, I know there was discussion earlier, so we can remove it or not. I've also placed some specs at the beginning of the list that could use some eyeballs. The virtual media/dhcp-less boot deploy interface nokia is interested in needs a minor revision, but I also feel it is in good shape.
15:27:57 * TheJulia feels bad for not having read the buffer from when she was on a call.
15:28:12 <jroll> seems like a decent list, though far too long to complete :)
15:28:31 <TheJulia> Well, no meeting next week :)
15:28:50 <jroll> probably not much review work either :P
15:30:01 <rloo> TheJulia is giving us homework. heh!
15:30:10 <TheJulia> lol
15:30:30 <TheJulia> But we can't call it homework ;)
15:31:08 <rloo> s/homework/ironi-ng/
15:31:28 <TheJulia> lol
15:31:32 <TheJulia> I like that!
15:31:53 * rloo thinks we're ready to move on
15:32:06 <rloo> :)
15:32:56 <TheJulia> Yup
15:33:04 * TheJulia lost connectivity for a minute :\
15:33:10 <TheJulia> And not at the paws of the cat
15:34:00 <TheJulia> So since everyone seems good with the list and we have no specific RFEs or discusison topics, lets jump to Open Discussion
15:34:29 <TheJulia> #topic Open Discussion
15:35:04 <jroll> I have a quick thing here
15:35:16 <jroll> this discussion happened a while back:
15:35:18 <jroll> #link http://lists.openstack.org/pipermail/openstack-dev/2018-April/129216.html
15:35:25 <jroll> and again today
15:35:27 <jroll> #link http://lists.openstack.org/pipermail/openstack-dev/2018-May/130423.html
15:35:27 <TheJulia> olivierb-: Best way for you to test your changes is to craft a custom IPA image or patch it. If your booting form pxe, then it is easy with taking apart the ramdisk and patching it
15:35:48 <openstackgerrit> Merged openstack/ironic-inspector master: Raise KeyboardInterrupt on SIGTERM - Workaround  https://review.openstack.org/563335
15:35:52 <jroll> tl;dr people want to get pycrypto out of global-requirements in rocky, some projects are blocking that, including pyghmi
15:36:20 <jroll> is anyone available to switch to the cryptography library in pyghmi and coordinate that with jarrod?
15:36:47 <TheJulia> I had someone reach out to me first thing and ask for jarrod's contact info to discuss exactly that
15:37:05 <jroll> that was me, see the april link for his plan :)
15:37:29 <TheJulia> if it was you this morning, my brain is a blur
15:37:36 <jroll> oh, not this morning, no
15:38:11 <jroll> so maybe we'll wait to see if this person and/or jarrod makes progress soon
15:38:20 <jroll> I just want to keep the requirements team unblocked :)
15:39:02 <TheJulia> The person that asked me seems to not be around at the moment
15:39:32 <TheJulia> #action TheJulia to follow-up w/r/t pycrypto in pyghmi - to determine if we have someone to take that on.
15:39:33 <dtantsur> TheJulia: it was etingof?
15:39:55 <jroll> thanks TheJulia
15:39:55 <TheJulia> dtantsur: well, I wasn't going to name him because I hadn't gotten confirmation back yet, but I'll follow-up
15:40:19 <rloo> action item, action item, action item, ... :)
15:40:24 <TheJulia> Speaking of following up things, there was the ceph tempurl thing last week, who is picking that patch up?
15:40:31 <rloo> (for etingof I mean, cuz he isn't here)
15:40:31 * TheJulia is asking now so it does not become yet another action item
15:40:41 <TheJulia> rloo: Excellent idea!
15:40:51 <jroll> TheJulia: it's on my list
15:41:01 <TheJulia> jroll: awesome! Thanks!
15:41:03 <rloo> thx jroll!
15:41:05 <jroll> np
15:42:06 <mgoddard> olivierb-, TheJulia: in kayobe we use environment variables to configure the IPA repo URL & version to use. In bifrost these could be set in dib_env_vars. I'm not sure how you could use a custom ironic-lib, perhaps via requirements.txt like you say. Take a look at the ironic-agent DIB element: https://github.com/openstack/diskimage-builder/tree/master/diskimage_builder/elements/ironic-agent
15:42:48 <TheJulia> I'd really just rip the cpio file apart and rebuild it, but I'm a little old fashioned
15:42:57 <mgoddard> rloo: I was wondering what the status of deploy steps is. Are you planning to implement it?
15:43:18 <rloo> mgoddard: yes, still planning on it. unless someone else wants to do it.
15:43:38 <rloo> mgoddard: hoping to get around to it next month.
15:44:38 <mgoddard> ok great. I'm up for helping on the coding and/or reviewing side - whatever works for you
15:44:44 <rloo> thx mgoddard!
15:45:49 <TheJulia> Awesome, well does anyone have anything else to bring up/discuss today?
15:45:55 <mgoddard> zshi: how is the BIOS work going? Are there any tempest tests and documentation in progress?
15:46:18 <mgoddard> Would be good to see tempest tests before merging the API
15:46:47 <mgoddard> yolanda_: ^^
15:47:21 <mgoddard> we can take this offline if everyone else is done here
15:47:37 <TheJulia> mgoddard: tempest api read tests, I guess could exist easily... otherwise we don't explicitly test cleaning in the gate, although maybe this is a good route to get there
15:48:09 <TheJulia> redfish support for bios could help us get there I guess
15:48:41 <TheJulia> Just thinking outloud
15:48:42 <mgoddard> TheJulia: yeah, the fake driver was built in a way that much of the BIOS code could be tested via tempest
15:49:21 <mgoddard> i.e., just writes any requested options to the DB
15:49:39 <TheJulia> True, and there are two sides to it
15:50:24 <TheJulia> Well, if there is nothing else, I guess we can all get ten minutes back :)
15:50:30 <TheJulia> well, more like 9 minutes now
15:50:32 <TheJulia> :)
15:50:35 <jroll> \o/
15:51:01 <dtantsur> :)
15:51:11 <TheJulia> Awesome!
15:51:14 <TheJulia> Thanks everyone!
15:51:18 <jroll> thanks!
15:51:23 <dtantsur> thanks
15:51:27 <TheJulia> #endmeeting