15:00:08 <TheJulia> #startmeeting ironic
15:00:09 <openstack> Meeting started Mon May  7 15:00:08 2018 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <TheJulia> o/
15:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:12 <openstack> The meeting name has been set to 'ironic'
15:00:16 <mjturek> o/
15:00:19 <vdrok> o/
15:00:21 <rpioso> o/
15:00:23 <mraineri> o/
15:00:25 <jroll> \o
15:00:26 <tomasg2012> o/
15:00:26 <etingof> o/
15:00:28 <bdodd> o/
15:00:31 <rloo> o/
15:00:50 <stendulker> o/
15:00:52 <cdearborn> \o
15:01:00 <jiapei> o/
15:01:06 <hshiina> o/
15:01:10 <TheJulia> We've got a few things on our agenda this week, hopefully this meeting will be nice and quick!
15:01:22 <TheJulia> As always the agenda can be found on the wiki page.
15:01:24 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic
15:01:40 <dtantsur> o/
15:01:58 <TheJulia> #topic Announcements / Reminder
15:02:41 <TheJulia> Summit is coming up in two weeks. I'll be busy that week, is there anyone willing to run the meeting that week?
15:03:56 <TheJulia> Also for those of you that will be there, we should do something unrelated to ironic... like go to the movies. Please feel free to reach out to me privately.
15:04:06 * rloo off that day
15:04:23 <jiapei> Sounds great
15:04:32 <dtantsur> May 21st seems to be a holiday here
15:04:59 <TheJulia> The following week is a holiday in the states.
15:05:02 <TheJulia> *shrugs*
15:05:07 <jroll> I'd just cancel the summit-week meeting, tbh
15:05:10 <dtantsur> ++
15:05:17 <TheJulia> Yeah, lets consider it cancelled.
15:05:30 <TheJulia> #action TheJulia to send out a email to cancel the meeting the week of the summit.
15:05:31 <dtantsur> I can run one on 28th if needed
15:05:50 <TheJulia> Does anyone have anything else to bring up announcements or reminder wise?
15:06:11 <TheJulia> dtantsur: I really should take a day off, so I may take  you up on that :)
15:06:21 <dtantsur> cool, yeah
15:07:16 * TheJulia guesses nobody has anything else
15:07:20 <TheJulia> Moving on then!
15:07:25 <TheJulia> #topic Action items from last week
15:07:40 <TheJulia> #link http://eavesdrop.openstack.org/meetings/ironic/2018/ironic.2018-04-30-15.00.log.html
15:08:16 <TheJulia> Two items were mine, one of which I put up and I believe we landed which was a deprecation note for the OneView docs. I didn't get to scrubbing the whiteboard
15:08:44 <TheJulia> arxcruz: You had one that you were going to begin setting up a new CI job, any progress there?
15:09:16 <arxcruz> TheJulia: not too much, we need to update our discovery tool to configure ironic automatically, we are working on that right now
15:09:34 <arxcruz> TheJulia: https://review.openstack.org/#/c/565716/ is the featureset we will use for ironic
15:09:35 <patchbot> patch 565716 - tripleo-quickstart - Adding ironic tests on fs001
15:09:45 <arxcruz> but the tests are failing because ironic isn't configured properly
15:09:49 <TheJulia> arxcruz: Okay, good to know
15:11:19 <TheJulia> arxcruz: so one thing about that, you may wish to just limit that to the scenario tests, as there are some api functional tests included that wouldn't help integration testing and would result on additional run time for the CI job.
15:11:33 <TheJulia> dtantsur has recently been posting patches to fix that with some of our testing
15:11:55 <TheJulia> Anyway, looks like we're good to move along
15:12:06 <dtantsur> yep, essentially changing tempest regex to ironic_tempest_plugin.tests.scenario
15:12:17 <arxcruz> TheJulia: sure, i'll still sync with dtantsur which tests you guys want :)
15:12:39 <TheJulia> perfect :)
15:12:42 <TheJulia> Anyway, onward!
15:12:47 <TheJulia> #topic Review subteam status reports
15:12:51 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:13:15 <TheJulia> Starting around line 150
15:14:54 <TheJulia> It looks like we're done with sighup support for this cycle?
15:15:19 <rloo> TheJulia: yup. i forgot to delete it from whiteboard, doing that now.
15:15:59 <TheJulia> #action TheJulia to follow-up regarding sighup work tracking in storyboard
15:16:45 <rloo> TheJulia: i already updated it in storyboard.
15:16:51 <TheJulia> #undo
15:16:51 <openstack> Removing item from minutes: #action TheJulia to follow-up regarding sighup work tracking in storyboard
15:16:53 <TheJulia> \o/
15:16:58 <TheJulia> One less action item!
15:17:00 <TheJulia> rloo: thanks!
15:17:56 <rloo> TheJulia: https://storyboard.openstack.org/#!/story/2001545. Was in the whiteboard until 2 minutes ago when i deleted it. also in the email that rama sent out last week :)
15:18:17 <TheJulia> Awesome
15:18:29 <TheJulia> Okay, I think everything else looks good.
15:18:48 <rloo> TheJulia: is bifrost working now? L373
15:18:55 <TheJulia> rloo: Follow-ing up on the backport we discussed last week during this meeting, I have receieved zero objections
15:19:16 <rloo> TheJulia: ok, then we should be good to backport!
15:19:24 <rloo> TheJulia: I'll approve after this meeting.
15:19:31 <TheJulia> I need to clean up that section of the whiteboard
15:19:32 <TheJulia> :(
15:19:35 <rloo> TheJulia: thx for sending the email
15:20:01 <TheJulia> #action TheJulia to clean-up the whiteboard
15:20:03 <TheJulia> rloo: no problem
15:20:12 <TheJulia> Anyway, I guess we can move on then
15:20:25 <TheJulia> #topic Priorities for the next week
15:20:46 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:20:49 <TheJulia> Line 168
15:21:02 <TheJulia> err
15:21:13 <TheJulia> Line 96
15:21:26 <TheJulia> dtantsur: done with hw types cleanup?
15:21:39 <dtantsur> this API jobs work is not finished
15:21:47 <dtantsur> #link https://review.openstack.org/564519
15:21:48 <patchbot> patch 564519 - ironic - Switch to the fake-hardware hardware type for API ...
15:22:06 <dtantsur> which is blocked by all that numerous patches to not run functional tests in the integration jobs
15:22:40 <TheJulia> ack, so they are out of order
15:22:42 * TheJulia fixes
15:22:49 <rloo> dtantsur: maybe list all those dependent patches then
15:23:18 <dtantsur> rloo: they're under one topic, see the etherpad
15:23:36 <rloo> dtantsur: ok, i see it now :)
15:24:45 <TheJulia> Is anyone aware of any bug fixes that need additional eyes this week?
15:25:44 <hjensas> TheJulia: Story: 2001970 :)
15:27:34 <TheJulia> Aside from bugs that may need eyes this week, I added a housekeeping item to update coreos, since it has been a very long time since we've bumped the version. The memory footprint is larger, but I'm still working on that. Hopefully it should pass the next CI run.
15:28:00 <TheJulia> hjensas: added, looks likewe might want to backport that to queens since the default changed in queens?
15:28:07 <rloo> is there a way to search for stories that are critical, vs eg low priority? (I think I may have asked and forgotten)
15:28:37 <TheJulia> rloo: not really, I was actually thinking of bringing up as an open discussion item if we want to talk about priority tagging
15:28:37 <hjensas> TheJulia: yes, I'll cherry-pick as soon as it lands in master.
15:28:42 <TheJulia> hjensas: ack
15:28:56 <TheJulia> rloo: the other point of view is to build a kanban board in storyboard
15:29:05 <TheJulia> and use the todo column as the ordering mechanism
15:29:06 <rloo> TheJulia: thx, fwiw, i think that is a serious issue. i feel somewhat blind.
15:29:27 <rloo> TheJulia: whatever we do, all of openstack / projects, should do a similar thing.
15:29:45 <rloo> it is bad enough now, going to a project and wondering if they are still using launchpad or storyboard.
15:30:08 <TheJulia> I'll take that as an action item to research this week
15:30:17 <rloo> TheJulia: thank you!
15:30:25 <TheJulia> #action TheJulia to look at priority communication through storyboard.
15:31:17 <TheJulia> rloo: the migration instructions detail disabling launchpad, of course that doesn't help when creators of some launchpads can't be reached.
15:31:23 <openstackgerrit> Ilya Etingof proposed openstack/virtualbmc master: Revert "Add Serial-over-LAN (SOL) support"  https://review.openstack.org/566646
15:31:37 <TheJulia> etingof: Thanks!
15:31:42 * TheJulia adds that to the priority list
15:32:48 <TheJulia> Are we good to proceed? are we good with the priorities for the week?
15:33:36 <vdrok> lgtm
15:34:07 * jroll is fine
15:34:22 <dtantsur> yep
15:34:26 <TheJulia> Moving on then!
15:34:44 <TheJulia> #topic Discussion
15:34:48 <TheJulia> We have three topics today
15:35:26 <TheJulia> The first is mine. Last week we noticed that CoreOS was very out of date and there was a story to make it such that we were periodically and automatically updating it ever so often
15:35:44 <TheJulia> #link https://storyboard.openstack.org/#!/story/1600228
15:36:25 <TheJulia> I'm working on getting it at least up to date at this point in time, but if someone is interested, it would be good for someone to pickup
15:36:35 <TheJulia> The next item is one that I believe rloo added.
15:37:13 <jroll> did the coreos thing need discussion or just a mention?
15:37:15 <rloo> Hi. Rama Yeleswarapu has been sending out the weekly ironic emails. She is no longer available to do so.
15:37:43 <rloo> I want to thank her for doing that; it has been very useful (e.g. I just looked at that email this morning)
15:38:00 <rloo> Is there a volunteer that would like to continue doing this?
15:38:03 <TheJulia> jroll: I'm kind of curious if people think it even really matters... without IPA being built by DIB as a regular thing I'm worried about dropping coreos builds.
15:38:13 <TheJulia> jroll: but I'm also convincing myself that we need to keep it :(
15:39:15 <TheJulia> Do we know if anyone finds the weekly status emails useful?
15:39:15 <jroll> TheJulia: yeah, I think we should keep it, though coreos becomes less and less... useful for this use case
15:39:21 <vdrok> thank you Rama!
15:39:36 * jroll tried to do this once and ran in to the same memory thing
15:39:41 <rloo> as an example email (if you don't know what I'm talking about): http://lists.openstack.org/pipermail/openstack-dev/2018-April/130050.html
15:39:53 <TheJulia> vdrok: ++
15:40:24 <jroll> so, I don't think anyone in this meeting would have found it useful, since it's just a copy/paste of the etherpad
15:40:31 <dtantsur> rloo: I tend to read them when I don't attend the meeting. but I can live without them as well.
15:40:41 <jroll> I find cdent's placement updates massively useful, and would much prefer something like that
15:40:56 <rloo> jroll: on which topic?
15:41:06 <rloo> jroll: cdent's is about a particular feature
15:41:09 <jroll> (color commentary on $things that happened in placement this week + notes on what is in flight
15:41:21 <rloo> jroll: if we want more detailed stuff, we could put that in the subteam reporting.
15:41:26 <jroll> rloo: on ironic as a whole. placement is just as busy as ironic altogether
15:41:56 <TheJulia> I kind of like that idea, and I'm somewhat willing to write a more detailed summary
15:42:01 <rloo> jroll: i would hope that our subteam, priorities, etc, that we discuss weekly would be a reflection of our week...
15:42:16 <TheJulia> And I think some of a condensed  stream of conciousness might be useful for people who miss the meetings
15:42:17 <rloo> but if TheJulia is willing to do it! :)
15:42:30 <TheJulia> the one warning is, it would be a stream of conciousness
15:42:36 <jroll> rloo: have you read chris' emails? they're not just a status report, it's more a personal stream of thought on things (plus a bit of status)
15:42:46 <TheJulia> you might end up with a scifi story with aliens or something
15:42:52 <jroll> ++
15:42:54 <rloo> One thing is if we don't have a copy of the whiteboard -- if you want to know what happened previously, you can use the time-thing on the whiteboard to see what was there previously.
15:43:07 * TheJulia actually suspects that it might be fun
15:43:16 <jroll> sometimes that time slider works
15:43:31 <rloo> jroll: yeah, but i am in such a hurry, that i don't really want someone's stream of consciousness.
15:43:41 <TheJulia> Whiteboard is super useful for status, but the delta from last week can be a mystery some weeks.
15:43:56 <TheJulia> espescialy with someone like myself that likes to clean-up things
15:44:01 <TheJulia> on the whiteboard that is
15:44:10 <jroll> rloo: then don't read it, you already know the status from the whiteboard ¯\_(ツ)_/¯
15:44:26 <TheJulia> Anyway, I'll let my consciousness see what it comes up with later today
15:44:31 <jroll> I find the personal opinions quite useful, personally
15:44:38 <rloo> jroll: it just serves as an easy place to see what was on the whiteboard, in the past.
15:44:51 <jroll> ah, I see
15:45:09 <jroll> anyway, I've spoken my opinion :)
15:45:23 <rloo> jroll: cuz, you know, we aren't that good with project management, getting links to stuff, etc.
15:45:30 <rloo> jroll: but i can figure out how to get the info in other ways.
15:46:01 <TheJulia> Anyway, we have 14 minutes left and another topic
15:46:09 <rloo> hmm. it just occurred to me. that i should send an email. cuz yeah, if you attend the meeting, like everyone here, there may not be a need for the weekly email.
15:46:31 <jroll> rloo: maybe you can take the 2 minutes per week to send it then? nothing wrong with having the copy/paste *and* julia's stream of conciousness :)
15:46:33 <TheJulia> rloo: that actually sounds like a good idea
15:46:36 <rloo> having said that, if TheJulia and others don't see a need, I'm fine. I'm actually just the messenger.
15:46:53 <rloo> jroll: nope. I did this before, i don't want to volunteer again.
15:46:54 <TheJulia> rloo: do you want to poll the list or shall I?
15:47:00 <jroll> ok
15:47:11 <rloo> TheJulia: why don't you poll, and mention your idea of the other type of email.
15:47:42 <TheJulia> #action TheJulia to send status/weekly happenings question email to the list
15:47:46 <rloo> let me be clear. I am fine if we don't do the weekly emails. I was trying to point out the pros/cons.
15:48:33 <TheJulia> rloo: Good to know, thanks!
15:48:45 <TheJulia> Okay, final on-agenda item!
15:49:16 <TheJulia> We have some additional developers in the channel (at least, I hope they are here today) from the DMTF that will be working on redfish and redfish support
15:49:25 <mraineri> Yup; we're here :)
15:49:31 <TheJulia> mraineri: Welcome!
15:49:44 <mraineri> Thanks!
15:49:46 <dtantsur> mraineri: hi, welcome!
15:49:46 <jroll> \o/
15:50:00 <bdodd> Thanks. Good to be here
15:50:05 <jiapei> Welcome!
15:50:05 <mraineri> So, my name is Mike Raineri; I'm one of the co-chairs of the Redfish Forum
15:50:05 <rloo> welcome!
15:50:06 <TheJulia> I expect we're going to see some more patches for sushy as well as maybe some new driver feature parity items get posted.
15:50:10 <TheJulia> bdodd: Welcome!
15:50:29 <mraineri> And part of our forum charter is to begin engaging with open cource communities to help with the adoption of Redfish in the field
15:50:29 <etingof> bdodd, mraineri, welcome o/
15:50:31 <rloo> i was going to ask whether it was going to be more work with sushy, or a new redfish library :)
15:50:32 <tomasg2012> I'm here as well
15:50:38 <tomasg2012> o/
15:50:46 <TheJulia> tomasg2012: Welcome!
15:50:53 <etingof> tomasg2012, \o
15:50:58 <jroll> welcome, y'all
15:51:12 <mraineri> Both bdodd and tomasg2012 work as contractors for the DMTF and will be available to help with the support for Redfish within OpenStack
15:51:27 <rpioso> bdodd, mraineri, tomasg2012: Welcome to ironic!
15:51:50 <rajinir> Welcome y'all
15:52:02 <mraineri> Thanks for the welcomes, and we look forward to working with you in the future
15:52:13 <mjturek> awesome!
15:52:19 <TheJulia> Awesome! If there are any how ironic works questions, feel free to ask in channel. At least Monday through Friday, there is almost always someone keeping an eye on IRC
15:52:30 <mraineri> Will do!
15:52:54 <TheJulia> Well, 7 minutes left. Does anyone have anything else that they want to discuss today?
15:52:58 <jroll> (or any other questions, like how adorable is my puppy today)
15:53:14 <rloo> I wanted to thank everyone that participated in last week's bug bash! Thanks! :)
15:53:29 <rloo> jroll: is auggie still cute? :)
15:53:34 <dtantsur> jroll: and how?
15:53:45 <TheJulia> Or should we go back to our scheduled program of talking about how cute the kittens and puppies are? :)
15:53:49 <jroll> dtantsur: SUPER, obviously :P
15:53:50 * rpioso wishes he could have attended.
15:53:58 <dtantsur> jroll: proof-pic needed!
15:54:15 <jroll> I'll be sure to post some shortly
15:54:21 <mjturek> jroll: you adopt a puppy recently!?
15:54:37 <jroll> yes :)
15:54:40 <mjturek> congrats!!
15:54:47 <jroll> heh thanks
15:54:57 * jroll thinks the meeting might be over now :P
15:54:59 <rpioso> jroll: New house, new puppy, ...
15:55:18 <TheJulia> jroll: indeed :)  And your puppy is super cute.
15:55:24 <TheJulia> Thanks everyone!
15:55:57 <rloo> Thanks TheJulia
15:56:05 <jroll> dtantsur: most recent pic: https://i.imgur.com/CD0YsYw.png
15:56:29 <rloo> awwww...
15:56:44 <TheJulia> jroll: that is approaching death by cute
15:56:49 <dtantsur> cccuuuute ^_^
15:56:59 <jroll> :D
15:57:06 <TheJulia> mraineri: bdodd: tomasg2012: clearly we can be a little silly at times :)
15:57:13 <rloo> (if we didn't already have a mascot...)
15:57:19 <mraineri> We appreciate it ;)
15:57:20 <jroll> bonus zoomies https://gfycat.com/JadedSomeHairstreakbutterfly
15:57:24 * jroll finds lunch now
15:57:26 <TheJulia> Anyway, have a wonderful day everyone!
15:57:35 <dtantsur> o/
15:57:37 <TheJulia> #endmeeting