15:00:18 <TheJulia> #startmeeting ironic
15:00:19 <openstack> Meeting started Mon Apr  9 15:00:18 2018 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:23 <openstack> The meeting name has been set to 'ironic'
15:00:27 <jroll> \o
15:00:35 <mgoddard> o/
15:00:41 <TheJulia> Good morning everyone
15:00:41 <etingof> o/
15:00:45 <kaifeng> o/
15:00:47 <hshiina> o/
15:00:47 <TheJulia> Time for an ironic meeting!
15:00:50 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
15:00:50 <rpioso> o/
15:00:56 <rloo> o/
15:01:08 <stendulker> o/
15:01:10 <TheJulia> #topic Announcements / Reminder
15:01:45 <TheJulia> I have created an etherpad to gather topics for the forum. Please add items this week.
15:01:47 <TheJulia> #link https://etherpad.openstack.org/p/YVR-ironic-forum-sessions
15:01:56 <hjensas> o/
15:02:04 <jroll> nice
15:02:50 <TheJulia> Does anyone have any other announcements or reminders to bring up?
15:03:36 * TheJulia hears crickets
15:03:49 <mmethot> lol
15:04:20 <TheJulia> Moving on!
15:04:42 <TheJulia> #topic Review action items from our previous meeting
15:04:46 <TheJulia> #link http://eavesdrop.openstack.org/meetings/ironic/2018/
15:05:09 <TheJulia> Ahh yes, to look at the bugs which was my action item.
15:05:11 <jlvillal> o/
15:05:34 <TheJulia> I looked, and I think we should revise processes... or at least our view or processes. Viewing the single group in launchpad does make it VERY easy though :)
15:05:42 <TheJulia> \o
15:06:13 <TheJulia> Anyway, we can discuss that later
15:06:18 <TheJulia> Onward!
15:06:37 <rloo> do we want to discuss bug bash now or later?
15:06:56 <TheJulia> #topic Review subteam status reports
15:06:58 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
15:07:05 <TheJulia> rloo: during open discussion I think :)
15:07:10 <rloo> TheJulia: ok
15:07:48 <openstackgerrit> yolanda.robla proposed openstack/ironic master: BIOS Settings: Add DB model  https://review.openstack.org/511162
15:07:48 <openstackgerrit> yolanda.robla proposed openstack/ironic master: Add bios_interface db field  https://review.openstack.org/528609
15:07:48 <rloo> TheJulia: we fixed that critical sushy bug, right?
15:07:49 <openstackgerrit> yolanda.robla proposed openstack/ironic master: BIOS Settings: Add DB API  https://review.openstack.org/511402
15:07:49 <openstackgerrit> yolanda.robla proposed openstack/ironic master: BIOS Settings: Add RPC object  https://review.openstack.org/511714
15:07:50 <openstackgerrit> yolanda.robla proposed openstack/ironic master: BIOS Settings: Add BIOSInterface  https://review.openstack.org/507793
15:07:50 <openstackgerrit> yolanda.robla proposed openstack/ironic master: BIOS Settings: Add BIOS caching  https://review.openstack.org/512200
15:07:51 <openstackgerrit> yolanda.robla proposed openstack/ironic master: WIP: Add Node BIOS support - REST API  https://review.openstack.org/512579
15:07:58 <TheJulia> So I went through and updated a few things, but I was somewhat out of touch last week attending a meeting.
15:08:31 <rloo> TheJulia: ^^ wrt the sushy bug, did a release get done?
15:08:41 <TheJulia> Looks like we did
15:08:41 <rloo> this bug: https://bugs.launchpad.net/sushy/+bug/1754514
15:08:43 <openstack> Launchpad bug 1754514 in sushy "Base authentication don't work" [Critical,Fix released] - Assigned to deray (debayan-ray)
15:08:45 <TheJulia> well, release
15:08:47 <TheJulia> hmmm
15:08:50 <TheJulia> Dmitry was going to create them
15:08:51 <TheJulia> checking
15:09:28 <TheJulia> Release is still pending https://review.openstack.org/#/c/558799/
15:09:29 <patchbot> patch 558799 - releases - Release sushy 1.3.2 for Queens
15:10:04 <rloo> TheJulia: ok, i'll update the status of that.
15:10:12 <TheJulia> I just did
15:10:15 <rloo> TheJulia: :)
15:11:51 <rloo> TheJulia: wrt storyboard migration, L235. what needs to be done there?
15:12:48 <jroll> rloo: do we want to call for volunteers for sighup support in ironic-inspector and networking-baremetal?
15:13:00 <rloo> jroll: oh, yeah, that'd be good.
15:13:12 * jroll added it
15:13:24 <TheJulia> rloo: bunch of patches are pending updating docs
15:13:29 <rloo> jroll: thx! (how'd he know i wasn't working on it... ? :D)
15:13:43 <jroll> heh
15:13:56 <TheJulia> Sounds good
15:14:10 <rloo> TheJulia: do you have a list or is there a topic. let's just get them done.
15:14:20 <jroll> ++
15:14:25 <TheJulia> I raced through them and didn't topic them. I can make a list
15:14:56 <rloo> TheJulia: thx.
15:15:03 <TheJulia> rloo: I'll make it after the meeting
15:15:08 <kaifeng> rloo: i can be the victim for ironic-inspector
15:15:11 <TheJulia> everyone done reviewing the status of all the things
15:15:15 * hjensas can look at sighup support for networking-baremetal.
15:15:17 <rloo> kaifeng: sweet, thx!
15:15:27 <jroll> thanks hjensas :)
15:15:27 <TheJulia> kaifeng: hjensas: awesome, thanks!
15:15:32 <mjturek> o/
15:15:38 <jroll> and thanks kaifeng :)
15:15:42 <TheJulia> \o mjturek
15:16:02 <rloo> thx hjensas!
15:16:20 * rloo done with status
15:16:31 <TheJulia> Onward to priorities for the week?
15:16:33 <jroll> ditto
15:16:39 <kaifeng> yw :)
15:17:44 <TheJulia> #topic Priorities for the coming week
15:18:27 <TheJulia> So it is clear we've been stalling out on the remaining of rescue. I've shuffled the text a little so we can hopefully have a little more clarity there
15:20:14 <jroll> are we stalling or just disagreeing?
15:20:29 <jroll> the one patch has a +2
15:20:32 <TheJulia> Cycling slowly
15:20:40 <TheJulia> very slowly
15:20:45 <jroll> yeah
15:20:56 <TheJulia> As for bios interface, the unit tests are failing
15:21:06 <TheJulia> specifically ones that wont fail locally since they require the database engine
15:21:23 <TheJulia> It impacts the entire stack of patches
15:21:36 <jroll> oh fun!
15:21:46 <rloo> ouch. someone looking at it, or is it 'i don't know how to fix' thing?
15:22:01 <jroll> we know that it's possible to connect local tests to a db engine, right? :)
15:22:18 <TheJulia> I looked at it earlier, I think it is the first time we've tried using json native fields
15:22:27 <rloo> a new set of patches was just done during this meeting, maybe that'll fix...
15:22:30 <jroll> looks like yolanda put up a new patch
15:22:32 <TheJulia> jroll: oh it is, but most people don't have their local db setup to support that
15:22:38 <TheJulia> jroll: oh, awesome
15:22:41 <jroll> sure, but it's possible
15:22:49 <jroll> ... wait, native json fields?
15:22:50 <TheJulia> yup, 7 minutes after
15:22:55 <yolanda> jroll, mine is just wip, but is a long chain
15:23:17 <jroll> yolanda: ah, I see
15:23:33 <TheJulia> jroll: yeah, as in it is stored as json instead of text
15:23:58 <jroll> TheJulia: yes, I know what they are, I didn't think they were in mysql until very very recently
15:24:23 <jroll> though, looking at the patch I don't think they are native json fields
15:24:33 <jroll> we can loop back to this later btw
15:24:43 <TheJulia> jroll: I think a couple years, but I had a similar thought earlier
15:25:02 <TheJulia> Anyway, does anyone have any other items for the priority list?
15:25:44 <rloo> TheJulia: please add your storyboard patches to that list
15:26:00 <TheJulia> that works
15:26:28 <TheJulia> Okay, I'll populate the list after the meeting
15:26:40 <rloo> works for me!
15:26:44 <TheJulia> Anything else? I think we're good as long as we make progress on rescue this week
15:27:17 <rloo> just looking at release schedule. rocky-1 milestone is next week. maybe we should aim to do a release *after* gtting rescue done.
15:27:17 * rpioso must leave early for a downstream group lunch
15:27:54 <rloo> (I'm good with priorities)
15:28:01 * jroll leaves a comment on the bios patch indicating the problem, easy peasy :)
15:28:11 <yolanda> thx for reviews!
15:28:12 <TheJulia> rloo: Possibly yeah, I guess only time will tell
15:28:28 <TheJulia> Anyway, are we good to move on to Open Discussion at this point?
15:29:25 <rloo> yes!
15:29:26 * jroll is fine
15:29:53 <TheJulia> #topic Open Discussion
15:30:26 <rloo> mjturek: bug smash?
15:30:35 <openstackgerrit> yolanda.robla proposed openstack/ironic master: WIP: Add Node BIOS support - REST API  https://review.openstack.org/512579
15:30:51 <TheJulia> So lets see, replaying brain from last week. I was at a baremetal provisioning forum last week, and the thought of federated cross organization ironic came up. I have a couple building block ideas that could help there, so I'll try to toss them up this week.
15:30:54 <mjturek> yep! The doodle is here https://doodle.com/poll/xa999rx653pb58t6
15:31:12 <mjturek> think a 2 hr window will work?
15:32:03 <rloo> i only see 7 people participated in doodle. that makes me sad.
15:32:17 <rloo> does that mean the rest aren't going to participate at all ?
15:32:18 <mjturek> :(
15:32:43 <TheJulia> mjturek: I just added myself
15:32:54 <TheJulia> #link https://doodle.com/poll/xa999rx653pb58t6
15:33:38 <TheJulia> I think a two hour window will work
15:34:06 <TheJulia> Seems like we should just agree on the most common time and move on?
15:34:26 <mjturek> UTC 1:00 PM to 3:00 PM seems most popular
15:34:41 <rloo> sold!
15:34:48 <TheJulia> :)
15:34:52 <mjturek> hoorraaaay!
15:35:01 <mjturek> where are we going to hold this? hangouts?
15:35:12 <mjturek> or how we do mid-cycle?
15:35:30 <rloo> it has been so long since we've had one, that i can't recall what/how we did it.
15:35:54 <TheJulia> mjturek: I think a hangout might be ?easiest?
15:35:55 <jroll> I'm fine with either - inclusivity would imply we should use infra's SIP bridge
15:36:03 <rloo> do we all go through the same bugs at the same time?
15:36:06 <TheJulia> it would, if it has been paid for recently
15:36:32 <rloo> dmitry used bluejean before? or something like that.
15:36:48 <TheJulia> yeah, I have access to a bluejeans account. We could also use that
15:36:58 <TheJulia> I'm okay with any of the above
15:37:08 <rloo> well, 6 people signed up. maybe more will join us. i think as long as the 6 can get access to whatever technology, i'm good.
15:37:37 <jroll> right, we should check with them before scheduling, but I expect bluejeans would be okay
15:37:51 <jroll> or just say "if you can't access this or object to it bla bla" to the email
15:38:05 <TheJulia> I can host in bluejeans I guess
15:38:36 <TheJulia> That will allow people to dial in easily
15:38:52 <mjturek> sounds good to me
15:38:59 <mjturek> details on the ML?
15:39:03 <rloo> in that case, just as good as SIP bridge, so lets use bluejeans.
15:39:12 <rloo> mjturek: yup, email please.
15:39:17 <TheJulia> #action TheJulia to create a bluejeans meeting for the time.
15:39:30 <TheJulia> mjturek: will you close out the poll, and I'll go ahead and create the meeting
15:39:36 <mjturek> perfect
15:39:38 <TheJulia> mjturek: and then send you the details to send an email
15:39:39 <mjturek> will do
15:40:02 <rloo> so we don't spend lots of time during bug bash, deciding how/what/process, might be good for someone mjturek? TheJulia? to propose something before hand?
15:41:00 <rloo> eg will we all look at each bug at the same time, to try to deal with it. or do we split the bugs and ping each other if tehre are questions about one of them?
15:41:03 <mjturek> I can propose something today if that's helpful
15:41:22 <TheJulia> mjturek: that would be awesome
15:41:28 <mjturek> and obviously we can have some back and forth to get a final shape of the thing
15:41:32 <mjturek> cool will do
15:41:34 <rloo> thx mjturek!
15:41:41 <mjturek> np!
15:43:13 <openstackgerrit> Ilya Etingof proposed openstack/sushy-tools master: OpenStack cloud driver added  https://review.openstack.org/523879
15:44:07 <TheJulia> Do we have anything else to discuss?
15:44:15 <rloo> crickets...
15:46:04 <TheJulia> Well, sounds like we're done for the day!
15:46:09 <TheJulia> Meeting wise at least
15:46:11 <TheJulia> Thanks everyone!
15:46:48 <TheJulia> #endmeeting