17:00:48 <TheJulia> #startmeeting ironic
17:00:48 <dtantsur> mmmmeeting time?
17:00:49 <openstack> Meeting started Mon Mar 19 17:00:48 2018 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:51 <TheJulia> o/
17:00:52 <jroll> \o/
17:00:53 <dtantsur> o/
17:00:53 <openstack> The meeting name has been set to 'ironic'
17:00:55 <etingof> o/
17:00:55 <rpioso> o/
17:00:56 <sambetts> o/
17:01:04 <rloo> o/
17:01:08 <jlvillal> o/
17:01:11 <TheJulia> Everyone ready for an ironic meeting?!
17:01:27 <jlvillal> Uh....yeah...yeah!!!
17:01:29 <hshiina> o/
17:01:32 <TheJulia> Excellent!
17:01:43 <TheJulia> Our agenda is on the wiki, as always
17:01:45 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
17:02:11 <TheJulia> I made a couple changes this morning.
17:02:22 <TheJulia> #topic Announcements / Reminders
17:02:53 <mjturek> o/
17:02:55 <TheJulia> #info Rocky Cycle Community Priorities have merged https://specs.openstack.org/openstack/ironic-specs/priorities/rocky-priorities.html
17:03:06 <rloo> yay!
17:04:19 <TheJulia> #info Regarding the Oneview driver, HPE has indicated they are aware of the requirement to remain in-tree. No other update at this time.
17:05:04 <TheJulia> #info XClarity driver CI may be delayed, to be determined.
17:06:17 <TheJulia> tl;dr Someone new will be picking up the 3rd party CI work, contact unknown at present but I'm in communication with Lenovo.
17:06:37 <TheJulia> Anyone else have any announcements or reminders to bring up?
17:07:18 <TheJulia> o/ crushil
17:07:32 <crushil> TheJulia, \o
17:07:38 <rpioso> Did an ML message go out re: lifecycle management discussions?
17:07:48 <TheJulia> rpioso: That is on my calendar for thursday
17:08:02 <rpioso> TheJulia: Cool
17:08:04 <TheJulia> rpioso: I'll try to get it done sooner :)
17:08:57 <TheJulia> Well, if there is nothing else announcement wise, we can move on...
17:08:59 <vdrok> o/
17:10:35 <TheJulia> One last thing, the reason for XClarity CI being delayed is that crushil will be moving on. I would like to thank him for his efforts, and hopes that he stays in touch with the community.
17:10:46 <dtantsur> crushil++ good luck
17:10:59 <crushil> TheJulia, dtantsur Thanks
17:11:06 <rloo> thanks crushil, sorry that you're moving on
17:11:25 <crushil> Thanks rloo. It was pleasure working with the Ironic community
17:11:43 <TheJulia> Moving on...
17:11:45 <TheJulia> #topic Reviewing Action Items from the last meeting
17:12:10 <TheJulia> We had three action items last week
17:12:22 <stendulker> o/
17:12:32 <TheJulia> (TheJulia) Reorganize the whiteboard
17:12:43 <TheJulia> (TheJulia) Get the community a taste of storyboard
17:12:50 <TheJulia> And finally
17:13:35 * jlvillal waits...
17:13:36 <TheJulia> (mjturek) Leading bug triaging.
17:13:42 <TheJulia> Sorry, slight interruption
17:13:55 <jlvillal> heh. I thought it was a dramatic pause :)
17:14:00 <TheJulia> As everyone has hopefully seen, the whiteboard has been reorganized.
17:14:02 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:14:12 <TheJulia> I also provided a taste of storyboard with ironic data
17:14:20 <TheJulia> #link https://nuc.mirroruniverse.org
17:14:31 <TheJulia> mjturek: how were the bugs?
17:14:35 <mjturek> did not get a lot done on the triage. Reviewed some of the New bugs but nothing too interesting
17:14:47 <TheJulia> Sounds good
17:14:56 <TheJulia> Time to move on to our next topic then!
17:15:20 <TheJulia> #topic Review subteam status reports
17:15:42 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:16:03 <TheJulia> Starting at line 148
17:16:16 <rloo> sorry this is an aside, but i am looking at the 3rd party CI and it needs to be updated. Maybe an action item for next week TheJulia? L68
17:16:59 <TheJulia> Perfectly valid :)
17:17:06 <rloo> dtantsur: do you know what the critical ironic bug is?
17:17:09 <TheJulia> #action TheJulia to review/update 3rd party CI section of the whiteboard
17:17:12 <rloo> dtantsur: forget it, i see it is sushy
17:17:38 <dtantsur> yep
17:18:25 <rloo> good work on approving bios config spec. for next week -- would be good to know if the code patches are ready for reviewing.
17:18:47 <TheJulia> zshi or yolanda, are either of you around?
17:18:54 * dtantsur remembers reviewing something
17:19:17 <TheJulia> vdrok: Regarding neutron event processing, it looks like the spec likey needs an update.
17:19:19 <rloo> vdrok: wrt neutron event processing L213. is that the latest status (from today, vs sept)?
17:19:25 <yolanda> hi TheJulia
17:19:29 <yolanda> yep, the patches should be ready
17:19:43 <jroll> awesome
17:19:48 <vdrok> rloo: will update the whiteboard, tldr rewriting the code
17:19:49 <rloo> are we 2018 or 2019? L222...
17:19:51 <TheJulia> yolanda: we would like someone to create an ordered list for us to begin reviewing from.
17:19:54 <rloo> thx vdrok!
17:19:59 <TheJulia> vdrok: thanks!
17:20:08 <yolanda> ok... let me work on that tomorrow
17:20:23 <TheJulia> yolanda: thanks, is it okay if I note it as an action item?
17:20:28 <yolanda> sure
17:20:28 <openstackgerrit> Michael Turek proposed openstack/ironic master: Add OpenBMC class for accessing nodes using OpenBMC  https://review.openstack.org/429836
17:20:36 <jroll> TheJulia: the patches are already in order on the branch, right?
17:20:40 * jroll sees 5 in one chain
17:20:53 <rloo> TheJulia: wrt nova virt/REST API. there were some questions in the priority spec; should we discuss at some point?
17:21:22 <jroll> rloo: ++
17:21:29 <TheJulia> #action yolanda to update list of bios interface patches in the whiteboard to represent review order.
17:22:00 <TheJulia> jroll: rloo: we can discuss it during the discussion or open discussion If that works
17:22:03 <yolanda> TheJulia,  there have been some reviews from Hironori as well. I'll talk with zshi tomorrow and we'll let you know
17:22:05 <jroll> sure
17:22:10 <TheJulia> yolanda: thanks
17:22:30 <yolanda> thx, is great to see progress on that feature!
17:22:51 <TheJulia> Everyone done reviewing the whiteboard?
17:23:07 <rloo> TheJulia: wrt storyboard. what is the plan? can we just DO IT?
17:23:20 <TheJulia> I was going to bring that during discussion :)
17:23:34 <rloo> TheJulia: okey dokey; i can wait :)
17:23:39 <TheJulia> short answer yes, long answer, I can have them do it this week and we can start using it say... monday?
17:24:14 <TheJulia> Anyway, Moving on to priorities for this week
17:24:26 <TheJulia> #topic Priorities for this next week
17:24:59 <rloo> fix sushy critical bug
17:25:08 <dtantsur> yep
17:25:19 <rloo> dtantsur: you know what needs to be done to ^^ ?
17:25:24 <dtantsur> rloo: review
17:25:33 <TheJulia> dtantsur: link?
17:25:50 <dtantsur> #link https://review.openstack.org/#/c/552817/
17:25:51 <patchbot> patch 552817 - sushy - Mark Systems/Managers/SessionService optional
17:25:51 <rloo> where are we wrt rescue work?
17:26:16 <TheJulia> Looks like were in disagreement land with regards to interface methods
17:26:21 <TheJulia> and design... again
17:26:36 <dtantsur> \o/
17:26:44 <rloo> TheJulia: with rescue?
17:27:23 <TheJulia> rloo: yup
17:27:27 <TheJulia> and deploy
17:27:44 <openstackgerrit> Lenny Verkhovsky proposed openstack/ironic master: Infiniband Port Configuration update[1]  https://review.openstack.org/553400
17:27:49 <jroll> I thought we got rescue done last cycle, except the nova side?
17:28:19 <rloo> TheJulia: which part/patch of rescue are we talking about, that is in disagreement?
17:28:29 <jroll> +1, I'm curious
17:29:07 <dtantsur> adding a new method because for $weird_reason deploy interfaces don't always call boot.prepare_instance..
17:29:16 <rloo> TheJulia: is it https://review.openstack.org/#/c/546919/?
17:29:17 <patchbot> patch 546919 - ironic - Prepare instance to unrescue by deploy interface
17:29:18 <TheJulia> ^that
17:29:50 <rloo> ok -- so what needs to be done to move forward. do we need to meet/agree on something?
17:30:01 <TheJulia> There is some inline discussion, I'd like to keep it as a priority this week to see if we can just get some consensus and move forward.
17:30:08 <dtantsur> ++
17:30:16 <rloo> TheJulia: ok, I'll make a note to look at that. thx.
17:30:30 <TheJulia> stendulker: In this discussion your patch on fixing for basically fixing the same thing for agent deployments was raised, do you think we can get that revised?
17:30:53 <TheJulia> It is noted as the "better fix" https://review.openstack.org/#/c/499050/  :)
17:30:53 <stendulker> TheJulia: I have posted revised patch
17:30:53 <patchbot> patch 499050 - ironic - Fix ``agent`` deploy interface to call ``boot.prep...
17:31:08 <TheJulia> Heh, that you have
17:31:23 * TheJulia updates priorites list
17:32:01 <stendulker> TheJulia: But one test related to ironic-tempest-dsvm-ipa-wholedisk-agent_ipmitool-tinyipa-multinode fails. Not able to get exact reason for the failure
17:32:15 <rloo> jroll, others: is that still a critical bug in nova? L112
17:32:40 <rloo> jroll: the importance is 'low' in the bug
17:32:42 <TheJulia> stendulker: Ugh, I can try to take a look this week
17:33:01 <stendulker> TheJulia: Thanks
17:33:02 <TheJulia> for nova it's importance may be low, for us it is higher
17:33:14 <jroll> rloo: I'm not sure I'd call it critical, it's probably high from our perspective (because CI gets into this situation). I updated the patch friday and will poke people today/tomorrow
17:33:25 <rloo> jroll: ok thx
17:33:26 <TheJulia> Does anyone have any other items they would like to see reviewed this week?
17:33:54 <rloo> TheJulia: i've got another question, wrt L117, 'Required Queens Backport'. do we still need that?
17:34:15 <TheJulia> rloo: I thought I had deleted that...
17:34:56 <TheJulia> etingof: would you be able to revise https://review.openstack.org/#/c/526773/ in the next day or so?
17:34:57 <patchbot> patch 526773 - ironic - Add boot mode support to ManagementInterface
17:35:06 * etingof looking
17:35:40 <rpioso> TheJulia, etingof: I offered to take another look at that patch.
17:35:44 <etingof> TheJulia, yes, but I'd like to engage rpioso as well
17:35:59 <TheJulia> Any objection to adding it to the priority list so we can make some progress in that direction?
17:36:07 <rpioso> +1
17:36:15 <etingof> +1!
17:36:27 <dtantsur> no objections
17:36:50 <TheJulia> Everyone good with that list of priorites?
17:37:05 <jroll> I'm happy
17:37:25 <dtantsur> LGTM
17:37:27 <rloo> +1
17:37:47 <TheJulia> Moving on then!
17:37:49 <TheJulia> #topic Appointing a bug triaging lead for the coming week
17:38:05 <TheJulia> Anyone want to be the vict^Wvolunteer this week?
17:38:16 * jroll has to step away for a few, sorry - consider me fine with moving the meeting or keeping it as is when we get to that topic
17:39:03 <dtantsur> I can try getting some time for bug triaging
17:39:12 <dtantsur> actually, I do some before every meeting anyway
17:39:42 <rloo> oh, sorry, related to rescue work -- are we planning on doing client release any time soon?
17:39:43 <TheJulia> If we can get some done before thursday, it will help us out. I'll see about getting them to push the buttons for storyboard migration on Friday
17:39:44 <rloo> thx dtantsur!
17:39:52 <TheJulia> rloo: already done
17:39:58 <rloo> TheJulia: sweet. thx!
17:40:12 <TheJulia> no problem
17:40:26 <TheJulia> Seems like we should all try to spend time on bugs this week...
17:41:19 <TheJulia> Anyway, I'm going to move on to discussion since we really all should try and spend some time looking at launchpad bugs this week
17:41:40 <TheJulia> #topic Discussion
17:41:53 <TheJulia> We have two items... well three, maybe. :)
17:42:19 <TheJulia> The first is do we move the meeting to 2PM or 3PM UTC?
17:42:30 <TheJulia> The results from the time poll can be found at https://doodle.com/poll/6kuwixpkkhbwsibk
17:43:11 <dtantsur> this is great for Europe, but I guess we exclude west coast?
17:43:27 <TheJulia> And those times are friendly-er to Japan in that it may be 11PM or 12PM. We don't have any New Zealand contributors, but it would also mean that the west coast of the united states would have to get up early :)
17:43:47 <TheJulia> I am willing to get up for a 7AM meeting, because I <3 you all
17:43:48 <dtantsur> like, really early :)
17:44:03 <TheJulia> Eh, not that early
17:44:28 <jlvillal> https://www.timeanddate.com/worldclock/fixedtime.html?msg=Ironic+meeting&iso=20180327T02&p1=1440&ah=1
17:44:38 <jlvillal> Oh wait wrong
17:45:05 <jlvillal> https://www.timeanddate.com/worldclock/fixedtime.html?msg=Ironic+meeting&iso=20180327T14&p1=1440&ah=1
17:45:13 <TheJulia> I think the time should also be a little more friendly to stendulker
17:45:15 <jlvillal> So 7am here on the west coast of the USA
17:45:29 <TheJulia> Thoughts/objections? Shall we just vote on it?
17:45:37 <stendulker> TheJulia: yes
17:45:50 * dtantsur cannot seriously ask people to wake up at 7am, which is deep night for him
17:46:07 <rpioso> jlvillal: That's during daylight savings time. It'll change in the fall.
17:46:11 <jlvillal> So 2PM UTC is 7AM pacific now. When Daylight Savings Times end it will be 6AM
17:46:12 <TheJulia> It is worth noting that I don't think we have any active contributors in .au or .nz who the time would be the most unfriendly to
17:46:25 <TheJulia> I like 6AM less than 7 AM
17:46:47 <TheJulia> Perhaps we vote on 3PM UTC or not changing then?
17:47:11 <jlvillal> 3PM times: https://www.timeanddate.com/worldclock/fixedtime.html?msg=Ironic+meeting&iso=20180327T15&p1=1440&ah=1
17:47:22 <jlvillal> Find your location :)
17:47:40 * TheJulia finds it amusing that the website knows I'm in Palm Springs, CA area
17:48:03 <rloo> so based on the poll, we are talking about 2pm vs 3pm, right? the only diff is jlvillal or hjensas if I read it correctly.
17:48:09 <rloo> and any future west coast US folks.
17:48:25 <rloo> so between the two times, much as I'd like hjensas, it seems like 3pm is the saner one?
17:48:38 <dtantsur> it feels so...
17:49:38 <dtantsur> so, essentially, move 1 hour earlier?
17:49:48 <jlvillal> Two hours
17:49:51 <rloo> is hjensas here?
17:50:00 <TheJulia> Yes, two hours, we are presently 5PM UTC
17:50:19 <rloo> (I guess i am wondering if hjensas would like to attend the meeting if he could attend the meeting)
17:50:20 <dtantsur> rly?
17:50:36 <dtantsur> hmm, maybe you're right /me hates timezones
17:50:48 <jlvillal> dtantsur, https://www.timeanddate.com/worldclock/fixedtime.html?msg=Ironic+meeting&iso=20180327T15&p1=1440&ah=1  Find Berlin :)
17:51:09 <dtantsur> jlvillal: this link is wrong, that's the problem.. Berlin is not UTC+2
17:51:25 <dtantsur> that's what confused me
17:51:35 <jlvillal> dtantsur, Ah, so not 7PM-ish right now where you are?
17:51:37 <TheJulia> I know this meeting is presently ?2 AM? for hshiina, so if we would like to vote we can now, or we can defer until next week.
17:51:44 <dtantsur> ah, 27 Mar will be after daylight switch
17:51:58 <TheJulia> dtantsur: I think we all dislike time zones
17:52:03 <jlvillal> dtantsur, Sorry I made it for next week :(
17:52:09 <dtantsur> I think we can vote, his vote is on the poll
17:52:45 * TheJulia tries to remember voting syntax
17:52:54 <jlvillal> #vote
17:53:02 <TheJulia> #vote 3pm nochange
17:53:06 * jlvillal is ignored as not meeting operator
17:53:06 <dtantsur> TheJulia: #startvote Description Options
17:53:22 <dtantsur> or maybe even #startvote Description? Options
17:53:28 <jlvillal> yes no. I assume for options
17:53:44 <jlvillal> #help startvote
17:53:47 <rloo> So the choices are 2pm or 3pm, right?
17:53:48 <TheJulia> #startvote Move_The_Meeting 3PM KeepTheSame
17:53:48 <dtantsur> #startvote Should we move this meeting to 3pm UTC? Yes, No
17:53:49 <openstack> Unable to parse vote topic and options.
17:53:51 <openstack> Only the meeting chair may start a vote.
17:53:54 <jlvillal> meh. Maybe I should submit a patch...
17:53:55 <dtantsur> TheJulia: copy my message
17:54:03 <TheJulia> #startvote Should we move this meeting to 3pm UTC? Yes, No
17:54:04 <openstack> Begin voting on: Should we move this meeting to 3pm UTC? Valid vote options are Yes, No.
17:54:05 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
17:54:10 <TheJulia> \o/
17:54:13 <dtantsur> :)
17:54:16 <TheJulia> #vote Yes
17:54:17 <dtantsur> #vote Yes
17:54:20 <rloo> if we say no, then 2pm or we keep it at 5pm?
17:54:29 <sambetts> #vote Yes
17:54:30 <TheJulia> no would keep it at this point
17:54:37 <rpioso> #vote Yes
17:54:38 <rloo> #vote Yes
17:54:49 <rloo> i think jroll would also vote yes
17:54:55 <hshiina> #vote Yes
17:55:07 <stendulker> #vote Yes
17:55:23 <TheJulia> Say I'll close voting in about 1 minute
17:56:11 <jlvillal> #vote yes
17:56:30 <TheJulia> Our next discussion topic is storyboard. If there are no objections, I'll tell infra to push the buttons later this week and we can start using storyboard next monday. There will naturally be an adjustment period, and we may want to have a call to discuss use/patterns next week.
17:56:34 <TheJulia> #endvote
17:56:35 <openstack> Voted on "Should we move this meeting to 3pm UTC?" Results are
17:56:37 <openstack> Yes (8): TheJulia, rloo, jlvillal, stendulker, rpioso, dtantsur, sambetts, hshiina
17:56:46 <TheJulia> So, I guess we move the meeting
17:56:51 <dtantsur> yep
17:56:51 <hjensas> Sorry, I just came in. But 3pm UTC is good for me. :)
17:56:52 <TheJulia> #action TheJulia to reschedule and send out email.
17:57:00 <TheJulia> Awesome, thanks hjensas
17:57:09 <TheJulia> Any objections/issues/questions regarding storyboard?
17:57:10 <jlvillal> TheJulia, So that means you will submit patch?
17:57:12 <rloo> hjensas: great
17:57:17 <TheJulia> jlvillal: Yes
17:57:20 <jlvillal> Thanks!
17:57:46 <TheJulia> rloo: jroll: I guess we can discuss nova virt driver stuff in channel when jroll returns.
17:57:58 <rloo> TheJulia: yup
17:57:59 <TheJulia> 3 Minute Warning
17:58:04 <dtantsur> anyway 3 minutes is not enough for a nova discussion :)
17:58:21 <rloo> who else is interested in the nova virt discussion besides dtantsur, TheJulia, jroll, me?
17:58:37 <dtantsur> I will have to leave soon
17:58:37 <rloo> adn wrt storyboard, action item TheJulia?
17:58:47 <dtantsur> yeah, and #agreed on the meeting :)
17:58:58 <rloo> dtantsur: so maybe tomorrow instead, to talk about nova virt
17:59:24 <TheJulia> #agreed Moving meeting to 3pm UTC
17:59:29 <dtantsur> don't wait for me, I guess
17:59:35 <TheJulia> #action TheJulia to start storyboard migration
17:59:35 <jroll> tomorrow wfm, sorry about leaving abruptly
17:59:36 <dtantsur> I'll read the scrollback
17:59:38 <rloo> TheJulia: do we need to hold off opening/updating bugs during xsition to storyboard?
17:59:57 <TheJulia> rloo: Only on friday I guess
18:00:01 <TheJulia> I'll follow-up
18:00:06 <rloo> TheJulia: ok, just give us some notice :)
18:00:07 <TheJulia> Thanks everyone!
18:00:11 <dtantsur> thanks TheJulia
18:00:14 <TheJulia> rloo: will do!
18:00:17 <TheJulia> #endmeeting