17:00:10 <TheJulia> #startmeeting ironic
17:00:11 <openstack> Meeting started Mon Feb 19 17:00:10 2018 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:12 <TheJulia> o/
17:00:13 <dtantsur> o/
17:00:14 <openstack> The meeting name has been set to 'ironic'
17:00:20 <jroll> ohai
17:00:22 <baha> o/
17:00:29 <rpioso> o/
17:00:30 <etingof> o/
17:00:45 <stendulker> o/
17:00:49 <hshiina> o/
17:01:07 <mgoddard_> /o\
17:01:10 <TheJulia> Our agenda is on the wiki as always
17:01:39 <TheJulia> Hopefully this meeting will be relatively quick given that next week is the PTG.
17:02:01 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:02:19 <TheJulia> #topic Announcements/Reminders
17:02:49 <TheJulia> #info Rocky PTG is next week, and as such next week's IRC meeting is cancelled.
17:03:35 <TheJulia> #info An initial schedule is up on the PTG planning etherpad. https://etherpad.openstack.org/p/ironic-rocky-ptg
17:03:57 <TheJulia> #info The at PTG evening gathering will be on Tuesday at 7 PM. Information is inside the planning etherpad.
17:04:23 <TheJulia> Also dtantsur, I believe we will be doing our final queens release for this cycle later this week?
17:04:30 <dtantsur> TheJulia: yep, by Thu
17:04:43 <TheJulia> #info Final queens release this week.
17:04:47 <TheJulia> Anyone have anything else?
17:05:54 <mjturek> o/
17:05:54 <TheJulia> On, on a side note, expect me to be sporadically available Wednesday-Friday. dtantsur will be likely be the one submitting the final queens release.
17:06:11 <dtantsur> a mere shadow of former powers :D
17:07:13 <TheJulia> And less stress :)
17:07:20 <TheJulia> Anyway, I guess we can move on!
17:07:33 <ricardoas> o/
17:08:06 <dtantsur> ++ move on
17:08:10 <TheJulia> #topic Review Action Items
17:08:51 <TheJulia> Last week, we had two action items. (1) Everyone triage bugs and (2) For myself to try and reproduce the crash of nova-conductor locally.
17:09:34 <TheJulia> I was unable to do the latter, but we determined that disabling bytecode from being stored on disk prevents the crash created by library incompatibilities in grenade.
17:10:08 * dtantsur triaged a few things and revives some older bugs
17:10:08 <TheJulia> Moving on!
17:10:15 <TheJulia> dtantsur: thanks!
17:10:19 <dtantsur> :)
17:10:46 <TheJulia> #topic Review sub-team status reports
17:10:50 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:11:21 <TheJulia> I doubt there are any updates worth discussing, since last week was a fairly quiet week.
17:12:10 <dtantsur> #action dtantsur add networking-baremetal and networking-generic-switch to his bug dashboard
17:12:19 * dtantsur dunno if #action works for non-chairs
17:13:37 <TheJulia> I don't believe so
17:13:38 <TheJulia> #action dtantsur add networking-baremetal and networking-generic-switch to his bug dashboard
17:14:08 <TheJulia> Looks like there is nothing to really discuss with regards to status, anyone have anything to bring up before we move on?
17:14:48 <dtantsur> it seems like we have 2 bugs in rescue
17:14:52 <dtantsur> to finish and backport
17:15:09 <dtantsur> https://review.openstack.org/#/c/544278/ and https://review.openstack.org/#/c/545186/
17:15:10 <patchbot> patch 544278 - ironic - Build instance PXE options for unrescue
17:15:11 <patchbot> patch 545186 - ironic - Set 'initrd' to 'rescue_ramdisk' for rescue with iPXE
17:15:35 * dtantsur is ready to move on
17:15:54 <TheJulia> dtantsur: please add those to the priorities list so we're tracking them (if they are not aleady there)
17:15:59 <TheJulia> already
17:16:05 <dtantsur> I think I did
17:16:11 <TheJulia> #topic Priorities for the coming week
17:16:12 <TheJulia> \o/
17:17:38 <mgoddard_> There is a bug when using cleaning with traits set: https://bugs.launchpad.net/ironic/+bug/1750027
17:17:38 <openstack> Launchpad bug 1750027 in Ironic "Traits & cleaning issue" [High,In progress] - Assigned to Mark Goddard (mgoddard)
17:17:45 <openstackgerrit> Merged openstack/ironic master: Conductor version cannot be null in Rocky  https://review.openstack.org/544382
17:17:55 <openstackgerrit> Merged openstack/ironic master: Clean nodes stuck in CLEANING state when ir-cond restarts  https://review.openstack.org/349971
17:18:04 <openstackgerrit> Merged openstack/ironic master: Fix rare HTTP 400 from port list API  https://review.openstack.org/545069
17:18:41 * dtantsur cherry-picks ^^^
17:18:50 <mgoddard_> Would be nice to get the fix merged before the queens release
17:19:01 <openstackgerrit> Dmitry Tantsur proposed openstack/ironic stable/queens: Fix rare HTTP 400 from port list API  https://review.openstack.org/545892
17:19:20 <openstackgerrit> Dmitry Tantsur proposed openstack/ironic stable/queens: Clean nodes stuck in CLEANING state when ir-cond restarts  https://review.openstack.org/545893
17:19:40 <TheJulia> I think that is good, I cleaned up the lists and removed prior items
17:19:59 <dtantsur> mgoddard_: I keep an eye on it, just waiting for the CI
17:20:36 <mgoddard_> dtantsur: thanks. jlvillal pointed out there is a py3.5 unit test failure so there will be at least another revision
17:20:37 <TheJulia> I agree we should likely try and merge/backport
17:21:20 <jroll> there's also that bug we're seeing in grenade that I'm hacking on - tl;dr explosive problems with placement if ironic goes down for too long
17:21:28 <dtantsur> oh
17:21:50 <TheJulia> jroll: has a bug been opened for that?
17:21:52 <jroll> here's the wip patch https://review.openstack.org/#/c/545479/
17:21:53 <patchbot> patch 545479 - nova - ironic: stop lying to the RT when ironic is down
17:22:01 <jroll> TheJulia: I should open a separate bug if there's not yet
17:22:03 * jroll will do today
17:22:24 <TheJulia> jroll: thanks, please add to the priorites list for the week since we will need ironic eyes on it
17:22:27 <TheJulia> err
17:22:32 <TheJulia> wip patch, I'll add that
17:22:52 <jroll> thanks
17:23:36 <TheJulia> Okay, added
17:23:41 <TheJulia> Anything else?
17:24:00 <dtantsur> not from me
17:24:18 <TheJulia> Everyone happy with the list?
17:24:31 * jroll is good
17:24:35 <TheJulia> Moving to Open Discussion since we have no discussion items on the agenda...
17:24:50 <TheJulia> #topic Open discussion
17:25:01 * jroll thanks derekh for putting together the thing
17:25:17 <TheJulia> Everyone going to remember to bring an ironic t-shirt for the team photo?
17:25:25 <TheJulia> Yes, thanks derekh!
17:25:36 <derekh> no prob
17:25:59 * jroll has one
17:26:13 <jroll> team photo is on thursday, for the curious
17:27:03 <TheJulia> \o/
17:27:09 <TheJulia> Does anyone have anything else to discuss?
17:27:59 <TheJulia> Otherwise, I think we can wrap this short meeting up for today.
17:28:00 <dtantsur> cri...
17:28:01 <devananda> I'd be ever so thrilled to join some of the shenanigans remotely, maybe do a video call in at some point
17:28:16 <dtantsur> devananda: we'll call you from the bar ;)
17:28:26 <TheJulia> ++++
17:28:33 <devananda> davidlenwell offered to pin a phone to his shirt while we use hangouts ;)
17:28:47 <dtantsur> ... or when we discuss converting to a CMDB finally?
17:28:52 <jroll> LOL
17:28:57 <devananda> dtantsur: yes pls! I've got a nice bottle of whisky here - I would love to raise a glass with ya'll
17:29:07 <dtantsur> :D
17:29:08 <devananda> dtantsur: bwahaha!
17:29:13 <TheJulia> So sounds like we have some plans!
17:29:16 <TheJulia> :)
17:30:47 * dtantsur seems to hear crickets again
17:30:50 <TheJulia> Anyway, the crickets as a service have returned with a beautiful cricket sound. I think we can call this meeting a wrap
17:30:55 <TheJulia> Thanks everyone!
17:30:57 <dtantsur> ++ thanks TheJulia
17:31:23 <TheJulia> Oh, one final thing, I'll break the etherpad up after I have lunch in a little bit, so expect to see text moving around in relation to the schedule
17:31:43 <TheJulia> #endmeeting