17:00:03 <dtantsur> #startmeeting ironic
17:00:05 <openstack> Meeting started Mon Feb  5 17:00:03 2018 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:08 <openstack> The meeting name has been set to 'ironic'
17:00:09 <jroll> \o
17:00:10 <dtantsur> o/
17:00:15 <rloo> o/
17:00:17 <mgoddard_> o/
17:00:21 <stendulker> o/
17:00:21 <bfournie> o/
17:00:26 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:00:33 <etingof> o/
17:00:39 <hshiina> o/
17:00:54 <dtantsur> hi (again) everyone! :) this might be the last time I chair this meeting, heh
17:00:54 <jlvillal> o/
17:00:56 <TheJulia> dtantsur: networking-baremetal could use two more things to land most likely, minor patches
17:00:57 <TheJulia> o/
17:01:07 <rpioso> o/
17:01:22 * jroll makes dtantsur the default substitute
17:01:28 <dtantsur> #topic Announcements / Reminder
17:01:39 <dtantsur> #info Feature freeze is upon us
17:01:53 <dtantsur> please be very considerate when approving anything that looks like a feature
17:02:01 <dtantsur> particularly anything that modifies API/RPC
17:02:06 <rloo> ptl election ends Feb 14. dtantsur has at least one more meeting, if not more :)
17:02:15 <dtantsur> rloo: if we have elections, that is ;)
17:02:24 <mjturek> o/
17:02:37 <dtantsur> #info All projects that have not created stable/queens will do it by Thu
17:02:44 <dtantsur> (all our projects, I mean)
17:03:00 <dtantsur> we will be releasing projects earlier too, when we find appropriate
17:03:28 <dtantsur> #info The multinode grenade job is broken and needs YOU to help debugging it
17:03:32 * jlvillal wonders who the candidate(s) are for PTL as he doesn't see any emails in quick search
17:03:48 <rloo> jlvillal: none yet for ironic.
17:03:50 <dtantsur> jlvillal: TheJulia is, I am not, that's all I know :)(
17:03:52 <TheJulia> jlvillal: I submitted my candidacy to the elections repo last friday, but have not sent an email
17:04:05 <rloo> ahhh, a candidate emerges... :)
17:04:07 <openstackgerrit> Sam Betts proposed openstack/ironic stable/ocata: Use zuul.override_checkout  instead of custom branch_override var  https://review.openstack.org/540830
17:04:08 <jlvillal> Ah :)
17:04:11 <jroll> https://github.com/openstack/election/tree/master/candidates/rocky/Ironic fyi
17:04:13 <jroll> :)
17:04:31 <rloo> thx jroll!
17:04:36 <dtantsur> #info The PTL nominations are accepted till Wed
17:04:40 <rloo> dtantsur is relieved...
17:04:46 <dtantsur> kinda ;)
17:04:47 <ricardoas> o/
17:05:02 <openstackgerrit> Sam Betts proposed openstack/ironic stable/pike: Use zuul.override_checkout  instead of custom branch_override var  https://review.openstack.org/540829
17:05:33 <dtantsur> #link https://etherpad.openstack.org/p/ironic-rocky-ptg PTG planning continues
17:05:39 <dtantsur> anything else I should mention?
17:06:00 * dtantsur is still struggling with a visa, sigh
17:06:04 <rloo> dtantsur: wrt ptg planning. are there any dates we need to be aware of. eg, deadline for topics? or will we go over them before ptg?
17:06:20 <rloo> dtantsur: oh, wait. maybe i should wait for our new leader...
17:06:31 <dtantsur> rloo: on the etherpad I asked topic to be submitted by Feb 16th
17:06:45 <dtantsur> but yes, the PTG planning will be in hands of the new victim :D
17:06:53 <TheJulia> The new leader can sort and break things into logical chunks
17:06:56 <rloo> s/victim/lucky duck/
17:06:57 <TheJulia> s/leader/victim/ :)
17:07:09 <dtantsur> let's agree on 'lucky victim' :D
17:07:13 <TheJulia> ++
17:07:18 * jroll confirms victim is the right word
17:07:19 <rloo> lucky bear?
17:07:23 <TheJulia> wait, that should be willing lucky victim
17:07:51 <dtantsur> lol, ok. ready to move on?
17:07:57 <TheJulia> ++
17:08:18 <dtantsur> #topic Review action items from previous meeting
17:08:30 <dtantsur> #link http://eavesdrop.openstack.org/meetings/ironic/2018/ironic.2018-01-29-17.00.html
17:08:51 <dtantsur> anything to report?
17:09:26 <TheJulia> I blocked the rescue patches at the logical point
17:09:39 <dtantsur> mjturek: anything new from the bug triaging?
17:09:50 <TheJulia> they have since been revised for standalone testing to not use the OSC commands, I have not had a chance to review them since noticing that this morning.
17:10:06 <rloo> thx TheJulia
17:10:08 <mjturek> hey dtantsur
17:10:17 <mjturek> I've been cleaning up the wishlist
17:10:27 <dtantsur> yeah, I've noticed it shrinking, thanks!
17:10:42 <mjturek> I have a list of bugs I've moved to Opinion, so if there's something you disagree with let me know!
17:11:28 <dtantsur> #link https://etherpad.openstack.org/p/ironic-bug-triage
17:11:31 <TheJulia> mjturek: is there any easy way to pull that list?
17:11:41 <dtantsur> TheJulia: it is there ^^^
17:11:44 <TheJulia> oh, nevermind :)
17:11:46 <openstackgerrit> Merged openstack/ironic master: Add validate_rescue() method to network interface  https://review.openstack.org/540445
17:11:48 <TheJulia> thanks!
17:12:08 <mjturek> :) thanks
17:12:17 <dtantsur> #topic Review subteam status reports (capped at ten minutes)
17:12:31 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard line 161
17:12:39 <pas-ha> dtantsur: re n-g-s, I think we have two more patches to land, one is actual bug, another is initial release note
17:12:45 <dtantsur> I haven't found a new place for my bug dashboard, still running it locally.. :(
17:12:51 <rloo> dtantsur: what's the critical ironic bug?
17:13:01 <dtantsur> rloo: IIRC multinode grenade?
17:13:13 <rloo> dtantsur: is it still critical?
17:13:18 <dtantsur> #link https://bugs.launchpad.net/ironic/+bug/1744139
17:13:19 <openstack> Launchpad bug 1744139 in Ironic "Grenade job fails due to systemd stopping n-cpu" [Critical,In progress] - Assigned to Julia Kreger (juliaashleykreger)
17:13:26 <dtantsur> rloo: yes. we have to re-enable the job asap
17:13:38 <rloo> dtantsur: okay
17:13:43 <dtantsur> or we're failing the rolling upgrade tag requirement
17:13:51 <pas-ha> yes, that
17:14:02 <TheJulia> the cause has likely shifted since we originally opened that bug
17:14:26 <rloo> TheJulia, dtantsur: wrt api version negotiation. is the TODO still valid, or is that done? or what is left...
17:14:26 <dtantsur> pas-ha: mind putting the patches after line 124?
17:14:30 <rloo> L204
17:14:34 <pas-ha> dtantsur: ok
17:14:53 <TheJulia> rloo: I think so yes
17:15:01 <TheJulia> rloo: just we are on hold until rocky+ptg
17:15:09 <rloo> TheJulia: ok, good.
17:15:30 <rloo> dtantsur: wrt classic driver deprecation. anything left that we need to do for queens?
17:15:53 <dtantsur> rloo: we need docs and CI updates, but they can be backported
17:16:02 <dtantsur> no feature work to my best knowledge
17:16:13 <rloo> dtantsur: ok, so all the TODOs need to be done & backported?
17:16:19 <dtantsur> yep
17:16:31 <jroll> nice
17:16:36 <rloo> dtantsur: good thing you'll have time when you aren't ptl ;)
17:16:41 <dtantsur> oh yeah
17:16:46 <dtantsur> maybe even refarch...
17:16:50 <TheJulia> what is this time word?
17:17:12 <jroll> refarch ++
17:17:18 <rloo> TheJulia: don't worry, it won't apply to you :D
17:17:27 <TheJulia> If I buy coffee, can we just get refarch banged out while we're in ireland?
17:17:38 <TheJulia> rloo: lol
17:17:39 <rloo> so routed network support... lots of stuff there. what is the 2-line synopsis?
17:17:52 <dtantsur> TheJulia: let's do it!
17:17:53 <sambetts> TheJulia: ++
17:18:09 <rloo> please add refarch to ptg topics
17:18:18 <dtantsur> rloo: it should be 1-2 patches left, I'm waiting for someone to clean up the status
17:18:20 <TheJulia> rloo: mostly merged, one or two minor things before we can release
17:18:40 <sambetts> yeah thanks so much to hjensas for getting that done BTW
17:18:47 <rloo> the minor things can go in this week or was it part of ffe that ended last Fri?
17:19:02 <hjensas_mobile> Routed networks, I think we need to push the last patch making the distributed thing. There is one or two patches to fix nits.
17:19:28 <TheJulia> rloo: this week is fine, the ring patch would be good to land this cycle if we can
17:19:39 <dtantsur> rloo: nothing that looks like a feature. corrections to the FFE are fine though.
17:19:43 <dtantsur> the border is really thin, I know
17:19:46 <hjensas_mobile> Unless I find time, via magic, and can get jroll's comments done by wednesday ...
17:19:46 <rloo> hjensas_mobile: if you can, could you update the whiteboard to make it clear. or maybe someone can add those patches to weekly priorities?
17:20:18 <hjensas_mobile> Rloo, i can once back home.
17:20:29 <rloo> i am not sure i like the ring patch landing so late, but if reviewers are confident...
17:20:49 <rloo> thx hjensas_mobile
17:20:49 <TheJulia> I'm fairly confident and it sets the service off being n+1
17:21:23 <dtantsur> let's ask it this way: what do we lose if we DON'T land it?
17:21:23 <rloo> wrt python 3.5... what's left to do?
17:21:26 <dtantsur> rloo: IPA
17:21:44 <rloo> dtantsur: oh. ok, so we have to carry that to rocky.
17:22:24 <TheJulia> dtantsur: we complicate installs potentially by implementing a required single point of failure
17:22:29 <jroll> TheJulia: hjensas_mobile: I'll check the responses on the patch after this meeting and we can decide how risky it is (not sure if julia has seen my comments)
17:22:40 <dtantsur> TheJulia: yeah, this sounds like a correction, not a new feature
17:22:43 <TheJulia> jroll: I have not
17:22:50 <dtantsur> rloo: yep :(
17:22:52 <hjensas_mobile> One can run two or three of the agent as is.
17:22:56 <openstackgerrit> Merged openstack/bifrost master: Allow missing ironic policy.json sample  https://review.openstack.org/540617
17:23:07 <rloo> dtantsur: that's ok, we need stuff to do in Rocky. ha ha.
17:23:17 <TheJulia> dtantsur: more so, tax form correction of sorts :)
17:23:23 <dtantsur> rloo: yeah, what a relief: we won't end up without a backlog :D
17:23:31 <hjensas_mobile> But they would all do heartbeat for all ironic nodes. So neutron would be a bit hammered.
17:23:41 <dtantsur> TheJulia: don't remind me, I have to do taxes for 2 countries :)
17:24:27 <dtantsur> anyway, are we done with the statuses?
17:24:40 <rloo> +done
17:24:43 <TheJulia> rloo: re: py35 full stack testing as well, but swift it looks like might be next cycle
17:25:50 <rloo> nice that we have some cisco CI working, thx sambetts :)
17:26:09 <dtantsur> #topic Deciding on priorities for the coming week
17:26:34 <rloo> docs & bugs...
17:27:12 <dtantsur> and CI, yes
17:27:23 <rloo> dtantsur: ansible doc: https://review.openstack.org/#/c/525501/
17:27:23 <patchbot> patch 525501 - ironic - Add docs for ansible deploy interface
17:27:42 <dtantsur> yep, what else?
17:27:55 <TheJulia> looks good to me
17:28:03 <rloo> do we care about uwsgi? https://review.openstack.org/#/c/525501/
17:28:04 <patchbot> patch 525501 - ironic - Add docs for ansible deploy interface
17:28:05 <TheJulia> yeah, we should likely try to land ansible docs
17:28:13 <TheJulia> rloo: wrong link?
17:28:16 <rloo> oops, i mean https://review.openstack.org/#/c/507067
17:28:16 <patchbot> patch 507067 - ironic - [devstack] Switch ironic to uWSGI
17:28:24 <dtantsur> rloo: it's a goal => yes
17:28:56 <dtantsur> though.. maybe not as a priority
17:28:59 <dtantsur> dunno
17:29:33 <TheJulia> it would be nice, but we already have one job running uwsgi, so to me, at least in my mind, it doesn't have to land in the next 3.5 days
17:29:46 <dtantsur> yep
17:29:52 <dtantsur> so, these five items, how does it look?
17:30:15 <TheJulia> works for me
17:30:17 <jroll> makes sense to me
17:30:18 <rloo> 5 items that are not that easy. do we have people working on them?
17:30:35 <rloo> I like 'fix as many bugs as possible' :)
17:30:45 <TheJulia> all of us :) ?
17:30:49 <dtantsur> I'm still on classic drivers deprecation
17:30:50 <rloo> dtantsur: should we try to do a release on Wed?
17:30:54 <dtantsur> rloo: yes
17:31:27 <dtantsur> let's not wait till the last moment
17:31:34 <TheJulia> agreed
17:31:40 <rloo> dtantsur: ok, so factor in the patches needed that are related to a release. like our favorite reno edits.
17:31:48 <dtantsur> reno \o/
17:31:54 <rloo> dtantsur: HOW MANY releases? ugh.
17:32:02 <dtantsur> yes, I'll take a look tomorrow, if nobody beats me to it
17:32:17 <rloo> sometimes it isn't good to have so many projects...
17:32:23 <dtantsur> anyone looking into the multinode CI? I can, but I don't know it really well
17:32:45 <TheJulia> I can start looking into it again since we now have logs
17:32:47 <jroll> I could try to help, but I'm fairly stacked up with irl meetings this week
17:33:10 * rloo wonders what 'irl'is
17:33:15 <jroll> "in real life"
17:33:21 <dtantsur> in WUT?
17:33:22 <rloo> ha ha
17:33:36 <NobodyCam> LOL
17:33:53 <TheJulia> lol
17:33:55 <dtantsur> okay, moving on? :D
17:34:11 <dtantsur> #topic Appointing a bug triaging lead for the coming week
17:34:20 <dtantsur> I have a feeling that it is everyone this time
17:34:43 <dtantsur> agreed?
17:34:46 <rloo> yup
17:35:03 <dtantsur> #action everyone: please triage new bugs and try to fix old ones this week
17:35:44 <dtantsur> next, I wanted to discuss what to fix and work on this week
17:35:45 <TheJulia> agreed
17:35:50 <dtantsur> but I feel like we've done it?
17:35:55 <TheJulia> I think so yes
17:35:57 <dtantsur> anyway, let's do it this way:
17:36:05 <dtantsur> #topic Open Discussion
17:36:13 <jroll> quick dumb question: RFEs get tagged confirmed until they're looked at, right?
17:36:31 <dtantsur> jroll: until approved rather, though we usually don't mark them triaged
17:36:35 <jroll> "looked at" meaning approved or spec requested
17:36:46 <dtantsur> mostly because they tend to be In Progress by that time
17:36:49 <jroll> dtantsur: I can leave it new if that's what we prefer
17:36:58 <dtantsur> nope, not New
17:36:58 * jroll put one up but not working on it very soon
17:37:09 <jroll> heh, ok. confirmed it is
17:37:09 <dtantsur> Confirmed is the right one for something that looks potentially acceptable
17:37:15 <jroll> thanks
17:37:20 <rloo> here's our documentation: https://docs.openstack.org/ironic/latest/contributor/code-contribution-guide.html#feature-submission-process
17:37:25 <rloo> but don't know if we really follow it
17:37:38 <dtantsur> oh, FYI:
17:37:41 <dtantsur> #info https://review.rdoproject.org/r/#/c/11795/
17:37:47 * dtantsur just got pinged about it
17:37:49 <jroll> ah, it's triaged. thanks rloo, I should've looked
17:38:30 <jroll> dtantsur: we all get the opportunity to break RDO ci now? awesome :P
17:38:45 <rloo> dtantsur: cool
17:38:54 <dtantsur> jroll: we have long had it :D now we can check if we do in advance
17:38:55 <rloo> we should document those somewhere...
17:39:00 <TheJulia> sweet, more things to break!
17:39:32 <TheJulia> rloo: that is a good point, ironic does get tested in several places outside direct view, might be good to enumerate where those are
17:39:42 <jroll> dtantsur: do those run on upstream patches, then?
17:39:55 <dtantsur> jroll: it's like experimental, you need to trigger it
17:39:59 <dtantsur> I never tried :)
17:40:12 <jroll> dtantsur: right, but I trigger it on review.o.o, right? not review.rdo.org
17:40:16 <dtantsur> but RDO CI works like a 3rd party CI
17:40:19 <dtantsur> yes
17:40:21 <jroll> ok cool
17:40:26 <jroll> sounds like a win \o/
17:40:32 <dtantsur> yep :)
17:41:00 <dtantsur> anything else we should talk about?
17:41:06 <TheJulia> Coffee?
17:41:22 <dtantsur> \o/
17:41:28 <dtantsur> not at 7pm probably though :(
17:41:29 <TheJulia> Deploying Crickets as a Service?
17:41:30 <jroll> coffee++
17:41:45 <dtantsur> okay, thanks all
17:41:50 <NobodyCam> :)
17:41:51 <TheJulia> Thanks dtantsur!
17:41:52 <dtantsur> #endmeeting