17:00:33 <dtantsur> #startmeeting ironic
17:00:34 <openstack> Meeting started Mon Jan 22 17:00:33 2018 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:37 <TheJulia> o/
17:00:38 <openstack> The meeting name has been set to 'ironic'
17:00:41 <dtantsur> hi all :)
17:00:48 <NobodyCam> howdy
17:00:48 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:00:48 <pas-ha> o/
17:00:55 <rpioso> o/
17:01:14 <jroll> \o
17:01:18 <rloo> o/
17:01:20 <hjensas> o/
17:01:23 <hshiina> o/
17:01:27 <bfournie> o/
17:01:30 <mgoddard_> \o/
17:01:38 <stendulker> o/
17:01:54 <dtantsur> #topic Announcements / Reminder
17:01:57 <dtantsur> We have a few
17:02:06 <dtantsur> #info Jan 25 - Client release deadline and Feature Freeze
17:02:10 <mjturek> o/
17:02:13 <dtantsur> this is Thursday
17:02:18 <dtantsur> now, related:
17:02:31 <dtantsur> #info dtantsur semi-unavailable Thu-Mon due to devconf.cz
17:02:39 <jlvillal> o/
17:02:51 <dtantsur> so TheJulia, if you're available, you'll have to request the clients releases please
17:03:02 <TheJulia> dtantsur: acknowledged, will do
17:03:04 <dtantsur> I'll try to be online as much as it's possible
17:03:22 <dtantsur> but on Thu I'll be in a train somewhere between Germany and Czechia
17:03:31 <rloo> TheJulia will run next Monday's meeting too?
17:03:40 <TheJulia> I can
17:03:46 <dtantsur> rloo: I should be here by that time, but in case I won't - yes
17:04:11 <rloo> dtantsur: ok, Action Item - dtantsur to be back for meeting on Monday :)
17:04:15 <dtantsur> got it :)
17:04:30 <dtantsur> so, lemme repeat probably:
17:04:45 <dtantsur> #info the feature freeze is coming, and the good time to request an exception, if you need it, is right now
17:05:03 <dtantsur> I have a few potential exceptions to discuss for later today
17:05:19 <dtantsur> but in the end all requests have to happen on the ML
17:05:23 <rloo> dtantsur: how do we decide whether to grant a FFE? vote? or 2 cores agree or ??
17:05:35 <dtantsur> meh, I knew somebody would ask :D
17:05:45 <dtantsur> 2 cores agree and no cores -2?
17:05:59 <rloo> dtantsur: ok, w/i some time period i guess.
17:06:24 <dtantsur> yep. for requests posted today we can give time till Thursday for cores to object
17:06:41 <dtantsur> if you post a request on Thu, it may be delayed, so plan ahead
17:06:58 <dtantsur> any more questions on the feature freeze?
17:07:01 <rloo> dtantsur: and what's the deadline, if we grant FFE, to get that feature in?
17:07:08 <dtantsur> so
17:07:16 <dtantsur> lemme double-check the schedule
17:07:28 <johnthetubaguy> so does traits need to request an exception now?
17:07:45 <rloo> maybe RC1 target week? feb 5-9?
17:07:47 <dtantsur> johnthetubaguy: tl;dr yes
17:07:53 <rloo> johnthetubaguy: we're going to get that in this week, right? :)
17:07:59 <dtantsur> the final release will happen on Thu, Feb 8th
17:08:16 <dtantsur> I don't want last-minute features, I've screwed up sushy enough :-/
17:08:18 <TheJulia> so even if we grant an ffe for traits, we can't land client support....
17:08:29 <rloo> dtantsur: the final RC is week of feb 19
17:08:37 <jroll> yeah, not worth ffe'ing traits, just land it this week :)
17:08:47 <dtantsur> rloo: rc1 is when we branch
17:08:48 <TheJulia> jroll: +++++
17:08:51 * jlvillal thinks we don't want any raw features getting into sushy...
17:08:52 <johnthetubaguy> jroll: ++
17:08:52 <rloo> TheJulia: true
17:09:03 <dtantsur> so rc1 is the final queens feature release
17:09:15 <dtantsur> then stable/queens gets created, and master switches to rocky
17:09:26 <dtantsur> so
17:09:28 <rloo> dtantsur: OH. then def week of Feb 5 is it. wonder if we should make it the week before, but ...
17:09:56 <dtantsur> #info Feb 8th is the final feature release, features that get an exception must land by Friday, Feb 2nd
17:10:04 <dtantsur> sounds reasonable?
17:10:09 <TheJulia> dtantsur: yes
17:10:15 <rloo> works for me. thx.
17:10:20 <jroll> ++
17:10:34 <dtantsur> more questions?
17:10:34 <rloo> johnthetubaguy: we'll get traits in if you get that nova patch in :)
17:10:52 <johnthetubaguy> rloo: trying :)
17:11:07 <rloo> johnthetubaguy: we actually can't get traits in until we fix that grenade test
17:11:13 <dtantsur> this ^^^
17:11:17 * jroll is surprised mentioning segfaults on upgrade in irc doesn't gather much attention
17:11:28 * johnthetubaguy nods
17:11:32 <dtantsur> I have a topic for a potential FFE for traits, let's wait for it please
17:11:36 <dtantsur> #info PTG planning has started: https://etherpad.openstack.org/p/ironic-rocky-ptg
17:11:53 <dtantsur> please dump your ideas :)
17:12:05 <TheJulia> jroll: I entirely expect it could have been the messenger or otherwise focus at the time, multiple variables
17:12:11 <dtantsur> #info stable/queens created for sushy and ironic-lib
17:12:27 <rloo> yay
17:12:33 <dtantsur> sushy got screwed up, sorry for that. we'll have an emergency fix release soon :(
17:12:50 <rloo> dtantsur: boo
17:13:21 <TheJulia> dtantsur: I thought we took care of that....
17:13:38 <rloo> TheJulia: i suspect he is referring to https://review.openstack.org/#/c/535910/
17:13:39 <patchbot> patch 535910 - sushy - Restores sushy session functionality.
17:14:00 <dtantsur> TheJulia: there is one small place where an argument is passed as positional, and adding back username and password broke it
17:14:17 <dtantsur> now, the patch does a lot of unnecessary changes, we need to clean it up
17:14:20 <TheJulia> argh
17:14:26 <dtantsur> the essence of the fix is one line
17:14:49 <TheJulia> okay, lets move on
17:14:55 * TheJulia appologies for slight derail
17:15:10 <dtantsur> #topic Review action items from previous meeting
17:15:27 <dtantsur> #link http://eavesdrop.openstack.org/meetings/ironic/2018/ironic.2018-01-15-17.00.html
17:15:54 <dtantsur> so, I posted patches enabling automatic migration to hardware types - see the whiteboard
17:16:11 <dtantsur> I need a patch to move the CI to hardware types, then we can deprecate
17:16:20 <dtantsur> this will be finished probably tomorrow
17:16:54 <dtantsur> jlvillal did announce the tempest plugin removal from tree
17:17:09 <dtantsur> mjturek: how was the bug triage?
17:17:11 <jlvillal> Yes, I did send out an email
17:17:19 <rloo> http://lists.openstack.org/pipermail/openstack-dev/2018-January/126232.html email about removal
17:17:43 <rloo> (and we broke pyghmi but no big deal :))
17:18:35 <dtantsur> yeah, we have a patch to fix pyghmi already
17:18:43 <dtantsur> any comments?
17:19:05 <rloo> not wrt AIs. should we mention grenade test breakage?
17:19:57 <dtantsur> well, let's do it
17:20:13 <dtantsur> #info the multinode grenade was broken and we disabled it, please be careful when approving patches affecting upgrade
17:20:25 <dtantsur> #topic Review subteam status reports (capped at ten minutes)
17:20:36 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard line 182
17:20:46 <rloo> wrt grenade tests, see whiteboard for more info :)
17:20:50 <dtantsur> sorry, I totally forgot about bugs. partly because my dashboard was sent to /dev/null :(
17:21:11 <dtantsur> I'll do something about it soon(ish)
17:22:06 <rloo> I haven't looked at the ironic client API version negotiation patches; how are they? close?
17:22:12 <TheJulia> I suspect not many teams made much progress due to the grenade issues last week. I for one, spent the majority of the week focused on that instead of reviewing, so i suspect there is just not much in the way of updates. :\
17:22:39 <dtantsur> rloo: they have my +2
17:22:50 <rloo> dtantsur: i'd say close then, thx!
17:23:22 <rloo> johnthetubaguy: even if we manage to land the traits stuff this week, what about the nova part? ff is this week for nova.
17:23:30 <dtantsur> any work that has "RPC" in it has to wait until the grenade job is fixed..
17:23:51 <jroll> oh, nova's FF is this week? sigh
17:23:55 <TheJulia> dtantsur: I'll try to hammer out min/max version in the client sometime today, although no promises
17:24:03 <dtantsur> TheJulia: awesome!
17:24:11 <rloo> jroll: yup :-( johnthetubaguy, can we (you) ask for FFE in nova?
17:24:13 <dtantsur> jroll: everyone's FF is M3
17:24:28 <johnthetubaguy> not sure how the nova FFE will work, normally PTL approved
17:24:46 <johnthetubaguy> its normally needed only after thursday though
17:24:53 <rloo> johnthetubaguy: ok, guess we'll see how things go this week
17:25:11 <rloo> it is the same problem with rescue work.
17:25:22 <jroll> dtantsur: ah right, got my dates mixed up with the RC1 cut
17:25:29 <rloo> is shiv here? i don't see him.
17:25:34 <dtantsur> yeah, it's complex.. RC1 is stable branching
17:25:49 <dtantsur> rloo: bad time for east asia..
17:26:27 <rloo> dtantsur: yeah, was wondering what the status was wrt CI for that. the patches are up, but given that traits is a higher priority, i am 99% sure rescue won't land this week.
17:26:53 * rloo hopes that she is proven wrong
17:27:04 <dtantsur> it all boils down the grenade recovering..
17:27:12 <dtantsur> * boils down to
17:27:23 <dtantsur> both patches have RPC bits that need testing by it
17:27:28 <rloo> even with grenade working, so many things to review this week... :-(
17:27:42 <rloo> and i'm sure that gate will be slow (er than usual)
17:28:06 <rloo> ok, i'm done with status (and trying to remain hopeful)
17:28:09 * TheJulia slihtly mentally steps away for a couple minutes
17:28:20 <dtantsur> moving on then?
17:28:38 <dtantsur> #topic Deciding on priorities for the coming week
17:28:46 <dtantsur> so
17:29:58 <rloo> dtantsur: we need to land the grenade fix, after nova lands the patch: https://review.openstack.org/535596
17:29:59 <patchbot> patch 535596 - ironic - Rework upgrade to upgrade nova/ironic
17:30:04 <dtantsur> I'd leave the 4 topics we discussed as important, with ironicclient gettign the highest priority
17:30:41 <dtantsur> because we have a rigid deadline for clients
17:31:01 <rloo> dtantsur: classic driver migration can slip to next week?
17:31:32 <dtantsur> rloo: I'd prefer it does not
17:31:46 <dtantsur> it's a big change, I'd like to have as much as possible before FF
17:31:48 <rloo> dtantsur: i'd prefer not either, but i prefer more that traits lands
17:31:55 <Nisha_Agarwal> dtantsur, ironic stable branch cut will be done this week, right?
17:32:00 <dtantsur> or rather: I'd like to have the database migration before FF; the actual deprecation, CI, docs can wait
17:32:08 <dtantsur> Nisha_Agarwal: no, on Feb 8th
17:32:15 <dtantsur> Nisha_Agarwal: but feature freeze is this Thu
17:32:31 <rloo> dtantsur: ok, i'll see what I can do :)
17:32:40 <Nisha_Agarwal> dtantsur, ok.
17:32:48 <dtantsur> rloo: the deprecation work is not blocked by the multinode CI, so we can do it around today..
17:33:39 <Nisha_Agarwal> so next week high priority bugs and high priority left over work from features will be merged in, right?
17:33:39 <rloo> ok, i'm good with the priorities, except we need to fix grenade job. but we all know that.
17:34:03 <dtantsur> Nisha_Agarwal: any bugs and features that get an exception
17:34:06 <TheJulia> w/r/t priorities, I'm good with what is there, we might want to add a note that the list may be updated as the week goes on if we land traits/rescue stuff and manage to get to be able to expose their apis
17:34:19 <dtantsur> I mean: 1. any bugs, 2. features that can an exception
17:34:25 <dtantsur> we don't need exceptions for bugs :)
17:34:35 <Nisha_Agarwal> dtantsur, yes :)
17:34:36 <dtantsur> TheJulia: yeah, this is always implied
17:34:49 <rloo> Nisha_Agarwal: no guarantee of 'merged in'. just that people might have time to focus on those other things.
17:35:02 <Nisha_Agarwal> rloo, yeah i know
17:35:23 <Nisha_Agarwal> rloo, i just asked because i the stable branch gets cut with FF
17:35:24 <Nisha_Agarwal> :)
17:35:32 <rloo> Nisha_Agarwal: good, wanted to clarify cuz you said 'will be merged in' above :)
17:35:57 <rloo> Nisha_Agarwal: and again, stable branch does not get cut with FF
17:36:12 <Nisha_Agarwal> s/i/i thought
17:36:26 <dtantsur> #topic Appointing a bug triaging lead for the coming week
17:36:42 <dtantsur> I'm not sure anyone will have time for it, but just in case you want to..
17:36:52 <TheJulia> mjturek: do you by chance have time again this week?
17:37:03 <mjturek> sure!
17:37:11 <TheJulia> thanks!
17:37:22 <dtantsur> thanks mjturek
17:37:33 <dtantsur> #action mjturek to continue leading the bug triage this week
17:37:38 <dtantsur> okay, let's discuss some FFEs
17:37:47 <dtantsur> #topic FFE: Routed network support
17:37:55 <dtantsur> #link http://lists.openstack.org/pipermail/openstack-dev/2018-January/126296.html
17:38:16 <dtantsur> this got 2 cores backing it, and 2 +1s from other cores. no objections so far.
17:38:51 <dtantsur> approving the FFE in 3...
17:38:56 <dtantsur> 2...
17:39:03 <dtantsur> 1...
17:39:04 <rloo> dtantsur: i thought we couldn't approve til Thurs
17:39:12 <dtantsur> rloo: this was requested earlier
17:39:20 <dtantsur> I was talking about things that can requested today or tomorrow morning
17:39:20 <rloo> dtantsur: heh, ok then.
17:39:28 <dtantsur> people had time to object, the last chance is right now :)
17:39:53 <dtantsur> #agreed the routed network support work gets an FFE
17:39:57 <dtantsur> hjensas: ^^^
17:40:05 <hjensas> \o/
17:40:06 <jlvillal> Do any of the patches actually touch Ironic at this time? Seems low risk to approve.
17:40:15 <dtantsur> jlvillal: only CI, I think
17:40:18 <hjensas> jlvillal: 1 patch + CI.
17:40:26 <jlvillal> Okay
17:40:33 <dtantsur> #topic Potential FFE: classic drivers deprecation
17:40:36 <jlvillal> No objection at this point from me.
17:40:46 <dtantsur> this was not formally requested, just collecting early feedback
17:40:51 <rloo> dtantsur: put me down as core reviewer for deprecation
17:40:56 <dtantsur> thanks rloo!
17:41:00 <rloo> dtantsur: cuz you're going to make me do it anyway :D
17:41:06 <dtantsur> you know me :)
17:41:23 <dtantsur> any early objections / questions?
17:42:10 <dtantsur> okay, I'll propose it formally later today
17:42:30 <dtantsur> #topic Potential FFE: rescue mode
17:42:51 <rloo> that won't work, it needs client update
17:43:05 <dtantsur> well, we can land the ironic part, and at least get rid of it
17:43:08 <rloo> are you good with it being the ironic code (and ipa code)?
17:43:19 <TheJulia> I think the ipa code already landed
17:43:30 <rloo> TheJulia: even better!
17:43:31 <dtantsur> I think there is a tinyipa patch? the coreos one landed
17:43:54 <TheJulia> even then, it is not api related, it is minor
17:44:05 <dtantsur> yep
17:44:20 <TheJulia> I'm +2 to granting an ffe for rescue and landing what we can
17:44:21 <rloo> dtantsur: so i'm good with it and can be core reviewer. unless we have a FFE for traits too. then my loyalties may change.
17:44:35 <dtantsur> this is my next topic :)
17:44:41 <dtantsur> but I can be a core for rescue
17:44:58 <dtantsur> however, I'm not leading the rescue work, so I won't request this FFE myself
17:45:11 <dtantsur> Nisha_Agarwal: can you please talk to Shiv, if he wants to do ^^^?
17:45:31 <Nisha_Agarwal> dtantsur, sure
17:45:35 <dtantsur> thanks!
17:45:55 <dtantsur> okay, this was just to collect initial feedback, you'll be able to agree/object on the ML
17:46:01 <dtantsur> #topic Potential FFE: traits API
17:46:04 <dtantsur> this last one I have
17:46:11 <rloo> ditto :)
17:46:15 <dtantsur> from the project's point of view, this is higher than rescue
17:46:26 <dtantsur> from the point of view of not annoying contributors, rescue is higher than this :)
17:46:39 <rloo> ditto == what i said above in rescue, applies here.
17:46:53 * TheJulia feels there is consensus
17:46:55 <dtantsur> yes, the scope of the FFE will be only ironic parts for both
17:47:16 <dtantsur> anyone here wants to request an FFE for traits? anyone objects to it?
17:47:39 <mgoddard_> I would like to request one :)
17:47:52 <dtantsur> mgoddard_: please do then (on the ML, with pros/cons/risks and backing cores)
17:48:00 <rloo> we need another core reviewer to commit to traits
17:48:03 <mgoddard_> dtantsur: will do
17:48:43 <dtantsur> I'll be busy with drivers and rescue..
17:48:58 <johnthetubaguy> having the API landed, but no client and nova bits is not ideal, but way better than not having it at all
17:49:20 <rloo> mgoddard_: guess you can ask later for another core to help out
17:49:21 <TheJulia> I can, I'd prefer to try and get everything pushed through prior and get the client bits too, but... grenade
17:49:27 * jroll side note: TheJulia: I'm discussing the gate breakage thing in -nova, fyi
17:49:29 <rloo> thx TheJulia
17:49:31 <dtantsur> johnthetubaguy, mgoddard_, not all cores are here or active right now: please find someone to back your FFE
17:49:41 <dtantsur> oh, thanks TheJulia
17:49:44 <rloo> anyway, traits will land this week. ha ha.
17:49:51 <dtantsur> ideally!
17:49:54 <mgoddard_> thanks TheJulia!
17:49:56 <dtantsur> #topic Open discussion
17:50:15 <dtantsur> if you want to quickly chat about your FFE, this is about the good time
17:50:38 <TheJulia> mgoddard_: Idea: test patch everything together and I guess we could consider landing because then we would be able to see grenade passing
17:50:55 <dtantsur> curl https://example.com/crickets
17:51:16 <rloo> crickets
17:51:22 * TheJulia thinks she needs to register a domain
17:51:34 <dtantsur> thanks all! 9 minutes of life are yours again
17:51:37 <dtantsur> #endmeeting