17:00:19 <TheJulia> #startmeeting ironic
17:00:20 <openstack> Meeting started Mon Dec 18 17:00:19 2017 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:23 <openstack> The meeting name has been set to 'ironic'
17:00:28 <sambetts> o/
17:00:30 <jroll> \o
17:00:31 <TheJulia> Everyone ready for a meeting of irony?
17:00:33 <rpioso> o/
17:00:35 <crushil_> \o
17:00:37 <TheJulia> err, ironic :)
17:00:41 <pas-ha> o/
17:00:43 <hshiina> o/
17:00:48 <datex> !
17:00:49 <jlvillal> o/
17:01:03 <rloo> o/
17:01:07 <TheJulia> Our agenda is on the wiki!
17:01:10 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
17:01:26 <TheJulia> #topic Announcements / Reminder
17:01:50 <TheJulia> jlvillal: The first annoucement is yours, would you like to take the floor?
17:02:15 <jlvillal> TheJulia, Thanks
17:02:36 <jlvillal> Hopefully every 3rd Party CI representative is here :)
17:02:59 <jlvillal> Basically tomorrow we will be removing the tempest-plugin code that is in openstack/ironic and openstack/ironic-inspector tomorrow
17:03:21 <jlvillal> So if your CI is pulling in the tempest code, then please update to use openstack/ironic-tempest-plugin instead.
17:03:36 <jlvillal> If you have any questions please ask me or on the channel.
17:03:41 <rloo> irmc looks like the only one represented here
17:03:43 <jlvillal> That is about all I got.
17:03:49 <TheJulia> #info Third Party CI - In tree tempest plugin code anticipated to be removed December 19th.
17:04:03 <TheJulia> jlvillal: Thanks
17:04:06 <rajinir> TheJulia. ok thanks
17:04:18 <TheJulia> Next up, deadlines!
17:04:54 <TheJulia> #info Non-client library release deadline is January 18th
17:05:22 <TheJulia> #info Client library release deadline is January 25th
17:05:34 <rloo> TheJulia: remind me, that includes ironic-lib, sushy, right?
17:05:39 <TheJulia> #info Feature Freeze is January 25th
17:05:45 <rloo> TheJulia: what about virtualbmc, networing-generic-switch?
17:06:15 <rpioso> rloo: idrac is, too.
17:06:27 <TheJulia> rloo: I believe we agreed at one point virtualbmc it does not apply... but I'd have to go back and look at prior discussions to be sure. For n-g-s, that is a plugin.
17:06:39 <rloo> TheJulia: thx.
17:06:40 <TheJulia> It does include ironic-lib, sushy, and other libraries that we utilize.
17:06:47 <TheJulia> Any questions?
17:06:53 <datex> hi everyone.
17:07:07 <TheJulia> And does anyone have any other announcements today?
17:07:47 * TheJulia senses the silence as a no....
17:07:59 <datex> Is depolyment ironic instance via BT still in progress?
17:08:07 <jlvillal> No meeting next week? and the next?
17:08:14 <jlvillal> As a reminder
17:08:16 <TheJulia> datex: Lets take that to open discussion in a little bit
17:08:24 <TheJulia> jlvillal: I was just going to note that as a reminder :)
17:08:26 <datex> ok, thank you
17:08:46 <jlvillal> I'll miss you all! :)
17:08:53 <TheJulia> Correct, we will not have meetings the next two weeks. I sense some cores are going to be around, but please as in channel if you need priority reviews or eyeballs on patches.
17:09:16 <TheJulia> I guess we should move on then!
17:09:23 <TheJulia> #topic Review action items from previous meeting
17:09:28 <rloo> so next meeting will be Jan 8, 2018 :)
17:09:37 <TheJulia> #undo
17:09:37 <openstack> Removing item from minutes: #topic Review action items from previous meeting
17:09:51 <TheJulia> #info Next meeting Jan 8, 2018
17:09:54 <TheJulia> #topic Review action items from previous meeting
17:10:15 <TheJulia> I double checked the bugs last week and we had very few bugs come in which minimized the need for triaging.
17:10:55 <TheJulia> And I don't know if Dmitry created the nova bug.
17:11:14 <rloo> TheJulia: maybe add the same action item for dmitry, so we can follow up next year
17:11:46 <jlvillal> We can wait until dtantsur gets back. But I did propose a patch to update the priority of the traits work to "essential"
17:11:49 <TheJulia> #action dtantsur to follow-up on client version negotiation bug in nova
17:12:01 <jlvillal> rloo, Made a comment that she wasn't sure if we update those or not.
17:12:03 <TheJulia> jlvillal: Thanks!
17:12:16 <jlvillal> The patch: https://review.openstack.org/528386
17:12:16 <patchbot> patch 528386 - ironic-specs - Move traits from "high" to "essential" priority
17:12:22 <TheJulia> jlvillal: your reading my mind :)
17:12:32 <jlvillal> :)
17:12:46 <TheJulia> I'll put that on the todo list for this week, anyway we should move on if there are no objections.
17:13:06 <TheJulia> #topic Review subteam status reports
17:13:20 <TheJulia> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:13:55 <TheJulia> On our whiteboard, subteam status reports start at line 144.
17:14:08 <rloo> TheJulia: do you know how to update the bug count?
17:14:26 <TheJulia> rloo: I do not
17:14:44 <TheJulia> Well, I guess it could be done by hand
17:15:57 <jroll> I believe it's at http://dashboard-ironic.7e14.starter-us-west-2.openshiftapps.com/
17:16:06 <jroll> (there's a more friendly url, but I don't know it)
17:16:11 <TheJulia> pas-ha: regarding the client reauth, do you know if anyone has volunteered to going to update/rebase the inspector patches?
17:16:18 * jroll updates the count
17:16:22 <pas-ha> TheJulia: me
17:16:40 <TheJulia> jroll: thanks!
17:17:24 <TheJulia> Hmm... I guess mgoddard has started taking over the trait work, is that correct?
17:17:31 <rloo> vdrok: will you be able to work on the clean up of deploy interfaces?
17:17:40 <rloo> TheJulia: yup, he has a patch up
17:17:44 <TheJulia> rloo: thanks!
17:17:55 <jlvillal> TheJulia, correct on mgoddard
17:19:08 <rloo> i'm concerned about the bios config work. the spec hasn't been approved yet. maybe this week, I'll touch base with you TheJulia and/or Dmitry, and see if we can get it done.
17:19:11 <vdrok> hey folks, good morning. sorry, I got caught up in things unrelated to upstream recently. this week I hope to finish it and get back here
17:19:23 <rloo> thx vdrok!
17:19:41 <TheJulia> rloo: Also concerned, I can dedicate time today after lunch to looking at it in depth.
17:19:57 <rloo> TheJulia: ok, we can discuss later, thx!
17:19:57 <TheJulia> Everyone done updating statuses on the whiteboard?
17:20:22 <rloo> jlvillal: good work on the tempest plugin work
17:20:34 <rloo> jlvillal: that seems like the only thing that went well/fast this cycle
17:20:51 <jlvillal> rloo, Thanks to everyone for their help in getting things reviewed and fixed up :)
17:21:07 <datex> vdrok: hi, do you have some time? I have a question.
17:21:08 <TheJulia> Out of curiosity, is anyone picking up the uwsgi work?
17:21:38 <vdrok> hey datex , yeah, ask after the meeting or in private
17:21:52 <TheJulia> Moving on to priorities!
17:21:52 <pas-ha> I could take uqsgi too
17:21:58 <pas-ha> uwsgi
17:22:06 <rloo> thx pas-ha!
17:22:11 <TheJulia> pas-ha: Thanks!
17:22:19 <TheJulia> #topic Deciding on priorities for the coming week
17:22:45 <datex> vdrok: I have send a mail to your inbox (vdrok@mirantis.com), thanks
17:22:54 <TheJulia> Back to the whiteboard, line 107!
17:23:01 <rloo> i don't think the tempest plugin is a priority any more? just needs 2? patches to be merged?
17:23:01 <jlvillal> Easy one is to keep #1. We should finish it tomorrow I hope.
17:23:20 <vdrok> datex: will take a look in a bit
17:23:29 <TheJulia> jlvillal: what about the follow-up items?  I'm thinking we need to just move the priority down at this point
17:23:30 <datex> vdrok: thanks
17:23:51 <jlvillal> TheJulia, Sure on moving it down
17:24:22 <rloo> because traits is now essential, maybe put the first patch down, although it needs an update: https://review.openstack.org/#/c/528238/
17:24:23 <patchbot> patch 528238 - ironic - Node traits: Add DB API & model
17:24:38 <jroll> ++, pretty close though
17:24:58 <TheJulia> I think: Auth refactor, bios spec, traits, rescue, routed networks, and tempest related cleanup?
17:25:15 <TheJulia> In order of course :)
17:25:38 <rloo> what state are the routed network patches in? they were WIP at some point.
17:25:47 <TheJulia> I think they were all updated last week
17:26:01 <rloo> can anyone vouch that they're ready to be reviewed?
17:26:02 <jlvillal> rloo, Removed WIP but I asked for some DSVM tests to be added...
17:26:07 <TheJulia> Hmm, they do need revisions now
17:26:28 <rloo> jlvillal: do you think they're ready to be reviewed? (besides the tests) or do you want tests to show that they're ready to be reviewed?
17:26:59 <jlvillal> rloo, They can be reviewed. I would prefer an update be done, but the basic concept is there.
17:26:59 <TheJulia> rloo: since it will be a few weeks, I think we might as well keep them on the list, but at the bottom so hopefully they get some review traffic over the next few weeks
17:27:09 <jlvillal> sambetts, May have more input as he has also been reviewing
17:27:17 <rloo> TheJulia, jlvillal: ok with me then
17:27:24 <TheJulia> any objections?
17:28:49 <jlvillal> No! :)
17:29:05 <sambetts> I think the routed networks patches can be reviewed, but until we have a working test env proving it works with nova/neutron, its pretty much blocked merging
17:29:33 <rloo> sambetts: is someone working on the testing?
17:29:45 <sambetts> I think hjensas is looking into it
17:29:51 <jlvillal> +1 on what sambetts said.
17:30:08 <rloo> does that work require changes to nova or neutron?
17:30:27 <jlvillal> Hopefully not. But testing of course will help to find out.
17:30:48 <TheJulia> rloo: does not appear to at this point
17:31:03 <jlvillal> I am unsure if it has even been tested in a local devstack environment or not.
17:31:09 <rloo> ok good. if it does, someone needs to point it out. please.
17:31:11 <sambetts> it shouldn't, its just a complicated devstack environment, and hopfully the other projects already have a foundation to setup an L3 network simulation but if not we'll be the first to try to similate an L3 network on infra
17:31:43 <sambetts> simulate*
17:32:05 <TheJulia> I added a note to the list saying that the routed networks was review for input only.
17:32:23 <TheJulia> That way we make it clear what the expectation is
17:32:56 <TheJulia> Any objections? Anyone have anything they should think that should be on the list? (Since, it will be a few weeks before we update the list again)
17:33:48 * TheJulia hears crickets
17:33:53 <rloo> i think that's good. it'll be a few weeks, but i am guessing there won't be that many folks around either
17:34:17 <TheJulia> Works for me!
17:34:22 <jroll> +1
17:34:53 <TheJulia> I guess it is time to move on then :)
17:35:04 <TheJulia> #topic Appointing a bug triaging lead for the coming week
17:35:19 <TheJulia> Do we have any victims... err, I mean volunteers?
17:35:23 <rloo> for the next 2? weeks :)
17:35:40 <TheJulia> Really, 3
17:36:02 <rloo> wow, bonus 2 weeks! :D
17:36:12 <rloo> i mean, bonus EXTRA 2 weeks :)
17:36:17 <TheJulia> lol
17:36:25 <TheJulia> Okay, I guess I'll put it on my plate
17:36:37 <TheJulia> Since I'll be around
17:36:39 <rloo> thx TheJulia!
17:36:57 <TheJulia> #action TheJulia to take on bug triaging until our next meeting.
17:37:17 <TheJulia> Topic RFE review
17:37:18 <TheJulia> err
17:37:23 <TheJulia> #topic RFE review
17:37:32 <TheJulia> rloo: do we have any RFE's that need a look over today?
17:37:55 <rloo> TheJulia: sorry, I don't know, I didn't feel like doing it. Happy Holidays! we'll resume next year :)
17:38:03 <TheJulia> Awesome!
17:38:16 <TheJulia> Since we have no set discussion topics, we can go directly to Open Discussion!
17:38:25 * rloo just wants to wrap things up since it is that season...
17:38:31 <TheJulia> #topic Open Discussion
17:38:34 <TheJulia> :)
17:38:54 <rloo> so what do folks think about a yearly release?
17:39:00 <rloo> no, let's not discuss it!
17:39:00 <TheJulia> datex: You mentioned interest in bit torrent based deploys?
17:39:05 <TheJulia> rloo: lol
17:39:38 <TheJulia> rloo: I have very very mixed feelings about the proposal and results, and I'll leave it at that for the time being :)
17:39:43 <rloo> i thought there had been a spec, maybe code patches for bit torrent, but the author left? all vague...
17:40:04 <rloo> TheJulia: me too, but nice that it is being discussed
17:40:43 * rloo thinks we need to figure out how to work effectively with fewer people
17:40:49 <rloo> maybe train crickets...
17:40:51 <TheJulia> rloo: Yeah, I think BT'izing deploys kind of goes hand-in-hand with pre-deployed machines, and that code never completely landed... that is unless it just becomes the machine can grok image_source being a bittorrent tracker url....
17:41:09 <rloo> TheJulia: well, datex hasn't responded so...
17:41:19 <TheJulia> rloo: That is a very good topic for the PTG, but something we should ponder....
17:41:19 <rloo> Are there only crickets now?
17:41:32 <TheJulia> I think there are only crickets....
17:41:46 <TheJulia> I must run a boring meeting :(
17:41:59 * rloo thinks TheJulia is really effective :)
17:42:32 <TheJulia> Last call for any open discussion topics, or I'll close our meeting out for this week in a couple minutes
17:42:56 <rloo> the last meeting of the year
17:43:05 <rloo> we need an action item : everyone have FUN
17:43:23 <rpioso> rloo: lol
17:43:27 <rpioso> I hope you have a wonderful holiday season, ironicers. And Happy 2018!
17:43:36 <rloo> ++
17:43:39 <TheJulia> #action Everyone have a wonderful quiet holiday! :)
17:43:44 <pas-ha> ++
17:43:55 <jroll> +++
17:44:00 <TheJulia> Thanks everyone!
17:44:02 <jlvillal> :)
17:44:17 <datex> sorry i'm back
17:44:58 <TheJulia> datex: Does the discussion from a few minutes ago give you an idea? We can dig up some links and discus further if your interested in carrying forward such a feature?
17:45:35 <datex> yes, i'm interested in bt deploy 'cause i saw this post https://www.mirantis.com/blog/cut-ironic-provisioning-time-using-torrents/
17:46:32 <TheJulia> Okay, well in that case, I'll end the meeting.
17:46:38 <TheJulia> Thanks again everyone!
17:46:42 <TheJulia> #endmeeting