17:00:10 <dtantsur> #startmeeting ironic
17:00:11 <openstack> Meeting started Mon Aug  7 17:00:10 2017 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:14 <openstack> The meeting name has been set to 'ironic'
17:00:17 <sambetts> o/
17:00:18 <jlvillal> o/
17:00:19 <NobodyCam> o/
17:00:20 <dtantsur> hi all!
17:00:25 <TheJulia> o/
17:00:35 <rama_y> o/
17:00:36 <baha> o/
17:00:45 <etingof> o/
17:00:49 <xavierr> o/
17:00:50 <stendulker> o/
17:00:51 <mjturek> O/
17:01:07 <fellypefca> o/
17:01:10 <dtantsur> welcome! our agenda as usual is at:
17:01:16 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:02:08 <dtantsur> #topic Announcements / Reminder
17:02:09 <yuriyz> o/
17:02:19 <dtantsur> #info PTL elections start later this week, please exercise your right to vote!
17:02:27 <dtantsur> thanks TheJulia for running against me :)
17:02:34 <TheJulia> Anytime! :)
17:02:57 <ricardoas> o/
17:03:02 <kaifeng> o/
17:03:08 <dtantsur> #info Pike RC1 release of most projects this week
17:03:08 <mgoddard> o/
17:03:19 <dtantsur> this does not directly affects us
17:03:30 <dtantsur> well, not until they create stable/pike for requirements
17:03:59 <ricardoas> that means we can still change driver-requirements.txt?
17:04:14 <dtantsur> driver-requirements can be changed, it's fully managed by us
17:04:25 <ricardoas> good!
17:05:45 <dtantsur> anything else?
17:05:59 <dtantsur> #info dtantsur is slowly cleaning up the bug list
17:06:13 <dtantsur> quite a few bugs are losing their assignees - pick'em while they're hot!
17:06:51 <TheJulia> Awesome
17:07:01 <rpioso> o/  Sorry for being a bit late.
17:07:19 <dtantsur> moving on?
17:07:32 <dtantsur> #topic Review subteam status reports (capped at ten minutes)
17:07:40 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:07:45 <dtantsur> start on line 116
17:07:55 <pas-ha> o/
17:08:16 <dtantsur> BFV is really, really close
17:08:35 <dtantsur> so are rolling upgrades
17:08:56 <jlvillal> :)
17:09:34 <dtantsur> do I remember it right that rloo is out for now?
17:09:41 <dtantsur> if so, somebody has to take over https://review.openstack.org/#/c/416565/
17:09:46 <TheJulia> You remember correctly
17:09:51 <dtantsur> volunteers? :)
17:10:41 <TheJulia> Preferably a non-core since we shouldn't approve our own edits.
17:10:41 <dtantsur> sigh, I can do it; I guess the docs are my fate nowadays
17:10:50 <TheJulia> dtantsur: I'll take care of it
17:10:52 <TheJulia> tomorrow
17:11:03 <dtantsur> thanks TheJulia! this is very close, mostly minor things IIRC
17:11:21 <jlvillal> dtantsur: rloo is on vacation this week
17:11:54 <dtantsur> for those enjoying reading docs, I certainly have some: https://review.openstack.org/#/c/486696/ :)
17:11:58 <dtantsur> thanks jlvillal!
17:12:18 <jlvillal> I have some concerns on BFV testing. That it isn't testing. Posted more over on #openstack-ironic
17:12:28 <jlvillal> But I don't want to side-track meeting
17:12:47 <dtantsur> well, it's an important thing to raise
17:12:53 * xavierr will review docs again
17:13:01 * kaifeng too
17:13:41 <dtantsur> jlvillal: wait, you're changing the API tests, and the job runs a scenario test
17:14:05 <dtantsur> stuff in tests/api is not run by it at all (though it's run by other jobs)
17:14:31 <dtantsur> if you want to check its validness, I suggest breaking something in the cinder interface
17:14:32 <jlvillal> dtantsur: Oh. So does anything run that test code?
17:14:44 <dtantsur> jlvillal: I think non-bfv jobs run all API tests
17:15:10 <jlvillal> Hmm. Okay. I will wait until after meeting to figure it out.
17:15:49 <jlvillal> dtantsur: Ah yeah. Failed in other tests. Sorry I was thinking that was specific to BFV. My mistake.
17:16:02 <dtantsur> no prob :) it can be confusing
17:16:16 <dtantsur> we should really move the API tests out of the integration jobs into their own job
17:16:29 <dtantsur> TheJulia: ^^^
17:16:30 <TheJulia> +1000
17:17:06 <dtantsur> forgot to announce: I've started cleaning up the release notes for the next (9.0.0?) release: https://review.openstack.org/491265
17:17:15 <dtantsur> thanks all who commented so far, I'll update it tomorrow
17:17:51 <TheJulia> 9.0.0 would follow our release cycling :)
17:18:44 <TheJulia> dtantsur: Thanks for picking that up, it was on my list to begin looking at first thing today :)
17:19:10 <dtantsur> haha, that's the benefit (?) of working on Sunday :)
17:19:23 <TheJulia> heh
17:19:28 <TheJulia> s/benefit/curse/?
17:19:37 <dtantsur> depends :) I had some boring time to fill
17:20:55 <dtantsur> the python 3 job is passing \o/
17:21:10 <jlvillal> That's awesome :)
17:21:15 <dtantsur> which reminds me that I should update the TC about the goals
17:22:20 <dtantsur> the Queens steps will be IPA and ironic-inspector, I guess
17:22:55 <xavierr> Is there any initiative of OpenStack drop support for python 2?
17:23:00 <dtantsur> sambetts: do you still hope to get IPA API versioning fully in Pike?
17:23:19 <dtantsur> xavierr: eventually. it's not easy, given downstream support for python 3
17:23:26 <dtantsur> it's not happening in Queens for sure
17:23:31 <sambetts> dtantsur: I think it would be a nice to have
17:23:33 <pas-ha> I would even go as far as build tinyipa with py3 by default
17:23:35 <sambetts> dtantsur: its very close
17:23:53 <dtantsur> pas-ha: let's start with updating the existing py3 job to do it (volunteers welcome;)
17:24:13 <dtantsur> sambetts: okay, let's try to merge it by the next meeting. otherwise, I think, it will be a bit too late
17:24:25 <dtantsur> everyone finished with the statuses?
17:24:51 <dtantsur> #topic Deciding on priorities for the coming week
17:25:00 * pas-ha lost net access, sitting on 2g mobile.. :/
17:25:09 <dtantsur> pas-ha: ugh :(
17:25:11 <TheJulia> pas-ha: ouch :(
17:25:44 <dtantsur> we still have some final docs work to do
17:25:46 <jlvillal> dtantsur: I lost track of what exactly you were looking for volunteers for.
17:25:47 <anupn> pas-ha, I will like to volunteer for that
17:25:58 <dtantsur> jlvillal: the python3 job to use python3 for tinyipa
17:26:01 <jlvillal> dtantsur: Updating existing py3 job to do ....  ?
17:26:07 <dtantsur> anupn: for this ^^^?
17:26:09 <jlvillal> dtantsur: Ah. Thanks :)
17:27:18 <anupn> dtantsur, yes, but of course need to go over some docs, have not played much with py3 upgrading
17:27:27 <dtantsur> anupn: thanks!
17:27:41 <dtantsur> sambetts: do I get it right that we need to land the ironic part of IPA API work first?
17:28:35 <dtantsur> mgoddard: are you up for working on your VIF refactoring patch chain this week?
17:30:04 <sambetts> dtantsur: yup the reason being that we need to know the ironic API version in the IPA part, and until its landed that isn't certain
17:30:10 <sambetts> as more API changes might land
17:30:59 <dtantsur> I hope we don't land more API changes ;) but yes, you're right
17:31:18 <dtantsur> I'd kick the VIF refactoring our for now, to be honest..
17:31:22 <dtantsur> opinions?
17:31:57 <TheJulia> no strong opinions either way
17:32:11 <sambetts> its internal tech debt, the main thing it'll affect is anyone writing drivers than use the mixins
17:32:25 <sambetts> s/than/that
17:32:44 <dtantsur> yeah, but I'm not sure we can finish all this in one week
17:32:57 <dtantsur> and I don't know if mgoddard has time for it
17:33:54 <TheJulia> Seems like the only real option is to do what we can and hold any breaking/impacting changes.
17:34:55 * dtantsur is unsure if it's "keep" or "move"
17:35:10 <dtantsur> anyway, here is the list. how does it look?
17:36:19 * dtantsur hears crickets
17:36:20 <jlvillal> Looks reasonable to me.
17:36:20 <TheJulia> dtantsur: looks good to me
17:36:25 <dtantsur> okay :)
17:36:38 <dtantsur> moving on then
17:36:41 <dtantsur> #topic Any cross-project sessions (esp. Nova and Neutron) needed for the PTG?
17:36:49 <dtantsur> this should be quick, mostly a reminder
17:37:05 <dtantsur> if we want a cross-session with folks, it's time to plan on it
17:37:28 <dtantsur> any immediate ideas on what we could discuss?
17:37:41 <jlvillal> Mogan? https://github.com/openstack/mogan
17:37:52 <dtantsur> jlvillal: what should we discuss there?
17:38:07 <jlvillal> No idea who is using Mogan though.
17:38:08 <jlvillal> dtantsur: Probably nothing. I just know they use Ironic.
17:38:23 <kaifeng> maybe neutron events or sth
17:38:24 <TheJulia> nothing that comes to mind dtantsur, there are possibilities on each side, but I suspect hallway track may be just as effective for minor things
17:38:43 <dtantsur> kaifeng: I think for neutron events we have a plan forward, right vdrok?
17:39:30 <pas-ha> Yep
17:39:34 <kaifeng> and routed network? i have not checked the board yet :P
17:39:59 <dtantsur> okay, let's put it this way:
17:40:17 <dtantsur> #action everyone please think of potential cross-project sessions at the PTG by next week
17:40:24 <wanyen> dtanstur, perhaps with nova to discuss rsc class scheduling?
17:40:45 <dtantsur> wanyen: I'm doing it every week :) it's done in Pike, what exactly would you like to discuss?
17:41:16 * dtantsur has to refresh the docs tomorrow
17:41:26 <mgoddard> dtantsur: I may have some time for VIF refactoring this week
17:41:44 <dtantsur> mgoddard: good, because we kept it on the list ;) this is something I'd prefer to finish rather earlier
17:41:53 <dtantsur> because of potential merge conflicts and breaking stuff
17:42:05 <wanyen> dtantsur, I am thinking to be able to use standard rsc class (as opposed to custom class) for Ironic.
17:42:23 <mgoddard> makes sense. I'll aim to address the comments in the next day or two
17:42:37 <dtantsur> wanyen: I agree with the PTG topic, but this is something you can raise to nova folks already (ML, scheduler meeting, etc)
17:42:45 <dtantsur> because the current plan is to remove this in Queens
17:43:31 <wanyen> dtantsur: remove this. what is this?
17:43:47 <dtantsur> wanyen: ability to use standard resource classes with ironic
17:44:00 <dtantsur> wanyen: edleafe and jaypipes are good people to talk to about that (and good people overall!)
17:44:36 <dtantsur> wanyen: I've put the topic to the etherpad, but without you attending it may be hard to advocate for your position
17:44:36 <wanyen> dtantsur, ilo team plan to do some PoC first and then talk to nova
17:44:41 <dtantsur> ack
17:45:15 <dtantsur> other ideas? you have a week to think about it :)
17:45:17 <wanyen> unfortunately, none of the ilo team member can attend PTG.  Is remote participation possible?
17:45:25 * edleafe reads back
17:45:49 <dtantsur> wanyen: I don't know; it highly depends on the rooms, their equipment and the internet quality
17:45:52 <edleafe> wanyen: what do you mean by "use a standard resource class"?
17:46:00 <dtantsur> wanyen: please direct your question to the foundation staff
17:47:22 <dtantsur> wanyen: could you please talk to edleafe in #openstack-nova? I'd prefer to move on with the topics
17:47:25 <wanyen> edleafe, nova has standard rsc class (CPU, memory, storage, PCI devices) that Nova virtual instance can use.  These rsc classes handle quantative rsc
17:48:05 <dtantsur> ready to move on?
17:48:06 <edleafe> wanyen: then an ironic node would still suffer the problems it has today
17:48:40 <TheJulia> dtantsur: lets move on
17:48:45 <TheJulia> 12 minute warning
17:48:52 <wanyen> edleafe, can you elaborate "problems"?
17:48:54 <dtantsur> #topic RFE review
17:49:07 <dtantsur> wanyen, edleafe, sorry, we have to follow the agenda :(
17:49:14 <edleafe> dtantsur: no worries
17:49:17 <dtantsur> #link https://bugs.launchpad.net/ironic/+bug/1635644 SNMP driver auto-discovery
17:49:17 <openstack> Launchpad bug 1635644 in Ironic "[RFE] SNMP driver auto-discovery" [Wishlist,In progress] - Assigned to Philippe Godin (godp1301)
17:49:30 <wanyen> dtantsur: sure, np.
17:49:39 * TheJulia tries to wrap her head around this
17:49:52 <dtantsur> so, this SNMP thing seems a simple win at first glance
17:50:11 <dtantsur> instead of operators providing a vendor (OID?), discover it from SNMP itself
17:50:22 <TheJulia> dtantsur: I like it
17:50:30 <dtantsur> etingof: may have opinions here
17:50:36 * etingof just proposed an alternative design in the review
17:51:28 <dtantsur> etingof: does it invalidate the RFE itself or only its implementation?
17:51:48 <etingof> it's more about the implementation
17:52:18 <etingof> there may be possible to make it more general/universal
17:52:24 <etingof> *a possibility
17:53:01 <TheJulia> etingof: using the system description field?
17:53:18 <etingof> no, using the sysORTable
17:54:03 <TheJulia> why not both?
17:54:17 <TheJulia> we're talking about snmp here :)
17:54:25 <etingof> yes, SNMP
17:54:42 <etingof> the sysDescr basically tells you the model of the device
17:55:00 <etingof> the sysORTable tells you what this device can do for you
17:55:34 <TheJulia> And hopefully most have a valid vlaue there, I would only worry that sysORTable is insufficient or incomplete for some vendors.
17:55:37 <etingof> the first involves more heuristics while the second is more formal and general
17:55:55 <etingof> yes, that is my concern as well
17:56:27 <TheJulia> I'm +1 to the overall idea, actual implementation details aside
17:57:01 <dtantsur> yeah, my question is whether we can approve the RFE and figure out the exact implementations in the patch
17:57:06 <dtantsur> (also 3 minutes warning)
17:57:30 <TheJulia> I think we can, rfe is conceptual, and since it would be largely limited to the mechanics of the driver, I think that is okay
17:57:30 <etingof> +1 for approving the RFE as is
17:57:40 <dtantsur> okay
17:57:49 <dtantsur> next
17:57:56 <dtantsur> #link https://bugs.launchpad.net/ironic/+bug/1688489 deprecate continue_node_clean() RPC
17:57:56 <openstack> Launchpad bug 1688489 in Ironic "[RFE] deprecate continue_node_clean() RPC API method" [Wishlist,Confirmed]
17:58:00 <TheJulia> actual implementation details, we can figure out or determine we need more consensus/information
17:58:09 <dtantsur> yuriyz: ^^^
17:59:10 <TheJulia> Im kind of -1 to this as is, at least thinking about it at the moment, since it feels like we're trying to route around performance issues
17:59:25 <TheJulia> but I could be convinced otherwise. I just fear touching the logic in cleaning with how it presently works
17:59:35 <dtantsur> "convinced otherwise" sounds like a spec ;)
17:59:41 <TheJulia> +1
17:59:52 <yuriyz> maybe I try to create the spec?
17:59:57 <dtantsur> yuriyz++
17:59:59 <yuriyz> ok
18:00:02 <dtantsur> aaaand, we're out of time :)
18:00:05 <dtantsur> thanks everyone
18:00:10 <dtantsur> #endmeeting