17:00:00 <dtantsur> #startmeeting ironic
17:00:00 <openstack> Meeting started Mon Mar 20 17:00:00 2017 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:01 <crushil> \o
17:00:02 <kaifeng> \o
17:00:03 <lucasagomes> o/
17:00:04 <openstack> The meeting name has been set to 'ironic'
17:00:05 <jlvillal> o/
17:00:08 <rama_y> o/
17:00:09 <rpioso> o/
17:00:12 <mjturek> o/
17:00:15 <aarefiev> o/
17:00:18 <soliosg> o/
17:00:21 <baha> o/
17:00:26 <kaifeng> O/
17:00:40 <xavierr> o/
17:00:46 <dtantsur> hi everyone! thanks for coming :)
17:00:47 <kaifeng> O/
17:00:56 <dtantsur> our agenda as usual can be found here:
17:01:00 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:01:18 <dtantsur> #topic Announcements / Reminders
17:01:31 <dtantsur> #info ironic-{core, release} groups were added to sushy-{core, release} groups respectively
17:01:39 <lucasagomes> o/
17:01:40 <dtantsur> more raw fish for all of us :)
17:01:43 <dtantsur> thanks lucasagomes!
17:01:45 <rloo> o/
17:01:48 <joanna> o/
17:01:49 <mjturek> \o/
17:01:53 <dtantsur> I don't think I have any announcements. anyone?
17:01:58 <rloo> dtantsur: i just added stuff to the agenda
17:02:02 <rloo> two announcements
17:02:11 <rloo> rloo is retiring from subteam-status-report duty; rama_y (Ramamani Yeleswarapu) has kindly agreed to take over. Thanks rama_y!
17:02:18 <dtantsur> #info rloo is retiring from subteam-status-report duty; rama_y (Ramamani Yeleswarapu) has kindly agreed to take over. Thanks rama_y!
17:02:21 <mariojv> thanks rama_y
17:02:21 * jroll has nothing
17:02:33 <dtantsur> #info new ironic liaisons: JayF for i18n; Rushil Chugh for oslo; soliosg (Solio Sarabia) for logging working group
17:02:39 <vdrok> o/
17:02:41 <rama_y> Thanks, rloo!
17:02:41 <mgould> o/
17:02:47 <jroll> woot
17:02:48 <dtantsur> thanks a lot! please don't forget to update the etherpad before meeting, if you have something to bring up
17:02:57 <mariojv> thanks for volunteering for liaison, JayF crushil soliosg
17:03:09 <rloo> thanks rama_y, JayF, crushil, and soliosg!
17:03:16 <alezil> o/
17:03:25 <NobodyCam> o/
17:03:27 <Nisha_Agarwal> o/
17:03:33 <crushil> np mariojv rloo
17:03:40 <dtantsur> anything else?
17:03:41 <kaifeng> o/
17:03:44 <Sukhdev> o/
17:04:09 <dtantsur> #topic Review subteam status reports
17:04:21 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:04:30 <dtantsur> starting with line 97
17:04:59 <dtantsur> \o/ @ standalone tests
17:04:59 <mariojv> for the OSC API versioning, rescue mode, and specific fault support priorities, i updated to the best of my ability even though i was away last week
17:05:10 <mariojv> please feel free to correct anything that's inaccurate
17:05:25 <mariojv> jay's away at least part of this week iirc
17:05:26 <rloo> vsaienk0: for standalone CI tests, is this the next patch that needs reviewing? https://review.openstack.org/#/c/437549
17:05:31 <stendulker> o/
17:06:49 <vgadiraj> o/
17:07:19 <rloo> jlvillal: wrt multinode grenade testing. Yay! is there a description somewhere that describes what is being tested?
17:07:35 <vsaienk0> rloo: yes
17:08:12 <rloo> vsaienk0: thx, i updated the etherpad :)
17:09:18 <jlvillal> rloo: I don't think so. Basically it is iron
17:09:32 <rloo> jlvillal: ok, will talk to you later about that
17:09:33 <jlvillal> rloo: I don't think so. As far as docs
17:09:48 <rloo> vsaienk0, sambetts_. what's the status wrt the network related stuff?
17:10:15 <rloo> vsaienk0, sambetts_: post-deploy VIF attach/detach, pyhsical network awareness, routed networks support?
17:10:17 <mariojv> i'd be curious about that too rloo - specifically links to things to review on the whiteboard would be great
17:11:21 <vsaienk0> rloo:  post-deploy VIF attach - need review https://review.openstack.org/#/c/424723/
17:11:21 <rloo> wrt the IPA versioning, i think the question was whether to use the ipa version, or add REST API versioning...
17:12:01 <vsaienk0> physnet awareness: I'm working on initial patch with devstack plugin/basic documentation to networking-baremetal
17:12:08 <rloo> I don't know if we need to meet/decide on that or not (IPA versioning). maybe we can wait for sambetts_ to ask...
17:12:49 <vsaienk0> rloo: pass portgroup information to Neutron spec: https://review.openstack.org/#/c/415003/ code: https://review.openstack.org/446763
17:13:05 <dtantsur> eeek, I forgot a small announcement
17:13:16 <dtantsur> #info dtantsur is on PTO the next week (Mar 27 - Mar 31)
17:13:35 <rloo> eeekkk, too late, dtantsur. you can't go on PTO :)
17:13:40 <dtantsur> :D
17:13:48 <Sukhdev> :-)
17:13:51 <dtantsur> can somebody please chair the meeting?
17:14:02 <rloo> isn't there a spec for physical network?
17:14:29 <vdrok> rloo: I've seen one
17:14:36 * mariojv tries to find link
17:14:50 <rloo> found it: https://review.openstack.org/#/c/435781/
17:14:51 <vdrok> rloo: https://review.openstack.org/435781
17:14:54 <mariojv> ty
17:14:57 <vdrok> :'(
17:15:09 <dtantsur> we're a bit past time for reviewing the status updates. how much time do folks still need?
17:15:21 <rloo> dtantsur: i'm still reading/reviewing. too much stuff...
17:16:04 <dtantsur> #info Please provides status updates on https://etherpad.openstack.org/p/IronicWhiteBoard *before*, not *during* the meeting
17:16:14 <jroll> when we started doing subteams, I wasn't imagining this many subteams
17:16:32 <jroll> this is totally too much for 10 minutes of meeting time
17:16:43 <rloo> agreed
17:16:59 <rloo> jroll: wrt nova. is it time to update our documentation about node.resource_class? :)
17:17:07 <dtantsur> soliosg, I guess we should remove ironic-inspector-tempest-plugin, right?
17:17:14 <jroll> (then again, I'm surprised we have so many priorities, too)
17:17:28 <rloo> i hope you all saw that there is no need for i18n wrappers for log messages.
17:17:36 <jroll> rloo: getting there yeah, I figure I'll get the upgrade path(s) approved and then write the docs all at once
17:18:03 <rloo> jroll: great. the traits stuff will be interesting!
17:18:12 <jroll> indeed :)
17:18:33 <soliosg> dtantsur: oh, so will we unify both tempest plugins (ironic and ironic-inspector) into the one in new repo?
17:18:35 <rloo> dtantsur: can we discuss i18n now, or later?
17:19:02 <rloo> dtantsur: wrt going forward, i want to make sure. we don't want i18n wrappers any more, so no _LE, _LW...
17:19:14 <rloo> except for user-facing stuff
17:19:27 <dtantsur> yeah, reading now, but let's move it to the discussion
17:19:32 <rloo> dtantsur: ok
17:19:47 <dtantsur> soliosg, yeah, that's the outcome from the PTG
17:20:15 <soliosg> dtantsur: ok, will add that to the whiteboard
17:20:33 <wanyen> jroll & rloo: how does traits handle backward compatibility?
17:20:35 <dtantsur> ready to move on?
17:20:42 <dtantsur> wanyen, let's please not discuss it here and now
17:20:51 * mariojv is ready to move on
17:20:52 <rloo> wanyen: i think that's where the brainstorming comes into play. dunno.
17:20:53 <lucasagomes> ++ to move on
17:20:56 <dtantsur> #topic Deciding on priorities for the coming week
17:21:08 <dtantsur> we cleared 2 items
17:21:08 <wanyen> dtantsur: ok
17:21:24 <mariojv> for this, if any of rescue, fault support, or OSC API versioning are going to be prioritized, i'd recommend doing only 1 of them at a time for now
17:21:32 <mariojv> rescue's probably the most far along
17:21:52 <jlvillal> Nice job getting two items from last week done :)
17:21:59 <joanna> I'll update the cinder API patch today, I think it should remain on the list
17:22:00 <dtantsur> mariojv, so, what would you suggest to take?
17:22:00 <mariojv> ++ gj
17:22:06 <mariojv> dtantsur: rescue
17:22:10 <dtantsur> joanna, ++ for keeping BFV
17:22:21 <dtantsur> as to redfish, I'd like to replace it with the spec update that lucasagomes posted
17:22:25 <joanna> dtantsur: awesome
17:22:37 <lucasagomes> dtantsur, yeah sounds good to create consensus on that
17:22:40 <mariojv> i consolidated all the code links into a link to the topic
17:22:52 <mariojv> for any needing rebase/updates, i will update this week
17:22:53 <rloo> now that we have some standalone tests, when do we remove those equivalent non-standalone tests?
17:23:32 <vdrok> I guess we want to watch them for a week or two, then remove
17:23:49 <dtantsur> something like that.. also a topic for later discussion, I think
17:23:52 <vdrok> and make the standalone voting
17:24:04 <rloo> vdrok: ok, so we want to get as many standalone tests working, so we can remove the others soon
17:24:12 <vdrok> yup
17:24:19 <rloo> dtantsur: only asking to see if those patches or patch is a priority :)
17:24:40 <dtantsur> ah
17:24:46 <dtantsur> yeah, I think we should wait a bit
17:25:13 <dtantsur> mariojv, what's the next rescue patch or a couple of patches we can pile on
17:25:14 <dtantsur> ?
17:25:27 * mariojv looks
17:25:48 <lucasagomes> api isn't it?
17:25:54 <mariojv> dtantsur: https://review.openstack.org/#/c/350831/32 and https://review.openstack.org/#/c/353156/14 will be manageable
17:26:02 <mariojv> lucasagomes: yep
17:26:08 <mariojv> lucasagomes: the rescuewait timeout is a small change
17:26:10 <dtantsur> if sambetts_ is not around, I'd kick IPA versioning probably...
17:26:11 * rloo is fine if there aren't many priorities of the week...
17:26:14 <mariojv> which is the 2nd one i suggested
17:26:15 <lucasagomes> mariojv, ++
17:26:26 <mariojv> i'll move updating those up on my todo list
17:26:30 <jroll> dtantsur: +1
17:27:10 <mariojv> feel free to remove /32 and /14 from those links
17:27:13 <mariojv> so it goes to the latest patch sets
17:27:17 <dtantsur> mariojv, are we really ready to review API already?
17:27:51 <mariojv> dtantsur: imho yes, there are some things to update now that we had reviews last week
17:28:14 <dtantsur> ok
17:28:19 <mariojv> had a +2 for a nice second there :)
17:28:28 <dtantsur> last candidate: client changes for driver comp?
17:28:54 <jroll> if they look ready +1
17:29:10 <jroll> (or close to ready)
17:29:13 <dtantsur> https://review.openstack.org/#/c/419274/ is close
17:29:14 * lucasagomes == jroll
17:29:21 <dtantsur> #define lucasagomes jroll
17:29:23 <jroll> need to get that out of the way
17:29:27 <lucasagomes> lol
17:29:33 <jroll> poor lucasagomes :P
17:29:42 <dtantsur> ok, 5 items. how does it look?
17:29:51 <lucasagomes> I mean, same opinion, if it looks ready I would include it
17:30:13 * dtantsur guessed, but still :)
17:30:13 <lucasagomes> dtantsur, lgtm
17:30:14 <vdrok> lgtm
17:30:15 <jroll> I'm fine with it
17:30:23 <mariojv> LGTM
17:30:35 <jroll> I hope we start getting networking things in there, so we don't rush them all in at the end
17:30:41 <mariojv> i'm glad we have the client patch since those get less attention in general
17:31:02 <dtantsur> jroll++
17:31:10 <dtantsur> mariojv++
17:31:12 <dtantsur> :)
17:31:19 <dtantsur> ok, I guess we can move on..
17:31:29 <dtantsur> #topic Appointing a bug liaison for the next week
17:31:49 <dtantsur> mjturek, are you enjoying it? :)
17:31:56 <dtantsur> any volunteers this time?
17:32:05 <mjturek> dtantsur: definitely! if someone wants to give it a go that's fine too
17:32:15 <mjturek> https://etherpad.openstack.org/p/ironic-bug-triage
17:32:34 <dtantsur> #link https://etherpad.openstack.org/p/ironic-bug-triage the current bug triaging effort etherpad
17:32:49 <dtantsur> thanks mjturek! I don't see other volunteers, soo :)
17:33:00 <mjturek> dtantsur: sure I'll do another week :)
17:33:03 <dtantsur> #action mjturek to continue to look after our bug list
17:33:31 <dtantsur> no discussion items, so I'm opening the floor
17:33:31 <jroll> thank you mjturek :)
17:33:35 <dtantsur> #topic Open discussion
17:33:40 <mjturek> np jroll :)
17:34:08 <mjturek> dtantsur: I had put an item here about a bug I saw
17:34:12 <jroll> wanyen: to answer your question, the traits work won't happen until queens. there isn't a plan yet, we're still brainstorming. there will be an upgrade path that won't require downtime, but may require operator action.
17:34:24 <dtantsur> #link https://bugs.launchpad.net/ironic/+bug/1672457 issue reported by Red Hat scale folks about ironic-conductor performance with time
17:34:24 <openstack> Launchpad bug 1672457 in Ironic "Ironic Conductor performance trends down with uptime" [Medium,Confirmed]
17:34:32 <lucasagomes> I added an item there regarding a comment from JayF in the redfish driver (https://review.openstack.org/#/c/438982/11/ironic/drivers/modules/redfish/utils.py L48)
17:34:36 <jroll> wanyen: (the operator action will likely be updating flavors)
17:35:02 <joanna> I have 2 questions
17:35:02 <lucasagomes> current the spec as only 1 option for the SSL cert verification, TheJulia proposed having two
17:35:12 <wanyen> jroll: thanks!  I have a few questions regarding traists.
17:35:29 <lucasagomes> but still... not sure how people would prefer that. So if you have a time to look at the comment and weight it would be great
17:35:34 * dtantsur is not sure we should discuss Queens traits now...
17:35:39 <jroll> wanyen: sure, feel free to ask me in channel or send me an email
17:35:47 <jroll> s/channel/ironic channel/
17:35:48 <dtantsur> lucasagomes, I'd stick with what python-requests accepts
17:36:00 <xavierr> cores, I'd like another review on https://review.openstack.org/#/c/386014/ it has one +2 and avoid oneview drivers to break due problems when allocating a node on oneview
17:36:01 <lucasagomes> dtantsur, right, and just document it better ?
17:36:02 <dtantsur> but two options also sound good
17:36:03 <xavierr> :)
17:36:06 <jlvillal> Which topic are we on? Did we finish with the performance one?
17:36:11 <vdrok> pas-ha added one thing to https://etherpad.openstack.org/p/ops-adopt-a-project-pike
17:36:12 <dtantsur> lucasagomes, if people feel like 2 options are cleaner, I'm also fine
17:36:15 <joanna> desired response code in case API is not available in specified version is 405, right?
17:36:22 <mariojv> dtantsur: i'm wondering if the perf issues can be reproduced with ocata, since those stats were from newton
17:36:22 <lucasagomes> dtantsur, right on
17:36:26 <mjturek> jlvillal: not yet, waiting for it to die down a bit
17:36:28 <lucasagomes> jlvillal, I think we mixed everything
17:36:29 <dtantsur> jlvillal, that was just info, I don't think we can fix it here and now
17:36:31 <mariojv> also wondering if default config options for # periodic task workers was used
17:36:50 <mjturek> dtantsur: fair enough, was wondering if it's cause for concern
17:36:56 <vdrok> joanna: 406 or 404
17:36:58 <dtantsur> joanna, whatever is NotAcceptable. except for new endpoints, we return 404 for them.
17:37:02 <lucasagomes> jlvillal, but the performance one seems interesting, justin works for RH and he's doing a lot of performance tests with ironic (and other projects)
17:37:16 <joanna> vdrok, dtantsur: thanks!
17:37:21 <dtantsur> mariojv, you may ask jkilpatr on #openstack-ironic
17:37:28 <mariojv> ok
17:37:35 <jlvillal> Yeah. Just I was getting slightly confused as appeared three maybe four things being discussed at the same time.
17:37:36 <jroll> yes, let's not debug performance issues in the meeting :P
17:37:53 <dtantsur> #info please keep updating https://etherpad.openstack.org/p/ops-adopt-a-project-pike
17:37:54 <nicodemos> I'd like to get some reviews on https://review.openstack.org/#/c/377106/ , I already answered vdrok questions
17:38:02 <joanna> I was also wondering why do we keep sample config in the repo?
17:38:08 <wanyen> jroll: ok.  Thanks!   The nova os_traits said that it addresses the problem for host aggregate.  However, based on my understanding host aggregate does not support Iornic yet.
17:38:10 <vdrok> dtantsur: are there some graphs related to memory? I saw only cpu there
17:38:12 <jroll> vdrok: ++ for pas-ha's comments on that etherpad
17:38:21 <lucasagomes> joanna, just as a reference ?
17:38:28 <dtantsur> vdrok, please ask jkilpatr in the channel
17:38:28 <jroll> wanyen: let's not discuss in this meeting, we can talk in #openstack-ironic or email
17:38:39 <lucasagomes> I actually find it useful, specially when liking people about a certain config option
17:38:42 <wanyen> jroll: ok.
17:38:44 <TheJulia> joanna: operator friendly reference
17:38:46 <mariojv> vdrok: i moved the convo to #openstack-ironic
17:38:56 <lucasagomes> joanna, but no big reason other than that *I think*
17:39:16 <dtantsur> ++
17:39:24 <jroll> I thought it was because the people that like in-repo config won that game of rock paper scissors
17:39:24 <joanna> ok. I'm just not used to keeping generated files in the repo as they're ususally hard to maintain
17:39:43 <joanna> but I suppose it's good if an operator can look it up on github, right?
17:39:46 <dtantsur> yeah, it's a trade-off
17:39:57 <mariojv> i personally find the sample config useful
17:39:58 <dtantsur> yep, you can link to a specific line, etc
17:40:07 <lucasagomes> joanna, right
17:40:10 <rloo> i don't think it is just on github; i thought those .sample files were packaged too
17:40:10 <jroll> joanna: the main thing is that the tox target to generate it requires all dependencies. which means you need postgres dev headers, numpy, and all sorts of related crazy
17:40:12 <mariojv> it is a bit annoying when it's out of date, but to me that annoyance cost is outweighed by the benefits
17:40:19 <jlvillal> dtantsur: Any news on Dell CI? I was reminded as I noticed it said -1 to my patch ;)
17:40:26 <joanna> dtantsur, jroll , lucasagomes, TheJulia, mariojv: thanks
17:40:43 <dtantsur> jlvillal, I did not get to chatting with folks. I remember it was not completely red, but I need to estimate it.
17:40:48 <jlvillal> dtantsur: Thanks.
17:41:24 <dtantsur> rloo, right, we do package them: https://github.com/rdo-packages/ironic-distgit/blob/rpm-master/openstack-ironic.spec#L122
17:41:44 <rloo> dtantsur: i think that is the most value for generating it!
17:42:07 <dtantsur> yep, it helps
17:42:09 <rpioso> jlvillal, dtantsur: I'm checking on the Dell CI.
17:42:14 <vdrok> re https://etherpad.openstack.org/p/ops-adopt-a-project-pike, the goal is I guess increasing "project maturity". one of the items there is number of SDKs, do we want to have more than 2?
17:42:21 <jlvillal> rpioso: Awesome. Thanks :)
17:42:32 <dtantsur> rpioso, thanks! please make sure to have an up-to-date HTTPS certificate, btw :) this is a common problem.
17:42:42 <vdrok> and if so, which ones are in more priority out of those listed on the sdk wiki
17:42:44 <rpioso> jlvillal: Which patch, please?
17:42:53 <dtantsur> vdrok, how many of folks here have a pet SDK? :) (I have)
17:43:02 <wanyen> jroll: there are still a few resource provider and os_trait email chains that I would like to follow, so I will discuss this topic with  you in a few days.
17:43:07 * jroll thinks the SDK metric is totally bogus
17:43:11 <dtantsur> jroll++
17:43:25 <vdrok> dtantsur: hah, just add it here https://wiki.openstack.org/wiki/SDKs, we'll get +1 :)
17:43:44 <jlvillal> rpioso: Most of them ;) But here is one: https://review.openstack.org/445636
17:43:56 <dtantsur> vdrok, no ironic yet, a barely started with compute :D
17:44:00 <rpioso> dtantsur: ty for the suggestion.
17:44:26 <rpioso> jlvillal: :-(  Thank you!
17:44:36 <jlvillal> rpioso: http://ci-watch.tintri.com/project?project=ironic&time=7+days  I see a lot of red red red red red ....
17:45:25 <jlvillal> HPE and Fujitsu appear to be in the same situation.
17:45:36 <mjturek> jlvillal: pkvmci is broken too
17:45:43 <mjturek> haven't had a ton of time to debug
17:45:45 <rpioso> jlvillal: We'll look into it.
17:45:52 <jlvillal> Thanks
17:46:24 <dtantsur> we should start improving our 3rdparty CI situation
17:46:24 <jroll> wanyen: okay, please read and figure out what "traits" means, I suggest to start with: http://specs.openstack.org/openstack/nova-specs/specs/pike/approved/resource-provider-traits.html
17:46:39 <jroll> wanyen: and realize that I don't have a solid plan yet, and I probably still won't have a plan when we talk :)
17:47:06 <dtantsur> with percentage of false negative not an order of magnitude more than one of our regular CI :-/
17:47:25 <jlvillal> dtantsur: ++
17:47:45 <dtantsur> I'd even suggest to have some goal, and assess it by end of Pike
17:47:52 <dtantsur> and maybe make some sad decisions ;)
17:48:03 <wanyen> jroll, I have read the spec that you mentioned that's why I have some questions.  No rush since it's for Queen.
17:48:25 <jroll> wanyen: cool, I'm ready to chat whenever you are, let me know :)
17:48:38 <wanyen> jroll: ok.  Tx
17:48:54 * dtantsur hopes his comments on 3rdparty CI were noted
17:49:06 <jroll> dtantsur: I noted them :P
17:49:10 <jroll> could use an #info
17:49:17 <jlvillal> dtantsur: # info it?
17:49:22 <dtantsur> yeah, gimme a second
17:49:24 <rloo> dtantsur: i was waiting to hear what the goals were first :)
17:49:37 <dtantsur> rloo, I don't have them, but I will soon(ish)
17:50:11 <rloo> dtantsur: okey dokey
17:50:14 <dtantsur> #info we expect 3rdparty CI to be comparably reliable to our regular CI. dtantsur plans on assessing each CI performance by the end of Pike.
17:50:39 <dtantsur> rloo, I'm still planning on a tool to get statistics out of gerrit
17:50:45 <dtantsur> given numbers, I can make proposals
17:50:47 <mariojv> thank you dtantsur, that'll be useful
17:50:47 <jlvillal> And if they aren't, they can be removed along with their driver.
17:50:50 <rloo> dtantsur: please add to that, what we decided in previous cycle, about 3rd party CI expectations
17:50:59 <dtantsur> sure, I need to review it
17:51:51 <dtantsur> anything else?
17:52:24 * dtantsur waits a minute more
17:52:33 <rloo> about ^^ ? no. did we want to discuss i18n of log msgs? I can discuss with you later if you want.
17:52:34 <jlvillal> Did we discuss the i18n thing?
17:52:47 <dtantsur> no, I forgot about it
17:53:01 <dtantsur> rloo, so, is it official now? I could not figure out from the mail thread?
17:53:04 <jroll> is there anything to discuss?
17:53:09 <rloo> dtantsur: yeah it is official.
17:53:13 <jroll> dtantsur: nova is removing them already, so yeah
17:53:14 <rloo> two things to discuss i think.
17:53:14 <dtantsur> jroll, rather to announce
17:53:36 <rloo> 1. starting now, should we remove/not approve any patches with i18n'd log msgs?
17:53:45 <dtantsur> #info OpenStack stops translating logs. we will remove translation markers around them soon.
17:53:49 <soliosg> nova already deleted *.po files from their project
17:54:05 <vdrok> rloo: I guess not only logs but exceptions too?
17:54:15 <dtantsur> vdrok, exceptions may propagate to users
17:54:17 <rloo> 2. someone (s) is bound to submit patches removing the i18n calls. i'm concerned about big patches, causing rebases of other patches.
17:54:23 <mariojv> i'd suggest that we only start refusing patches with _() after the removal happens
17:54:32 <mjturek> they disabled the hacking job's check for translations as well. Not sure if we have one too
17:54:34 <rloo> vdrok: not clear about exceptions, they could be userfacing.
17:54:44 <dtantsur> mariojv++
17:54:44 <jlvillal> We should be clear and emphasize that it is "log" messages. Not messages that the user will see. Which I think for us is most messages.
17:54:45 <vdrok> ok
17:54:51 <jroll> rloo: we should get a volunteer now, and do it in small chunks
17:54:55 <lucasagomes> mariojv, yeah I was wondering if I should remove from the patches I have up in the queue now
17:55:28 <dtantsur> #info please consider removing translation markers around *logs* in your patches to make our life easier
17:55:39 <dtantsur> lucasagomes, if you have comments to address, certainly yes
17:55:49 <dtantsur> if it's close to landing, I'd say land it and follow up
17:55:54 <rloo> ok, so ok with translation markers for now.
17:55:56 <lucasagomes> dtantsur, right on
17:55:57 <jlvillal> I would defer to keeping for exceptions as they could hit the user. Without clear guidance otherwise.
17:56:07 <rloo> jlvillal: ++
17:56:22 <dtantsur> generally, _() stays, everything else goes away
17:56:32 <dtantsur> unless we made a mistake and used a wrong marker
17:56:40 <dtantsur> _() means "user visible"
17:56:48 <mariojv> oh, ok
17:56:53 <mariojv> so just remove _LE, _LW, etc?
17:57:20 <dtantsur> mariojv, right. but double-check that they are actually not visible to a user (e.g. we don't do raise SomeError(_LE(..)))
17:57:32 <mariojv> ok
17:58:01 <dtantsur> volunteers? :)
17:58:17 <rpioso> How do we want to partition it?
17:58:31 <jlvillal> So is this a "Pike priority"? I mean when is it expected to be done?
17:58:43 <rloo> no, not a priority.
17:58:49 <dtantsur> rpioso, "use common sense" I guess..
17:58:59 <dtantsur> each driver separately, etc
17:59:01 <rloo> we don't have to remove anything; nothing will be translated is all.
17:59:04 <soliosg> how to split the work would be importante, per file, folder, etc
17:59:04 <mariojv> agreed unless there's some openstack wide mandate that this has to be in by end of pike
17:59:20 <jroll> there is not a mandate
17:59:20 <joanna> I can take the API part if this helps?
17:59:26 <jroll> it's just, "you can remove these now"
17:59:26 <dtantsur> my only concern is inconsistency
17:59:27 <jlvillal> rloo: Okay, good.
17:59:31 <jroll> joanna: ++
17:59:35 <dtantsur> so either remove or not :)
17:59:44 <dtantsur> joanna, thanks!
17:59:47 <dtantsur> and we're out of time
17:59:50 <jroll> dtantsur: this is a distributed system, eventual consistency ftw :)
17:59:53 <jlvillal> dtantsur: I will volunteer for ironic-lib
17:59:55 <dtantsur> thanks everyone, let's move to the channel!
17:59:56 <joanna> dtantsur: noted :)
18:00:02 <dtantsur> thanks jlvillal!
18:00:03 <mariojv> thanks all
18:00:05 <dtantsur> #endmeeting