17:00:04 <dtantsur> #startmeeting ironic
17:00:05 <openstack> Meeting started Mon Mar 13 17:00:04 2017 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:07 <jlvillal> o/
17:00:08 <openstack> The meeting name has been set to 'ironic'
17:00:16 <TheJulia> o/
17:00:19 <NobodyCam> o/
17:00:19 <rpioso> o/
17:00:25 <rloo> o/
17:00:26 <rama_y> o/
17:00:30 <hshiina> o/
17:00:37 <hurricanerix> o/
17:00:39 <jason77> o/
17:00:52 <jroll> \o
17:00:56 <dtantsur> welcome everyone, thanks for coming!
17:00:58 <JayF> \o/
17:01:02 <dtantsur> let's give folks a few more minutes to join
17:01:07 <vdrok> o/
17:01:12 <stendulker> o/
17:01:14 <lucasagomes> o/
17:01:17 <yolanda> o/
17:01:25 <crushil> \o
17:01:38 <mgould> o/
17:01:48 <soliosg> o/
17:01:55 <dtantsur> as usual, our agenda is at
17:01:58 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:02:11 <dtantsur> a few things to discuss today, good :)
17:02:18 <dtantsur> #topic Announcements / Reminders
17:02:31 <dtantsur> the main announcement is that the pike priorities are approved!
17:02:35 <lucasagomes> o/
17:02:37 <dtantsur> #link http://specs.openstack.org/openstack/ironic-specs/priorities/pike-priorities.html
17:02:41 <alezil> o/
17:02:55 <dtantsur> so, I've updated the whiteboard with all the topics we have there
17:03:18 <dtantsur> you have a few minutes more to write your status updates ;)
17:03:23 <dtantsur> (but please do it in advance)
17:03:32 <dtantsur> also
17:03:59 <dtantsur> please keep generating ideas for ops adopt-a-project:
17:04:02 <dtantsur> #link https://etherpad.openstack.org/p/ops-adopt-a-project-pike
17:04:37 <dtantsur> next, a boot-from-volume subteam meeting is scheduled now:
17:04:41 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/Ironic-BFV
17:04:51 <dtantsur> please add to your calendars, if you're interested
17:05:06 <dtantsur> and the last thing from me:
17:05:09 <dtantsur> #info dtantsur is checking health of 3rdparty CI currently. If you get a email, please act accordingly.
17:05:11 <JayF> dtantsur: who is "ops" re: that etherpad
17:05:26 <JayF> dtantsur: Is that some kind of OpenStack Operators group?
17:05:30 <jroll> JayF: osic ops team :P
17:05:34 <dtantsur> JayF, details are there, but I think there is a group of ops interested in improving certain projects
17:05:37 <jroll> melvin's thing
17:05:39 <dtantsur> ah, yeah, this is more detailed ;)
17:05:55 <JayF> jroll: okay, that answers my question. Was curious if it was the OSIC thing or something different
17:05:59 <jroll> :)
17:06:16 <rloo> dtantsur: i didn't understand the last thing. 'if you get a email...'.?
17:06:16 <dtantsur> anyone has anything else to announce? or any questions?
17:06:22 <dtantsur> rloo, if you don
17:06:29 <vgadiraj> o/
17:06:29 <dtantsur> don't get a email - no need to bother
17:06:33 <rloo> dtantsur: what email?
17:06:50 <dtantsur> rloo, sigh, which you did not get, because you're not a 3rdparty CI owner
17:06:59 <rloo> dtantsur: you mean, if you send an email?
17:07:05 <rloo> dtantsur: OH.
17:07:05 <joanna> o/
17:07:13 <rloo> dtantsur: thx for explaining.
17:07:25 <dtantsur> I'm writing to certain folks maintaining about 3rdparty CI about problems I've spotted
17:07:29 <soliosg> I think the third announcement (3rd party CI) kills one item from the Discussion section!
17:07:46 <dtantsur> soliosg, not entirely kills, let's get to it in its time
17:07:54 <soliosg> ack
17:07:56 <dtantsur> anything else? questions?
17:07:59 <rloo> dtantsur: thx, i didn't know if you meant if our patch got 3rd party CI failure or somethin' like that
17:08:18 <dtantsur> rloo, sorry, please bear with my English :)
17:08:30 <dtantsur> (5 months more!)
17:08:32 <rloo> dtantsur: no worries; that's why i asked :D
17:08:47 <rloo> dtantsur: you aren't counting down, are you? ;)
17:08:54 <dtantsur> ofc I'm not ;)
17:08:58 * JayF bear metals with dtantsur's english
17:09:06 <dtantsur> \o/
17:09:10 <dtantsur> ok, moving on :)
17:09:15 <dtantsur> #topic Review subteam status reports
17:09:27 <dtantsur> we need MOAR of them!
17:09:29 <dtantsur> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:09:38 <dtantsur> starting with line 94
17:10:15 * jlvillal sometimes wonders if dtantsur knows about "more" ;)
17:10:28 * dtantsur does not, obviously :)
17:10:36 <jlvillal> :D
17:10:36 <rloo> TheJulia: can i update the BFV status stuff?
17:10:56 <rloo> TheJulia: I don't think L119 is still true?
17:11:19 * TheJulia raI just removed 119
17:11:32 <rloo> thx TheJulia!
17:12:00 <TheJulia> rloo: and the real answer is I would expect anyone to be willing/able to update anything that is pertinent, but that is just me :)
17:12:16 <galyna1> o/
17:12:29 <rloo> TheJulia: yes, just didn't know if you were in midst of updating or not :)
17:12:38 <rloo> is mario around?
17:12:43 <jroll> he's out
17:12:46 <TheJulia> I was and then was distracted
17:12:49 <dtantsur> JayF, re rescue report, do you think we could just link to the gerrit topic instead of listing all patches?
17:12:50 <rloo> mario did some work on the osc default api version change
17:13:03 <jlvillal> #info Almost complete with making multi-node multi-tenant grenade working. This has been a long road. Will need to change the experimental job to a non-voting job.
17:13:07 <JayF> dtantsur: sure, I can update it for that way next week
17:13:11 <dtantsur> thnx
17:13:16 <JayF> dtantsur: better way to clean that up is for more reviews and landings ;)
17:13:39 <dtantsur> true :)
17:13:57 <JayF> With mario out this week, I'll try to update those patches based  onreview feeback
17:14:44 <rloo> so not much status wrt network-related stuff
17:15:14 <dtantsur> yep. I hope it's because I only added the new subteams today.
17:15:27 <rloo> nice that redfish driver spec has been approved!
17:15:33 <dtantsur> \o/
17:15:40 <lucasagomes> JayF, ++ I will keep on reviewing the rescue stuff, it's close I think
17:15:43 <lucasagomes> rloo, ++ o/
17:15:53 <rloo> lucasagomes: so is sushy under ironic umbrella?
17:16:04 <lucasagomes> rloo, not yet, this is something i would like to discuss
17:16:13 <lucasagomes> perhaps open discussion today ?
17:16:28 <dtantsur> yep, let's leave it (I'm +1)
17:16:36 <dtantsur> * leave it for open discussions
17:17:16 <dtantsur> 2 minutes to review the subteam reports
17:17:47 <rloo> lucasagomes: i added a note about sushy & ironic in that subteam thing
17:17:59 <lucasagomes> rloo, oh ok thanks
17:18:06 * rloo good with subteam reports
17:18:31 <dtantsur> before we move on: quick poll: do we find our Trello board still useful? answers: yes/no/let's talk later?
17:18:39 * dtantsur votes no
17:18:46 <rloo> yes if it is kept up to date
17:18:56 <TheJulia> I'm also a no, too many different ways of tracking work
17:19:05 <JayF> I never looked at the trello board, personally
17:19:05 <vsaienk0> no
17:19:20 <jroll> I was mostly the only one that updated it, and so assumed I was the only one that looked at it
17:19:36 <jroll> and the subteam reports are now good enough that I rarely use it
17:19:37 <joanna> I looked at it
17:19:51 <rloo> i look at it sometimes, because that info isn't readily available anywhere else. if we put that info in subteam reports, then we don't need.
17:19:56 <joanna> and it was misleading for me, but only because it seemed outdated
17:20:00 <jroll> rloo: which info?
17:20:12 <dtantsur> ok, this does not seem like an easy win, let's postpone is till open discussion, or even bring to the ML
17:20:14 <rloo> overall, nova & ironic specs, patches
17:20:21 <jroll> ah
17:20:25 <dtantsur> it was just a quick poll, thanks :)
17:20:32 <dtantsur> #topic Deciding on priorities for the coming week
17:20:39 * jroll votes no, just for the record
17:21:02 <jroll> priority #1 has been in merge conflict for some time, we should remove that
17:21:10 <dtantsur> ++ just wanted to propose
17:21:20 <dtantsur> I'd also remove node tags, takes more time than we expected
17:21:36 <dtantsur> and get rescue there instead. or BFV. or both.
17:21:42 <jroll> +1
17:21:56 <jroll> we need to keep pushing on BFV or we won't get it done this cycle
17:21:57 <lucasagomes> +1 for rescue
17:22:05 <jroll> need to get some chunk of it done each week
17:22:13 <lucasagomes> the standalone stuff that vsaienk0 is working is in good shape as well
17:22:14 <dtantsur> let's take the first patch of BFV, and a couple of rescue
17:22:18 * dtantsur finds links
17:22:26 <lucasagomes> (I haven't looked at the fixes you pushed today yet vsaienk0 sorry, didn't have time)
17:22:38 <jlvillal> jroll: priority 1 = stand-alone testing?
17:23:03 <jroll> don't ask me, I have no clue what's going on :)
17:23:08 <jroll> oh that
17:23:20 <jlvillal> jroll: From your comment on "merge conflict"
17:23:22 <jroll> jlvillal: no, it was previously some tempest tests for portgroups/vifs
17:23:34 <jlvillal> jroll: Ah, okay. Thanks!
17:23:39 <dtantsur> jlvillal, I've removed the item with conflicts
17:23:45 <dtantsur> now yes, it's number one for me
17:23:56 <jlvillal> Thanks. I wasn't fast enough reading the whiteboard...
17:24:16 <JayF> I'm not going to be here next Monday, but I'd suggest for next week we make rescue patches a priority
17:24:16 <dtantsur> JayF, what should we take from rescue?
17:24:28 <JayF> I would wait until next week as mario is out this week
17:24:29 <dtantsur> I suggest taking one patch from it already
17:24:31 <dtantsur> ah, ack
17:24:32 * lucasagomes is not Jayf, but he thinks the API part
17:24:35 <JayF> I'll get it through at least one round of review today
17:24:35 <rloo> TheJulia: sorry, remind me. how much of bfv needs to land before doing the nova part? all of it?
17:24:39 <JayF> s/today/this week/
17:24:42 * dtantsur looks around
17:24:48 <JayF> and then if everyone bears down on it next week we can land it
17:24:51 <dtantsur> Redfish driver then? seems like an easy win
17:24:59 <TheJulia> rloo: The majority of it, and the volume connection API
17:25:04 <JayF> dtantsur: how do we feel about related nova patches going in there?
17:25:04 <jroll> s/driver/hardware type/, right? :)
17:25:19 <lucasagomes> yeah it's only a hardware type and 2 interfaces (power and management)
17:25:26 <rloo> TheJulia: ok, would be good to work backwards from nova deadlines, to have an idea as to when to target the work
17:25:32 <lucasagomes> I didn't create a old-style driver, I think we don't need it. right ?
17:25:39 <jroll> lucasagomes: +1 from me
17:25:42 <TheJulia> rloo: agreed
17:25:45 <dtantsur> JayF, you mean, on the list? well, depends on how actionable from our part they are
17:25:47 <JayF> lucasagomes: ++ exactly, it's explicitly disallowed to create new oldstyle drivers iirc
17:25:52 <lucasagomes> cool
17:26:08 <JayF> dtantsur: frantically looking for the link, but gerrit doesn't share my urgency
17:26:19 <jroll> JayF: dtantsur: fwiw, I plan to start keeping my own list of important nova patches, and asking for help with reviews when needed
17:26:43 <dtantsur> jroll, that would be super helpful
17:26:43 <jroll> idk that we need the whole team prioritizing nova patches
17:26:56 <dtantsur> ++ (though I do keep a list in my gertty)
17:26:59 <JayF> dtantsur: jroll: https://review.openstack.org/#/c/441544 is the one I was referring to, honestly I just want someone ironic other than just me to look at it :)
17:27:10 <jroll> ya, figured, already on my list :)
17:27:17 * jroll says that before it loads...
17:27:19 <jroll> yeah
17:27:21 <jroll> that one :D
17:27:25 <dtantsur> JayF, will check as well
17:27:34 <dtantsur> still don't think it should be on the list for everyone tbh
17:27:39 <rloo> so redfish driver is optional. maybe we should instead review ipa rest api version spec instead?
17:27:47 <JayF> dtantsur: I'm fine with that, just like I said, goal was more-than-just-jay :)
17:27:57 <rloo> also fault support spec needs reviews
17:27:59 <dtantsur> rloo, just wanted to get it out of our radar finally
17:28:24 <rloo> dtantsur: i understand, but the ones that need spec reviews will never move along w/o the specs being approved.
17:28:29 * dtantsur is worried about landing too many specs before we land code from previous specs
17:28:39 <rloo> dtantsur: and those ones have higher priority than redfish driver
17:28:43 <yolanda> i need reviews on the custom deployment steps as well
17:29:10 <yolanda> i have a pair of -1s to answer, but i'd like to get more feedback
17:29:14 <dtantsur> everyone's spec needs review ;) I'd like to move specs to "finished", not only "approved" from time to time ;)
17:29:17 <JayF> fault support spec is probably not close enough to be a priority
17:29:20 <rloo> yolanda: yes, but that is optional, the others i mentioned are higher priority
17:29:25 <JayF> but I'd love for more interested people to look at it, as we have a new patchset up
17:29:32 <dtantsur> but if everyone thinks I'm wrong, I'm ready to drop specs there instead
17:29:39 <rloo> JayF: what do you mean, the spec needs more work for fault support?
17:30:01 <JayF> Yeah, I think we're going to have to prototype some of the code to wrap oour heads fully around the driver apis for it
17:30:17 <JayF> but the rest APIs are 100% laid out
17:30:29 <rloo> JayF: so we shouldn't review it for now?
17:30:48 <JayF> I would love a review from folks, but I don't think it's priority, and anyone reviewing should be aware it's about 80% done
17:31:01 <rloo> JayF: ok, going to add a comment to that effect.
17:31:17 <dtantsur> IPA API seems close, so I'd take it instead of low-priority E-Tags https://review.openstack.org/#/c/341086/
17:31:27 <dtantsur> wdyt?
17:31:43 <jroll> I'm not opposed
17:31:50 <dtantsur> rloo?
17:31:53 <lucasagomes> I haven't reviewed that yet but sounds fine, /me adds to his list
17:31:53 <rloo> sigh. no, i think we should leave etags spec.
17:32:11 <rloo> cuz... there was movement in that spec last week, probably? cuz it was a priority. we should get it approved soon.
17:32:30 <rloo> dtantsur: but i think it would be good to add ipa api version spec too
17:32:39 <dtantsur> ok, 6 items be it. please work hard :)
17:33:04 <dtantsur> I hope sambetts_ is around to update it
17:33:31 <dtantsur> we have 6 items on priorities. any more comments?
17:33:40 * dtantsur wants to move to the discussion
17:33:41 <rloo> if anyone finds out about sambetts_ availability; if he isn't, please scratch that priority
17:34:03 <dtantsur> or we can update it ourselves
17:34:40 <dtantsur> meanwhile, who wants to be the bug triager this week? mjturek wanna continue? :)
17:35:01 <mjturek> dtantsur: I wouldn't mind! I'm getting the swing of it
17:35:11 <dtantsur> cool!
17:35:15 <mjturek> fyi - https://etherpad.openstack.org/p/ironic-bug-triage
17:35:21 <dtantsur> #action mjturek to continue helping with bug triage
17:35:26 <dtantsur> #link https://etherpad.openstack.org/p/ironic-bug-triage
17:35:37 <mjturek> keeping a summary of what I changed
17:35:42 <dtantsur> thanks!
17:35:45 <mjturek> np
17:35:49 <jroll> thanks for doing that, mjturek :)
17:35:56 <dtantsur> any comments before we move on?
17:35:59 <mjturek> np jroll :)
17:36:22 <dtantsur> #topic Impressions about third party CI gate jobs that usually fail, reasons they fail, and how we can help to fix them
17:36:36 <dtantsur> as I already said, I started reaching out to maintainers about their CI
17:36:47 <dtantsur> still, it's a bit hard to measure quality of each CI
17:36:53 <dtantsur> do we have any formal metrics?
17:37:01 <dtantsur> also soliosg, sorry, it was your topic :)
17:37:39 <jroll> this site gives some pass/fail metrics http://ci-watch.tintri.com/project?project=ironic&time=7+days
17:37:41 <soliosg> Yeah, I added this item because it seems we don't pay attention to 3rd party jobs now, passing or failing
17:37:46 <dtantsur> jroll++ I was using it
17:37:50 <dtantsur> #link http://ci-watch.tintri.com/project?project=ironic&time=7+days
17:38:07 <dtantsur> soliosg, I do. but I agree, it's hard to pay attention when they are random
17:38:20 <dtantsur> I also don't like HTTPS error on half (or all?) of logs sites
17:38:36 <jroll> ya, we need to get folks improving these systems
17:38:43 <dtantsur> #action dtantsur this week goes over the list of CI and contacts maintainers if he spots any problems
17:38:47 <jlvillal> Thanks soliosg and dtantsur. I do sometimes wonder if some of the 3rd Party CI is not living by the spirit of what we want. Since I see so many of them fail again and again.
17:38:49 <dtantsur> which is something I started already
17:39:08 <jlvillal> And one purpose of the 3rd Party CI is so they can keep their drivers in tree
17:39:18 <dtantsur> I've even see one CI passing on a patch when our CI was all red
17:39:30 <dtantsur> I'm going to follow up with the maintainers on it
17:39:42 <soliosg> dtantsur: Right, such randomness is what makes difficult to pay attention to
17:40:09 <JayF> dtantsur: I'd personally be interested in a summary of that work, maybe to the mailing list?
17:40:23 <JayF> dtantsur: i.e. if a given 3rd party CI is super reliable, that's a great input to code reviewing, as is the alternate
17:40:24 <rloo> when we initiated this, did we note down what we expected from 3rd parties? wrt success/failure rates, etc?
17:40:31 <dtantsur> JayF, which kind of summary? I don't want to call names, though they're obvious
17:40:54 <vdrok> rloo: yeah, I remember that stated in the spec
17:41:11 <JayF> dtantsur: Calling names being specifically what I wanted; like "These CIs: blah, blah, blah, are passing reliable, whereas these have the following issues..."
17:41:20 <JayF> dtantsur: not so much to call them out but to inform me as a reviewier
17:41:22 <jroll> rloo: yeah, we kinda dropped the ball on getting it in docs: https://docs.openstack.org/developer/ironic/dev/third-party-ci.html
17:41:23 <JayF> dtantsur: but up to you
17:41:35 <jroll> rloo: the spec has some rough numbers though
17:41:47 <dtantsur> JayF, ok, I'll think about it. I still need more data collected, 7 days is not too much.
17:41:52 <rloo> jroll: we should pick up the ball then...
17:41:52 <mmedvede> slightly related: would you prefer a consistently failing CI still reporting? (context: I am one of maintainers of IBM PowerKVM CI, and turned off reporting on ironic for now)
17:42:28 <dtantsur> good question
17:42:36 <vdrok> maybe we should have some status page for such cases
17:42:39 <dtantsur> mmedvede, do we have such information exposed somewhere?
17:42:42 <jroll> rloo: sure, I don't know that I have time
17:42:46 <dtantsur> vdrok, we have a wiki, in theory
17:42:58 <dtantsur> #link https://wiki.openstack.org/wiki/ThirdPartySystems
17:43:01 <rloo> jroll: heh, let's ask for a volunteer :)
17:43:31 <vdrok> dtantsur: oh, cool
17:43:36 <jroll> FYI these are the third party CI requirements for all of openstack, which includes a wiki page for each system:
17:43:38 <jroll> #link https://docs.openstack.org/infra/system-config/third_party.html
17:43:40 <dtantsur> mmedvede, yours is not marked as being down on https://wiki.openstack.org/wiki/ThirdPartySystems
17:44:03 <mmedvede> dtantsur: so, we use the same user also for nova, so it is fine there
17:44:11 <dtantsur> I'm using this wiki page, and its subpages to figure out the expected status
17:44:23 <dtantsur> mmedvede, well, you can at least update the "comments" field with "broken for ironic" or something
17:44:31 <mmedvede> dtantsur: ack
17:44:36 <dtantsur> thanks!
17:45:30 <dtantsur> anyone wants to pick back https://docs.openstack.org/developer/ironic/dev/third-party-ci.html ?
17:46:16 <JayF> dtantsur: if nobody picks it up now, if someone can summarize it in a bug I bet I can find someone to pick it up
17:46:32 <rloo> whoever does, should talk to krtaylor to find out where its at
17:46:35 <dtantsur> JayF, well, I'd pick it, but I don't know certain details, like required changes
17:46:40 <jroll> summary: "decide on final third party CI requirements and write them down"
17:46:41 <dtantsur> ++ for talking to krtaylor first
17:46:50 <nicodemos> dtantsur: do you plan any requirements change for 3rd party CI?
17:46:53 <jroll> the second part of that is easy
17:46:56 <jroll> the first not so much
17:47:02 <dtantsur> nicodemos, not before we make them reliably working..
17:47:12 <mjturek> fyi krtaylor is out today
17:47:14 <jroll> (e.g. decide if requiring to report within 8 hours is reasonable or not)
17:47:30 <dtantsur> let's start with collecting some statistics and reporting back
17:47:43 <jroll> there's some details here but they are old, need to be reviewed again http://specs.openstack.org/openstack/ironic-specs/specs/6.2/third-party-ci.html
17:47:44 <dtantsur> I can figure out gerrit API and write something like a custom dashboard (if there is no existing)
17:47:48 <jlvillal> I have noticed at least one CI voting a day or two later.
17:47:53 <dtantsur> sounds like an action?
17:48:03 <jroll> dtantsur: ++
17:48:15 <rloo> thx dtantsur for volunteering ++
17:48:17 <jroll> dtantsur: maybe talk to cinder PTL, they might have something already
17:48:33 <dtantsur> #action dtantsur to collect / write a tool / find a tool to collect advanced statistics about 3rdparty CI
17:48:37 <dtantsur> jroll++
17:49:03 <rloo> what about that ci page -- JayF wanted someone to open a bug against it?
17:49:16 <dtantsur> let's open a placeholder bug for sure
17:49:34 <JayF> rloo: I only wanted a bug because then it's easier to delegate
17:49:38 <dtantsur> something like "Populate this page with real data: <link>"
17:49:42 <JayF> rloo: if someone is going to JFDI I don't care abouta  bug :)
17:50:03 <rloo> ok, no bug needed. if someone wants one, please open it.
17:50:06 <rloo> let's move on now :)
17:50:10 <TheJulia> 10 minute warning
17:50:12 <dtantsur> yeah, let's move on
17:50:21 <dtantsur> #topic Status check on having a local copy of tempest manager.py
17:50:33 <dtantsur> tl;dr: do we still need it? soliosg, pas-ha?
17:50:51 <soliosg> I believe we still needed
17:51:20 <rloo> soliosg: why
17:51:21 <soliosg> From Andrea's reply to pas-ha, it sounded like QA wants to stick to the original plan
17:51:25 <vdrok> yup, I guess the outcome of the ML discussion was to have it
17:51:38 <vdrok> so that not to increase the amount of jobs
17:51:51 <jlvillal> That is how I read the email thread. Need to make a local copy in Ironic.
17:51:56 <rloo> soliosg: please update that patch then, with link to mailing list and the summary, and then lets get on with it :)
17:52:05 <lucasagomes> rloo, ++
17:52:09 <jroll> yeah, it's only temporary, let's just get it done
17:52:25 <dtantsur> note that a follow-up to this patch should be trimming this file down to what's needed for our CI to pass..
17:52:34 <soliosg> Ack
17:52:38 <dtantsur> just in case temporary is not too temporary..
17:52:43 <dtantsur> thanks soliosg!
17:53:01 <dtantsur> #agreed we'll continue with carrying manager.py (or it's slimmer version) in-tree for now
17:53:12 <dtantsur> moving on?
17:53:19 <dtantsur> #topic Boston summit/forum brainstorming
17:53:26 <dtantsur> #link http://lists.openstack.org/pipermail/openstack-dev/2017-March/113115.html
17:53:38 <dtantsur> rloo, that's you
17:53:52 <rloo> to be clear, my intent was NOT to actually do brainstorming today. i just wanted to bring it up
17:54:14 <rloo> what is ironic's involvment (if any) going to be at the summit forum.
17:54:15 <dtantsur> yeah. this may be driven by people who actually go to Boston
17:54:17 <TheJulia> Have we created an etherpad yet?
17:54:24 <jroll> there's action items on there, fwiw, we should do those
17:54:24 <dtantsur> not me
17:54:26 <jroll> I haven't
17:54:48 <dtantsur> I can start an etherpad, but it's probably not fair for me to populate it, as I don't plan to go
17:54:48 <jroll> rloo: I know at least 2 ironic people that plan to go
17:55:02 <rloo> as a group/ironic, do we actually want/care about this?
17:55:16 <TheJulia> https://etherpad.openstack.org/p/BOS-ironic-brainstorming ?
17:55:21 <jroll> dtantsur: as PTL, I think you should help populate it, surely you have questions for deployers/ops/users :)
17:55:33 <rloo> thx TheJulia!
17:55:34 <jroll> rloo: about getting fedback from deployers/ops/users? I hope we do
17:55:43 <dtantsur> I can help, sure, but I want people actually present to be aware of it ;)
17:55:47 <rloo> jroll: i hope so too but didn't want to assume anything ;)
17:55:52 <TheJulia> I care about it, and I can put some stuff in sometime over the next few days
17:55:53 <jroll> dtantsur: yeah, fair
17:55:53 <dtantsur> thanks TheJulia
17:55:56 <dtantsur> #link https://etherpad.openstack.org/p/BOS-ironic-brainstorming
17:56:03 <jroll> TheJulia: thanks!
17:56:25 <dtantsur> anything else here before we move on?
17:56:41 <dtantsur> #topic Open discussion
17:56:46 <dtantsur> lucasagomes, sushy time? ;)
17:56:50 <dtantsur> also 3 minutes left
17:56:51 <lucasagomes> well 4 minutes heh
17:57:01 <lucasagomes> so, sushy under the Ironic umbrella. What do you guys think about it ?
17:57:03 <JayF> +2
17:57:06 <TheJulia> +2
17:57:12 <NobodyCam> +a
17:57:13 <lucasagomes> the library is pretty small, 792 LOC with unittests included
17:57:13 <NobodyCam> lol
17:57:14 <jroll> +2
17:57:16 <lucasagomes> lol
17:57:16 <lucasagomes> ok
17:57:16 <dtantsur> if we position sushy as ironic-specific redfish library, it should be under ironic governance for sure
17:57:28 <jlvillal> +2 we want redfish :)
17:57:30 <jroll> dtantsur: which we should :)
17:57:47 <dtantsur> if we plan on general-purpose library.. I hope we don't :)
17:57:49 <lucasagomes> ok I will put a patch for the governance doing that then :D
17:58:06 <rloo> what are the options? if it isn't under ironic umbrella, then what?
17:58:07 <wanyen> what's ironic planfor redfish-python?
17:58:10 <JayF> dtantsur: if someone wants to make it a general purpose lib, I suggest we let them and try to rope them into revieiwng more ironic things ;)
17:58:16 <JayF> rloo: I'd assume not-big-tent, not governed at all
17:58:18 <lucasagomes> dtantsur, it's ironic-specific and I prefer to keep it that way
17:58:27 <dtantsur> JayF++
17:58:42 <nicodemos> Ironicers, I'd like to ask some review in https://review.openstack.org/#/c/408298
17:58:55 <lucasagomes> wanyen, I think the idea was, when pyhton-redfish is mature enough we will re-evaluate it
17:59:04 <jroll> wanyen: we don't plan to use python-redfish, there are architectural problems with it that make it a bad fit for ironic right now
17:59:09 <jroll> and what lucasagomes said :)
17:59:16 <lucasagomes> wanyen, that's what I got from the spec, because at the moment (you can check the comments in the spec itself) we can't use it
17:59:20 <wanyen> I like to understand Ironic's plan for redfish-python lib.
17:59:28 <nicodemos> it would remove some custom code from oneview drivers and use ironic deploy implementation instead :)
17:59:32 <lucasagomes> wanyen, it's in the spec
17:59:33 <dtantsur> wanyen, let's talk about it when it's ready
17:59:51 <dtantsur> nicodemos, will try to get to it
17:59:53 <jroll> and we're at time
17:59:55 <dtantsur> yep
17:59:55 <jroll> ish
17:59:58 <dtantsur> thanks everyone
17:59:59 <jroll> thanks dtantsur !
18:00:02 <lucasagomes> o/
18:00:02 <NobodyCam> thank you all
18:00:04 <rloo> thks all!
18:00:04 <dtantsur> #endmeeting