17:00:00 <jroll> #startmeeting ironic
17:00:01 <openstack> Meeting started Mon Feb  8 17:00:00 2016 UTC and is due to finish in 60 minutes.  The chair is jroll. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:05 <openstack> The meeting name has been set to 'ironic'
17:00:06 <davidlenwell> o/
17:00:07 <dtantsur> o/
17:00:08 <devananda> o/
17:00:08 <jroll> hey everyone :)
17:00:11 <rpioso> o/
17:00:11 <lucasagomes> hi there
17:00:15 <NobodyCam> o/
17:00:16 <mkovacik> o/
17:00:17 <jroll> as always, the agenda is here:
17:00:21 <mgould> o/
17:00:22 <stendulker> o/
17:00:22 <jroll> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
17:00:37 <jlvillal> o/
17:00:49 <rloo> o/
17:01:03 <jroll> #topic announcements and reminders
17:01:15 <TheJulia> o/
17:01:25 <jroll> #info midcycle is next week! if you haven't yet, please rsvp here and add any topics you wish to discuss https://etherpad.openstack.org/p/ironic-mitaka-midcycle
17:01:27 <jroll> #link https://etherpad.openstack.org/p/ironic-mitaka-midcycle
17:01:41 <JayF> o/
17:01:44 <krtaylor> o/
17:01:46 <jroll> #info ironic meeting for february 15 will be cancelled due to midcycle
17:02:16 <rloo> jroll: why cancel the meeting?
17:02:26 <jroll> I'm still evaluating a/v systems, I'd like to come back to that in open discussion
17:02:28 <sambetts> o/
17:02:37 <jroll> rloo: any point to having it if we're having three days worth of meetings?
17:02:44 <jroll> I'd rather not
17:03:05 <rloo> jroll: i wasn't going to attend the meeting, but it seems separate.
17:03:22 <jroll> we typically cancel the midcycle week's meeting, idk
17:03:39 <jroll> we can have one if folks want to, I'd prefer not to
17:03:56 <rloo> jroll: i'm fine with cancelling. just askin in case others aren't. i think we typically cancel cuz the midcycle IS happening that day.
17:03:57 <dtantsur> I will be on PTO on Monday
17:04:21 <rloo> jroll: continue on, there are no nays. sorry about that.
17:04:28 <jroll> no worries
17:04:30 <jroll> does anyone have other reminders or announcements?
17:05:39 <jroll> #topic subteam status reports
17:05:53 <jroll> as always, these are on the whiteboard:
17:05:56 <jroll> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:06:02 <jroll> beginning at line 173
17:06:13 <jroll> I'll give folks a few moments to review/update
17:07:23 <rloo> dtantsur: 19 high bugs? that seems like a lot. Maybe we should deal with those in midcycle
17:07:48 <dtantsur> rloo, yeah, though we have some high bugs that are not easy to solve
17:07:55 <betherly> o/
17:07:58 <dtantsur> we also have way too many assigned/in progress bugs
17:08:06 <JayF> IDK where in subteam status it'd best fit; but TinyIPA merged
17:08:17 <dtantsur> I don't have time to check whether people are actually working on them
17:08:21 <dtantsur> JayF, \o/
17:08:24 <jroll> \o/
17:08:25 <rloo> JayF: under testing I think.
17:08:26 <zer0c00l> JayF: Yay
17:08:32 <sambetts> whoop!
17:08:32 <rloo> JayF: and yeah, yay!
17:08:40 <NobodyCam> :) nice
17:09:08 <rloo> dtantsur: too many meaning no patches or patches waiting to be reviewed or ?
17:09:21 <mgould> JayF: yay!
17:09:48 <dtantsur> rloo, I didn't check it, just my gut feeling that 116 in progress bugs is too much
17:09:58 <jroll> +1 dtantsur
17:10:04 <rloo> dtantsur: ahh. didn't we have some sort of rule that if assigned/progress with no patch after x time, we unassign?
17:10:08 <dtantsur> it might be due to the gate problems we've experienced though. needs investigation
17:10:19 <rloo> dtantsur: maybe something to do in midcycle?
17:10:22 <dtantsur> rloo, we do have such rule, which I usually manually enforce ;)
17:10:35 <jlvillal> dtantsur: I know that there are some people who assign bugs to themselves and then I don't see progress on them. I'm talking about people who don't attend this meeting.
17:10:44 <lucasagomes> JayF, sambetts w00ts for tinyipa
17:11:04 <jroll> rloo: added to the midcycle list
17:11:10 <rloo> jlvillal: I suspect we're all guilty of that.
17:11:38 <dtantsur> rloo, we do forget a bug or two usually (I definitely do), but some people assign dozens to themselves
17:11:48 <dtantsur> and often disappear
17:12:04 <rloo> dtantsur: ok, we need a bug scrub or something. let's add to midcycle.
17:12:11 <devananda> ++ bug scrub
17:12:12 <jlvillal> rloo: yes. It can happen.
17:12:28 <devananda> also, I wonder if other teams have any automation around unassigning inactive bugs
17:13:03 <lucasagomes> that would be a good thing to check/have
17:13:03 <jlvillal> Also on bug scrub, I don't think we should be too shy about unassigning bugs if no progress and we can't contact them.
17:13:11 <devananda> jlvillal: ++
17:13:13 <[1]cdearborn> o/
17:14:06 <devananda> lucasagomes: I posted a question on the dracclient gov review
17:14:31 <rloo> wrt tinyipa; it merged so it is being used in gate?
17:14:33 <lucasagomes> devananda, thanks will take a look
17:14:33 <jroll> whoever added "updates to docs.o.o" and "effectiveness of setting priorities" to the midcycle etherpad, could you please add your name? :)
17:15:00 <jroll> rloo: still waiting on https://review.openstack.org/#/c/269684/
17:15:05 <jroll> sambetts: apparently that needs an update
17:15:18 <rloo> jroll: thx
17:15:24 <sambetts> :( more rebase
17:16:34 <rloo> dtantsur: thx for the ipa + inspector test
17:16:43 <dtantsur> :)
17:16:57 <jroll> +1
17:17:03 <jroll> anything else in this section?
17:17:26 <jroll> #topic breaking change in dhcp_factory.DHCPFactory.update_dhcp(). How to handle it?
17:17:30 <jroll> #link https://review.openstack.org/#/c/206245/53/ironic/common/dhcp_factory.py
17:17:32 <jroll> rloo: this is you
17:17:43 <rloo> jroll: so that was merged last week I think.
17:17:58 <rloo> jroll: and there is a change to the update_dhcp() method
17:18:14 <rloo> jroll: which isn't backwards compatible with any out-of-tree implementations.
17:18:40 <rloo> jroll: should we have allowed that change? is it OK and we 'just' need a reno about it? not sure what to do about it besides not bring it up:)
17:18:43 <devananda> we don't explicitly guarantee stability of that interface the way we do with the driver API
17:18:54 <jroll> rloo: right, I believe we discussed this in the ironic/neutron meeting and agreed that it was okay, and we should reno/email about it
17:18:57 <jroll> because what deva saisd
17:18:59 <lucasagomes> I think we should send an email to ML with a headsup for people saying that we may break their out of free dhcp plugin code
17:18:59 <jroll> said*
17:19:24 <lucasagomes> devananda, jroll yeah, but if we can avoid we may should
17:19:32 <lucasagomes> like we could have another method to update the vifs for portgroups
17:19:39 <lucasagomes> update_dhcp_portgroup() or something like that
17:19:42 <jroll> lucasagomes: right, this was fairly unavoidable without getting insane
17:19:48 <JayF> Do we know of anyone with an out of tree dhcp provider? I'd be curious what it'd be plugging into.
17:19:49 <jroll> iirc
17:19:55 <jroll> JayF: someone was working on an isc one
17:19:56 <rloo> jroll, devananda, lucasagomes: ok, that's fine with me. The reno can be added in a subsequent patch.
17:20:01 <rloo> any volunteer to email?
17:20:04 <jroll> I can email
17:20:08 <lucasagomes> jroll, hmm I mean, if you have 1 method for ports and another for portgroups
17:20:12 <rloo> thx jroll
17:20:14 <devananda> lucasagomes: I didn't see any reasonable way to not make this change, fwiw
17:20:16 <dtantsur> JayF, I suspect ionutbalutoiu might
17:20:18 <lucasagomes> that would be avoided, casue the base class would be noop for portgroup
17:20:41 <lucasagomes> and plugins can implement that portgroup dhcp update method within them
17:21:33 <lucasagomes> devananda, yeah fair enough, plus we don't guarantee the backward compat as you mentioned
17:22:27 <rloo> ok, my item has been addressed. that was fast! (thx.)
17:22:44 <dtantsur> example: https://github.com/ionutbalutoiu/ironic/commit/30e68fb5cb40d7ca45f33c0dca10d97ef674653b
17:22:57 <dtantsur> can't quickly figure out if it was affected
17:23:30 <lucasagomes> dtantsur, apparently not because he's not using the "vifs" option from update_dhcp_opts
17:23:37 <lucasagomes> which is the dict that has changed
17:23:49 <lucasagomes> s/option/param
17:24:05 <dtantsur> right, good
17:24:25 <jroll> I'll email regardless
17:24:31 <dtantsur> ++
17:24:37 <lucasagomes> jroll, +1
17:25:22 <jroll> anything else on this topic?
17:26:01 <jroll> #agreed jroll to email about the breakage
17:26:03 <jroll> #topic open discussion
17:26:11 <jroll> so, one thing I want to bring up here
17:26:41 <jroll> infra folks have very heavily recommended that we use their asterisk VOIP system, rather than a proprietary system
17:26:49 <jroll> with two concerns about proprietary video systems:
17:27:00 <jroll> 1) it will exclude folks that will not use non-free software
17:27:17 <jroll> 2) it will exclude folks with low internet bandwidth
17:27:31 <dtantsur> iirc bluejeans allows to call-in via a phone
17:27:57 <jroll> right, so does vidyo, but that may incur phone charges for international folks no?
17:28:00 <sambetts> jroll: did you see my link to this the other day? https://free.gotomeeting.com/
17:28:04 <jroll> they suggested using etherpad along with it
17:28:12 <mgould> jroll: how much bandwidth does the Asterisk system require?
17:28:17 <dtantsur> what if we need to share a screen?
17:28:21 <jroll> sambetts: no, but that has the same issues and also "up to three people"
17:28:30 <jroll> mgould: it's a SIP system; whatever that takes
17:28:41 <devananda> jroll: have you decided whether we will use video or screen sharing at all?
17:28:43 <dtantsur> jroll, dunno, depending on whether they have free local numbers
17:28:48 <sambetts> jroll: its not limited if someone signs up for a 30 day free trail
17:28:55 <jroll> devananda: this is what we're talking about right now
17:28:58 <sambetts> no billing info required
17:29:03 <jroll> sambetts: meh, we have two video systems that will work already
17:29:09 <sambetts> ok :)
17:29:17 <jroll> so my larger question is
17:29:35 * lucasagomes likes the concerns raised and agrees with them
17:29:44 <jroll> do we absolutely require video and/or screen sharing, at the risk of excluding some folks? or will voice + etherpad + irc suffice?
17:29:49 <jlvillal> I would think VOIP using Asterisk should use in the kilobits per second.  Maybe less than 256 kilobits per second. Audio is fairly low bandwidth. From what I recall.
17:30:11 <devananda> sambetts: free trial doesn't solve either of those concerns, fwiw
17:30:15 <jroll> jlvillal: yep, 64k voice is considered somewhat high quality
17:30:47 <rloo> is 'everyone' at the midcycle going to want to do something all together? if folks break up into groups to do their own thing, then they can do video/share screens then?
17:30:54 <devananda> I feel pretty strongly that we should not use a system which is limited in # of people, or requires such high bandwidth / low latency that it excludes any geographic regions
17:31:05 <devananda> for the primary channel, at least
17:31:06 <dtantsur> bluejeans seems to have a lot of local numbers https://www.intercallonline.com/listNumbersByCode.action?confCode=7220882266
17:31:22 * jlvillal adds clean home-office to TODO list :)
17:31:29 <jroll> devananda: ++
17:31:30 <devananda> rloo: the problem even with breaking off into groups that do video is that will, potentially, exclude certain folks
17:31:49 <rloo> devananda: true, maybe up to the group to decide?
17:32:03 <rloo> how much screen sharing might be needed?
17:32:05 <lucasagomes> rloo, yeah that sounds fair, assuming we will break into groups
17:32:09 <devananda> rloo: afaik, all of the video conference things are size limited. what happens when someone wants to join the group, but can't becaues of that?
17:32:15 <jroll> I've also noticed during our midcycles that breaking into groups to do a thing usually results in 90% of attendees listening anyway
17:32:18 <rloo> in past mid-cycles, did people need to look at screens? more like whiteboards?
17:32:36 <jroll> devananda: vidyo and blue jeans are not size limited to the best of my knowledge
17:32:45 <rloo> well, let's try with voice only for this midcycle and see how it goes.
17:32:59 <dtantsur> hundred(s) of participants
17:33:00 <jroll> devananda: I've personally seen >100 people on vidyo, fwiw
17:33:04 <devananda> neat
17:33:10 <devananda> I thought # of presenters was limited on those
17:33:29 <dtantsur> at least 9 seems possible with bluejeans
17:33:33 <jroll> # of videos may be limited, but it chooses which to display based on who is making noise
17:33:55 <jroll> anyway, I feel like we should at least try voice + etherpad
17:34:01 <devananda> IMO, white board + voice + etherpad for notes would be fine. as much as I like to see everyone
17:34:05 <rloo> i counted 24 folks max, that have signed up on the etherpad for the midcycle.
17:34:11 <devananda> jroll: do we have a decent option for shared whiteboard (besides etherpad) ?
17:34:17 <jroll> if we feel that it's terrible we can move to vidyo for the next day
17:34:28 <jroll> devananda: unsure, there are certainly web things out there
17:34:35 * dtantsur is the only non-native here right now, so he's in minority apparently
17:34:44 <mgould> jroll, devananda: for drawing diagrams and the like?
17:34:47 <rloo> dtantsur: what is a non-native?
17:34:48 <devananda> mgould: yes
17:34:55 <dtantsur> rloo, ... english speaker
17:34:57 <mgould> cool
17:35:00 * mgould likes diagrams
17:35:06 <jlvillal> dtantsur: lucasagomes is here too :)
17:35:12 <lucasagomes> devananda, jroll ++ we can try, if there's a topic that we really need video we maybe can figure out a way too
17:35:18 <dtantsur> he lives in ireland, so he does not count :D
17:35:21 <lucasagomes> bluejeans or the other one mentioned
17:35:27 <jroll> dtantsur: yeah, I feel your concerns but I'm not sure it's worth potentially excluding people
17:35:27 <lucasagomes> dtantsur, I'm non native
17:35:28 <devananda> dtantsur: we have many contributors from east asia. timezones usually prevent them from joining this meeting regularly ...
17:35:44 <jroll> lucasagomes: yeah, I need to test but I can spin up a room on my end in 60 seconds apparently
17:35:57 <devananda> maybe I'm being idealistic, but I hope some of them will make the midcycle
17:36:19 <lucasagomes> jroll, nice, me and dtantsur can do something for bluejeans if needed on our end as well
17:36:28 <jroll> devananda: I see some people from asia in the etherpad already :)
17:36:31 <lucasagomes> devananda, according to the etherpad they will
17:36:34 <devananda> awesome
17:36:36 <mgould> devananda: it’s unfortunate that they can’t join the regular meetings
17:36:44 <devananda> mgould: I know :(
17:36:51 <jroll> mgould: tis :/
17:37:02 <devananda> mgould: fwiw, we tried alternating meeting times last year, but found that it hurt the project velocity overall more to split
17:37:05 <dtantsur> hmm, I can only hope they will find phone working for them..
17:37:17 <mgould> yeah, makes sense
17:37:39 <rloo> devananda, mgould: besides the fact that it seemed like half the time or more, not many folks showed up and sometimes no core.
17:37:43 <jroll> dtantsur: I hope so too :/
17:37:51 <devananda> rloo: right
17:37:57 * jlvillal is technically a non-native English speaker. At least he has been told that he only knew Spanish until age three
17:38:25 <dtantsur> jlvillal, I'm not sure it's a good comparison to be honest
17:38:35 <lucasagomes> jlvillal, :-) are you still able to speak it?
17:38:44 <jlvillal> true!  and no :(
17:38:46 <devananda> dtantsur: I think that's where asterisk will work better -- it's lower bandwidth, should work better than a video call for folks outside of major us/eu metropolitan areas
17:39:08 <rloo> so did we decide?
17:39:18 <lucasagomes> +1 for me, I think we should try
17:39:19 <dtantsur> devananda, I'm not talking about bandwidth, I'm talking about people not understanding what is going on at all
17:39:24 <devananda> dtantsur: ahh
17:39:33 <jroll> devananda: fwiw, I've heard it's easier for non-native speakers to communicate when facial expressions, body language, etc can be conveyed
17:39:35 <devananda> dtantsur: well - not like video is going to help in that case either
17:39:36 <lucasagomes> if not we already have a plan B
17:40:03 <dtantsur> just FYI: for a non-native speaker lips movements and face expressions give a lot of hints. and understanding who is speaking helps adjust to an accent faster.
17:40:24 <devananda> jroll: one on one, definitely ... but I can't imagine trying to do that with 20 people
17:40:38 <mgould> dtantsur, TIL
17:40:38 <dtantsur> but maybe it's only me, I've also been very bad at listening :D
17:40:40 <devananda> dtantsur: fair
17:40:44 <jlvillal> It can be difficult for speakers of other languages to understand native English speakers if they are speaking fast.
17:40:45 <jroll> devananda: I'm hoping we don't have 20 people talking at once :D
17:40:52 <lucasagomes> yeah, but we can also fallback to IRC if someone do not understand something
17:41:02 <devananda> jroll: heh
17:41:12 <jroll> yeah, so let's try VOIP+etherpad+irc to start. I'll verify that I can use external participants easily if needed. and I'll include both in my email about these details :)
17:41:23 <mgould> in that case we should make clear at the start of the meetings that “I can’t hear you, can we fall back to IRC” is an option
17:41:33 <mgould> or people will be too embarrassed to ask
17:41:36 <jlvillal> jroll: Please provide info for how to connect to the VOIP, if you haven't already :)
17:41:42 <jroll> jlvillal: yeah, I will be
17:41:45 <dtantsur> mgould, people will be to embarrassed anyway
17:41:56 <mgould> dtantsur: true
17:42:00 <mgould> accessibility is hard :-(
17:42:04 <lucasagomes> dtantsur, heh ++
17:42:09 <devananda> dtantsur: point made. reflecting on my time studying other languages and you're correct -- it hasn't worked for me virtually in the past, but f2f, absolutely true
17:42:13 <rloo> too embarassed to say they can't hear? or to say they can hear but don't understand?
17:42:23 <dtantsur> rloo, the latter
17:42:42 <rloo> dtantsur: got it. we don't have any deaf folks I hope.
17:43:00 <dtantsur> I can't guarantee it, but hopefully not
17:43:38 <JayF> As someone with hearing problems, I kinda hate non-video get-togethers too (difficult to understand what's being said), but I likely won't participate in the mid-cycle so I shouldn't get a vote :)
17:44:23 <lucasagomes> JayF, right, but would having a video chat help you with that?
17:44:26 <lucasagomes> or it would be the same?
17:44:31 <JayF> Yes, it helps significantly
17:44:40 <JayF> to the level where I almost always try to avoid audio-only meetings
17:44:54 <devananda> best quality online voice "meetings" I've ever had with folks was years ago, using teamspeak, where everyone wore head sets
17:44:54 <jroll> so the crazy computer nerd in me wants to actually run both and have my system pipe audio between the two. would take some work but is doable
17:45:01 <lucasagomes> I see
17:45:15 <jroll> I may test that out actually
17:45:25 <lucasagomes> devananda, ++ I used it to play counter strike in the past
17:45:48 <mgould> jroll: so folks with good connections can use video, and folks without can use audio?
17:45:53 <jroll> so let's say: we'll definitely have VOIP, we may have video at the same time, we may have video on standby
17:45:54 <jroll> mgould: yeah
17:46:18 <jroll> shouldn't be too hard to set up using jack, I'm just scared I'll break my audio altogether :D
17:47:02 <devananda> jroll: that would be awesome
17:47:09 <devananda> if it works, I mean :)
17:47:13 <jroll> heh
17:47:32 <jroll> breaking audio altogether is not abnormal on my linux system anyway, so I'll give it a shot :)
17:47:54 <devananda> if video for speakers helps non-native english speakers // folks with hearing difficulties, then yea, i'm all for us having that _in addition_ to the open source audio only channel
17:47:55 <jroll> so yeah, I'll send an email with details by wednesday at the latest
17:48:03 <jroll> nod, agree
17:48:25 <jroll> devananda: by saying as much, you agree to help me test this out :D
17:48:30 <devananda> jroll: sure thing
17:48:32 <mgould> jroll: good luck!
17:48:57 <jroll> alright, I think we're in agreement here
17:49:02 <jroll> anything else folks want to chat about?
17:49:07 <mkovacik> guys, I'd like your +/-1 on HA for Inspector spec https://review.openstack.org/#/c/253675/ warning: it's a bit longer reading ;)
17:49:29 <mgould> mkovacik: how much has it changed in the last couple of weeks?
17:49:43 <dtantsur> oh, yeah, anyone knowing about HA could help us a lot by looking at it
17:49:44 <mkovacik> mgould, almost no change
17:50:00 <mkovacik> dtantsur, ++
17:50:11 <devananda> mkovacik: you're not kidding about it being long :)
17:50:20 <mkovacik> mgould, that's no change I remember making ;)
17:50:29 <dtantsur> devananda, you didn't see how impressive the paper version of this spec looks :D
17:50:30 <mkovacik> devananda, yeah
17:50:37 <devananda> dtantsur: paper?!
17:50:43 <devananda> how quaint :)
17:51:11 <devananda> mkovacik: I'll try to give it a quick read today
17:51:17 <mkovacik> devananda, we used to have some f2f reviews with dtantsur in the office over a cup of tea over the spec
17:51:19 <dtantsur> devananda, yeah, we had an old-school spec review some time ago with a printed spec :)
17:51:23 <devananda> could you tldr; one thing, though, before I start
17:51:34 <mkovacik> devananda, sure
17:51:35 <lucasagomes> mkovacik, dtantsur hah that's awesome!
17:51:51 <lucasagomes> you guys should try s/tea/beer too :-)
17:52:29 <mkovacik> lucasagomes, we can involve you and your (home) office, too :D beers on me ;)
17:52:29 <devananda> is this proposing active/passive or active/active availability -- and in either case, why is inspection a critical enough service in the data center to require HA?
17:52:36 <devananda> (not that I think it's not -- but I'd like to understand your reasoning)
17:52:40 <lucasagomes> mkovacik, wfm
17:53:03 <devananda> I didn't see an answer to either of those in a skim of the problem description
17:53:31 <mkovacik> devananda, it's active--active spec, the reasoning behind is we're a single point of failure atm
17:53:32 <devananda> (ok, two questions)
17:53:54 <devananda> mkovacik: yes, inspector has SPoF, but what other systems depend on it?
17:54:05 <dtantsur> I think this discussion can be easily moved to the channel, as we have only 7 minutes left here
17:54:12 <devananda> dtantsur: sure thing
17:54:30 <mkovacik> dtantsur, devananda right
17:54:39 <lucasagomes> devananda, within Tripleo, there are use cases where we want to have inspector on the overcloud too (baremetal to tenant case)
17:54:43 <lucasagomes> so inspector needs to scale up
17:55:16 <devananda> lucasagomes: ahh, gotcha
17:55:36 <devananda> happy to discuss more in channel :)
17:56:04 <mkovacik> devananda, dtantsur, lucasagomes I'll be relocating home, please bare with me, back in ~2hours
17:56:55 <jroll> anything else or can I close this one out? :)
17:57:51 <jroll> alright, thanks for a great meeting everyone :D
17:57:53 <NobodyCam> nothing here
17:57:55 <jroll> #endmeeting