17:01:19 <devananda> #startmeeting ironic
17:01:21 <openstack> Meeting started Mon Jun 29 17:01:19 2015 UTC and is due to finish in 60 minutes.  The chair is devananda. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:22 <TheJulia> o/
17:01:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:24 <openstack> The meeting name has been set to 'ironic'
17:01:34 <NobodyCam> \o/
17:01:34 <rameshg87> o/
17:01:36 <lucasagomes> o/
17:01:38 <devananda> good morning/afternoon/evening/night, everyone
17:01:43 <jlvillal> o/
17:01:43 <rloo> hi
17:01:43 <devananda> as usual, our agenda is here:
17:01:45 <devananda> #link https://wiki.openstack.org/wiki/Meetings/Ironic
17:01:54 <dtantsur> o/
17:02:26 <devananda> #chair nobodycam
17:02:27 <openstack> Current chairs: devananda nobodycam
17:02:33 <devananda> #chair NobodyCam
17:02:34 <openstack> Current chairs: NobodyCam devananda nobodycam
17:02:43 <devananda> #topic announcements
17:02:46 <NobodyCam> :)
17:02:59 <devananda> first things first -- the location for the midcycle is confirmed
17:03:16 <jroll> \o/
17:03:28 <NobodyCam> many thanks to BadCub and devananda for getting that confirmed
17:03:37 <jlvillal> Along with 6,000 statisticians at the convention center ;)
17:03:40 <devananda> sorry that it took so long -- I had been emailing folks in the Seattle office to try to arrange it, but basically had to go into the office in person to finish things
17:04:01 <devananda> which wasn't possible while travelling the last few weeks
17:04:06 <devananda> so anyway, it's done now.
17:04:14 <devananda> #link https://www.eventbrite.com/e/openstack-ironic-sprint-august-2015-tickets-17533862254
17:04:31 <devananda> please RSVP there so that I can keep track of who and how many are coming
17:04:37 <BadCub> ugh.. sorry for dropping in late
17:05:08 <Sukhdev> devananda: do you have agenda for the sprint?
17:05:34 <devananda> Sukhdev: nope. let me start an etherpad
17:05:51 <NobodyCam> #link https://etherpad.openstack.org/p/ironic-liberty-midcycle
17:06:03 <NobodyCam> ^^^ from white board
17:06:05 <Sukhdev> devananda: I am wondering if Ironic-neutron folks should attend as well -
17:06:06 <devananda> oh
17:06:12 <devananda> NobodyCam: great, ty
17:06:24 <devananda> Sukhdev: it would be great to have one or two, yea
17:06:45 <Sukhdev> devananda: cool - will discuss with the management and let you know
17:07:15 <devananda> #info midcycle sprint is the week before LinuxCon NA, in the same city -- just FYI for those who may be attending both events
17:07:52 <devananda> any other announcements?
17:08:21 <NobodyCam> that covers mine
17:08:27 <devananda> #topic subteam status reports
17:08:49 <devananda> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:09:18 <rloo> jroll: how 'close' are we, wrt the neutron/ironic specs
17:09:26 <devananda> oh yah - dtantsur recently revamped his bug dashboard page
17:09:32 <dtantsur> :)
17:09:35 <NobodyCam> ya looks very good !
17:09:53 <jroll> rloo: we mostly have agreement from the subteam working on it
17:10:29 <devananda> jroll: any progress on the nova/ironic stuff we talked with jaypipes last week about? need me to dive into that again this week at all?
17:10:39 <NobodyCam> jroll: awesome wrok.. thanks to every one on the team!
17:10:43 <rloo> jroll: nice. and i thought there was talk about possibly needing a nova spec? no need?
17:11:01 <jroll> rloo: nova folks tell me we shouldn't need one
17:11:18 <jroll> devananda: I've been out since tuesday, will be picking it up today/tomorrow
17:11:29 <jroll> devananda: needs a quick update, nothing major
17:11:33 <rloo> jroll: good news wrt nova
17:11:36 <devananda> jroll: ok, cool.
17:11:48 <jroll> rloo: for now, until someone decides they want one :)
17:12:02 <rloo> jroll: didn't you get sign off on that? :D
17:12:22 <jroll> rloo: :P
17:13:20 <rloo> jlvillal: are there any urgent testing things that ought to be done before you get back in AUg?
17:13:20 <devananda> jroll: I dont see the multihost nova-compute spec on hte whiteboard, adding it under the nova section
17:13:33 <jroll> devananda: sounds good
17:13:36 <NobodyCam> oh ya
17:13:42 <NobodyCam> jlvillal: is gone for a month
17:14:24 <rloo> when is the nova deadline for specs?
17:14:35 <NobodyCam> rloo: last week I think
17:14:58 <rloo> NobodyCam: oh. so that multihost nova-compute spec won't make it in liberty?
17:14:59 <jlvillal> rloo, I'm not sure about urgent testing things.
17:15:07 <jroll> rloo: spec submission deadline was last week
17:15:21 <jroll> rloo: not sure when freeze is, and if this falls in priority or non-priority
17:15:30 <rloo> jroll: oh, submission deadline. phew.
17:16:12 <jroll> rloo: jay pipes and dan smith agreed to hack on this at the nova midcycle, I think we can do it this cycle
17:16:14 <devananda> I dont know where it falls in nova's priority queue either, but it has two nova cores backing it already
17:16:26 <jlvillal> rloo, I don't think there is anything urgent, in regards to testing.  At the moment my management fully supports me working on functional testing.  So I believe I will be able to resume work when I return.
17:16:45 <lucasagomes> nice, any ironic folks attending the nova mid-cycle?
17:16:49 <devananda> as long as we keep moving forward on it with them, I think there's a good chance to get it done
17:16:56 <rloo> jlvillal: thx
17:16:56 <jroll> lucasagomes: I am, idk about anyone else
17:17:00 <devananda> and the upside is, there's very little work needed in Ironic
17:17:10 <NobodyCam> jlvillal: have you handed any open items off tosomeone else and if so who?
17:17:24 <NobodyCam> just so we know to to ping
17:17:31 <lucasagomes> jroll, ack, yeah should be enough would be good to have at least 1 core
17:17:44 <jroll> lucasagomes: yeah, though hoping someone else shows up :)
17:17:52 <jroll> lucasagomes: though it's the same week as OSCON
17:17:53 <devananda> lucasagomes: nova midcycle is the same week as OSCON, which I already planned to attend.
17:18:13 <jlvillal> NobodyCam, I don't know of any open items regarding functional testing except for the main open item, which is add more functional tests.
17:18:16 <devananda> so unfortunately I will not make hte nova midcucle
17:18:19 <lucasagomes> devananda, jroll I see... yeah that complicate things indeed
17:18:23 <krtaylor> jlvillal, when you return, I'd like to start talking about CI testing also
17:18:33 <jlvillal> krtaylor, Great!
17:18:52 <devananda> jlvillal: main item on my mind re: functional testing -- move it into our tree and out of tempest
17:19:49 <jlvillal> devananda, I agree.
17:19:55 <devananda> I'm going to timebox the subteam discussion to another 2 minutes
17:20:03 <devananda> also, we haven't talked about drivers at all
17:20:15 <devananda> which is part of this section of hte meeting
17:20:27 <devananda> looks like the iRCM driver is ready for reviews
17:20:30 <jroll> there's nothing in the drivers section except "I need reviews" afaict
17:20:34 <devananda> *iRMC
17:20:36 <devananda> yea
17:20:43 <jroll> and we've know that for quite some time :)
17:20:51 <devananda> how's the refactoring of boot / deploy coming?
17:20:52 <lucasagomes> yeah iRMC seems ready indeed, gotta review it again this week
17:21:11 <lucasagomes> devananda, ive tested the boot deploy split, it works found some minor problems
17:21:17 <rameshg87> devananda: I posted the first patch set. after that I am yet to refactor other stuffs.
17:21:19 <lucasagomes> reported in the patch itself
17:21:31 <rameshg87> devananda: I am yet to work on issues reported by lucasagomes
17:21:35 <rameshg87> *issue
17:21:43 <devananda> cool - so they're progressing well
17:21:48 <rameshg87> everything is not caught in gate :(
17:22:08 <devananda> rameshg87: how many patch sets deep is it now // do you think it's going to take?
17:22:32 <rameshg87> after this may be 3-4
17:22:45 <rameshg87> agent and rest of virtual media drivers
17:22:50 <lucasagomes> #link https://review.openstack.org/#/c/166513/
17:22:54 <rameshg87> after this, it should be getting easier rather
17:23:14 <rameshg87> at least I hope so ..
17:23:17 <devananda> rameshg87: ah, that's not too bad. please make sure they all have the same gerrit topic, and could you add a link to the whiteboard in the "drivers" section
17:23:32 <rameshg87> devananda: sure.
17:23:37 <devananda> I'd like us to track something that big which affects all the drivers in the weekly meetings
17:23:40 <devananda> thanks much
17:24:05 <devananda> moving on, because time
17:24:13 <devananda> #topic node names
17:25:04 <devananda> this seems kinda minor, but it could have a noticeable impact
17:25:08 <rloo> quick  background. the node names were meant to allow for host names only, and then got changed to host-names.domain.
17:25:24 <rloo> but the code doesn't really detect hostnames properly so chris submitted a patch.
17:25:33 <rloo> but there was already a bug/ask to relax the names.
17:25:40 <NobodyCam> #link https://review.openstack.org/#/c/193587
17:25:42 <rloo> so... we should just decide what-to-do
17:25:57 <dtantsur> probably it was a wrong idea to go with name=host name
17:26:04 <rloo> if we fix existing hostname, it means a microversion bump
17:26:16 <dtantsur> e.g. I would be surprised to not be able to use underscore in any "name"
17:26:33 <dtantsur> rloo, every API change means microversion bump, but this is also a breaking change
17:26:43 <rameshg87> +1, I was surprised
17:26:45 <lucasagomes> I think I would prefer names to be relaxed, I find hostnames a bit misleading since that name is not used to determine the instance hostname
17:26:45 <jroll> dtantsur: I agree. I see a use case for only numbers too
17:26:57 <rloo> dtantsur: yeah, so when i first saw the patch, i thought why fix it, let's just relax the name.
17:27:10 <rloo> dtantsur: i mean, if we have to do a microversion bump anyway, etc
17:27:12 <jlvillal> Somewhat as a tangent.  But it seems like the host name valid code might be better in something like oslo.utils.
17:27:23 <devananda> the original requirement for this functionality was that we allow a way to reference Nodes by a human-readable name
17:27:57 <devananda> we've gone fairly far afield from that along the way. I'm not sure where the FQDN requirement came in that introduced "." separators, eg, https://bugs.launchpad.net/ironic/+bug/1433832
17:27:57 <openstack> Launchpad bug 1433832 in Ironic "Fix is_hostname_safe for RFC compliance" [Medium,Fix released] - Assigned to Michael Davies (mrda)
17:28:26 <devananda> jlvillal: I agree w.r.t. moving the RFC-complicancy-checking bits to oslo.utils, fwiw
17:28:35 * dtantsur does not remember either, Kilo cycle was messy..
17:29:08 <rloo> ahh, i think that was jroll (but i could be wrong). I mean, jroll added a patch and mrda fixed it to be 'right'...
17:29:08 <gabriel-bezerra> I agree with relaxing too.
17:29:18 <devananda> rloo: my isue with completely relaxing the name is that it is a resource identifier, so it must match RFC3986
17:29:21 <devananda> #link https://tools.ietf.org/html/rfc3986#page-11
17:29:44 <jroll> rloo: I don't believe I did?
17:29:46 <lucasagomes> devananda, yeah it's exposed in the URL so should be compatible with that
17:29:47 <rloo> devananda: so if we relax it to conform to RFC3986?
17:30:01 <devananda> rloo: that's fine with me
17:30:03 <dtantsur> lucasagomes, devananda, sorry, I'm not sure I understand you. everything may be encoded in a URL...
17:30:12 <dtantsur> using %.. notation obviously
17:30:15 <devananda> dtantsur: yup
17:30:15 <lucasagomes> dtantsur, yes compatible == url encoded
17:30:35 <devananda> s/that's fine with me//
17:30:54 <devananda> dtantsur: how about typing it on the command line?
17:31:04 <devananda> everything can be quoted and escaped in bash, too
17:31:35 <dtantsur> I'm not advocation allowing weird thing btw. I'm not even suggestion allowing Russian :)
17:31:40 <dtantsur> * suggesting
17:31:58 <dtantsur> but support for underscores is not something I feel comfortable using
17:32:06 <jroll> what if we just allowed anything ascii?
17:32:43 <dtantsur> note that I pretty much imagine people wanting local languages, but that might go too far
17:33:03 <dtantsur> jroll, ASCII == chr(0)..chr(127)?
17:33:14 <jroll> dtantsur: yeah, something like that
17:33:18 <lucasagomes> yeah we can come up with something reasonble I believe, like alphanumerics + special symbols in <list>
17:33:34 <dtantsur> ++
17:33:35 <lucasagomes> list being = ( '-', '_', '.')
17:33:52 <devananda> lucasagomes: let's not invent our own standard (again)
17:34:01 <NobodyCam> per rfc" unreserved  = ALPHA / DIGIT / "-" / "." / "_" / "~"
17:34:28 <devananda> thus my suggestion we stick to the RFC :)
17:34:39 <NobodyCam> ++
17:34:44 <lucasagomes> which is fair enuff
17:35:00 * dtantsur is lost, which part of RPC? host names? domains?
17:35:17 <lucasagomes> rfc3986
17:35:40 <rloo> I think rfc3986, the 'characters' part?
17:35:41 <lucasagomes> which is basically anything... url encoded
17:35:42 <jroll> dtantsur: https://tools.ietf.org/html/rfc3986#page-11 is what was linked earlier
17:36:18 <dtantsur> ah, sorry, I finally understood this unreserved thing :) +1
17:36:39 <rloo> so it'll need a spec, right? (for whoever does it. don't know if chris has given up on us or not)
17:36:46 <devananda> let's continue discussing this on the bug report here
17:36:49 <devananda> #link https://bugs.launchpad.net/ironic/+bug/1434376
17:36:49 <openstack> Launchpad bug 1434376 in Ironic "Node name rule relaxation" [Wishlist,In progress] - Assigned to Chris St. Pierre (stpierre)
17:37:13 <devananda> I hope this doesn't need a spec -- it's either a bug fix, or we shouldn't be doing it at all
17:37:29 <rloo> devananda: well, the spec mentions hostname I believe.
17:37:38 <rloo> devananda: or hostname.domain. can't recall now.
17:37:49 <rloo> devananda: and we can't change the original spec.
17:38:02 <devananda> rloo: sure. but that spec != live documentation of the state of hte project today
17:38:23 <rloo> devananda: fine with me. i like bugs better.
17:38:28 <NobodyCam> i think bug should cover us here
17:38:35 <devananda> that spec was implemented last cycle, and that code released. we need to understand that folks will be using that code for several years to come
17:39:06 <devananda> so what ever non-standards-compliant type checking we released in Kilo is exactly what some operators will be stuck with for a while
17:39:33 <devananda> anyway, before I rant on that, let's move on to the next topic
17:39:43 <NobodyCam> ++
17:39:44 * rloo was hoping for a rant
17:39:47 <lucasagomes> heh
17:39:51 <devananda> actually, going to skip one and come back to it
17:39:55 <devananda> #topic release model spec
17:40:04 <jroll> ohai
17:40:09 <devananda> #link https://review.openstack.org/#/c/185171/
17:40:11 <devananda> jroll: hi there!
17:40:16 <jroll> so I've had lots of feedback on this spec
17:40:24 <jroll> all good stuff, and I think I've incorporated it all
17:40:34 <jroll> so I'd like to get eyes on this, land it, and get back to releasing software
17:40:45 <lucasagomes> jroll, was looking at it right now, I remember we talked about re global requirements
17:41:02 <lucasagomes> to have somehting like a "-2 LGTM" in the projects/requirements
17:41:02 <jroll> lucasagomes: yeah, there's a thing in there
17:41:17 <devananda> I see that dhellmann and ttx both gave you feedback -- that's fantastic -- and you've just posted a new rev, which I haven't read yet
17:41:47 <lucasagomes> jroll, yeah not sure if u want to mention that in the spec tho, plus we would need somehow to not break gate-ironic-requirements job
17:41:48 <lucasagomes> in gate
17:41:54 <devananda> jroll: any specific changes worth calling out?
17:42:10 <lucasagomes> since right now any update to the requirements.txt in the ironic tree that is not in gr will cause gate to fail
17:42:35 <jroll> devananda: nothing major, just some clarifications and corrections from ttx's comments
17:42:43 <jroll> lucasagomes: oh, hrm :/
17:42:51 <jroll> lucasagomes: I don't think that's true unless that's new
17:43:23 <lucasagomes> I think it's there for a while
17:43:24 <lucasagomes> e.g https://review.openstack.org/#/c/196010/
17:43:34 <lucasagomes> gate-ironic-requirements http://logs.openstack.org/10/196010/1/check/gate-ironic-requirements/68a3886/ : Incompatible requirement found; see https://wiki.openstack.org/wiki/Requirements in 16s
17:43:49 <jroll> lucasagomes: urgh
17:43:58 <lucasagomes> I mean it can be worked out, I just pointing out in case u want to put in the spec
17:44:18 <jroll> yeah, idk
17:44:24 <jroll> if you want it in the spec, add it
17:44:28 <jroll> er, review it
17:44:38 <lucasagomes> yeah I will add a comment about it
17:44:39 <jroll> I don't know it needs to be there, this is more about process IMO
17:44:46 <lucasagomes> yeah sure
17:45:12 <NobodyCam> *15 minutes left
17:45:47 <devananda> jroll: changes LGTM, though I may want to discuss (separately) about the spec tree structure changes
17:46:02 <jroll> devananda: sure
17:46:08 <devananda> jroll: but that detail isn't a critical part of the spec
17:46:23 <lucasagomes> added
17:46:28 <jroll> devananda: agree
17:47:28 <devananda> cool. well, let's get a few more eyes on it this week and try to land it by next monday if we can
17:47:46 <NobodyCam> ++
17:47:59 <devananda> and then make the changes to semver version numbres -- I'd love to be able to tag our first release in this model before OSCON
17:48:23 <devananda> #topic liberty priorities
17:48:32 <devananda> #topic how about we just call them priorities
17:48:35 <devananda> :)
17:48:39 <lucasagomes> tl;dr that spreadsheet is not updated
17:48:59 <lucasagomes> I started put some stuff there, other people helped too, but yeah need more work
17:49:10 <rloo> devananda: priorities is fine with me :)
17:49:29 <devananda> lucasagomes: yea, i put a few things up, but agree -- it needs more work. since the rush at the end of kilo, we all sort of stopped tracking priorities well
17:49:30 <gabriel-bezerra> rloo, devananda: +1
17:49:38 <rloo> devananda: basically, wanted to get an idea of our priorities, since i know that we're itchin' for a release soon :)
17:49:48 <devananda> which has been the normal fall-out from the end of cycle crunch period
17:49:55 <lucasagomes> yeah
17:50:14 * devananda renames the tab to Current Priorities
17:50:46 <devananda> #link https://docs.google.com/spreadsheets/d/1Hxyfy60hN_Fit0b-plsPzK6yW3ePQC5IfwuzJwltlbo
17:51:42 <devananda> fwiw, I don't like using a google spreadsheet -- but it's better than launchpad for quickly seeing what's going on
17:52:21 <devananda> lucasagomes: so actually -- what "big effort items" are missing from this?
17:52:40 <lucasagomes> release model ?
17:52:51 <lucasagomes> tho it doesn't involve code, we need review
17:52:53 <devananda> eh, that's not code
17:53:16 <NobodyCam> would name relaxtion be a BIG effort item
17:53:26 <devananda> NobodyCam: oh gawh i hope not
17:53:31 <NobodyCam> :)
17:53:41 <lucasagomes> yeah I gotta go through the specs that have been merged and is in the queue and put it there
17:54:22 <krtaylor> what about adding more functional tests?
17:54:31 <devananda> krtaylor: totally important
17:54:37 <jlvillal> +1
17:55:09 <NobodyCam> * 5 minute warnning bell *
17:55:24 <rloo> is the ironic-lib refactoring important?
17:55:34 <devananda> but we've used this spreadsheet in the past to track feature implementation status for big ticket / high priority items, during the crunch leading up to a release
17:55:54 <jroll> rloo: imo yes, enables partition images in agent drivers
17:55:55 <devananda> perhaps we should, with the release model changing, rethink how we track that ongoing work slightly
17:56:02 <gabriel-bezerra> Should drivers go in the spreadsheet too? We have the OneView one we want done for Liberty.
17:56:03 <jroll> rloo: big missing feature me thinks
17:56:14 <dtantsur> I also see it as a way not to forget things we agreed on on the summit :)
17:56:26 <devananda> #action devananda to think about the ways we have/should track and communicate major project priorities
17:56:26 <lucasagomes> gabriel-bezerra, yes
17:56:32 <devananda> #topen discussion
17:56:40 <devananda> #topic open discussion
17:56:44 <NobodyCam> :)
17:57:05 <gabriel-bezerra> I can't edit the spreadsheet. How does it work?
17:57:19 <lucasagomes> maybe we can talk about that patch from JoshNang that allows exposing "fail" provision state in the api
17:57:27 <devananda> gabriel-bezerra: difference there is, one team is working on adding a new driver. it's great, but not affecting other teams.
17:57:33 <jroll> gabriel-bezerra: iirc cores can only update the spreadsheet
17:57:35 <lucasagomes> I gave it a go today, but, it requires some stuff such as breaking the lock
17:57:44 * lucasagomes grabs the link
17:57:56 <lucasagomes> #link https://review.openstack.org/#/c/196229/
17:58:11 <JoshNang> yeah i think there are quite a few caveats in that patch
17:58:35 <lucasagomes> yeah, I put some comments there... but I like the idea
17:58:46 <lucasagomes> we def need something like that
17:58:55 <devananda> JoshNang: i also had an idea -- s/fail/abort/ because that's a better verb to express the intent
17:59:03 <JoshNang> ++ for abort
17:59:07 <lucasagomes> yeah
17:59:18 <lucasagomes> one thing tho DEPLOYWAIT already supported "deleted"
17:59:24 <lucasagomes> which is kinda like an abort for DEPLOYWAIT
17:59:31 <lucasagomes> so we may have some duplication there
17:59:32 <gabriel-bezerra> devananda: I see.
17:59:43 <NobodyCam> * last minute *
17:59:43 <gabriel-bezerra> jroll: OK.
17:59:44 <lucasagomes> anyway we got 1 min and we won't be able to solve it in that time
17:59:47 <devananda> lucasagomes: yep, which is either inconsistent, or a breaking API change
17:59:50 <gabriel-bezerra> rloo: thanks for adding it.
18:00:04 <lucasagomes> devananda, yeah
18:00:05 <dtantsur> we should anyway start with a spec, I guess..
18:00:19 <NobodyCam> Great meeting Thanks to Everyone!
18:00:20 <jroll> good meeting, thanks everyone
18:00:26 <devananda> cheers, thanks all!
18:00:39 <devananda> #endmeeting