17:02:19 <NobodyCam> #startmeeting Ironic
17:02:19 <NobodyCam> #chair devananda
17:02:20 <openstack> Meeting started Mon Jun 15 17:02:19 2015 UTC and is due to finish in 60 minutes.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:21 <NobodyCam> Welcome everyone to the Ironic meeting.
17:02:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:24 <openstack> The meeting name has been set to 'ironic'
17:02:25 <openstack> Current chairs: NobodyCam devananda
17:02:26 <dtantsur> o/
17:02:28 <NobodyCam> Of course the agenda can be found at:
17:02:29 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
17:02:29 <krtaylor> o/
17:02:30 <TheJulia> o/
17:02:31 <zhenguo> o/
17:02:37 <NobodyCam> FYI: Nobodycam is in poor bandwidth area and may drop at any moment
17:02:38 <alex_xu> o/
17:02:43 <NobodyCam> #topic Greetings, roll-call and announcements
17:02:43 <NobodyCam> Roll-call: Who's here for the Ironic Meeting?
17:02:45 <cdearborn> o/
17:02:46 <naohirot> o/
17:02:48 <NobodyCam> :) welcome all
17:02:53 <rloo> o/
17:02:55 <lucasagomes> o/
17:02:57 <jroll> \o
17:03:08 <TheJulia> Good UGT everyone. :)
17:03:17 <cinerama> hi
17:03:22 <NobodyCam> great to see everyone thhis fine monday
17:03:28 <jlvillal> o/
17:03:44 <NobodyCam> lets kickk this off
17:03:45 <NobodyCam> #topic announcements:
17:03:45 <NobodyCam> Devananda IS in Tel Aviv. WE hope he's having fun :)
17:04:14 <lucasagomes> sounds sunny :-)
17:04:15 <NobodyCam> NobodyCam: and BadCub: are also traveling this week
17:04:33 <NobodyCam> I here tel Aviv is quite warm this time of year
17:04:34 <BadCub> eep.. sorry.. lateness happened
17:04:43 <NobodyCam> :)
17:04:59 <NobodyCam> any other announcements
17:05:25 <NobodyCam> BadCub: I know you have to leave early. want to talk about the mid-cycle?
17:05:36 <BadCub> NobodyCam: yeah
17:05:39 <NobodyCam> #topic Mid-Cycle
17:06:09 <BadCub> Spoke with devananda this morning. He has sent a request to Facilities at HP Seattle to host the mid-cycle Aug 12-14.
17:06:21 <BadCub> Polling for dates is considered officially closed
17:06:50 <NobodyCam> do you have the poll results?
17:06:56 <BadCub> getting now
17:07:26 <BadCub> 10 Yes for Aug 12-14
17:07:35 <BadCub> One vote for Aug 5-7
17:07:47 <BadCub> Two votes for Aug 19-21
17:07:52 <jroll> BadCub: so does being 100% solid on those dates depend on HP facility response?
17:07:59 <BadCub> not a high viter turnout.
17:08:05 <BadCub> s/viter/voter
17:08:30 <BadCub> jroll: from what devananda and I discussed, if HP is negative, we will try to find alternative location
17:08:45 <NobodyCam> ++
17:08:46 <jroll> BadCub: ok, so hold off on booking travel :)
17:09:07 <BadCub> jroll: yes please. I hope to have answer from HP facilities by EOW
17:09:14 <rloo> BadCub: location in seattle or location in US (west)?
17:09:29 <jroll> ok, thanks :)
17:09:37 <BadCub> rloo: the location will be Seattle
17:09:46 <rloo> BadCub: thx
17:09:50 <BadCub> yw
17:09:55 * lucasagomes hopes he can go
17:09:59 <NobodyCam> ++
17:10:26 <BadCub> I will keep everyone updated as SOON as I hear back
17:10:36 <NobodyCam> awesome thank you BadCub for all the effort in getting this planned
17:10:49 <BadCub> My pleasure
17:11:07 <NobodyCam> any thing else about the mid-cycle
17:11:22 <BadCub> yes
17:11:37 <BadCub> if we can get an early headcount, I can try to setup a small group block at one of the hotels
17:11:57 <BadCub> if not, that's cool too
17:11:57 <NobodyCam> :) maybe we can use the white board
17:12:02 <BadCub> yes
17:12:04 <jroll> +1 whiteboard
17:12:09 <jroll> or another etherpad we can plan work on
17:12:10 <BadCub> ++
17:12:30 <NobodyCam> ++
17:12:38 <TheJulia> ++
17:12:48 <lucasagomes> +1
17:13:06 <jroll> https://etherpad.openstack.org/p/ironic-liberty-midcycle
17:13:09 <jroll> #link https://etherpad.openstack.org/p/ironic-liberty-midcycle
17:13:11 <NobodyCam> cool new pad or whiteboard /me is good with either
17:13:11 <jroll> done.
17:13:17 <BadCub> I am traveling this week and won't be on a great deal, if someone would kindly volunteer to set up said whiteboard/epad, I would be deeply greatful
17:13:23 <NobodyCam> or that ^^^
17:13:27 <NobodyCam> awesome Thank you jroll
17:13:29 <BadCub> jroll: thank you! :)
17:13:39 * jroll adds to whiteboard
17:13:47 <NobodyCam> :)
17:14:02 <NobodyCam> so we can use that for mid-cycle planning
17:14:48 <NobodyCam> ok then moving along
17:15:09 <NobodyCam> #topic SubTeam: status report
17:15:10 <NobodyCam> Posted on Whiteboard
17:15:12 <NobodyCam> #link https://etherpad.openstack.org/p/IronicWhiteBoard
17:16:05 <jroll> added some notes on neutron integration stuff there
17:16:05 <NobodyCam> I would like to ask... Should we add BiFrost as a official sub-team?
17:16:15 <jroll> would love eyes on the specs to see how insane we are
17:16:15 <dtantsur> NobodyCam, and inspector, and inspector :)
17:16:21 <jroll> NobodyCam: dtantsur +1
17:16:27 <naohirot> NobodyCam: I updated irmc part, and I'd like core team to review irmc deploy driver #link      https://review.openstack.org//#/q/owner:+naohirot%2540jp.fujitsu.com+status:+open,n,z
17:16:31 <NobodyCam> jroll: dtantsur ++
17:16:41 <NobodyCam> jroll: naohirot: awesome thank you
17:16:43 <TheJulia> NobodyCam: +1 on both bifrost and inspector
17:17:06 <rloo> i was going to say -1 on bifrost and inspector.
17:17:09 <NobodyCam> TheJulia: would like to handle the bifrost section moving forward?
17:17:12 <rloo> what about ironic-lib then
17:17:15 <NobodyCam> rloo: oh
17:17:16 <rloo> and ironic
17:17:25 <TheJulia> NobodyCam: Absoloutely
17:17:28 <naohirot> NobodyCam: liberty-1 is Jun 25, so what is the current status of core team's review?
17:17:29 <rloo> or +1
17:17:34 <lucasagomes> NobodyCam, official subteam?
17:17:38 <rloo> guess it depends on what these statuses are for etc
17:17:49 <NobodyCam> lucasagomes: (listed on the whiteboard)
17:18:04 <lucasagomes> ah... +1
17:18:10 <dtantsur> lucasagomes, that means, I'll put the major news about inspector on the dashboard every week :)
17:18:18 <naohirot> NobodyCam: what features are planed to be part of liberty-1?
17:18:22 <dtantsur> and ditto for bifrost
17:18:30 <NobodyCam> I figured it would a quick way for folks to stay updated on
17:18:33 <rloo> dtantsur: but i like your email messages :)
17:18:34 <dtantsur> naohirot, whatever we land?
17:18:40 <dtantsur> rloo, I hope so :)
17:18:42 <jroll> dtantsur: \o/
17:18:43 <NobodyCam> and ya ironic-lib should prob also be htere
17:19:02 <jlvillal> Nova sub-team would like feedback on: https://bugs.launchpad.net/nova/+bug/1289048  Is it still an issue?
17:19:03 <openstack> Launchpad bug 1289048 in OpenStack Compute (nova) "Ironic nova driver spawn() makes too many redundant calls" [Low,Confirmed]
17:19:06 <rloo> dtantsur: I'm fine with adding inspector/bifrost, but i wanted to understand what would  be reported there
17:19:16 <rloo> bifrost and inspector don't affect ironic directly.
17:19:25 <jroll> jlvillal: we've somewhat mitigated it but it could be better
17:19:38 <dtantsur> rloo, major news for those interested
17:19:38 <lucasagomes> dtantsur, w00t
17:19:48 <jroll> jlvillal: I suggest you spin up devstack and maybe list the calls that currently happen on a delpoy
17:19:51 <jlvillal> jroll: Thanks.  Trying to figure out if we should try to get someone working on it.
17:20:01 <jroll> jlvillal: it's pretty low priority
17:20:03 <naohirot> dtantsur: It's not clear to me that whatever we land means
17:20:06 <jlvillal> jroll: Okay.  Thank you.
17:20:15 <jroll> jlvillal: if it was a problem then my team would be all over it :P
17:20:20 <rloo> naohirot: it really is 'wahtever we land'
17:20:22 <jlvillal> :)
17:20:26 <rloo> naohirot: of course, there are priorities
17:20:30 <dtantsur> naohirot, it literaly means: we're trying to land as much stuff as it's possible, we can't make any promises
17:20:33 <rloo> naohirot: so maybe that's what you might want to know
17:20:33 <lucasagomes> jlvillal, as jroll said :-)
17:20:42 <NobodyCam> naohirot: I don't believe we have set any riorities for l-1
17:20:45 <jlvillal> Thanks all
17:20:46 <dtantsur> naohirot, whatever we manage to land, will enter liberty-1. that's my understanding
17:20:50 <NobodyCam> priorities *
17:20:58 <naohirot> rloo: no core member can do just wait?
17:21:07 <jroll> so speaking of "liberty-1" has everyone had a chance to look at the release model spec?
17:21:09 <dtantsur> NobodyCam, boot-deploy split is one
17:21:21 <dtantsur> a lot of stuff depends on it
17:21:26 <rloo> naohirot: i don't know what you mean. Are you saying that core members just wait for ??
17:21:27 <jroll> naohirot: cores try to review everything, but we're all human unfortunately
17:21:54 <dtantsur> naohirot, you mean, what you can do? review other's patches to free some core reviewer's time
17:21:57 <rloo> jroll: i have no idea how liberty-1 fits in with your new release model. is it mentioned in the spec?
17:22:02 <dtantsur> naohirot, and timely address comments on your patches of course
17:22:11 <jroll> rloo: basically we ignore openstack's milestones
17:22:13 <dtantsur> that's all (we all) can do to speed up the thing
17:22:16 <naohirot> rloo: I don't know the meaning of whatever land.
17:22:29 <rloo> jroll: that's what i thought. so 'liberty-1' won't mean anything to ironic.
17:22:32 <NobodyCam> dtantsur: yep thatspec ha landed
17:22:40 <jroll> rloo: correct.
17:22:58 <lucasagomes> jroll, yup I did :-)
17:23:00 <naohirot> rloo: therefor I thought that all I can do is just waiting for good luck?
17:23:07 <dtantsur> naohirot, I started reviewing your iRMC stuff today, just didn't have time to finish. stay tuned please :)
17:23:10 <lucasagomes> didn't vote yet, I've to finish my thoughts but so far so good
17:23:15 <dtantsur> will try to finish tomorrow
17:23:22 <lucasagomes> thanks for the answer on the global requirements
17:23:39 <jroll> lucasagomes: cool, ty sir
17:23:57 <rloo> naohirot: no, good luck doesn't help much. i find that if patches are really well written etc, they get reviewed faster etc. but again, the reviewing isn't an automated process and we are all busy and have our own priorities
17:24:05 <lucasagomes> I think we are out of topic here?
17:24:12 <jroll> naohirot: also, large patches take a lot of time to review.
17:24:18 <jroll> lucasagomes: aren't we always :)
17:24:21 <rloo> +1 lucasagomes
17:24:25 <NobodyCam> lucasagomes: yep
17:24:25 <dtantsur> +1
17:24:26 <BadCub> +1
17:24:32 <naohirot> jroll: I know all we are human, but as I mentioned many time, I'd like to know the priority of core member's tasks.
17:24:32 <dtantsur> let's move on
17:24:35 <NobodyCam> #topic New dashboard proposed by huawei
17:24:35 <NobodyCam> #link https://github.com/niuzhenguo/ironic-dashboard
17:24:35 <NobodyCam> #link https://review.openstack.org/191131
17:24:53 <zhenguo> hi all, I proposed the dashboard project.
17:24:57 <rloo> oh, i had questions about subteams. will ask later.
17:24:58 <NobodyCam> this as I under stand was put up like last week
17:24:58 <dtantsur> why isn't it on stackforge btw? :)
17:25:06 <dtantsur> oh, you did apply for it, right?
17:25:07 <NobodyCam> I first heard of it this mornign
17:25:20 <jroll> so, I have a few concerns here.
17:25:40 <TheJulia> I have a few concerns as well
17:25:41 <zhenguo> it's a horizon plugin like tuskar-ui,
17:25:51 <NobodyCam> hi zhenguo
17:25:56 <jroll> 1) this is the first, afaik, time that any of the ironic team has heard anything about this. it's a 2500 line code drop without git history, etc.
17:26:05 <zhenguo> and recently I see other porjects like magnum apply it for openstack.
17:26:09 <jroll> 2) it's based on very outdated code. uses pxe_deploy_kernel etc.
17:26:22 <jroll> 3) it's importing tuskar. tuskar has nothing to do with ironic or horizon.
17:26:28 <jroll> tuskar is only a tripleo thing
17:26:36 <jroll> 4) test coverage is lacking
17:26:55 <zhenguo> yes, it's a init repo only on github now
17:27:10 <jroll> 5) last point, the proposal puts this under the ironic team. is the ironic core team supposed to maintain this?
17:27:12 <dtantsur> zhenguo, oh, what does it add on top of Tuskar UI?
17:27:33 <zhenguo> it's not on top of tuskar ui
17:27:36 <jroll> and on that note, is any of the ironic core team interested in maintaining this?
17:27:38 <NobodyCam> zhenguo: with only a very quick look I think its early to be perposing to the govenence repo at this time
17:27:40 <dtantsur> ah, I see
17:27:42 <zhenguo> it's for horizon
17:27:57 <jroll> zhenguo: it's importing tuskar e.g. https://github.com/niuzhenguo/ironic-dashboard/blob/32012e7ce3bad710a6cfcbab3ad375a5d371c4dc/ironic_dashboard/baremetal/nodes/tests.py#L26
17:28:09 <zhenguo> https://review.openstack.org/#/c/191142/
17:28:28 <TheJulia> I have to agree with NobodyCam.  I think this is good for stackforge so it can itererate and evolve, but it is not the one UI gui for openstack considering we also know of a JS one in development now.
17:28:43 <zhenguo> jroll, it's split from tuskar so left something to be cleaned later :)
17:28:54 <lucasagomes> right that's including the project under the ironic umbrella
17:29:16 <dtantsur> zhenguo, what's the reason of the split?
17:29:16 <jroll> regardless of stackforge or openstack, does the ironic core team want to and/or have the time to maintain this?
17:29:17 <TheJulia> s/openstack/ironic/
17:29:28 <dtantsur> jroll, on stackforge, it does not matter
17:29:31 <jroll> I fully support a horizon plugin for ironic, fwiw
17:29:39 <jroll> dtantsur: if it's under ironic in governance, it does.
17:29:46 <zhenguo> dtantsur: as I understand, tuskar-ui is specifically geared towards TripleO
17:29:48 <TheJulia> jroll: if it goes into openstack umbrella, I say a vote is required.
17:29:57 <lucasagomes> jroll, I think most have the intention to have something... A UI was even part of the graduation plans and Josh was working on one right?
17:30:05 <zhenguo> ironic needs it's own dashboard for self-services needed
17:30:06 <NobodyCam> jroll: I also share your concerns about maintaining this
17:30:09 <rloo> my suggestion is that some description is written similar to our spec process. it isn't clear that this is a plugin for horizon.
17:30:09 <dtantsur> zhenguo, well, yes. Did you talk to the folks about splitting away the common code?
17:30:11 <lucasagomes> but it needs to mature, it seems that there's more people focused on different efforts to do the same thing
17:30:26 <jroll> lucasagomes: honestly the thing josh was working on was really only about graduation, we don't care to use it.
17:30:37 <NobodyCam> and I also do like the idea of a ironic dashboard
17:30:39 <lucasagomes> right
17:30:48 <JoshNang> i've asked before if anyone wanted to pick it up, no takers yet
17:30:53 <dtantsur> zhenguo, also, tuskar UI is under Horizon program. why do you want to put this thing under the baremetal?
17:31:00 <lucasagomes> I think that, as any project that wants to be part of the Ironic umbrella it needs to first go somewhere else
17:31:02 <lucasagomes> mature
17:31:04 <zhenguo> dtantsur, not really split, I reuse some code of that
17:31:08 <lucasagomes> and then we can talk about including it or not
17:31:14 <NobodyCam> lucasagomes: ++
17:31:21 <dtantsur> lucasagomes, ++
17:31:29 <lucasagomes> it seems that this project is not at this stage already
17:31:35 <jroll> +1
17:31:38 <lucasagomes> we cna give a feedback on the idea, so yes having a dashboard is nice
17:31:45 <zhenguo> yes, maybe I can put it to stackforge first
17:31:47 <lucasagomes> but I won't discuss this project specifics because it's not yet time
17:31:51 <lucasagomes> zhenguo, +1
17:32:04 <NobodyCam> how about we give Ironic folk a week or so to look at it and revisit in next meeting?
17:32:11 <dtantsur> ++ for stackforge, and I believe it should aim for Horizon program, not for Ironic
17:32:14 <lucasagomes> that was the path for bifrost, IPA and inspector (discoverd at the time)
17:32:15 <NobodyCam> oh I like starting on stackforge
17:32:23 <NobodyCam> ++
17:32:34 <lucasagomes> once we have something substential we can promote it to the ironic umbrella if people have an agreement
17:32:36 <jroll> NobodyCam: I think it's clear it needs to mature, let's not spend another meeting on it :)
17:32:40 <lucasagomes> because we then commit to maintain it
17:32:49 <NobodyCam> jroll: ack +
17:32:57 <rloo> i don't think this is solely up to the cores. I'd like to hear from the ironic community as to whether this is wanted/useful to them.
17:33:01 <zhenguo> so as a horizon and tuskar-ui core member, I think I can enrich it quickly.
17:33:05 <lucasagomes> rloo, +1
17:33:22 <jroll> zhenguo: I suggest you (and your team?) discuss this more with the ironic team in our channel, and we can work together on it. it was quite odd having this much code dropped without hearing anything about it
17:33:30 <NobodyCam> I'm going to put a action item for zhenguo to put it up on stackforge
17:34:00 <rloo> I'd prefer if a discussion/something is mentioned in email so the community is aware of it
17:34:19 <dtantsur> rloo, ++, and so that comments are not lost
17:34:20 <jroll> rloo: +1, zhenguo can you send an email to the list once it's on stackforge?
17:34:35 <NobodyCam> #action zhenguo put Ironic dashup on stackforge and bring attention to it via the ML
17:34:37 <lucasagomes> yeah an email to the ML. Saying your working on a dashboard
17:34:39 <NobodyCam> ^^ ??
17:34:44 <jroll> +1 NobodyCam
17:34:45 <lucasagomes> and people can even start to collaborate
17:34:52 <lucasagomes> NobodyCam, +1
17:34:56 <NobodyCam> :)
17:34:59 <rloo> or come out of the woodwork with their own 'UI'...
17:35:03 <zhenguo> yes,
17:35:03 <lucasagomes> and ofc, zhenguo thanks for that!
17:35:07 <krtaylor> zhenguo, http://docs.openstack.org/infra/manual/creators.html
17:35:42 <zhenguo> thanks krtaylor
17:35:45 <NobodyCam> zhenguo: yes this is a great start :) I look frward to seeing wheree it goes
17:35:56 <krtaylor> ++ for stackforge, zhenguo, I just did this, let m ekno wif you have questions
17:36:04 <sambetts> It might be worth talking to the horizon team about this too because I know they are working on something to split the different project panels out into separate repos <project-name>-ui e.g. magnum-ui etc.
17:36:14 <NobodyCam> sambetts: good point
17:36:24 <jroll> sambetts: that's what this is
17:36:29 <jroll> zhenguo is a horizon core
17:36:50 <sambetts> :) awesome
17:37:08 <NobodyCam> awesome.. good to move on?
17:37:19 <zhenguo> ok
17:37:26 <NobodyCam> #topic Mircoversion guideline
17:37:27 <NobodyCam> #link https://review.openstack.org/187112
17:37:38 <alex_xu> NobodyCam: thanks, it's my turn
17:37:44 <NobodyCam> yep
17:37:45 <NobodyCam> :)
17:37:48 <alex_xu> really hope you guys can give suggestion for microversion guideline in api-wg. The current version I think already address the concern between nova and ironic. Hope this can merged early then avoid there is third version created by other project :)
17:38:01 <alex_xu> the only different I think it is error response body compare to ironic spec. So I think the review won't be too hard. :)
17:38:16 <alex_xu> And one question I want to ask quickly at here
17:38:17 * lucasagomes adds to the TODO list
17:38:27 <alex_xu> neutron is going to implement microversion also. There is one more thing is "experimental" flag, which introduced in nova spec also, but nova currently don't want to support it. So want to you guys opinion whether Ironic want to support it.
17:38:50 <rloo> alex_xu: to date, ironic hasn't used the 'experimental' flag.
17:38:52 <jroll> alex_xu: as in an experimental microversion?
17:38:56 <jroll> I'd be very -1 on that
17:39:06 <lucasagomes> yeah we didn't use any experimetal flag
17:39:18 <rloo> alex_xu: does any project want the experimental flag? If not, just delete it.
17:39:21 <alex_xu> jroll: yes, it is expected to be a method to introduce new api
17:39:30 <dtantsur> oh please no
17:39:42 <rloo> I feel dtantsur's pain
17:39:46 <jroll> nova-baremetal was experimental, we saw how that went
17:39:51 <alex_xu> rloo: only in neutron spec now, neutron didn't implement it yet
17:39:54 <dtantsur> btw I'm planning to have basic support for microversions for inspector as well https://blueprints.launchpad.net/ironic-inspector/+spec/api-versioning
17:39:55 <jroll> -2 on ironic using the experimental flag from me
17:40:16 <rloo> -2 also. Just delete it and wait for (hopefully never) some project to ask for it.
17:40:19 <alex_xu> yea, people have concern that is a way to enable non-standard api
17:40:35 <lucasagomes> yeah, if it's exposed people will use it
17:40:37 <lucasagomes> regardless
17:40:58 <alex_xu> ok, looks like nova and ironic on same side, let me talk with neutron team :)
17:41:00 <rloo> well, we'd block it (I hope) but don't even provide it as a possibility. makes it easier then :)
17:41:30 <NobodyCam> ya
17:41:35 <jroll> to be clear
17:41:44 <jroll> I'm okay with it being part of the api-wg guidelines, saying it's ok
17:41:52 <alex_xu> ok, thanks all, no more question, but please help me on the review, really hope get consistent between nova and ironic first :)
17:41:52 <jroll> but I will never let a patch with that flag land in ironic
17:42:16 <alex_xu> jroll: ok, I see now
17:42:29 <rloo> jroll: but if that is in the guidelines, *someone* will say, hey, it is in the guidelines, so why can't it go into ironic. easier not to have that discussion.
17:43:02 <NobodyCam> :)
17:43:30 <NobodyCam> any other question for alex_xu
17:43:31 <jroll> rloo: that's what the -2 is for :P
17:43:32 <jroll> anyway
17:43:34 <dtantsur> alex_xu, on thing is not clear in guidelines IMO
17:43:38 <rloo> and jroll, we don't know who the future core reviewers will be for Ironic ;)
17:43:51 <dtantsur> alex_xu, in Ironic we used to "hide" new features, when old version is used
17:44:07 <dtantsur> alex_xu, we (at least some of us) no longer want to do it for non-breaking changes
17:44:22 <dtantsur> alex_xu, not sure if it's implied by the guideline or not
17:44:52 <rloo> dtantsur: oh, my head hurts. did we decide that? not to hide new features?
17:45:13 <alex_xu> ok, how about ask neutron team opinion again, if they still think expermentail usefule for them, I will bring this up to ML again, to see if whether we need put in api-wg
17:45:58 <dtantsur> rloo, we had an agreement between me, mordred and devananda :) but I'm close to -2 anything that will hide new features
17:46:22 <dtantsur> I was actually planning to propose patch removing this behavior for existing non-breaking microversions, and see what people say
17:46:38 <rloo> dtantsur: oh, didn't know that. we need some way to capture/communicate those things.
17:46:42 <NobodyCam> dtantsur: I'd like to see that patch
17:47:08 <NobodyCam> rloo: I believe it was just chatter at this point
17:47:08 <alex_xu> dtantsur: hide new features in old version is behavior nova we have i think
17:47:25 <dtantsur> alex_xu, that's what I'm strongly opposed to
17:47:35 <dtantsur> (and won't implement for inspector)
17:48:15 <rloo> alex_xu: guidelines are 'guidelines'. it doesn't mean that they have to be followed, right?
17:48:15 <alex_xu> dtantsur: why? the new feature only be introduced by new microversion
17:48:31 <dtantsur> alex_xu, I don't see a sane reason to do it for non-breaking change
17:48:39 <jroll> can we not have this conversation here for the millionth time
17:48:40 <dtantsur> (I obviously see a reason for a breaking change)
17:48:44 <jroll> take it to the ML
17:48:45 <lucasagomes> heh yeah
17:48:45 <dtantsur> jroll, ++
17:48:48 <NobodyCam> ++
17:48:50 <alex_xu> rloo: emm...but the goal is we have consistent implementation, at least for the part people want to supported I think
17:49:06 <alex_xu> jroll: ok
17:49:17 <jroll> alex_xu: sorry, but we've had this conversation in ironic a million times
17:49:30 <jroll> and we only have 10 minutes left
17:49:36 <dtantsur> ... and we can't come to agreement anyway
17:49:36 <NobodyCam> yep:
17:49:41 <rloo> jroll: but the decision is affected by the guidelines, depending on what it means to have guidelines.
17:49:49 <jroll> rloo: then review the guideline spec.
17:49:51 <alex_xu> jroll: I see, thanks let me talk about this also :)
17:49:54 <rloo> dtantsur: ^^
17:50:08 <NobodyCam> ok moving on?
17:50:11 <jroll> +1
17:50:14 <lucasagomes> yes
17:50:16 <NobodyCam> #topic Open Discussion / Food For Thought
17:50:23 * jroll eats this thought food
17:50:35 <NobodyCam> that was the last topic on the agenda
17:50:37 <dtantsur> nom-nom
17:50:39 <jlvillal> alex_xu: I wanted to say thanks for staying up so late to discuss this.
17:50:49 <lucasagomes> alex_xu, yeah totally, thank you
17:50:50 <alex_xu> jlvillal: :)
17:50:55 <jroll> if nobody has open discussion items feel free to continue with microversion discussions I guess
17:51:03 <NobodyCam> alex_xu: and for all the work you've put on this ..
17:51:04 <alex_xu> lucasagomes: np
17:51:05 <lucasagomes> naohirot, you had some concerns in the other topic. If u want to bring it up here
17:51:11 <jroll> but wanted folks to be able to speak up on other things
17:51:31 <NobodyCam> rloo: you had somehting I cut you off from above?
17:51:40 <jroll> lucasagomes: so I think in general it sounds like we aren't communicating priorities down to driver authors etc
17:51:53 <jroll> lucasagomes: or people not active in the day-to-day discussions in general
17:51:55 <rloo> NobodyCam: nope, i'm good. oh the subteam stuff.
17:52:09 <rloo> NobodyCam: did we want to decide about adding bifrost/inspector to subteam reports?
17:52:40 <lucasagomes> jroll, right, yeah well reviewing stuff is a bottleneck for us :-(
17:52:52 <rloo> jroll: +1. i thought there was some etherpad with liberty priorities. am trying to recall if it (priorities) was in the email deva sent out.
17:53:00 <wanyen> +1 fro adding bifrost and inspector to subteam report
17:53:03 <NobodyCam> rloo: I do like reading the subteam reports on the whiteboard just to keep uptodate on what going on
17:53:05 <jroll> lucasagomes: yeah, but sounds like naohirot has no ideas about what our priorities are right now (boot/deploy split etc)
17:53:10 <dtantsur> rloo, we can have a lazy consensus :)
17:53:11 <lucasagomes> we had a spreadsheet last cycle with some priorities
17:53:22 <dtantsur> +MANY of the spreadsheet again
17:53:23 <jroll> rloo: this was around brainstorming so not sure how accurate https://etherpad.openstack.org/p/ironic-liberty-priorities
17:53:27 <dtantsur> * for
17:53:30 <naohirot> lucasagomes: I got out of sync
17:53:37 <rloo> NobodyCam: if people think it would be useful to have bifrost/inspector, let's add them then.
17:53:51 <rloo> NobodyCam: as long as dtantsur and TheJulia are OK with providing that info :)
17:54:00 <jroll> yeah, that priorities etherpad isn't very clear
17:54:12 <lucasagomes> naohirot, I see, I think we all are kinda out of sync in the priorities right now? I think we all agree boot and deploy split is one of them
17:54:18 <lucasagomes> the network is another I would say
17:54:43 * dtantsur thinks ENROLL state aka finishing the damned state machine is a priority as well
17:54:51 <jroll> lol, +1 dtantsur
17:54:53 <lucasagomes> yeah
17:55:04 <NobodyCam> dtantsur: ++
17:55:10 <lucasagomes> so let's put it down folks in a spreadsheet like we had for Kilo? If people agree with it
17:55:22 * NobodyCam will try and get reviews done while traveling
17:55:26 <jroll> I'll admit we've been horrible about reviewing the irmc patches
17:55:26 <wanyen> jroll, any update from networking neturon vlan and port aggregation?
17:55:27 <lucasagomes> or etherpad, whatever is best
17:55:30 * naohirot I was invited to another channel. so I got lost what we are discussing right now
17:56:04 <NobodyCam> naohirot: it Open Discussion
17:56:08 <NobodyCam> it's*
17:56:14 <rloo> we should have priorities 'spelled out' for each cycle. somewhere.
17:56:19 <NobodyCam> with 4 minutes left
17:56:23 <jroll> rloo: lucasagomes +1
17:56:26 <jlvillal> +1 on documenting priorities
17:56:27 <naohirot> maybe I'll ask in the ironic channel.
17:56:44 <jlvillal> If priorities could be linked to patches for review, that is a big bonus too.
17:56:50 <NobodyCam> we can get BadCub to help there I believe
17:57:03 * jlvillal realizes that takes a lot of work to keep that in sync.
17:57:06 <rloo> i think email is good wrt priorities. etherpad is good too as long as folks don't modify it (too much). otherwise, the priorities will change and i won't know.
17:57:09 <NobodyCam> tracking and keeping things organazided
17:57:09 <dtantsur> ++ for assigning BadCub to everything :)
17:57:18 <NobodyCam> lol
17:57:32 <TheJulia> ++
17:57:36 <lucasagomes> jlvillal, https://docs.google.com/spreadsheets/d/1Hxyfy60hN_Fit0b-plsPzK6yW3ePQC5IfwuzJwltlbo/edit?pli=1#gid=1604970109
17:57:38 <lucasagomes> that's what we had
17:57:53 <dtantsur> we can continue it..
17:58:00 <NobodyCam> ya
17:58:01 <rloo> if it was clear wat the priorities were, would it help folks wrt reviews. i am a bit doubtful but i guess it won't hurt.
17:58:12 <lucasagomes> yeah we can create another tab for Liberty
17:58:14 <lucasagomes> and continue that
17:58:26 <dtantsur> rloo, it will help folks not to be disappointed that they're not getting too much attention. maybe..
17:58:27 <NobodyCam> ++ for tab per cycle!
17:58:42 <NobodyCam> rloo: and helps keep me focused
17:58:51 <jlvillal> First tab for current cycle :)
17:58:53 * NobodyCam can get sidetracked esaliy
17:59:01 <rloo> NobodyCam: well, if it will help you, then yes!
17:59:07 <NobodyCam> :)
17:59:19 <lucasagomes> jlvillal, heh ack
17:59:22 * jlvillal thinks order should be reversed.  So tabs are in reverse chronological order
17:59:28 <rloo> thanks for volunteering BadCub!
17:59:42 <NobodyCam> lol.. he has had to step away
17:59:42 <dtantsur> :)
17:59:53 <dtantsur> that's why we did it so easily, no?
17:59:53 <NobodyCam> he'll read al this in the log
17:59:54 <rloo> NobodyCam: that's fine. it is recorded here in the logs :)
18:00:01 <NobodyCam> one minute
18:00:08 <dtantsur> we can have #agreed on it :D
18:00:24 <rloo> dtantsur: or action item... ?
18:00:28 <dtantsur> ++
18:00:34 <dtantsur> we're out of time
18:00:39 <TheJulia> I thought we already had an action item for that
18:00:51 <lucasagomes> right I will put something in the spreadsheet
18:00:56 <lucasagomes> let's wrap it up
18:01:02 <lucasagomes> thank you all for the meeting!
18:01:05 <dtantsur> thanks!
18:01:07 <NobodyCam> thank you all
18:01:08 <sambetts> thanks o/
18:01:09 <cinerama> thanks folks
18:01:15 <jlvillal> Ciao
18:01:18 <NobodyCam> see ya in channel
18:01:23 <NobodyCam> #endmeeting