19:00:43 <devananda> #startmeeting Ironic
19:00:43 <openstack> Meeting started Mon Sep 29 19:00:43 2014 UTC and is due to finish in 60 minutes.  The chair is devananda. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:47 <openstack> The meeting name has been set to 'ironic'
19:00:50 <devananda> hi all!
19:00:54 <adam_g> o/
19:00:56 <devananda> as usual, agenda is posted here:
19:00:58 <devananda> #link https://wiki.openstack.org/wiki/Meetings/Ironic
19:01:01 <NobodyCam> morning / afternoon /eveing
19:01:24 <JayF> o/
19:01:30 <devananda> #topic announcements
19:01:37 <GheRivero> o/
19:01:46 <linggao> \o
19:01:52 <devananda> Only one from me
19:02:12 <devananda> I'm coordinating for us to have a presence in the Operator track on Monday in Paris
19:02:28 <NobodyCam> awesome!
19:02:30 <lucasagomes> nice!
19:02:40 <devananda> if anyone is giving a talk that day, please ping me after the meeting so we can make sure the scheduling doesn't conflict
19:02:56 <devananda> any other announcements from folks?
19:03:17 <NobodyCam> typing now
19:04:04 <NobodyCam> I would like to anmounce that will will be having some new folks joining our efforts. Please Welcome BertieFulton from SAP
19:04:17 <jroll> \o BertieFulton
19:04:19 <devananda> BertieFulton: hi!
19:04:20 <lucasagomes> BertieFulton, welcome :)
19:04:22 <JayF> welcome
19:04:23 <dtantsur> BertieFulton, o/
19:04:35 <BertieFulton> Thanks everyone
19:04:41 <NobodyCam> :)
19:05:09 <NobodyCam> there may also be other folks from sap joining
19:05:28 <devananda> BertieFulton: feel free to jump in, or just follow along, if taht suits you. there's somewhat of a structure to our meetings, with some open discussion at the end.
19:05:33 <NobodyCam> I don't see any of the other handles online at this time
19:05:43 <devananda> #topic Juno RC status
19:05:51 <devananda> #link https://launchpad.net/ironic/+milestone/juno-rc1
19:06:00 <devananda> as you can see, we still haven't tagged the RC
19:06:04 <devananda> which means Kilo is not open yet
19:06:12 <devananda> that'll all happen when there are no open bugs on that page
19:06:47 <devananda> several of us have been dog piling on the hash ring bug over the weekend
19:07:12 <devananda> #link https://review.openstack.org/#/q/status:open+project:openstack/ironic+branch:master+topic:hash-ring,n,z
19:07:41 <devananda> I'm going to keep working on that until it is done and merged
19:07:55 <adam_g> is there a chance https://bugs.launchpad.net/ironic/+bug/1310135 might get targeted to Juno?
19:07:56 <lucasagomes> yeah I hope tomorrow I will get something working for the take_over()
19:07:57 <uvirtbot> Launchpad bug 1310135 in nova "Stopping an instance via the Nova API when using the Nova Ironic driver incorrectly reports powerstate" [High,In progress]
19:07:57 <devananda> reviews would be appreciated as it's the only thing blocking our release at the moment
19:07:57 <rloo> devananda: so all four patches, including the one that is WIP?
19:08:03 <NobodyCam> I have sarted reviewing with the first patch in the set
19:08:20 <devananda> but ... there are some other bugs that have been found that I wnt to brin gup
19:08:36 <devananda> adam_g: that's one of them. we can target it, but I haven't coordinated that with Nova yet
19:08:55 <devananda> mikal: I don't suppose you're around?
19:09:19 <devananda> jogo: or perhaps you can help -- any chance we can target the fix for https://bugs.launchpad.net/ironic/+bug/1310135 to Juno?
19:09:20 <uvirtbot> Launchpad bug 1310135 in nova "Stopping an instance via the Nova API when using the Nova Ironic driver incorrectly reports powerstate" [High,In progress]
19:09:31 <NobodyCam> also not sure this is the correct place in the meeting but I would like to get more eyes on a couple of spec reviews before we open kilo https://review.openstack.org/#/c/103225 and https://review.openstack.org/#/c/121297
19:09:46 <devananda> this is another bug that's also been requested that we get a fix in Juno - https://bugs.launchpad.net/ironic/+bug/1367182
19:09:48 <uvirtbot> Launchpad bug 1367182 in ironic "Ilo* drivers should use only ilo credentials to maintain compatibility across releases" [Medium,In progress]
19:10:19 <devananda> I'm not thrilled with the patch they've proposed, however, so if it takes much longer to rework (longer than the other fixes we have in flight) I dont want to delay the release for it
19:10:43 <dtantsur> well, what they have now is not perfect, but it's something to start with
19:10:45 <devananda> I'm fine with it landing, if a reasonable fix is proposed in time
19:11:11 <lucasagomes> the fix would be to remove the namespacing from the driver options?
19:11:17 <devananda> dtantsur: it still exposes ipmi_* properties in the ilo driver, though
19:11:19 <dtantsur> at least we won't have to make too many com[atibility layers, if we decide to switch to something shared (like just username or bmc_username)
19:11:21 <lucasagomes> or using ipmi_ for ilo
19:11:22 <rloo> there's a workaround for that ilo bug though, right? ie, put in ipmi credentials.
19:11:48 <devananda> rloo: yes. the bug is just that the ilo driver -also- rquiers the user to put in ipmi user/pass
19:11:53 <devananda> which are effectively the same values
19:11:58 <dtantsur> devananda, but it no longer _requires_ them at least, right?
19:12:09 <devananda> so it's an API bug, essentially. not a functionality bug.
19:12:23 <rloo> devananda: right, so still can use. just not great. the hash-ring stuff though seems more urgent to fix.
19:12:30 <devananda> rloo: right
19:12:31 <wanyen> deva,
19:12:38 <lucasagomes> rloo, +1
19:12:40 <devananda> dtantsur: it requires them but automatically adds them for you
19:12:55 <dtantsur> devananda, IIRC it does not call node.save()
19:13:03 <dtantsur> so they're not persisted
19:13:07 <dtantsur> (I may be wrong)
19:13:19 <wanyen> deva, we have teh fix for 1367182 already.  we will submit that for review if upsteam is willing to consider it for juno.
19:13:50 <dtantsur> wanyen, isn't it https://review.openstack.org/#/c/124704/ ?
19:14:23 <wanyen> our last proposal was to dynamically convert ilo credentail to ipmi credential
19:14:45 <devananda> dtantsur: ah, if it's not persisted, then I thnk it's fine
19:15:10 <devananda> adam_g: on the Nova bug, what do you think of at least landing the Ironic side of the fix?
19:15:37 <dtantsur> devananda, I checked - it's not. so unless save() is called anywhere else, we're fine
19:15:40 <adam_g> devananda, i think that woudl narrow the race for sure
19:15:45 <devananda> are there any other bugs that folks feel should be targeted to Juno?
19:16:04 <lucasagomes> hmm I think I got one
19:16:05 <lucasagomes> lemme see
19:16:25 <lucasagomes> https://launchpad.net/bugs/1373671
19:16:26 <uvirtbot> Launchpad bug 1373671 in ironic "SSH driver does not work with non-english locale" [High,In progress]
19:16:34 <devananda> lucasagomes: ++
19:16:42 <lucasagomes> there's a fix in the review already, and tripleo ci have been rebuilt
19:16:44 <dtantsur> right, quite bad one
19:16:47 <lucasagomes> ok tagging
19:17:16 <dtantsur> I guess we'll land it long before hashring series :)
19:17:35 <devananda> the hash ring changes, up to but not including the periodic task, are probably ready to land now
19:17:46 <devananda> at least IMO :)
19:18:09 <lucasagomes> devananda, is the "online" field better documented? I will take a look after the meeting
19:18:13 <lucasagomes> cause that was a bit confusing
19:18:26 <dtantsur> ++
19:18:30 <devananda> lucasagomes: I posted that just before the meeting. but i'm happy to add more inline docs to it or change the name
19:18:47 <wanyen> dtantsur: yes https://review.openstack.org/#/c/124704/
19:18:48 <lucasagomes> devananda, ack, grand them :)
19:18:50 <lucasagomes> cheers
19:18:54 <lucasagomes> then*
19:19:02 <NobodyCam> devananda: if there are minor issues with the hash ring (not that I've found any) better to land and address with anothwer patch or fix before landng
19:19:32 <devananda> NobodyCam: if we find them, fix before landing, only because this is a release blocker
19:19:42 <NobodyCam> ack :)
19:19:48 <devananda> meaning that the release may be tagged at any time after all the targeted bugs are closed
19:19:59 <devananda> so if we need to do a follow on patch, we actually need to target it too
19:20:11 <devananda> *we would actually ...
19:20:23 <devananda> to communicate to the openstack release team that we aren't ready for them to release
19:20:35 <NobodyCam> ahh yes very good point
19:20:55 <devananda> any other questions on the release process, targeted bugs, etc?
19:20:57 <rloo> there's still rc2 or 3 before actual release, although it gets more onorous (sp) to fix bugs then, right?
19:21:12 <devananda> rloo: we should treat RC1 as though it's final
19:21:26 <devananda> rloo: and not tag it unless we actually dont know of any more blocking bugs
19:21:27 <rloo> devananda: of course!
19:21:40 <devananda> what happens when we tag RC1 is that we re-open master for Kilo development
19:21:54 <devananda> and after that, any bug fixes taht need to be applied to Juno need to be handled separately as a backport
19:22:24 <lucasagomes> there's a deadline to tag rc1 right?
19:22:27 * lucasagomes checks wiki
19:22:30 <devananda> rloo: so, hopefully, there actually won't be any rc2 or rc3 :)
19:22:50 <devananda> lucasagomes: the goal was last thursday. the deadline is when Juno final is released
19:22:50 <lucasagomes> #link https://wiki.openstack.org/wiki/Juno_Release_Schedule
19:23:00 <lucasagomes> gotcha
19:23:07 <lucasagomes> fair enuff
19:23:33 <devananda> ok, moving on
19:23:36 <devananda> #topic Kilo planning
19:23:38 <wanyen> deva, so can we target https://bugs.launchpad.net/ironic/+bug/1367182 for RC1?
19:23:39 <uvirtbot> Launchpad bug 1367182 in ironic "Ilo* drivers should use only ilo credentials to maintain compatibility across releases" [Medium,In progress]
19:24:10 <devananda> wanyen: I already did :)
19:24:22 <devananda> two things for this topic
19:24:25 <wanyen> deav, ty
19:24:35 <wanyen> s/deav/deva
19:24:56 <devananda> - kilo summit
19:24:59 <devananda> - kilo specs
19:25:25 <devananda> NobodyCam asked if we could open kilo specs today. I think that's fair
19:25:32 <devananda> though I still wont look at them until Juno is tagged :)
19:25:45 <dtantsur> I'm not against some good read :)
19:25:56 <lucasagomes> yeah, and lets remember that we've changed the way kilo specs are proposed
19:26:03 <lucasagomes> we better update the template first etc
19:26:08 <devananda> lucasagomes: right
19:26:14 <NobodyCam> we should land  before we open kilo https://review.openstack.org/#/c/103225 and https://review.openstack.org/#/c/121297
19:26:21 <devananda> I also think we should follow the lessons we learned (same ones Nova learned, too)
19:26:36 <devananda> specs are kinda heavy handed, and some patches just don't require a spec
19:26:43 <devananda> eg, cleanup and refactoring
19:27:15 <devananda> but don't be afrai to say "this change should be discussed, please propose a spec" if you feel that it would benefit from that
19:27:30 <NobodyCam> how about the stuff we talked about with the initial spec being just a paragraph or two
19:27:48 <devananda> NobodyCam: yep. for things that are probably larger, that's definitely good
19:27:55 <wanyen> deva, uefi spec already approved in Juno but we would like to do more in Kilo such as adding uefi support for ilo virtual meida ipa driver, do we need to submit a new spec for kilo?
19:28:05 <devananda> wanyen: yes
19:28:13 <jroll> devananda: we should send an email to the list about these things, when we open specs for kilo
19:28:16 <wanyen> deva, ok.
19:28:20 <jroll> about the short initial spec etc
19:28:21 <lucasagomes> jroll, +1
19:28:28 <devananda> wanyen: though it might be fairly simple, eg. just refer to the already approved spec and describe any differences
19:28:32 <jroll> so everyone is up to date on process
19:28:37 <devananda> jroll: indeed we should. sounds like you are volunteering :)
19:28:46 <jroll> bah
19:28:50 * jroll stops talking
19:28:52 <NobodyCam> lol
19:28:52 <lucasagomes> there was an email after the mid-cycle but it would be good to reinforce it
19:28:54 <devananda> jroll: lol
19:28:57 <lucasagomes> jroll, hah
19:29:02 <jroll> devananda: I can do that, I'll run a draft past you before I do
19:29:25 <devananda> jroll: thanks. also that seems to be the sort of thing JayF likes to do
19:29:32 <jroll> oh
19:29:37 * jroll steers his bus toward JayF
19:29:37 <wanyen> deva, okay. We will do that .
19:29:38 <NobodyCam> # action for jroll ?
19:29:45 <jroll> NobodyCam: yeah, that's fine
19:29:46 <JayF> Hey, I thought I had to say things to be volunteered to do things
19:29:57 <devananda> JayF: you've said things in the past. that's good enough :)
19:30:04 <JayF> You've removed a serious tool in getting me to stay quiet ;)
19:30:12 <devananda> \o/
19:30:31 * devananda likes it when everyoen has things to say
19:30:43 * JayF nominates jroll to do the email thing
19:31:00 <devananda> #agreed kilo specs to re-open this week, preceeded by an email describing the changes over Juno process
19:31:04 <lucasagomes> heh seems nobody really likes to send emails to the list
19:31:23 <jroll> lucasagomes: words are hard :)
19:31:33 <lucasagomes> jroll, yup
19:31:36 <devananda> #agreed Kilo specs may be initially done as a light-weight proposal only, to guage direction and interest before investing lots of time in a full spec
19:31:58 <dtantsur> may be or should be?
19:32:07 * dtantsur likes nit-picking
19:32:10 <jroll> may be
19:32:11 <devananda> may be
19:32:14 <dtantsur> ack
19:32:19 <devananda> I dislike process for process' sake
19:32:24 <dtantsur> ++
19:32:29 <romcheg> +!
19:32:32 <JayF> ++
19:32:36 <devananda> so if I know this thing is an approved direction, doing a light weight spec is still just a waste of time
19:32:38 <jroll> dtantsur: it's more of "if you are not sure that people will care at all about this feature"
19:32:40 <devananda> anyway :)
19:33:05 <dtantsur> heh it would help me a lot with my Juno discovery efforts :)
19:33:11 <devananda> any questions on Kilo at this point, without going into a discussion of actual features (lets save that for the specs or ML)
19:34:27 <devananda> I'm happy to see the gDoc getting longer :)
19:34:44 <devananda> oh, for reference, here's the link again for the summit planning
19:34:45 <devananda> #link https://docs.google.com/spreadsheets/d/1XBKdeDeGfaRYaThjIIoYRwe_zPensECnxsKUuqdoVmQ/edit#gid=0
19:35:22 <devananda> ok, moving on then
19:35:28 <devananda> #topic subteam reports
19:35:37 <adam_g> heya
19:35:47 <adam_g> so the parallel tempest jobs are now part of our check pipeline, non-voting
19:35:48 <devananda> adam_g, dtantsur, GheRivero - hi! how's everything?
19:35:51 <NobodyCam> devananda: anything more about us having a presence in the Operator track on Monday in Paris
19:35:54 <NobodyCam> oh nm
19:36:05 <adam_g> and the sideways grenade job should be showing up there soon too https://review.openstack.org/#/c/124562/
19:36:07 <devananda> NobodyCam: not yet. I'll pass on details when I have them
19:36:20 <GheRivero> nothing new for Juno
19:36:26 <devananda> adam_g: awesome work! thanks!
19:36:42 <adam_g> enabling parallel tempest tests tickles the race condition addressed by https://launchpad.net/bugs/1310135
19:36:43 <uvirtbot> Launchpad bug 1310135 in nova "Stopping an instance via the Nova API when using the Nova Ironic driver incorrectly reports powerstate" [High,In progress]
19:36:52 <adam_g> once that is addressed the job should be more stable and we can make it voting
19:37:18 <devananda> adam_g: I'd like to keep it non-voting for a few weeks to get some more data in logstash
19:37:28 <adam_g> devananda, +1
19:37:28 <devananda> adam_g: so we can spot other races it may be exposing
19:37:54 <lucasagomes> +1
19:38:04 <adam_g> jroll, did you ever make any progress on getting the agent ramdisk booting with lower memory?
19:38:04 <devananda> adam_g: do you know if its logs are going to be available there already? I haven't actualy checked ...
19:38:39 <jroll> adam_g: not really, I think DIB images will be our only option, I got pulled into some other things
19:38:39 <adam_g> devananda, for those tests? yeah, they should all be available in logstash AFAIK
19:38:50 <adam_g> jroll, ah, ok
19:38:51 <devananda> #info tempest parallel test has exposed https://launchpad.net/bugs/1310135 - fixes are proposed to nova and ironic
19:38:53 <uvirtbot> Launchpad bug 1310135 in nova "Stopping an instance via the Nova API when using the Nova Ironic driver incorrectly reports powerstate" [High,In progress]
19:39:01 <jroll> adam_g: still on my radar to get done asap
19:39:19 <devananda> #info tempest parallel test shoudl stay non-voting for a few weeks of stability while we gather logstash data and ensure it is stable before enabling voting
19:39:35 <devananda> adam_g: cool
19:39:54 <devananda> GheRivero: thanks! no news is good news in this case :)
19:40:02 <NobodyCam> ++
19:40:18 <devananda> jroll: anything else to report on IPA?
19:40:32 <jroll> devananda: I don't think so; JayF anything from you?
19:40:45 <devananda> linggao: hi! anything to report on ipminative / pyghmi ?
19:40:59 <JayF> I don't believe I have anything to report either.
19:41:01 <devananda> wanyen: hi! anything (besides the bug we already covered) to report on the iLo driver?
19:41:02 <JayF> I would mention that
19:41:02 <linggao> hi devananda, nop
19:41:13 <JayF> w/r/t IPA tempest testing, getting it running in less ram requires getting DIB elements
19:41:17 <NobodyCam> linggao: just  big thank you fir check-ironic-xcat-third-party
19:41:20 <JayF> and I believe that NobodyCam is working on that atm
19:41:30 <wanyen> we submitted ios script to dib. we did tsetingfor bios-only, legacy and uefi mode.
19:41:33 <devananda> JayF: ah, cool. NobodyCam, how's that going?
19:41:37 <wanyen> s/ios/iso
19:41:52 <devananda> wanyen: nice! can you paste a link to that review here for us?
19:42:00 <linggao> NobodyCam, glad to contribute something.
19:42:01 <jroll> JayF: devananda: yuriy was also working on that :)
19:42:19 <JayF> wanyen: you probably know this but for the sake of the meeting, the `make iso` target landed for the IPA CoreOS  builder
19:42:20 <jroll> (neither work yet)
19:42:46 <NobodyCam> devananda: I will prob be picking up from yuriz work here: https://review.openstack.org/#/c/103105
19:43:20 <devananda> NobodyCam: ++
19:43:46 <dtantsur> anyone wants bug numbers? :)
19:43:55 * NobodyCam does
19:43:56 <lucasagomes> yes?
19:44:04 <dtantsur> Open: 94 (-6). 3 new (0), 26 in progress (-6), 0 critical, 12 high (+2) and 4 incomplete (0); juno-rc1: 6 (-9)
19:44:18 <dtantsur> so good job closing tasks in progress
19:44:18 <NobodyCam> oh luv the -
19:44:21 <devananda> dtantsur: of course :) thought I pinged you at the start of this topic, sorry
19:44:31 <lucasagomes> :) nice
19:44:37 <wanyen> eav, link https://review.openstack.org/#/c/123642/
19:44:46 <dtantsur> also, we reduced number of open bugs by ~40 during this month
19:44:57 <lucasagomes> o/
19:44:58 <dtantsur> (also thanks to nova folks taking part of our headache))
19:45:10 <devananda> #info ISO target for iLO driver proposed to disk-image-builder at https://review.openstack.org/#/c/123642/
19:45:11 <NobodyCam> great work everyone!!!!
19:45:23 <dtantsur> I see open bugs <100 as a great milestone
19:45:31 <wanyen> JayF: yes. Tx
19:45:32 <dtantsur> and that's all from me :)
19:45:41 <devananda> dtantsur: that reminds me, for bugs that affect Ironic but where the fix is only necessary within the Nova driver
19:45:48 <lucasagomes> dtantsur, cheers, +1 for the < 100 ob
19:45:49 <devananda> dtantsur: we should probably mark the Ironic side as wont-fix
19:45:52 <devananda> I did that for several last week
19:46:14 <dtantsur> devananda, me too some time ago, but I didn't finish back then
19:46:14 <devananda> otherwise they are likely to be left dangling and open on our side, and require manually closing them later
19:46:26 <devananda> dtantsur: cool, thanks. I think we're good now :)
19:46:34 <lucasagomes> won't fix or invalid?
19:46:34 <dtantsur> devananda, I'll revisit bug list this week just in case
19:47:19 <devananda> lucasagomes: I'm going to go with wontfix ... which I think is in line with what nova wants
19:47:19 <lucasagomes> it sounds more like invalid for me because the code is not in our tree so can't be fixed in ironic
19:47:26 <lucasagomes> right
19:47:32 <devananda> but the bug is not itself invalid
19:47:35 <lucasagomes> just to confirm in case I see some and have to close
19:47:38 <devananda> it's just not fixable within this project
19:47:42 <lucasagomes> devananda, invalid for ironic I meant
19:47:45 <lucasagomes> oh
19:47:58 <lucasagomes> right, yeah... I happy with any, just to know which one to use
19:48:09 <devananda> yea. i'm not sure it matters, but we should be consistent
19:48:14 <devananda> so let's go with "wontfix" :)
19:48:19 <lucasagomes> ok :)
19:48:34 <devananda> also, following sdague's email about nova bug statuses, and the edits to the openstack Bug wiki page
19:48:50 <devananda> please start using status:confirmed for bugs taht we have confimred
19:49:11 <devananda> and status:triaged *only* if the bug report contains a suggested solution/fix, but not any code
19:49:47 <devananda> #topic open discussion
19:49:54 <dtantsur> devananda, right, I also noticed that. Launchpad has different definition :(
19:49:54 <harshada_kakad> hi , have anyone launched instance in ironic using ubuntu/centos image?
19:49:55 <devananda> look! 10 minutes of open discussion :)
19:50:11 <NobodyCam> BertieFulton: how was your first meeting. Can I ask are there any areas you would to focus your efforts on began with?
19:50:20 <devananda> harshada_kakad: hi! I don't understand your question?
19:50:53 <lucasagomes> harshada_kakad, you mean ubuntu being the host os for the ironic services and centos the tenant image?
19:50:58 <harshada_kakad> i want to launch baremetal instance using image ubuntu/centos ///
19:51:15 <jroll> harshada_kakad: it has been done, I don't see what the issue would be
19:51:19 <BertieFulton> NobodyCam: Very informative would be the best description.
19:51:22 <jroll> harshada_kakad: ironic just writes an image to disk
19:51:30 <lucasagomes> harshada_kakad, ok, but did u try and it fail? what happened?
19:51:55 <devananda> harshada_kakad: ubuntu and centos are different distributions of linux. Ironic can write out -any- disk image, not just those.
19:52:11 <harshada_kakad> i m trying to get kernel and initeramfs using disk-image builder for centos7..
19:52:39 <lucasagomes> harshada_kakad, right, I think you should talk to the guys at #tripleo about it
19:52:53 <harshada_kakad> but it fails as there is no busybox for centos7 ...
19:53:09 <devananda> harshada_kakad: the developer meeting is not the best time to ask usage questions. Please ask usage questions on the openstack@ mailing list
19:53:15 <harshada_kakad> and due to which cnt launch instance using centos
19:53:17 <NobodyCam> BertieFulton: : I know the first meeting can be overwhelming
19:53:32 <harshada_kakad> ok
19:53:45 <NobodyCam> BertieFulton: We're here (mostly in #openstack-ironic) to help
19:54:17 <BertieFulton> NobodyCam: I think we have a number of areas we would like to focus our efforts on. Boot from Volume is a big area of interest for us
19:54:49 <devananda> so, I dunno about everyone else, but I'm really looking forward to Paris :)
19:54:56 <lucasagomes> o/
19:55:09 <devananda> BertieFulton: there have been several discussions about boot from volume, along two avenues
19:55:14 <wanyen> BertieFulton, boot from SAN volume?
19:55:30 <BertieFulton> wanyen: and NFS
19:55:36 <devananda> BertieFulton: a) using iPXE to mount an iSCSI volume from the ramdisk, then boot from that
19:55:42 <NobodyCam> BertieFulton: that would a great area to jump in with ... but as you can see ^^^^ also a very active area
19:56:09 <lucasagomes> ^ ! /me has big plans for ipxe for K
19:56:10 <devananda> BertieFulton: using an FC card and HBA to attach at the hardware level, then config the machine's bios to boot from that
19:56:13 <BertieFulton> NobodyCam: I'm thinking I maybe should backtrack and fix some bugs for a while :)
19:56:41 <JayF> lucasagomes: BertieFulton: I would love boot from block from block with ipxe support
19:56:51 * JayF needs to start hacking on bonding support for pxe
19:56:53 <JayF> lol
19:56:57 <devananda> BertieFulton: starting with bug fixes is great! look for the low-hanging-fruit tag
19:57:30 <devananda> BertieFulton: https://bugs.launchpad.net/ironic/+bugs?field.tag=low-hanging-fruit
19:57:31 <lucasagomes> JayF, yeah once we separate the boot interface from deploy interface that will be easier
19:57:36 <NobodyCam> oh we have a LHF tag... kewl... /me learns something new
19:58:16 <BertieFulton> devananda: thanks, will do :)
19:58:30 * devananda reminds the bug team to use the LHF tag :)
19:58:54 <NobodyCam> two minutes
19:59:12 <devananda> might as well end a minute early
19:59:17 <devananda> cheers - thanks everyone!
19:59:23 <wanyen> tx
19:59:23 <lucasagomes> thanks everyone
19:59:25 <BertieFulton> Thanks very much
19:59:30 <jroll> thanks y'all :)
19:59:35 <devananda> #endmeeting