19:01:40 <devananda> #startmeeting ironic
19:01:41 <openstack> Meeting started Mon Aug 11 19:01:40 2014 UTC and is due to finish in 60 minutes.  The chair is devananda. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:44 <openstack> The meeting name has been set to 'ironic'
19:01:55 <devananda> Hi! As usual, the agenda can be found here:
19:01:58 <devananda> #link https://wiki.openstack.org/wiki/Meetings/Ironic
19:02:06 <devananda> #chair NobodyCam
19:02:07 <lucasagomes> NobodyCam, yup, she was on today
19:02:08 <openstack> Current chairs: NobodyCam devananda
19:02:12 <JayF> o/
19:02:14 <GheRivero> o/
19:02:22 <NobodyCam> lucasagomes: :)
19:02:27 <linggao> o/
19:02:35 <devananda> hm, ok. I hope she's actually back -- there are some -2's she needed to lift last tiem I checked
19:02:37 <rloo> o/
19:02:40 <devananda> #topic announcements
19:02:53 <devananda> rloo: hi! welcome back :)
19:03:00 <rloo> hi devananda.
19:03:07 <rloo> lifted ;)
19:03:12 <devananda> awesome, thanks
19:03:23 <devananda> so, probably the biggest announcement for the week -- it's my last meeting before I'm on vacation
19:03:34 <NobodyCam> :)
19:03:46 <devananda> I will probably be reachable on my cell phone if the planets align just-so ...
19:03:51 <NobodyCam> devananda: three weeks
19:03:57 <devananda> but really. From 8/18 - 9/3, I'm *GONE*
19:03:59 <NobodyCam> enjoy
19:04:03 <devananda> I totally trust all of you :)
19:04:08 <mrda> lol
19:04:13 <lucasagomes> heh o/
19:04:20 <devananda> especially NobodyCam to run the meetings and lucasagomes to represent us in the weekly project sync's with ttx
19:04:20 <lucasagomes> enjoy the holidays
19:04:23 <NobodyCam> party ar deva house
19:04:44 <NobodyCam> ar=at
19:04:48 <devananda> my goal for this week, and to a degree, this meeting, is to make sure all the plans are clear
19:04:56 <devananda> so ya'll do not feel blocked in my absense
19:05:20 <devananda> so as the meeting goes on, please raise any concerns about that in the relevant subject area
19:05:26 <devananda> also -- the day after I get back is feature freeze!
19:05:36 <devananda> #link https://wiki.openstack.org/wiki/Juno_Release_Schedule
19:06:11 <devananda> one other small announcement - I've taken fedora support off the standing agenda
19:06:34 <devananda> according to dtantsur, it's been stable for a while, so we can free up that slot
19:06:35 <NobodyCam> and our spec freeze today?
19:06:41 <matty_dubs> Nice work, dtantsur!
19:06:49 <dtantsur> :)
19:06:50 <NobodyCam> awesome :)
19:06:51 <mrda> good job!
19:06:58 <devananda> #topic release cycle status
19:07:07 <devananda> so - as I said, featuer freeze is in 3 weeks
19:07:22 <JayF> devananda: I'd strongly suggest, esepecially given you're leaving and the status of the open specs that sit, that we go ahead and say we're done with spec approvals for J
19:07:26 <devananda> a few months back, I'd said feature proposal freeze would be this thursday. I'd actually like to close it today.
19:07:33 <devananda> JayF: exactly
19:07:52 <devananda> as point of reference, most (if not all) other projects closed their specs a few weeks ago
19:07:54 <NobodyCam> +!
19:07:56 <NobodyCam> +1
19:08:02 <devananda> I wanted to wait until a week after our sprint. so here we are
19:08:26 <rloo> is it fair to change the date?
19:08:40 <rloo> (not that I have any specs, but for those that do)
19:08:48 <NobodyCam> awesome job everyone with reguard to our first round of specs
19:08:55 <devananda> rloo: there has been PLENTY of time for folks to propose and iterate on specs
19:08:56 <Shrews> yeah, good job on that, spec cores
19:09:00 <JayF> rloo: The proposal freeze has already passed, and there are not any open specs, IMO, that are ready for Juno
19:09:05 <lucasagomes> sounds good... we gotta also talk maybe in the open discussion what we are doing with the specs that are in the queue and will be moved to K, if they should adhere to the new spec format first (having only an introduction) etc...
19:09:08 <devananda> rloo: and all the ones that are left are actually ones I don't think we can do
19:09:26 <rloo> ahh, in that case, no need to change the date, just don't approve any cuz they aren't ready.
19:09:36 <harshada_kakad> so cnt the open spec be approved ??
19:10:23 <devananda> any cores or spec-cores object to closing spec reviews for Juno today?
19:10:42 <NobodyCam> harshada_kakad: do you have a link?
19:10:45 <devananda> (will give it a minute for folks to say something)
19:10:51 <rloo> yeah, I object
19:10:55 <NobodyCam> devananda: yes please.
19:11:02 <harshada_kakad> https://blueprints.launchpad.net/ironic/+spec/seamicro-serial-console
19:11:14 <harshada_kakad> i had put up this in agenda too ...
19:11:24 <dtantsur> harshada_kakad, what's the spec link for it?
19:11:48 <NobodyCam> harshada_kakad: ya do you a spec up?
19:11:50 <lucasagomes> harshada_kakad, there's a spec for it? or just the bp page?
19:12:04 <devananda> harshada_kakad: this BP was proposed after the spec-proposal deadline. I'm sorry, but it will have to wait for K.
19:12:04 <harshada_kakad> syeap just the BP page ..
19:12:12 <JayF> devananda: ++
19:12:13 <harshada_kakad> i dnt have any spec ..
19:12:14 <devananda> harshada_kakad: and it needs a spec
19:12:38 <devananda> rloo: would you prefer we simply dont approve any more, then close it officially on thursday?
19:12:41 <dtantsur> harshada_kakad, please have a look at https://wiki.openstack.org/wiki/Ironic/Specs_Process
19:12:46 <harshada_kakad> actually i am almost ready with the code cahnges ...
19:12:47 <harshada_kakad> :(
19:12:52 <rloo> just looking at the proposed timeline. Aug 14 was supposed to be a spec review day and sept 4 unmerged J spec proposals must rebase on K
19:12:57 * NobodyCam makes note to self to watch bp's more closely
19:13:22 <JayF> rloo: There are no spec proposals in the pipeline that will be merged for J that aren't already, afaict
19:13:28 <rloo> devananda: yeah, I'd prefer not closing it officially cuz that goes against the proposed timeline. I don't know if there is someone who isn't here, that might want to push for their spec to be approved.
19:13:33 <devananda> rloo: in retrospect, that was a mistake on my part. Alsow hat JayF just said
19:14:06 <JayF> rloo: NobodyCam and I have worked really hard (along with others) to get the specs landed that are going to have a chance at getting in for J
19:14:17 <devananda> rloo: as JayF said, there are more specs proposed which I think could land in J -- they are too contentious, or were proposed too late.
19:14:18 <JayF> rloo: if you have a specific spec in mind that we should reconsider, please point it out and lets take a look at it
19:14:37 <rloo> devananda, JayF: if that is the case, then I guess it is OK to change the date/make it official since none seem ready.
19:14:50 <NobodyCam> devananda: we can concider the close to EOD today?
19:14:57 <devananda> NobodyCam: sure
19:15:12 <harshada_kakad> yeap that would really be better ..
19:15:23 <NobodyCam> rloo: harshada_kakad: I'm happy to look at specs until eod if needed
19:15:29 <rloo> I don't have any specs in mind, I just want to make sure that we are being fair to folks that might not be here to voice their opinion.
19:15:43 <dtantsur> just a reminder: we're way past spec proposal deadline
19:15:49 <devananda> #agreed spec freeze moved to EOD today, instead of EOD thursday.
19:16:07 <NobodyCam> rloo: if its supper critical folks can ask for an execption if they are not here now
19:16:09 <harshada_kakad> i guess in BP i have put up all the deatils ...
19:16:17 <NobodyCam> that does not say they'll get it
19:16:19 <NobodyCam> but...
19:16:30 <devananda> #info None of the remaining specs proposed in time for Juno are likely to be landed anyway (they are contentious / related to discovery in some way / need to be discussed at the summit)
19:17:01 <devananda> harshada_kakad: your proposal for seamicro is really too late in the cycle. It should be proposed once Kilo opens.
19:17:04 <JayF> harshada_kakad: http://lists.openstack.org/pipermail/openstack-dev/2014-August/041960.html this lays out our process for getting things spec'd for K
19:17:18 <harshada_kakad> ohh ok ..:(
19:17:25 <JayF> harshada_kakad: And feel free to start writing code, and put it up as WIP, although we're likely to -2 until K opens
19:17:32 <lucasagomes> +1 ^
19:17:33 <dtantsur> devananda, heh, we need to solve this miscomunication somehow...
19:17:41 <NobodyCam> #link http://lists.openstack.org/pipermail/openstack-dev/2014-August/041960.html
19:17:43 <JayF> harshada_kakad: I know it's no fun, we have to do that for many of our features we're using at Rackspace, and work to get them in alter :)
19:17:45 <JayF> *later
19:17:48 <devananda> dtantsur: I think we just did :)
19:17:49 <harshada_kakad> cnt we do anything to go in JUNO ...
19:17:57 <devananda> harshada_kakad: bug fixes
19:18:04 <devananda> harshada_kakad: please come fix bugs for Juno. or write docs :)
19:18:09 <harshada_kakad> i have really worked hard for it ..
19:18:33 <harshada_kakad> yeap i have actually stared looking after that as well ....
19:18:44 <devananda> harshada_kakad: that's nice. but this is an open community of developers, with a process that we all adhere to
19:18:58 <harshada_kakad> but it would be good if mine this BP cud go in ....
19:19:11 <devananda> harshada_kakad: I am delighted taht you want to contribute to Ironic, and we'll all be happy to help. but it's too late for a new feature in Juno.
19:19:14 <harshada_kakad> yeap i understand tht ...
19:19:15 <devananda> moving on
19:19:18 <devananda> #link https://launchpad.net/ironic/+milestone/juno-3
19:19:19 <dtantsur> sorry, can we leave it to open discussion?
19:19:28 <devananda> we have A LOT still to do in the next three weeks
19:19:43 <devananda> there are 7 BP in "needs code review"
19:19:50 <devananda> one unknown and one "started" ?
19:20:00 <lucasagomes> yup expect me to poke the authors in the next weeks about the status of the approved specs/bp
19:20:20 <wanyen> I don't see uefi boot on the juno list.  The spec has been approved.
19:20:25 <devananda> yea, lucas is goign to be tracking the progress towards Juno-3 while I"m gone
19:20:30 <devananda> wanyen: thanks. Let me fix that
19:20:43 <wanyen> deva, thanks!
19:20:54 <devananda> are there any other specs approved but not relfected on the juno-3 status page?
19:20:58 <devananda> I've tried to get them all, but ...
19:21:12 <devananda> oh, but I haven't updated it since friday :)
19:21:41 <Shrews> devananda: i had one for nodelocked retry
19:21:42 <lucasagomes> devananda, the drac one confuses me... the boot management is part of a interface that was already merged I don't understand why we need a spec to actually implement one already agreed interface... but anyway, I will check with ifarkas the status of that
19:21:58 <rameshg87> devananda, there is one more. ilo virtual media-ipa deploy driver.
19:22:03 <devananda> Shrews: didn't that get completed in J2 ?
19:22:05 <dtantsur> lucasagomes, he's on PTO, I guess will get back to it soon
19:22:12 <lucasagomes> dtantsur, yup
19:22:16 <Shrews> devananda: ah right, thats j3. nm
19:22:25 <JayF> lucasagomes: the drac proposal that I -2'd was related to node discovery and raid configuration. I think the drac power driver is already in.
19:22:40 <devananda> JayF: yep
19:22:50 <lucasagomes> JayF, yeah, the power is... I'm talking about the spec for Drac to implement the management interface
19:23:04 <JayF> lucasagomes: do you have a link?
19:23:10 <devananda> wanyen, rameshg87: ilo-virtualmedia-ip and uefi-boot are now targeted
19:23:12 <lucasagomes> JayF, which is grand, it was approved but I'm more questioning whether we needed a spec for that or not
19:23:16 <devananda> please update the BP statuses
19:23:26 <lucasagomes> JayF, https://blueprints.launchpad.net/ironic/+spec/drac-management-driver (will get the spec link)
19:23:44 <mrda> I think we should clarify the *purpose* of specs - is it for new interfaces, or significant new work?  That difference might account for DRAC power management.
19:23:45 <dtantsur> lucasagomes, I remember having some discussion with Imre on it, so I guess it was helpful :)
19:23:45 <wanyen> deva, ilo vitualmedia now has two spec.  should we call them out seperately?
19:23:47 <JayF> lucasagomes: the spec is merged
19:23:54 <JayF> lucasagomes: http://git.openstack.org/cgit/openstack/ironic-specs/plain/specs/juno/drac-management-driver.rst is what the spec link goes to
19:23:59 <JayF> lucasagomes: it's already in
19:24:00 <lucasagomes> JayF, yup it's...
19:24:03 <devananda> wanyen: each spec needs a separate BP on launchpad
19:24:55 <devananda> dtantsur: you're right -- we need to make the PROCESS more clear
19:25:34 <wanyen> deva, so we will put both ilo vitual edia iscsi and ipa sboth under ilo virtual media deploy driver bucket
19:25:36 <devananda> #info we should better document and communicate the spec process (interactions with launchpad in particular) for Kilo
19:25:48 <dtantsur> I came to an unusual conclusion that specs can be actually helpful for refactoring
19:26:08 <dtantsur> but that's another long story :)
19:26:12 <devananda> wanyen: every spec requires a separate blueprint on launchpad, with the same name as the spec file
19:26:19 <rameshg87> wanyen, we have two blueprints right now - one for ilo virtual media-iscsi and another one for ilo virtual media-ipa
19:26:53 <wanyen> reamesh, ok. So, my question is taht we should put both specs on teh Juno list
19:26:58 <lucasagomes> dtantsur, heh bring to the open topics? sounds interesting
19:27:10 <devananda> so, there are a lot of blueprints (featuers) targeted to Juno3
19:27:12 <dtantsur> lucasagomes, maybe
19:27:28 <wanyen> right now the juno list only listed ilo virtul media deploy driver.  Shouldwe update it to reflect the new bps?
19:27:29 <devananda> far far more than we had aimed at any other milestone in this (or the last) cycle
19:27:49 <rameshg87> wanyen, both the specs are now in the juno list. devananda just updated it now.
19:28:18 <wanyen> raemesh, ok.  Tx.  Sorry I didn't look at the newest list.
19:28:33 <NobodyCam> devananda: we have more folks working on ironic this cycle too :)
19:28:35 <devananda> lucasagomes: what's blocking the new mgmt iface BP from being "implemented" ?
19:28:40 <devananda> NobodyCam: true :-D
19:28:49 <lucasagomes> devananda, tempest
19:29:16 <lucasagomes> devananda, having tempest test to the new api was part of the spec, there's a patch up in tempest (will get the link) that still needs to be merged
19:29:44 <lucasagomes> #link https://review.openstack.org/#/c/113276/
19:30:01 <devananda> lucasagomes: awesome. please comment on the whiteboard to taht effect.
19:30:08 <lucasagomes> will do
19:30:16 <devananda> I've updated priority on two BPs
19:30:23 <devananda> bumped https://blueprints.launchpad.net/ironic/+spec/support-external-dhcp to LOW
19:30:31 <devananda> bumped https://blueprints.launchpad.net/ironic/+spec/ironic-ilo-virtualmedia-driver to HIGH
19:30:40 <devananda> are there any concerns about the current prioritization of BPs?
19:31:15 <JayF> Aside: Support external DHCP has code up for review already, and I'm sure Ellen would appreciate reviews if someone can spare a moment.
19:31:47 <jroll> ^ it's looking pretty close
19:31:58 <NobodyCam> should we bump ilo-virtualmedia-ipa to high?
19:32:01 <JayF> The person authoring that change on Rackspaces' side has their internship end on Friday, and it'd be very nice if we could get this merged before she leaves.
19:32:47 <devananda> I don't see code for https://blueprints.launchpad.net/ironic/+spec/uefi-boot-for-ironic on its whiteboard (jsut a link to the spec)
19:32:56 <devananda> rameshg87: is there code up for that yet?
19:33:23 <rameshg87> devananda, code is not raised for review yet for uefi
19:33:31 <lucasagomes> JayF, added to my todo list here, will review it tomorrow morning
19:33:35 <JayF> Thanks lucas
19:33:39 <devananda> rameshg87: how soon do you expect it to be ready?
19:33:54 <wanyen> deva, the code is alomost ready.  we should be able to put up on review very soon
19:34:02 <wanyen> I met the code for uefi boot
19:34:17 <wanyen> s/met/meant
19:34:29 <devananda> wanyen: thanks. at this point, there are 3 weeks to land it. please post the code soon
19:34:41 <wanyen> dev, will do.
19:34:47 <wanyen> s/dev/deva
19:35:23 <devananda> ok -- any last minute questions on the plan for J3 befoer we move on?
19:35:31 <devananda> we're past the midpoint and still have all the subteam reports
19:35:57 <NobodyCam> deva with you gone .. at what point should we bump blueprints with no code? or no progress?
19:36:07 <devananda> don't bump them
19:36:11 <devananda> nag the owners
19:36:12 <NobodyCam> ack
19:36:29 <devananda> I'll get back and do a sanity check with lucas on the progress
19:36:45 <NobodyCam> :)
19:36:53 <devananda> assuming ironic still works, I'll tag Juno3 and start the feature freeze
19:37:03 <JayF> What about any remaining open specs? At the end of the day -2 them and welcome them to resubmit when K opens?
19:37:04 <devananda> anything that was really close can apply for a FFE at that point
19:37:07 <jroll> heh
19:37:14 <devananda> JayF: yep. and FFE's
19:37:15 <jroll> "assuming ironic still works"
19:37:20 * jroll breaks everything
19:37:24 <dtantsur> I like it too ^^^
19:37:50 <devananda> by that i mean, like, somejhow if our gate is broken (or all of openstacks' gate is broken) then I won't, you know, tag anything
19:37:52 * NobodyCam pokes jroll and dtantsur with a stick :-p
19:38:09 <dtantsur> :)
19:38:14 <devananda> ok, moving on :)
19:38:19 <devananda> #topic subteam status reports
19:38:26 <devananda> adam_g: hi!
19:38:32 <adam_g> hey!
19:38:40 <devananda> adam_g: you've done some awesome things with tempest lately - -can you (link to a) summary?
19:38:54 <adam_g> massive summary of all CI related stuff @ https://etherpad.openstack.org/p/IronicCI
19:39:12 <NobodyCam> #link https://etherpad.openstack.org/p/IronicCI
19:39:23 <adam_g> two of the most urgent topics is grenade testing and getting tempest smoke tests passing, grenade is dependent on the latter
19:39:34 <adam_g> #link https://review.openstack.org/#/q/topic:ironic_grenade,n,z
19:39:40 <adam_g> #link https://review.openstack.org/#/q/topic:ironic_tempest,n,z
19:39:56 <devananda> ooh, and thanks for using topics :)
19:40:09 <adam_g> i think the majority of the grenade stuff is up on gerrit and ready for review, there may be some related work elsewhere to get stuff in the gate and actually passing
19:40:24 <adam_g> Shrews has been picking up the final loose ends up on the tempest front and i believe he's got some final patches up as well
19:40:55 <adam_g> some of the large patch queue has started to land, i think others will probably be blocked until sdague is back from vacation next week
19:41:09 <adam_g> but im hoping to have most of it flushed through before then, so we can work with him and infra in getting this stuff enabled in the gate
19:41:27 <devananda> yea. we need both of those in place fairly soon
19:41:37 <JayF> If anyone has pull with any of the devstack folks, I know IPA has two patches outstanding to openstack-dev/devstack for IPA devstack support to land. Which works from my testing and jroll's testing
19:41:37 <adam_g> devananda, by feature freeze, right?
19:41:50 <devananda> noav  will probably grant us a FFE for the migration tests
19:41:53 <JayF> Then the reviews are already up to allow IPA to test as well
19:41:58 <lucasagomes> yup I got the iPXE patch on devstack as well
19:41:58 <devananda> but only if it looks REALLY close to done at that point
19:42:14 <lucasagomes> jroll, btw, I updated the iPXE patch to workaround that cleanup/apache error
19:42:22 <lucasagomes> in case u wanna try it again
19:42:27 <jroll> lucasagomes: oh, nice, I'll check that out again
19:42:28 <NobodyCam> lucasagomes: link to ipxe patch
19:42:35 <adam_g> devananda, ack.
19:42:43 <jroll> lucasagomes: was that fix in the devstack patch or?
19:42:51 <lucasagomes> #link https://review.openstack.org/#/c/99677/
19:42:57 <NobodyCam> TY
19:43:02 <jroll> ok, cool
19:43:25 <adam_g> its worth noting  that we wont be able to enable parallel tempest testing until a new version of eventlet is released upstream, to address https://bugs.launchpad.net/ironic/+bug/1321787.  we will probably just need to keep it smoke-serial until that is released, and then flip the switch once the new version is available on the slaves
19:43:26 <devananda> dtantsur: any big news on bugs? if not, I'd like to skip this time as we need to focus on features for the next 3 weeks.
19:43:27 <uvirtbot> Launchpad bug 1321787 in tripleo "Paramiko does not properly work with eventlet concurrency" [High,Triaged]
19:43:42 <dtantsur> Open: 133 (+2). 8 new (+1), 35 in progress (-1), 0 critical, 15 high (+1) and 8 incomplete (-1)
19:43:46 <jroll> JayF: fyi it seems like most of devstack-core is on vacation :(
19:43:52 <dtantsur> that's it, I still need help triaging some bugs
19:44:03 <dtantsur> that require deeper knowledge of nova
19:44:07 <dtantsur> that's all from me
19:44:22 <NobodyCam> dtantsur: please feel free to ping /me i'm happy to help
19:44:24 <devananda> dtantsur: thanks. feel free to poke me on IRC if there are specific bugs that you want eyes on. I used to be nova-core, so I can probably help with those
19:44:38 <devananda> dtantsur: or poke comstud - he knows much more about nova than I do :)
19:44:52 <dtantsur> ack, thanks!
19:45:11 <jroll> yes, give everything to comstud :P
19:45:27 <comstud> wat
19:45:34 <devananda> adam_g: thanks! I hope sdague is understanding that there are things outside of our control that prevent the tempest parallel tests
19:45:41 <devananda> jroll: any quick updates on IPA?
19:45:52 <comstud> dtantsur: ya, just let me know what you need to know about nova
19:46:00 <JayF> devananda: jroll is distracted
19:46:03 <jroll> devananda: hi!
19:46:03 <JayF> devananda: in his place, I'll say
19:46:14 <jroll> I'll say what JayF was going to say :P
19:46:16 * JayF upstaged
19:46:19 <devananda> lol
19:46:27 <dtantsur> :)
19:46:31 <jroll> our main priority this week is getting check jobs in for the IPA driver
19:46:34 <NobodyCam> will the reall jroll please stand up
19:46:36 <NobodyCam> lol
19:46:44 <jroll> this email outlines most of tht work: http://www.mail-archive.com/openstack-dev@lists.openstack.org/msg31525.html
19:46:53 <jroll> NobodyCam: lolol
19:47:22 <devananda> jroll: good stuff. Oh, that should have also tagged [QA] on there
19:47:27 <NobodyCam> #link http://www.mail-archive.com/openstack-dev@lists.openstack.org/msg31525.html
19:47:33 <jroll> gah, yeah :|
19:47:42 <devananda> you may need to poke them when theyre all back from vacation too :p
19:47:46 <jroll> so, it seems most of devstack-core is on vacation until tuesday
19:47:48 <jroll> yeah :P
19:48:20 <devananda> also, I'm going to suggest that perhaps IPA testing stops at check for now, so we don't overcomplicate things while merging things with Nova
19:48:32 <devananda> GheRivero: hi! any updates on Oslo?
19:48:40 <GheRivero> oslo.utils landed in ironic last week and the oslo.incubator modules were also updated.
19:48:48 <devananda> \o/
19:48:49 <JayF> devananda: I strongly disagree, but we can talk about that outside of the meeting.
19:49:01 <devananda> #info oslo.utils landed in ironic last week and the oslo.incubator modules were also updated.
19:49:02 <GheRivero> the only missing point is updating the policy mechanish https://review.openstack.org/#/c/97731/
19:49:17 <GheRivero> nothing more in the short term
19:49:23 <devananda> GheRivero: I realized we are also not testing DB migrations in our gate still :(
19:49:52 <GheRivero> yes i see that this weekend. working on that
19:49:56 <devananda> thanks much
19:50:00 <JayF> GheRivero: question for you; should we (in IPA) be doing occassional oslo.incubator syncs? Is that something you should do? Does it matter?
19:50:02 <NobodyCam> *10 minute bell*
19:50:06 <GheRivero> i hope to have something earlier this week
19:50:09 <devananda> mrda: hi! you (we) are up :)
19:50:14 <mrda> hey
19:50:20 <GheRivero> JayF: I'll take a look to that,
19:50:28 <JayF> GheRivero: thanks!
19:50:36 <mrda> So the 10,000 foot view is that the scheduler has merged into Nova
19:50:48 <mrda> and we're onto the driver proper
19:50:48 <NobodyCam> Nice!!!
19:51:08 <mrda> the driver is in 5 chunks (starting with https://review.openstack.org/#/c/111223)
19:51:20 <mrda> and the first one is ready to go.
19:51:35 <mrda> So I've been out for a week, getting back up to speed just as Deva disappears
19:51:39 <devananda> mrda: I merged a few patches from ironic into those 5 chunks last week, andthere are a few more that we may want to merge
19:51:46 <devananda> mrda: all my notes are on the whitebaord
19:52:01 <devananda> also, dan has comments outstanding on chunk 3
19:52:04 <mrda> that's about it really - except that we need quick turnarounds when we propose ironic patches as we don't have long
19:52:44 <devananda> #info DO NOT approve changes to ironic/nova/* without coordinating with mrda or devananda
19:52:47 <mrda> nova will be strick on timelines, so we need all of these done by J3
19:52:50 <devananda> also that ^
19:53:10 <mrda> and thanks Deva for your outstanding work over the last week while I was on leave :)
19:53:24 <wanyen> deva, what's teh plan for fixing the instance info gor ilo & ipa driver?
19:53:26 <lucasagomes> mrda, there's a patch from dan that you +1, so I +2 it today assuming you have seem that
19:53:39 <devananda> if there are *critical* fixes for the ironic/nova/* code, please get them worked out *now*
19:53:48 <lucasagomes> mrda, this https://review.openstack.org/#/c/113047/
19:53:59 <mrda> lucasagomes: I'll check later (not awake yet)
19:54:03 <devananda> the cost of changing these 5 chunks, in human time, is quite high
19:54:05 <lucasagomes> awesome, ok
19:54:06 <mrda> lucasagomes: but thanks
19:54:18 <devananda> it's about 5x the time to update a simple patch
19:54:44 <devananda> and I''ve given mrda full permission to poke all of you with sharp objects if you go changing any code in the nova driver (or its unit tests)
19:54:54 <mrda> \o/
19:55:00 <devananda> wanyen: it's fixed
19:55:13 <NobodyCam> *5* minute bell
19:55:16 <wanyen> deva, great!  thanks!
19:55:17 <devananda> wanyen: https://bugs.launchpad.net/ironic/+bug/1353631
19:55:18 <uvirtbot> Launchpad bug 1353631 in ironic "adding a new driver requires changing patcher.py" [Medium,Fix committed]
19:55:43 <devananda> adam_g: the migration code -- has it been proposed to ironic now?
19:55:52 <adam_g> oh yes!
19:56:06 <adam_g> #link https://review.openstack.org/#/c/112402/
19:56:10 <adam_g> could use some review
19:56:11 <devananda> that should be landed as a prereq to the grenade tests too, right?
19:56:14 <devananda> cool, thanks
19:56:22 <adam_g> devananda, yeah, totally forgot to mention
19:56:39 <devananda> great
19:57:00 <devananda> thanks everyone for the subteam reports -- great progress on doing all the things!
19:57:03 <devananda> #topic Open Discussion
19:57:10 <devananda> 3 minutes left
19:57:32 <NobodyCam> who added https://review.openstack.org/#/c/111232/
19:57:32 <devananda> there's a question on refactoring iscsi & pxe
19:57:35 <devananda> #link https://review.openstack.org/#/c/111232/
19:57:41 <NobodyCam> :)
19:58:00 <devananda> it's a direction we want to go in Kilo. this doen't go all the way. is it even helpful? I dunno.
19:58:01 <wanyen> we like to use ipmitool sendsensordat ato ceilometer and remote console inilo driver.  can we just file a bug to for the mix and match fucntions?
19:58:09 <devananda> rameshg87_: ^
19:58:25 <dtantsur> I still think the split is useful as it is
19:58:40 <harshada_kakad> hey if i submit spec today EOD can there be cahnce for approval?
19:58:41 <lucasagomes> this has to deal with the new boot interface that we want to have for kilo?
19:59:08 <NobodyCam> i'd like more time to make sure we do the split right. so I'm not sold that rushing it in J is worth while
19:59:10 <devananda> harshada_kakad: no. sorry. I already explained that the PROPOSAL DEADLINE has passed several weeks ago.
19:59:20 <harshada_kakad> ok
19:59:21 <dtantsur> harshada_kakad, I'm sorry, it's very unlikely. For many of us it's already EOD and we're past proposal deadline
19:59:21 <harshada_kakad> :(
19:59:38 <harshada_kakad> ok
19:59:40 <rameshg87_> devananda, NobodyCam, it doesn't go all the way to separate interfaces right now.
19:59:44 <lucasagomes> yeah, the pxe driver is bloated and splitting may be good, just wondering how the refactor could affect ongoing work for the specs (which should be priorized)
20:00:02 <devananda> harshada_kakad: in the future, please consider filing the proposal before implementing the code in private
20:00:21 <devananda> harshada_kakad: that will help you to align with our development process, and help us to be aware of the work you're doing so that tohers don't duplicate it
20:00:21 <harshada_kakad> yeap ..
20:00:37 <NobodyCam> beep. thats time
20:00:39 <devananda> lucasagomes: right -- that's a VERY good point
20:00:40 <harshada_kakad> yes sure
20:00:46 <rameshg87_> devananda, NobodyCam, but helps to split up the code and make it available for ilo driver for use for now. we can have it go in the separate boot and deploy interfaces in K.
20:01:08 <devananda> #info concern that https://review.openstack.org/#/c/111232/ may adversely impact work on prioritized specs for Juno3. perhaps bump to after?
20:01:21 <NobodyCam> continue in channel?
20:01:23 <devananda> cheers -- thanks everyone for another great meeting :)
20:01:25 <dtantsur> devananda, well, we can just give it low prioirty :)
20:01:30 <devananda> #endmeeting