19:00:11 <devananda> #startmeeting ironic
19:00:12 <openstack> Meeting started Mon Apr 21 19:00:11 2014 UTC and is due to finish in 60 minutes.  The chair is devananda. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:15 <openstack> The meeting name has been set to 'ironic'
19:00:23 <GheRivero> o/
19:00:25 <devananda> hi all!
19:00:29 <devananda> as usual, the agenda is here
19:00:30 <devananda> #link https://wiki.openstack.org/wiki/Meetings/Ironic
19:00:30 <NobodyCam> Hi
19:00:33 <comstud> o/
19:00:48 <devananda> yesterday was the deadline for summit proposals -- and the summit's coming up really soon!
19:00:58 <devananda> so i'd like to talk about the **18** proposals we have alraedy received
19:01:07 <NobodyCam> :)
19:01:07 <devananda> and how to prioritize them, since we only have 4 slots
19:01:40 <NobodyCam> #link http://summit.openstack.org
19:01:50 <lucasagomes> wow 18
19:01:58 <devananda> #topic summit proposals
19:02:01 <jroll> devananda: there's plenty of unconference time for things that don't get slots, yes?
19:02:15 <devananda> jroll: there is unconference time, yes
19:02:26 <jroll> cool :)
19:02:32 <devananda> another aspect everyone should be aware of
19:02:42 <devananda> our four slots are on tuesday, co-timed with the cross-project workshops
19:02:48 <devananda> which some of us will need to attend, too
19:03:08 <NobodyCam> :)
19:03:08 <linggao__> o/
19:03:39 <devananda> of the 18 sessions, broadly, i see a few categories of topics
19:03:55 <devananda> scale/speed/stability
19:04:21 <devananda> new features/third-party drivers/make it work for some particular flavor of hardware
19:04:49 <devananda> architectural changes
19:05:18 <devananda> my opinion is that, geting everyone together to talk about a *specific* feature or third-party driver or piece of hardware
19:05:23 <devananda> is not an efficient use of those four slots
19:05:35 <NobodyCam> +1
19:05:37 <devananda> and those proposals are better run in the unconference space during the week
19:05:45 <devananda> i'd like y'all's opinion on that
19:05:48 * jroll nods
19:05:51 <JoshNang> +1
19:05:52 <jroll> +1
19:05:57 <matty_dubs> That seems quite reasonable to me.
19:06:15 <devananda> ok, cool
19:06:16 <linggao__> +1
19:06:17 <lucasagomes> yeah makes sense for me as well
19:06:34 <jroll> I (somewhat selfishly) wonder if the agent model counts as a specific feature or more of an architecture thing :)
19:06:38 <devananda> architectural things are a bit more important for everyone to be involved in // aware of
19:06:48 <devananda> jroll: right - i was just going to point that out
19:06:48 <GheRivero> +1
19:06:56 <matty_dubs> Yeah, I was actually thinking of the agent stuff as the possible exception
19:06:56 <jroll> since we've talked about making it the default at some point
19:06:58 <jroll> ok
19:07:05 <matty_dubs> Though I don't have a strongly-vested interested
19:07:07 <devananda> i'd put the following sessions in that category
19:07:15 <devananda> http://summit.openstack.org/cfp/details/405
19:07:29 <devananda> http://summit.openstack.org/cfp/details/325
19:07:33 <devananda> http://summit.openstack.org/cfp/details/225
19:07:46 <lucasagomes> jroll, yeah I think we are going towards having the agent as default (I expect it at least)
19:07:50 <devananda> http://summit.openstack.org/cfp/details/121
19:07:57 <devananda> http://summit.openstack.org/cfp/details/100
19:08:12 <NobodyCam> #405? Multi-tenancy using Ironic
19:08:15 <devananda> for those that dont want to click everthing
19:08:45 <devananda> oh, there's a few others too. i'll just type out the titles...
19:09:23 <devananda> multitenancy, chassis level operations (two proposals), widnows deployment, hardware control functions
19:09:54 <devananda> and IPA, which seems to require some rearchitecture
19:10:07 <devananda> or at least some changes to architecture, to do what ya'll want
19:10:41 <devananda> i think we can condense all that into two sessions
19:10:52 <devananda> (but maybe i'm overly optimistic)
19:12:17 <NobodyCam> devananda: how do you see multitenancy as part of the session
19:12:53 <NobodyCam> that could lead us down several rabbit holes (no pun intented)
19:12:58 <devananda> yep
19:13:19 <devananda> every time that comes up, it leads us into long unresolvable discussions of firmware security
19:13:24 <devananda> but
19:13:42 <devananda> there are some things we can do to mitigate the other aspects
19:14:07 <devananda> i dont feel like that needs a session unto itself. we'll just rehash those discussions from the last summit
19:14:37 <NobodyCam> +1 I would put that one in the if theres time catagory
19:15:11 <jroll> I feel like multi-tenancy is a good one to bump to unconf so we can all argue for a few hours :)
19:15:25 <devananda> k
19:15:31 <jroll> friendly arguments of course :P
19:15:39 <NobodyCam> I would be happy to sit down and talk about it.. just not sure its worth one of or pressious slots
19:15:47 <devananda> jroll: sure
19:15:48 <matty_dubs> I think it'd be interesting if we could be fairly aggressive in identifying things we need to hash out in separate discussions
19:15:49 <jroll> you know we won't be able to stop that one on time
19:15:54 <matty_dubs> For that one
19:16:22 <devananda> jroll: i think that some usable action items can come out of it (doc the risks, do better network isolation, etc)
19:16:22 <NobodyCam> we could do it over drinks.. :) might be more fun that way
19:16:48 <jroll> NobodyCam: +1
19:16:52 <jroll> devananda: agreed
19:16:57 <devananda> also, i think we need a session to discuss what the road towards graduation looks like
19:17:03 <devananda> a whole session jsut for that
19:17:17 <NobodyCam> +1 with defined action items
19:17:26 <lucasagomes> NobodyCam, +1!
19:17:26 <jroll> I'd like to get the nova people in on that if y'all feel it's necessary
19:17:29 <NobodyCam> (at the end)
19:17:33 <devananda> getting Ironic to graduate is my primary goal for the project this cycle
19:17:47 <lucasagomes> devananda, +1, I put one up, but I think we need to have the nova one first
19:17:50 <devananda> jroll: that's a separate session :)
19:17:52 <devananda> #Link http://summit.openstack.org/cfp/details/215
19:18:04 <devananda> so the nova one CANT happen first
19:18:05 <jroll> ah, ok
19:18:06 <lucasagomes> yeah that ^
19:18:12 <devananda> nova track is wed/thu/fri
19:18:16 <devananda> our track is tuesday
19:18:16 <lucasagomes> :/
19:18:35 <devananda> hm
19:18:35 <matty_dubs> Oh, tangential, but I updated https://etherpad.openstack.org/p/IronicGraduationDiscussion based on the changes to the upstream doc
19:18:40 <devananda> matty_dubs: thanks!
19:18:53 <NobodyCam> but we can go to nova with a well defined plan for our graduation
19:18:58 <devananda> lucasagomes: do you feel we should wait until after the nova session to have the "road to juno" session in an unconference room?
19:19:28 <lucasagomes> devananda, I do... we have a hard depedency on the things on nova
19:19:40 <NobodyCam> I think it would be better for us to have a plan and make changes if we need to based on nova's input
19:19:42 <devananda> mikal: hi! you're probably not awake yet, but this would be a good question for you, too. let's chat later :)
19:19:48 <devananda> lucasagomes: indeed
19:20:12 <lucasagomes> devananda, we can make sure we are prepare for the nova one, have the topics and arguments up and ready
19:20:24 <lucasagomes> and then after it the ironic one should be quite straight forward
19:20:29 <lucasagomes> we would know what to do
19:20:41 <jroll> I think we should have the session tuesday, and then maybe loop back around after the nova talks
19:20:57 <jroll> as needed
19:20:57 <devananda> lucasagomes: independent of nova, we can discuss what else is required
19:21:03 <NobodyCam> jroll: + that would be my first vote.
19:21:06 <devananda> testing, docs, ceilometer ,horizon, etc
19:21:26 <lucasagomes> right, yeah...
19:21:35 <devananda> we're supposed to integrate with all of those too, and so far, haven't done much
19:21:36 <jroll> is ceilometer a requirement for graduation?
19:22:48 <lucasagomes> jroll, hmm I don't think we are... I'm a bit confused about it as well
19:22:58 <devananda> jroll: heat and horizon definitely are. there's discussion/implication that integration with all integrated projects is required
19:23:06 <NobodyCam> jroll: I do not think so... nova Bmdoes not work with Ceilometer currently
19:23:07 <devananda> heat doesn't apply in our case, fwiw
19:23:21 <devananda> NobodyCam: it doesn't have to do with what nova-bm does/not do
19:23:30 <devananda> new integrated prjoects must integrate with existing integrated projects
19:23:30 <NobodyCam> ack :)
19:23:39 <lucasagomes> jroll, we need to have pair functionality with nova bm, and it's not deprecated... so if someone implements some ceilometer integration in nova bm that will become a graduation requirement for us as well
19:23:44 <jroll> ok
19:23:46 <jroll> yeah
19:23:54 <devananda> lucasagomes: hm, well, no one should do that -- but we still need it, IMO
19:24:09 <devananda> because we've got a clear interaction point with ceilometer, discussion at the last summit with them about it,
19:24:10 <lucasagomes> devananda, yeah, I would -1 that in nova bm >:D
19:24:16 <devananda> and ongoing work on the ML and in gerrit for it
19:24:32 <devananda> similarly, nova-bm has no horizon plugin, but we'll need it
19:24:33 <devananda> anyway
19:24:33 <devananda> let
19:24:38 <lucasagomes> devananda, yup, eglynn is the new ceilometer ptl and I think he's looking at ironic
19:24:41 <lucasagomes> not nova bm for it
19:24:48 <devananda> let's unwind to the topic of sessions (not have one now :) )
19:25:05 <devananda> i think there's a lot for us to talk about, in addition to the nova-bm deprecation plan
19:25:05 <NobodyCam> heehe
19:25:33 <devananda> so, i see 3 slots filled so far
19:25:37 <devananda> 1. road to juno
19:25:43 <devananda> 2. ironic-python-agent
19:25:53 <devananda> 3. other architectural changes
19:26:01 <devananda> (i'll merge several proposals and come up with a list of those)
19:26:19 <devananda> fourth slot -- what's going to be the most useful for everyone?
19:26:20 <NobodyCam> 4. how to track all teh ironic etherpads :-p
19:26:26 <jroll> ^^
19:26:27 <devananda> NobodyCam: metapad!
19:26:31 <NobodyCam> hehehe
19:27:19 <lucasagomes> lol
19:27:28 <devananda> i'm seeing ya'lls input here
19:27:30 <NobodyCam> how about changing blue print to be review based worth a session?
19:27:36 <jroll> I'd like to talk about scalability
19:27:37 <devananda> ah
19:27:46 <lucasagomes> jroll, +1
19:27:48 <jroll> NobodyCam: is anybody against that? are there hard questions to answer?
19:27:55 <devananda> NobodyCam: i dont think that's worth a whole session. no one has objected ...
19:28:25 <devananda> jroll: scalability and performance seems like a good topic
19:28:39 <lucasagomes> scalability problems seems to be the one, since the main (or one of) characteristics of openstack is scalability
19:28:55 <NobodyCam> ack. :) scalability to me also implys we have the ablity to messure our perforamce
19:29:45 <devananda> it's much more useful to talk about scalability
19:29:47 <devananda> when we have hard numbers
19:29:59 <devananda> anyone have resources (hardware and time) to do some benchmarks
19:30:01 <devananda> ?
19:30:09 <jroll> someone was working on that...
19:30:15 * jroll tries to think of who exactly
19:30:31 <devananda> boris-42 was talking about rally, iirc
19:30:36 <jroll> I have hardware and might could find some time, but I don't want to make any promises
19:30:37 <NobodyCam> #link http://summit.openstack.org/cfp/details/275
19:30:38 <jroll> yes
19:30:47 <comstud> we will probably do some scale testing ourselves... soon
19:30:52 <comstud> i suppose we already did some
19:30:57 <comstud> wrt that that thread starvation issue
19:30:58 <jroll> right
19:31:00 <comstud> :)
19:31:06 <devananda> aiui, rally would let us get perf data from runs inside a cloud
19:31:24 <lucasagomes> I think romcheg was looking at some benchmarks as well
19:31:34 <vkozhukalov> devananda:  afaik romcheg is working right now on implementing some rally related stuff to test API performance
19:31:36 <devananda> i'm thinking more along the lines of a) on real hardware b) meaasuring concurrency c) changing parameters, like # of conductors, and seeing how (b) changes
19:31:49 <devananda> so API perf is useful but not the whole picture
19:32:15 <vkozhukalov> at least it is something to discuss
19:32:20 <devananda> i'm also very interested in conductor performance, identifying IO/network bottlenetcks (and validating suspected ones)
19:32:28 <matty_dubs> I don't have much experience with this, but I have access to a small number of beefy boxes if that's useful.
19:32:39 <NobodyCam> seems there is enough about scalability that could fill a slot
19:32:47 <devananda> matty_dubs: beefy boxes == test with lots of VMs
19:32:50 <jroll> right, I'm more interested in conductor performance
19:33:08 <devananda> matty_dubs: but that should be fairly easy with devstack. change # of VMs, then issue lots of "nova boot"
19:33:47 <devananda> matty_dubs: do you have time to work on that? I'm happy to assist -- I have several years' experience with benchmarking systems
19:34:09 <matty_dubs> devananda: I can probably make some time for this, but I'd need some guidance.
19:34:14 <matty_dubs> I'm also the son of a performance engineer ;)
19:34:20 <devananda> :)
19:34:36 <devananda> matty_dubs: thanks! let's talk after the meeting
19:34:40 <matty_dubs> Sure thing.
19:35:05 <devananda> ok! going to give a few more minutes if anyone has thoughts/objections/
19:35:23 <devananda> or feels like omg-i-have-to-talk-about-kittens at the summit
19:35:34 <vkozhukalov> devananda: boris-42 is sitting next to me in the office so i could be helpful, but i prefer to concentrate on IPA stuff
19:35:35 <devananda> and then move on
19:35:54 <NobodyCam> +1 for fourth slot being on scalability
19:35:59 <jroll> vkozhukalov: we need to benchmark deploying through IPA too :)
19:36:07 <devananda> vkozhukalov: having some API performance tests from rally would be great
19:36:25 <NobodyCam> scalability & kittens
19:36:33 <matty_dubs> NobodyCam: Sold!
19:36:38 <devananda> jroll: i'd love to see a comparative test on real hw between dib's ramdisk and IPA
19:36:57 <vkozhukalov> devananda: jroll: ok, will think about what i can do
19:36:58 <lucasagomes> NobodyCam, +1, kittens r nice, we should have pics of kittens while deploying a node... we can fetch them from flickr or something
19:37:11 <NobodyCam> http://dailykitten.com
19:37:24 <lucasagomes> lol
19:37:31 <devananda> #agreed summit slot usage will be: road to juno, IPA, other arch changes, perf & scaling.
19:37:43 <NobodyCam> ++
19:37:52 <matty_dubs> http://dailykitten.com/feed/ = KaaS? (Kittens as a Service)
19:37:56 <devananda> #action devananda to merge and bump other sessions, see about reserving a block of unconference space
19:38:01 <NobodyCam> w/ pictures of cute kittens
19:38:09 <jroll> devananda: agreed about comparisons
19:38:17 <devananda> #action matty_dubs to do some benchmarks of ironic-conductor scalability
19:38:47 <devananda> thanks everyone! moving on
19:38:53 <devananda> #topic blueprint design process
19:39:01 <NobodyCam> matty_dubs: lol...Kaas++++
19:39:10 <devananda> anyone _not_ know what this topic is in reference to?
19:39:53 <devananda> #link http://lists.openstack.org/pipermail/openstack-dev/2014-April/033081.html
19:39:56 <devananda> just in case :)
19:40:13 <NobodyCam> the only think I was un happy with was... "the create bad BP" but I can also see the need for a place holder
19:40:25 <jroll> I think bad is the wrong word
19:40:26 <NobodyCam> s/think/thing/
19:40:29 <lucasagomes> devananda, using gerrit to manage/approve bps?
19:40:35 <devananda> lucasagomes: yes
19:40:36 <jroll> maybe skeleton is a better word for that
19:40:45 <jroll> or incomplete
19:40:47 <NobodyCam> or place holder
19:40:51 <jroll> sure
19:40:52 <NobodyCam> ya ++
19:40:55 <lucasagomes> +1 place holder
19:40:56 <devananda> lucasagomes: nova has adopted this. neutron and tripleo and several other projects are moving towards it as well
19:41:01 <NobodyCam> anything other then "BAD:
19:41:02 <devananda> there's a summit track on this, too
19:41:09 <devananda> #link http://summit.openstack.org/cfp/details/3
19:41:38 <devananda> given that, I'm inclined to hold off on implementing anything in Ironic until after that summit track
19:41:44 <devananda> s/track/session/
19:42:04 <lucasagomes> devananda, right... I think it's a good move (as I expressed in the ML), we def need a better way to track bps and approve them
19:42:14 <NobodyCam> I would vote to adopt the nova standard after reviewing it
19:42:40 <devananda> cool
19:42:54 <lucasagomes> one thing I feel about the nova model, is that the template they use for creating a bp is hmm too complicated... I felt that they assume that they person that is proposing the bluepring knows everything before they start
19:43:03 <lucasagomes> so I think we should have it a bit more flexible
19:43:16 <lucasagomes> approve the idea, but leave some implementations details
19:43:17 <lucasagomes> for later
19:43:26 <NobodyCam> devananda: and is a bit much for our needs
19:43:31 <devananda> lucasagomes: *nod*
19:43:46 <jroll> +1 lucas
19:44:03 <lucasagomes> devananda, it's hard to figure out everything that is needed and going to impact before actually start coding it
19:44:11 <comstud> I kind of like the implementation being in it
19:44:13 <lucasagomes> we need a flexible template for the submitions
19:44:19 <comstud> you can leave it blank on first iterations of the BP review.
19:44:24 <lucasagomes> comstud, me too, but it's not always possible
19:44:37 <comstud> to get an idea if it's worth figuring out the implementation
19:44:44 <lucasagomes> comstud, yeah, having some "phases" of development is fine for me
19:44:53 <jroll> comstud: right, but wherever this gets written down should explicitly say that so people aren't -1 with 'lol incomplete'
19:45:05 <comstud> if you don't review the implementation...
19:45:07 <matty_dubs> Isn't that how patches unfold anyway? Multiple revisions with inline comments?
19:45:13 <comstud> you'll get a lot of crap code that you have to just -2 anyway
19:45:16 <NobodyCam> lucasagomes: yes. I see this process as a way to reduce the amount of forgotten gottcha's incountered implamenting BP's
19:45:25 <comstud> i dunno, just my thoughts offhand
19:45:46 <vkozhukalov> is it supposed that we'll start implementing only after final approval of bp? or we are going to have kind of stages?
19:45:47 <devananda> and the amount of very incomplete/vague BPs that get left hanging (or rejected) because LP is a terrible forum
19:45:50 <devananda> to discuss features
19:46:00 <devananda> vkozhukalov: yes -- implementation only after BP is approved
19:46:22 <devananda> vkozhukalov: one purpose is to create a better system for discussion of features (impact, implementationd etails, API changes, etc)
19:46:22 <matty_dubs> Is there a risk that BPs will take as long to review as patches? Potentially bouncing around for weeks?
19:46:32 <devananda> matty_dubs: yes! that's good though!
19:46:36 <comstud> I think impl before BP is approved is fine.. it's up to you if you want to risk your time
19:46:40 <comstud> it's sometimes nice to have reference
19:46:51 <comstud> it just won't be +A'd until BP is +A'd
19:46:54 <comstud> heh
19:46:54 <lucasagomes> yeah i like that ^ as well
19:47:07 <lucasagomes> but we can't approve it before it's approved
19:47:12 <lucasagomes> I mean, can't approve the code
19:47:23 <NobodyCam> comstud: ++ yes dev just understands that the BP may get changed
19:47:33 <NobodyCam> lucasagomes: yes
19:47:42 <devananda> one (if not the main) purpose of this is to create a better system for discussion of features (impact, implementationd etails, API changes, etc)
19:47:49 <devananda> since launchpad blueprint interface is really terrible for that discussion
19:48:01 <devananda> it's a good reference point, once the feature is agreed upon, though
19:48:05 <devananda> eg, for generating release notes
19:48:17 <Shrews> devananda: how will BP tracking work?
19:48:20 <devananda> just look at any blueprint that's been around for a few months and had a lengthy design discussion
19:48:29 <devananda> Shrews: see the original email. it's detailed there
19:48:58 <devananda> Shrews: tldr; review in gerrit -> +2/+A -> copy/paste to launchpad -> don't change after that (except for status updates)
19:49:29 <NobodyCam> devananda: will that cut/past be done by the approver?
19:49:30 <devananda> #agreed a more formal (ie, in gerrit) BP review process is good, but we're not going to implement anything until (after) the summit
19:50:01 <devananda> #agreed and we need to strike a balance, appropriate for Ironic, between beign too heavy-handed with early requirements and stifling developers
19:50:28 <devananda> we've got 10 min left, so i'd like to move on
19:50:38 <devananda> #topic integration tests
19:50:49 <devananda> adam_g: any updates from last week?
19:51:10 <adam_g> so
19:51:14 <adam_g> http://logs.openstack.org/92/89392/1/check/check-tempest-dsvm-virtual-ironic/26a0ac0/logs/testr_results.html.gz
19:51:24 <adam_g> all is passing except one neutron test, which im working on right now
19:51:33 <devananda> awesome!
19:51:35 <adam_g> the functional scenario test is up and passing. should have everything green this week and we can start relying on it
19:52:08 <jroll> nice!
19:52:15 <adam_g> thats about it on the QA side
19:52:20 <devananda> adam_g: think it's time that we prepare a change to infra to enable it?
19:52:43 <adam_g> devananda, as in get it added as a non-voting job to the other pipelines?
19:52:46 <lucasagomes> adam_g, good stuff!
19:53:24 <devananda> adam_g: at least move it out of experimental
19:53:26 <NobodyCam> on the tripleO tests I am not seeing the node post back to our api. I am not seeing any errors in the deploy it self, so I am digging into firewall type issues atm
19:53:50 <adam_g> devananda, sure. what projects do we want it checking? ironic, nova, neutron, tempest, devstack? or everything?
19:54:07 <devananda> adam_g: same ones where tempest-dsvm-ironic runs today
19:54:25 <adam_g> NobodyCam, where are they running? i wrestled with similar issues last week and it turned out to be firewalling
19:54:57 <devananda> adam_g: actually, i think it -virtual-ironic is already a non-voting job in all the right places
19:55:02 <adam_g> NobodyCam, or, do you have a URL of some failed results?
19:55:23 <adam_g> devananda, okay, cool. ill see what needs to change to get it moved out of experimental and set it as WIP till our tests are green
19:55:42 <NobodyCam> adam_g: any tripleO-undercloud-ironic test from https://review.openstack.org/#/c/85529/
19:55:45 <devananda> thanks
19:56:09 <devananda> #topic open discussion
19:56:27 <devananda> 4 minutes left :)
19:57:03 * NobodyCam is really thinking of how to work in Kaas as a ironic easter egg
19:57:29 <lucasagomes> devananda, I will try to break the oslo messaging patch into small pieces tomorrow
19:57:37 <lucasagomes> devananda, thanks for the review
19:57:37 <Shrews> rebuild command is nearly done. just need to deal with nova not liking that the node is already powered on.
19:58:15 <devananda> lucasagomes: I'm OK with it beign a large patch -- it's very interrelated
19:58:18 <devananda> lucasagomes: just hard to review
19:58:48 <lucasagomes> devananda, yeah... lots of changes and the commit message is horrible listing all the changes as bullet points
19:59:17 <NobodyCam> one minute
19:59:53 <devananda> Shrews: good stuff! perhaps we can just turn the ndoe off at the right time? :)
20:00:17 <devananda> ok, thanks everyone! can't wait to see ya'll at the summit in a few weeks!!!
20:00:19 <NobodyCam> Thank you all! great meeting
20:00:27 <NobodyCam> is there a meeting next week
20:00:42 <matty_dubs> Is it a holiday?
20:00:47 <devananda> NobodyCam: why wouldn't there be?
20:00:54 <devananda> afaik, we have 2 more meetings before the summit
20:00:56 <NobodyCam> ??? not sure
20:01:02 <NobodyCam> :)
20:01:04 <devananda> ok
20:01:08 <devananda> #endmeeting