19:00:03 <NobodyCam> #startmeeting Ironic
19:00:03 <NobodyCam> #chair devananda
19:00:04 <NobodyCam> Welcome everyone to the Ironic meeting.
19:00:04 <openstack> Meeting started Mon Mar 17 19:00:03 2014 UTC and is due to finish in 60 minutes.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:09 <openstack> The meeting name has been set to 'ironic'
19:00:10 <openstack> Current chairs: NobodyCam devananda
19:00:15 <NobodyCam> Of course the agenda can be found at:
19:00:16 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
19:00:23 <NobodyCam> #topic Greetings, roll-call and announcements
19:00:23 <NobodyCam> Who's here for the Ironic Meeting?
19:00:27 <jroll> \o
19:00:35 <Shrews> \o
19:00:39 <mrda> \o
19:00:43 <rloo> \o
19:00:47 <linggao> o/
19:00:51 <agordeev2> o/
19:01:00 <NobodyCam> phew thought it was going to be a quicker meeting then I had thought
19:01:09 <adam_g> o/
19:01:10 <dwalleck> 0/
19:01:12 <NobodyCam> hello all
19:01:19 <NobodyCam> and welcome
19:01:42 <NobodyCam> announcements:
19:01:42 <NobodyCam> Happy Saint Patrick's Day
19:01:53 <GheRivero> o/
19:02:36 <NobodyCam> oh ya another announcement
19:02:44 <NobodyCam> https://review.openstack.org/#/c/70348 -- LANDED!!!!!
19:03:00 <rloo> awesome!
19:03:03 <adam_g> \o/
19:03:04 <mrda> woohoo!
19:03:13 <NobodyCam> we are getting there
19:03:34 <NobodyCam> any one else have any announcements
19:03:35 <adam_g> should we update developer docs with instructions on how to bootstrap devstack+ironic?
19:03:46 <agordeev2> NobodyCam: many thanks for applying a lof effort. Shrews, adam_g, devananda, and other guys. Thanks!!
19:03:49 <NobodyCam> Yes and the etheroad too
19:03:54 <agordeev2> a lot of *
19:03:58 <dwalleck> yes please!
19:03:58 <JayF> o/
19:04:03 <NobodyCam> :) *(BLUSH)*
19:04:23 <NobodyCam> adam_g: can that be a action item for you??
19:04:29 <adam_g> yea
19:04:56 <NobodyCam> #action adam_g to update instructions on how to bootstrap devstack+ironic
19:05:03 <NobodyCam> awesome thank you adam_g
19:05:09 <adam_g> np
19:05:27 <NobodyCam> ok we have a light agenda today
19:05:37 <NobodyCam> so we'll jump right in to :
19:05:45 <NobodyCam> #topic Ongoing integration & testing work
19:06:05 <devananda> hi! sorry I'm late
19:06:07 <NobodyCam> so the main devstack patch landed that is a hugh step for us
19:06:19 <NobodyCam> Welcome devananda Glade you could make it
19:06:30 <devananda> NobodyCam: please carry on :) this machine's a bit ... slow ...
19:06:37 <NobodyCam> :)
19:06:58 <NobodyCam> I wanted to give a quick up date on the TripleO work
19:07:23 <NobodyCam> as of friday I was able to deploy a workload from the undercloud with ironic
19:07:51 <NobodyCam> all but two of the patches for that landed over the weekend
19:08:25 <mrda> more good news! Great!
19:08:28 <NobodyCam> I am working the two left now. and will be starting to integrate with seed vm this week
19:08:57 <max_lobur1> o/
19:09:10 <NobodyCam> once we have that over cloud will be last up if that fits with the OoO story
19:09:10 <linggao> NobodyCan, can the procedure be put on somewhere? We are  not good at using TripleO
19:09:48 <NobodyCam> #action NobodyCam to update Ironic TripleO use docs
19:09:52 <NobodyCam> linggao: ^^^
19:10:07 <linggao> thanks ^_^
19:10:12 <NobodyCam> :)
19:10:31 <NobodyCam> any question on TripleO work?
19:10:32 <NobodyCam> oh
19:10:50 <NobodyCam> #link https://review.openstack.org/#/c/80725
19:11:08 <NobodyCam> #link https://review.openstack.org/#/c/72969
19:11:12 <devananda> NobodyCam: linggao: that info should live here: https://wiki.openstack.org/wiki/Ironic/TripleO
19:11:29 <devananda> (and yes, itneeds to be updated)
19:11:38 <NobodyCam> :) there is also a etherpad too I think
19:12:12 <devananda> NobodyCam: on second thought, eventually it should move into tripleo-incubator's autogenerated docs
19:12:14 <linggao> devananda, thanks for the urls.
19:12:21 <NobodyCam> any other questions/ comments?
19:12:44 <NobodyCam> devananda: wont they be part of OoO's docs
19:13:02 <NobodyCam> in the end I hoping for just set USE_IROIC
19:13:14 <NobodyCam> USE_IRONIC even
19:13:56 <devananda> NobodyCam: yes
19:14:14 <NobodyCam> any one have anything on / about the devstack work?
19:14:15 <NobodyCam> :)
19:15:01 <NobodyCam> are we good to move on?
19:16:03 <NobodyCam> ok we can come back if needed. we have a very light agenda today
19:16:16 <NobodyCam> so that brings us to:
19:16:17 <NobodyCam> #topic Food for Thought / Open Discussion
19:16:18 <agordeev2> NobodyCam: just few tiny improvements for devstack. https://review.openstack.org/#/c/80958/ https://review.openstack.org/#/c/80977/ if they count
19:16:39 <NobodyCam> #link https://review.openstack.org/#/c/80958
19:16:50 <NobodyCam> #link https://review.openstack.org/#/c/80977
19:16:57 <NobodyCam> agordeev2: awesome TY
19:17:46 <NobodyCam> o we have only two FFT items:
19:18:00 <NobodyCam> Functional/Integration testing of vendor drivers & Driver architecture for Chassis object
19:18:40 <NobodyCam> has anyone put anythough behind the Chassis
19:19:46 <jroll> have not
19:19:50 <NobodyCam> I love to see a blue print to allow the chassis to act a holding place for node options,
19:20:14 <NobodyCam> ie all the power manager type options
19:20:24 <adam_g> devananda, how far did you manage to get on friday /w integrating ironic+devstack into the gate?
19:20:27 <NobodyCam> thou Not sure how that fits
19:20:49 <NobodyCam> devananda: thoughts on ^^^
19:21:47 <linggao> There should be operations like power on/off the chassis, right?
19:22:09 <NobodyCam> oh so like power off a whole group
19:22:14 <NobodyCam> that would be neat
19:22:24 <NobodyCam> deploy a whole grooup
19:22:26 <devananda> adam_g: two patches still in flight to finish that, i think
19:22:54 <NobodyCam> devananda: you have links we can #lnk here?
19:22:54 <devananda> NobodyCam, linggao - nope. doing group operations within ironic is not in scope for the near future
19:23:08 <wanyen> discover hardware for the whole chassis as another example
19:23:10 <devananda> group operations touches on scheduling too closely
19:23:11 <NobodyCam> ahh sounded really neat
19:23:24 <devananda> which is the scheduler's responsibility
19:23:25 <NobodyCam> :-p
19:23:26 <linggao> node grouping should be introduced some time for performance
19:23:55 <devananda> ironic would expose group information, and the scheduler should be able to make group-aware decisions
19:24:08 <linggao> For power actions againg chasis, I meant powering on/off the chasis itself.
19:24:09 <devananda> but until there is such awareness in the scheduler, it's premature to add it to ironic
19:24:38 <devananda> linggao: ah. so. THAT is more in-scope :)
19:24:49 <NobodyCam> lol I want a single command to deploy my seti farm ...lol... j/k
19:25:03 <devananda> NobodyCam: yes -- use Heat for that
19:25:10 <NobodyCam> hhehehe ya
19:25:35 <NobodyCam> this is open floor any one want to jump in
19:25:56 <NobodyCam> questions / comments / rants :-p
19:26:13 <devananda> adam_g: re devstack support in the gate -- https://review.openstack.org/#/c/80652/ and https://review.openstack.org/#/c/80653/
19:26:26 <adam_g> devananda, cool, thanks
19:26:32 <NobodyCam> #link https://review.openstack.org/#/c/80652
19:26:39 <NobodyCam> #link https://review.openstack.org/#/c/80653
19:26:41 <linggao> I'll write a blueprint for chassis operations, is there one already?
19:27:09 <dwalleck> I'm really interested in the ironic + devstack testing/gating process. I used to work on Tempest and I work on another third party testing system also. Who/how is the best way to get involved?
19:27:28 <NobodyCam> linggao: porb a good topic for summit.. may better there in the open form?
19:27:59 <devananda> linggao: let's discuss it at the summit in the larger context of scheduling operations
19:28:17 <devananda> linggao: tuskar already has a need for multiple types of logical groupings to model failure domains
19:28:39 <devananda> linggao: eg, power, network, and storage -- 3 different failure domains, and a node may belong to more than one
19:28:48 <devananda> linggao: so chassis is not the complete answer
19:29:20 <adam_g> dwalleck, hit me up. now that we have initial support in devstack, id like to spend time this week with tempest-against-ironic and getting some basic ironic exercise tests in devstack
19:29:23 <NobodyCam> :)
19:29:26 <devananda> dwalleck: best way to get involved -- ask in channel. adam_g has expressed an interest in looking at the tempest suite as soon as we get the tests going in the gate
19:29:29 <devananda> heh
19:29:39 <dwalleck> sounds good. Thanks!
19:29:57 <linggao> devananda, I meant the hareware opentations on chassis itself.
19:30:01 <agordeev2> i'm excited about ironic python agent. What's the current status? Anyone interested?
19:30:11 <linggao> grouping is a different idea,
19:30:35 <jroll> agordeev2: hey
19:30:39 <linggao> I do not think chassis object should be used as a node grouping tool.
19:30:44 <NobodyCam> agordeev2: the python-ironicclient
19:30:46 <devananda> agordeev2: jroll and JayF are working on that
19:30:48 <jroll> I can briefly talk about the agent
19:31:08 <NobodyCam> oh the deploy agent
19:31:12 <jroll> we have a patch in to infra to make the agent an openstack project
19:31:17 <JayF> agordeev2: the merge request for infra is here: https://review.openstack.org/#/c/79088/4
19:31:30 <JayF> #link https://review.openstack.org/#/c/79088
19:31:32 <NobodyCam> do we have links for the teeth stuff we can link here?
19:31:36 <NobodyCam> awesome :)
19:31:38 <jroll> we are currently ripping out dependencies not approved by openstack, and changing our test suite to use testr and use more environments
19:31:47 <agordeev2> jroll: are you planning to introduce driver that support custom plugins/extentions?
19:31:58 <jroll> #link https://github.com/rackerlabs/teeth-agent
19:32:00 <JayF> #link https://github.com/rackerlabs/teeth-agent
19:32:07 <JoshNang> agordeev2: in the agent?
19:32:12 <jroll> #link https://github.com/rackerlabs/ironic-teeth-driver
19:32:25 <devananda> linggao: ah, gotcha. please propose a summit session about what your specific interest in chassis operations is, and include a note that it is not related to grouping (folks will probably assume it is, if this is not explicit)
19:32:29 <jroll> agordeev2: what kind of plugins/extensions do you have in mind
19:32:31 <agordeev2> JoshNang: yup. In the agent. Eg. 3rd party plugins for harware configuration and so on
19:32:44 <jroll> agordeev2: yes, that already exists for hardware
19:32:54 <jroll> our hardware detection/configuration stuff is pluggable
19:33:19 <jroll> our current plan is to work hard and get a demo working before the summit
19:33:26 <jroll> I've already proposed a summit session on the agent
19:33:44 <NobodyCam> would it good to add a teeth-agent topic to the next meeting?
19:33:46 <linggao> devananda, sure. I'll. thanks
19:33:59 <jroll> NobodyCam: if people would like to talk about it, sure :)
19:34:16 <NobodyCam> jroll: I'd like to get people talking about it
19:34:20 <jroll> I hope by next meeting, infra will merge that patch
19:34:22 <jroll> got it
19:34:29 <agordeev2> jroll: great. How i can get involved too? I'm in a need of comprehensive data-driven disk partitioning at least (and have some stuff for it)
19:34:30 <JayF> So for the patch
19:34:35 <JayF> Infra has "new project Fridays"
19:34:47 <JayF> if we get the agent ready to merge before friday, we should be able to merge on Friday
19:34:58 <jroll> agordeev2: start sending patches :)
19:35:03 <NobodyCam> #action NobodyCam to add teeth-agent topic to agenda
19:35:09 <devananda> jroll: if you guys re blocked on anything, don't hsitate to ping me
19:35:15 <jroll> agordeev2: patches can go via PR on github for now, and through gerrit after that
19:35:19 <agordeev2> jroll: GH pull request? ok
19:35:26 <agordeev2> jroll: TY
19:35:43 <jroll> devananda: sure, thanks. I'm trying to respect the feature freeze and just pull our patches in when needed :)
19:35:44 <JayF> agordeev2: we're all in #openstack-ironic and will give responsive reviews :D
19:35:49 <jroll> ^
19:36:15 <jroll> anything else about the agent?
19:36:35 <agordeev2> JayF: jroll okay guys. I'll ping you someday :)
19:36:39 <linggao> devananda, we also have some ideas on node hardware operations like resetting BMC, getting beacon status etc. Should I also propose it together in the same summit sesssion?
19:36:48 <NobodyCam> anything about anything else
19:37:44 <NobodyCam> linggao: that sounds like two sessions
19:37:45 <devananda> linggao: yep. as proposals come in, i may move some topics around
19:38:23 <linggao> ok, I'll put them in 2 sessions first, the you guys decide if merge them or not.
19:38:38 <NobodyCam> linggao: awesome TY
19:38:52 <linggao> :)
19:39:05 <NobodyCam> anything else, or is that it for today?
19:39:15 <devananda> fyi, we will probably be limited to 5 pr 6 sessions. last summit, i think we spent about half the time talking about features we hjaven't gotten around to implementing yet
19:39:42 <NobodyCam> devananda: ++
19:39:49 <devananda> so i'd like us to learn from that and will be trying to keep the sessions focused on what we can achieve in the following 6mo
19:40:07 <NobodyCam> lets talk about what we are going to actually be working on
19:40:16 <NobodyCam> :-p
19:40:20 <devananda> :)
19:40:37 <devananda> no other topics from me this week
19:40:46 <NobodyCam> if we are done we can get 20 minutes back
19:40:48 <devananda> we can end early if no one else has things
19:41:14 <NobodyCam> awesome Thank you everyone
19:41:23 <jroll> thank you!
19:41:24 <mrda> thanks NobodyCam
19:41:34 <JoshNang> no complaints on ending early :)
19:41:47 <NobodyCam> :) ok then lets call it
19:42:01 <NobodyCam> last chance
19:42:27 <NobodyCam> Thak you all
19:42:30 <NobodyCam> #endmeeting