19:00:09 <NobodyCam> #startmeeting Ironic
19:00:09 <NobodyCam> #chair devananda
19:00:09 <NobodyCam> Welcome everyone to the Ironic meeting.
19:00:09 <openstack> Meeting started Mon Feb 10 19:00:09 2014 UTC and is due to finish in 60 minutes.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:14 <openstack> The meeting name has been set to 'ironic'
19:00:15 <openstack> Current chairs: NobodyCam devananda
19:00:21 <NobodyCam> Of course the agenda can be found at:
19:00:21 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
19:00:28 <devananda> hi all!
19:00:29 <NobodyCam> #topic Greetings, roll-call and announcements
19:00:29 <NobodyCam> Who's here for the Ironic Meeting?
19:00:33 * matty_dubs is
19:00:39 <max_lobur_cell> Here
19:00:40 <GheRivero> o/
19:00:42 <NobodyCam> hi devananda o/
19:00:46 <jroll> \o just listening in
19:00:47 <lucasagomes> :D
19:00:50 <haomeng2> o/
19:00:52 <coolsvap> Swapnil
19:00:52 <rloo> hi
19:00:57 <mrda> I'm here (for the first time)
19:01:04 <devananda> mrda: welcome! :)
19:01:10 <NobodyCam> welcome jroll and mrda
19:01:12 <jroll> my first as well :)
19:01:15 <jroll> thanks
19:01:21 <mrda> \o/
19:01:24 <NobodyCam> announcements:
19:01:30 <NobodyCam> Next Monday the 17th is a holiday in the US.
19:01:41 <haomeng2> wel  mda
19:01:53 <NobodyCam> and I'll prob be gone latter part of friday
19:02:04 <matty_dubs> Do you actually get the 17th off? We don't. :'(
19:02:16 <NobodyCam> :-p lol yep
19:02:35 <NobodyCam> but I'll be around for the meeting .. Most likly :)
19:02:51 <devananda> I'll also be around for the meeting next week
19:03:00 <NobodyCam> anyone else?
19:03:19 <jroll> I should be around
19:03:25 * matty_dubs will be here; will anyone _not_?
19:03:33 <devananda> two small announcements that I didn't put on the agenda
19:04:02 <devananda> i'd like to welcome max_lobur_cell and romcheg (who's not in channel??) to ironic-core :)
19:04:06 <haomeng2> i will be around
19:04:16 <NobodyCam> w00 h00 :)
19:04:20 <GheRivero> congrats all!
19:04:24 <matty_dubs> congrats!
19:04:28 <max_lobur_cell> Thank everyone for support!
19:04:28 <haomeng2> congts
19:04:29 <lucasagomes> :)
19:04:39 <mrda> congrats max_lobur_cell and romcheg
19:04:50 <devananda> and get a quick check of folks who think they will make it to the sprint in CA on march 3 - 7
19:05:05 * NobodyCam is planning on it
19:05:12 <lucasagomes> I'm going
19:05:18 <max_lobur_cell> Not me :-\
19:05:20 <matty_dubs> I plan to be there. Any word on venue?
19:05:23 <jroll> I'm a maybe. sunnyvale, right?
19:05:23 * GheRivero will do
19:05:35 <lucasagomes> jroll, yes
19:05:46 <devananda> matty_dubs: venue and stuff is all set up, see the email from Robert Collins (lifeless) last week, iirc
19:05:58 <mrda> I'll have to decline, even though I would love to, as I spent my travel credits on the nova mcm :(
19:06:03 <haomeng2> not me
19:06:03 <rloo> most likely will be there for part of it
19:06:16 <devananda> for those who are coming, please coordinate with cody-somerville so he has an accurate head count, etc
19:06:17 <coolsvap> devananda: any options for remote participation?
19:06:42 <max_lobur_cell> +
19:06:55 <devananda> coolsvap: we'll do etherpads for as much as possible, and doubtless there will be folks in IRC
19:07:09 <NobodyCam> humm not sure coolsvap ... I'm sure we can come up with somehting
19:07:18 <devananda> coolsvap: but setting up video conference etc for everyone to watch is not likely
19:08:15 <NobodyCam> awesome!
19:08:26 <NobodyCam> look forward to seeing every one
19:08:46 <coolsvap> devananda: etherpads are most welcome!
19:09:18 <devananda> ok, moving on
19:09:21 <max_lobur_cell> Yup, etherpads are ok
19:09:43 <NobodyCam> #topic Call-outs
19:09:50 <NobodyCam> Nova driver
19:10:13 <NobodyCam> 1st up lucasagomes Awesome job
19:10:44 <NobodyCam> driver is starting to get split up in to small (more easly landed patched)
19:10:52 * lucasagomes getting the links
19:10:57 <devananda> great job, guys!
19:11:02 <devananda> one question i have on that work
19:11:03 <NobodyCam> all current patches are linked on the agenda
19:11:24 <NobodyCam> sure .... /me thinks he knows hte question
19:11:25 <devananda> with the code getting split up, how should we faciliate folks who want to assemble it
19:11:32 <devananda> to test / track / continue work on it
19:11:36 <NobodyCam> lol yup /me did
19:11:45 <lucasagomes> #link https://review.openstack.org/#/c/51328/
19:11:46 <lucasagomes> #link https://review.openstack.org/#/c/71026/
19:11:46 <lucasagomes> #link https://review.openstack.org/#/c/71429
19:11:58 <devananda> ideas i have -- and please toss others out there too
19:12:02 <NobodyCam> it a ton of git foo it keep up to date
19:12:12 <devananda> section on https://etherpad.openstack.org/p/IronicWhiteBoard with instructions to cherry-pick them in the right order
19:12:30 <devananda> or a branch on github that anyone can pull
19:12:54 <NobodyCam> I can do the ether pad update
19:12:55 <devananda> or we have a linear series of patches in gerrit and, to test it, one checks out the tail patchset
19:13:32 <devananda> for folks using tripleo to test, the last one is the only viable one. You can export a branch ref to build images with, but not multple revisions
19:13:59 <lucasagomes> if you checkout a patch, it checks the dependecies as well
19:14:35 <NobodyCam> git needs the idea of a meta patch
19:14:41 <lucasagomes> so if u check the 51328 (main driver) as it depends on the host manager patch (71429) it's going to be checked
19:15:04 <devananda> lucasagomes: right -- so if we keep all the patches in gerrit in a single dependency line, then it works
19:15:13 <lucasagomes> yup
19:15:21 <devananda> lucasagomes: the hostmanager patch and the iscsi patch were originally posted independently
19:15:41 <lucasagomes> devananda, yea... hmm that needs to be fixed
19:15:50 <lucasagomes> the hostmaneger should depend on the iscsi patch
19:16:15 <devananda> they're functionally independent, AIUI
19:16:17 <NobodyCam> ++ my bad
19:17:00 <devananda> but if we keep them all ordered as a dependent chain, then ya, it makes testing easier
19:17:09 <devananda> any objections to that?
19:17:23 <lucasagomes> devananda, kinda, the hostmanager needs a function to get the iscsi initiation, if not depending on the patch which adds that function to a common place we are going to need to depende on the libvirt module
19:17:42 <lucasagomes> so I think that the hostmanager one have to dependend on the iscsi yes
19:17:58 <devananda> lucasagomes: https://review.openstack.org/#/c/71429/7/nova/scheduler/ironic_host_manager.py
19:18:11 <devananda> how does taht depend on iscsi?
19:18:40 <lucasagomes> ohh my bad! I confused that with the volume manager
19:18:43 <lucasagomes> volume driver*
19:18:48 <devananda> ahh yes :)
19:18:57 <lucasagomes> the volume driver needs to depend on the iscsi
19:19:01 <devananda> yep
19:19:01 <lucasagomes> hmm
19:19:26 <devananda> I dealt with this when I worked on landing the original nova-baremetal driver
19:19:48 <NobodyCam> I could put up a hack nova-ironic element in my repo that cherry picks the patches in order..
19:19:48 <devananda> it can be tricky to manage ~ 10 patch sets with non-linear dependency and >1 person working on them
19:20:03 <devananda> NobodyCam: that's basically what I did for baremetal
19:20:33 <lucasagomes> indeed :/ it's messy
19:20:39 <devananda> NobodyCam: it is a bit of a pain to maintain it; it makes it easy for others to consume; and it hides the real complexity of pulling from gerrit
19:20:47 <NobodyCam> we already had this : https://github.com/NoBodyCam/ironic-element/blob/master/nova-ironic/install.d/89-nova-ironic-services
19:20:53 <devananda> a similar idea might be to maintain a bash script that pulls the right patches
19:21:09 <devananda> eg, it pulls trunk and then cherry-picks in the right order
19:21:43 <lucasagomes> yea
19:21:56 <NobodyCam> bash script is right out there for all to see...
19:22:26 <haomeng2> +
19:22:32 <NobodyCam> we could stach it in ironic/tools
19:22:43 <devananda> ++
19:22:51 <lucasagomes> yea that would work
19:23:06 <NobodyCam> easy for us all to keep updated too
19:23:07 <NobodyCam> :)
19:23:24 <NobodyCam> ++ for bash script to cherry pick
19:23:28 <devananda> who wants to take that on?
19:23:51 <NobodyCam> I can give it a stab
19:23:58 <devananda> graet, thanks!
19:24:31 <NobodyCam> #action Nobodyca come up with bash script to cherry pick needed reviews
19:24:41 <devananda> #action NobodyCam to add a bash script in ironic/tools/ to pull necessary ironic patches in Nova tree
19:24:47 <NobodyCam> :-p
19:24:58 <devananda> I'm going to skip the call outs for testing things
19:25:05 <NobodyCam> ack
19:25:08 <devananda> and go to i3 status / etc. we can come back to testing if there's time
19:25:19 <devananda> #topic Icehouse Planning
19:25:33 <devananda> so there's several bits here taht folks should be aware of
19:25:37 <devananda> hopefully most are :)
19:25:58 <devananda> some projects have adopted a Feb-18 deadline for new major code submissions
19:26:13 <devananda> to try to give reviewers time to digest things before I3 closes
19:26:45 <devananda> our review queue has been really slow... but, we just added 2 more folks to core -- so hopefully it'll speed up
19:27:09 <devananda> how do folks feel about that feb 18 "no new big patches" deadline?
19:27:31 <lucasagomes> tight :P
19:27:32 <max_lobur> it will
19:27:40 <mrda> how does that mesh with the meetup being in the first week of march?
19:27:41 <NobodyCam> I know there are some folks pushing hard to get some patches in
19:27:50 <devananda> mrda: not at all :)
19:27:56 <mrda> good :)
19:28:05 <rloo> what is a major code submission?
19:28:21 <devananda> rloo: also a good question
19:29:12 <matty_dubs> i3 is early March?
19:29:47 <NobodyCam> rloo: anything "new" / "are not doing now"????
19:29:57 <devananda> matty_dubs: march 6
19:30:17 <NobodyCam> 18 is tuesday
19:30:23 <NobodyCam> after next
19:30:33 <rloo> so 8 days away
19:30:38 <devananda> rloo: for example, a whole new power driver
19:30:42 <NobodyCam> I would vote for the 21 -- friday of that week
19:30:44 <matty_dubs> So the 18th seems pretty conservative. >2 weeks?
19:30:53 <matty_dubs> NobodyCam++
19:31:02 <lucasagomes> NobodyCam, +1
19:31:08 <NobodyCam> 17 is holiday too
19:31:10 <GheRivero> +1
19:31:35 <haomeng2> +
19:31:39 <devananda> how about phrased this way -- no new major features. but we'll continue to accept improvements (and particularly bug fixes) to existing features
19:31:47 <devananda> and to look at any code taht's already been proposed
19:32:10 <NobodyCam> devananda: for 21st ?
19:32:21 <devananda> eg, the work max_lobur has been doing on resolving a race condition. it's goign to be a substantial change (not just the one that's up there but the ones taht will follow it)
19:32:30 <devananda> that needs to continue as it's fixing a serious bug
19:32:39 <NobodyCam> ya
19:32:56 <NobodyCam> + 1 on wording
19:33:01 <lucasagomes> seems reasonable +1
19:33:14 <devananda> great.
19:33:33 <devananda> which leads me to ask...
19:33:46 <devananda> what bugs and BPs should we be prioritizing for I3?
19:34:00 <devananda> what can we postpone to the post-featurefreeze fix-all-the-bugs cycle?
19:34:11 <lucasagomes> devananda, https://blueprints.launchpad.net/ironic/+spec/windows-disk-image-support posponed
19:34:48 <rloo> i thought no bps were accepted after I3.
19:34:50 <devananda> right, so that's a good example of why I'm raising this discussion
19:34:57 <NobodyCam> lucasagomes: their are folks working hard on that one
19:35:15 <lucasagomes> NobodyCam, right, I haven't seem any code yet
19:35:22 <max_lobur> devananda: task cancellation is for I3? it looks huge
19:35:42 <lucasagomes> and the implementation is not marked as "started" or anything
19:35:53 <devananda> both the HP and SeaMicro folks would like to land drivers and features, but some of the code isn't even up at all yet
19:36:05 <devananda> at least SeaMicro put code up two weeks ago :)
19:36:13 <NobodyCam> lucasagomes: see pm
19:36:15 <rloo> lucasagomes: if you're referring to the windows one, there's a comment that they'll have initial code for reivew by feb 12.
19:37:02 <Wanyen> HP code is under internal review.  We plan toupload it this week.
19:37:34 <lucasagomes> rloo, NobodyCam ack
19:37:34 <devananda> so if a new feature (eg, windows support in the pxe driver) is posted on feb 12, is that enough time for us to test it, review it, etc, by I3 -- given the existing backlog of bug fixes, and the work on the nova driver?
19:37:37 <NobodyCam> welcome Wanyen
19:37:50 <Wanyen> Thanks!
19:38:32 <NobodyCam> did we set our freze date as 21st or 18th?
19:38:45 <matty_dubs> Is there ever really a _guarantee_ that things will be reviewed by a given time?
19:38:58 <matty_dubs> vs. "get your patch in soon if you want it to land in i3"?
19:39:03 <devananda> NobodyCam: i haven't responded to the thread yet, so we dont officially have a freeze date, but 18th is the common "stop submitting new features" deadline
19:39:22 <NobodyCam> devananda: ack!
19:39:26 <devananda> matty_dubs: correct. there's no guarantee, but most projects are telling folks to stop submitting new major features about 2 weeks ahead of I3 cut
19:39:41 <devananda> matty_dubs: so that there is at least a chance they'll get reviewed in time :)
19:41:29 <devananda> NobodyCam: erm, sorry, in my speed-typing i mistyped -- not a freeze date
19:41:42 <devananda> freeze is I3. no new features land after that, just bug fixes
19:41:59 <NobodyCam> ya
19:42:32 * NobodyCam recalls some nova bm bugs that may have been questionable when landing that code
19:42:36 <matty_dubs> So maybe it's just me (and note that I'm not tackling anything major so I don't have a strong opinion), but it seems like "We're reluctant to accept patches adding new features after the 21st, but to be sure your patch has time to be reviewed, you should look at posting it by the 18th" or something is reasonable, without needing a lot of thought on hard deadlines.
19:43:26 <devananda> matty_dubs: s/21st/march 6th/
19:44:15 * NobodyCam lost the agenda :-p
19:44:15 <rloo> devananda: i thought after march 6, no new features.
19:44:32 <devananda> rloo: right :)
19:44:47 <devananda> rloo: so new features should be posted by 2/18 to give us time to review
19:44:58 <rloo> so matty_dubs comment 'We're reluctant to accept patches adding new features after March 6' isn't right?
19:45:17 <matty_dubs> Oh, I just meant a soft deadline, as discussed above -- 18th as the "do yourself a favor and get your patches in" mark, the 21st as a "we'll frown upon feature submissions after this because it's cutting it close", and March 6 as the "Nope!" hard deadline.
19:45:26 <devananda> ahh
19:45:44 <rloo> matty_dubs. no 21 I don't think? Seems like there are two dates, Feb 18 and March 6?
19:45:50 <devananda> matty_dubs: i guess i dont see much difference between "d oyourself a favor" and "we'll frown" :)
19:46:29 <matty_dubs> Sure, that works. My point was really just that I think we've spent a lot of time debating 18th vs. 21st but if it's not a hard cutoff, I'm not sure there's a huge difference between them.
19:46:35 <rloo> and just a nit, but I don't think it is March 6. Isn't there a code freeze 2 days before?
19:46:42 <lucasagomes> ok folks... so priorities (what is needed for us to get out of incubation): nova bm migration, neutron integration for pxe and console access (something else?)
19:46:54 <lucasagomes> and the ironic driver for nova
19:47:13 <NobodyCam> #link https://launchpad.net/ironic/+milestone/icehouse-3
19:47:57 <devananda> rloo: ah, you're right -- https://wiki.openstack.org/wiki/Icehouse_Release_Schedule. I got 3/6 from launchpad as the date it's released, but the branch is tagged 2 days ahead
19:47:57 <NobodyCam> nova isn't actually  graduation requirment is it?
19:48:09 <devananda> NobodyCam: correct
19:48:39 <lucasagomes> ack
19:48:43 <NobodyCam> but nice to have!
19:48:46 <devananda> for one, we can't control whether nova accepts our driver. for another, as an incubated project, it's quite reasonable for nova not to accpet it before we graduate
19:49:25 <NobodyCam> that beggs the question is the nova bm migration path / script a requirment then?
19:49:49 <devananda> NobodyCam: good point -- that may be a more reasonable requirement for the Juno release, then
19:50:01 <devananda> I'll bring that up tomorrow
19:50:16 <rloo> what does it mean to 'graduate' then?
19:50:25 <lucasagomes> devananda, yea, cause that bp is marked as essential, maybe it should go for high or medium then
19:50:30 <devananda> rloo: to become part of the integrated development cycle
19:50:44 <devananda> lucasagomes: yea. i'll update it after I confirm
19:50:48 <lucasagomes> ack
19:50:52 <rloo> devananda. ah, thx for clarifying.
19:50:53 <lucasagomes> neutron integration any news?
19:51:04 <devananda> rloo: some of the details around graduation have only recently really been hashed out by the TC and codified
19:51:04 <NobodyCam> TEN MINUTE BELL
19:51:05 <lucasagomes> I tried it last week on friday, but didn't get it to work
19:51:14 <rloo> devananda. so that is diff from the goal of ironic being able to 'replace' baremetal.
19:51:21 <lucasagomes> I'll give it another shot tomorrow, any one has any tips?
19:51:21 <devananda> lucasagomes: hmm... ok. i was about to ask what's stopping that from landing
19:51:39 <devananda> lucasagomes: i need to give it a whirl soon too
19:51:52 <devananda> NobodyCam: did you get the PXE->neutron patch working?
19:52:07 <lucasagomes> all I did was cherry picking #70468 on top of my ironic and tested
19:52:18 <NobodyCam> no.. but did not do any work over hte weekend
19:52:20 <lucasagomes> devananda, ack
19:52:34 <lucasagomes> maybe it's my env as well, cause it's a bit messy I will retry tomorrow with a new env and all
19:52:37 <lucasagomes> I let u know
19:52:50 <lucasagomes> console access, anyone has any updates on it?
19:53:02 <devananda> none here
19:53:05 <lucasagomes> we need a trigger on the API to start/stop the console
19:53:11 <lucasagomes> I will try to add that soon
19:53:25 <lucasagomes> but we also need to test sun jings patchs
19:53:25 <devananda> lucasagomes: and we'll need to expose some info back to the client
19:53:33 <devananda> about how to access the console itself
19:53:37 <NobodyCam> I have not seen linaggo on
19:53:54 <NobodyCam> has anyone?^^
19:54:03 <lucasagomes> NobodyCam, nop :(
19:54:10 <devananda> not i
19:54:17 <devananda> neither sunjing nor linggao
19:54:19 <lucasagomes> devananda, ack, I will see how nova does it
19:54:26 <lucasagomes> and make something similar for ironic
19:54:31 <Wanyen> Has console code been merged yet?
19:54:41 <devananda> Wanyen: no. IBM put patches up
19:54:53 <devananda> Wanyen: but they were not updated after receiving feedback
19:54:59 <lucasagomes> #link https://review.openstack.org/#/c/64100/
19:55:04 <lucasagomes> that's the console patch
19:55:07 <lucasagomes> it's abandoned :/
19:55:12 <Wanyen> Thanks!
19:55:13 <NobodyCam> Ty lucasagomes
19:55:20 <NobodyCam> 5 minutes
19:55:37 <max_lobur> lifeless: r u around?
19:55:59 <devananda> going to toss up a few actions from all that...
19:56:21 <devananda> #action devananda to check with TC regarding graduation requirement for the nova driver and nova_bm db migrations
19:56:31 <Wanyen> Imeant thanks for providig the link for console code.
19:56:36 <lucasagomes> haomeng2, any news on the sending ipmi data back to ceilometer?
19:57:02 <devananda> #action lucasagomes to add API for start/stop console && GET console endpoint info (how does nova expose this?)
19:57:25 <devananda> #action people to test the PXE driver -> Neutron integration patch and figure out if/why it's not working
19:57:28 <lucasagomes> Wanyen, you welcome
19:57:38 <devananda> ok... last 2 minutes ....
19:57:41 <devananda> #topic open discussion
19:57:53 <lucasagomes> quick topic on the open discussion
19:57:57 <lucasagomes> about the objects/base.py
19:58:09 <lucasagomes> there's a couple of patches changing it slightly (it means diverging from nova)
19:58:14 <lucasagomes> should we go for it in Ironic?
19:58:25 <lucasagomes> I'm always confusing when reviewing such patches
19:58:32 <lucasagomes> confused*
19:58:38 <devananda> lucasagomes: that hasn't made it into oslo afaik
19:58:46 <lucasagomes> yea not yet
19:58:46 <max_lobur> for instance?
19:58:59 <devananda> lucasagomes: what are the changes? do we need them?
19:59:02 <max_lobur> get rid of dict iface?
19:59:05 <lucasagomes> max_lobur, e.g https://review.openstack.org/#/c/60025/
19:59:12 <devananda> ahh
19:59:18 <NobodyCam> ONE minute
19:59:20 <max_lobur> ah yup
19:59:27 <lucasagomes> well, we don't "need" it
19:59:35 <max_lobur> let's continue in ironic
19:59:37 <lucasagomes> ack
19:59:40 <NobodyCam> ++
19:59:42 <Haomeng> :)
19:59:48 <NobodyCam> great meeting every one
19:59:55 <Wanyen> when is the ronic channel?
19:59:58 <devananda> thanks all!
20:00:01 <max_lobur> thanks everyone
20:00:03 <devananda> #endmeeting