19:00:01 <NobodyCam> #startmeeting Ironic
19:00:01 <openstack> Meeting started Mon Jan  6 19:00:01 2014 UTC and is due to finish in 60 minutes.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:02 <NobodyCam> #chair devananda
19:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:03 <NobodyCam> Welcome everyone to the Ironic meeting.
19:00:05 <openstack> The meeting name has been set to 'ironic'
19:00:06 <openstack> Current chairs: NobodyCam devananda
19:00:11 <NobodyCam> Of course the agenda can be found at:
19:00:12 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting
19:00:18 <NobodyCam> #topic Greetings, roll-call and announcements
19:00:19 <NobodyCam> Who's here for the Ironic Meeting?
19:00:33 <rloo> me
19:00:36 <linggao> me
19:00:40 <lucasagomes> o/
19:00:46 <ifarkas> o/
19:00:51 <pcarver> me, though I have nothing particular to discuss
19:01:09 <NobodyCam> welcome old and new "nicks"
19:01:13 <dkehn> here
19:01:19 <NobodyCam> everyone is welcome
19:01:50 <NobodyCam> looks like thats about it
19:01:51 <NobodyCam> announcements:
19:01:51 <NobodyCam> Devananda is down under at LCA, So I don't expect he'll make the meeting.
19:01:54 <NobodyCam> And our Ukrainian friends are most likely still on vacation.
19:02:23 <NobodyCam> anyone else have any announcemrnts?
19:02:54 <NobodyCam> we'll move on to
19:02:57 <NobodyCam> #topic Outstanding, in-progress or Action Item updates
19:03:46 <NobodyCam> As the I2 release date gets closer Devananda thought it would be good to go over the blueprints and bugs
19:03:57 <NobodyCam> so lets jump in to BluePrints
19:04:06 <NobodyCam> PXE driver should mount target iSCSI volume and "dd" image
19:04:06 <NobodyCam> #link https://blueprints.launchpad.net/ironic/+spec/pxe-mount-and-dd
19:05:15 <NobodyCam> I not sure on this one why its taged as needs review but dose not have a assignie
19:06:02 <NobodyCam> so we'll skip over it.
19:06:02 <NobodyCam> Map instances to conductors using a consistent hashing algoritm
19:06:04 <NobodyCam> #link https://blueprints.launchpad.net/ironic/+spec/instance-mapping-by-consistent-hash
19:06:12 <NobodyCam> this is one deva is working on
19:07:05 <NobodyCam> I know i have seen several reviews releted to it, so again with out deva we can skip over it
19:07:16 <NobodyCam> use ipmitool to provide serial console access
19:07:16 <NobodyCam> #link https://blueprints.launchpad.net/ironic/+spec/serial-console-access
19:07:44 <linggao> It is in code review.
19:07:51 <NobodyCam> this is Sun Jing
19:07:57 <lucasagomes> sun jing is woking on it , there's a review up already
19:08:00 <lucasagomes> #link https://review.openstack.org/#/c/64100/
19:08:19 <linggao> sun jing has implemented the support for ipmitool.
19:08:41 <linggao> Needs to support ipminative after icehouse.
19:08:53 <lucasagomes> yea so, in ironic we have an driver's interface for the console
19:09:01 <lucasagomes> with it's own start/stop methods etc
19:09:18 <NobodyCam> awesome,
19:09:27 <NobodyCam> lucasagomes: is that also in the cli?
19:09:29 <lucasagomes> so it doesn't need to be implemented within ipmi* (power interfaces)
19:09:45 <lucasagomes> NobodyCam, not yet
19:09:53 <linggao> I agree with lucasagomes
19:09:53 <NobodyCam> ack
19:10:39 <NobodyCam> looks like sun jing's review has several -1 on it. do se know if they are being addressed?
19:11:14 <lucasagomes> this thing about having a separeted console interface in Ironic is being addressed there
19:11:44 <NobodyCam> :)
19:12:23 <NobodyCam> ok next up:
19:12:23 <NobodyCam> add Neutron support
19:12:24 <NobodyCam> #link https://blueprints.launchpad.net/ironic/+spec/add-neutron-support
19:12:35 <NobodyCam> dkehn: any word
19:12:38 <NobodyCam> :-p
19:13:00 <dkehn> in the middle of working it, hopefully have at least a WIP soon
19:13:12 <NobodyCam> awesome !!!1
19:13:29 <dkehn> code is mostly there and I I've figured out the testing, at least through neutron
19:13:54 <dkehn> the other way , will need help but I think to make
19:13:59 <dkehn> I2 that might be good
19:14:11 <NobodyCam> sweet :)
19:14:33 <dkehn> thats it
19:14:36 <dkehn> for me
19:14:44 <NobodyCam> our testing guru is still on vacation
19:14:55 <NobodyCam> should be back tomorrow
19:15:12 <NobodyCam> and with that we can move on to bugs
19:15:58 <NobodyCam> again we are still short some people I will mention them here for those who are readding the logs
19:16:09 <NobodyCam> Bugs:
19:16:15 <NobodyCam> non-unique pxe driver 'instance_name' causes problems
19:16:16 <NobodyCam> #link https://bugs.launchpad.net/bugs/1236536
19:16:20 <NobodyCam> that GheRivero
19:16:25 <NobodyCam> *thats
19:16:35 <NobodyCam> GheRivero: Are you here?
19:17:23 <NobodyCam> if he shows up we can come back to him
19:17:25 <NobodyCam> sync_power_states does not handle missing driver info well
19:17:25 <NobodyCam> #link https://bugs.launchpad.net/bugs/1262912
19:17:46 <NobodyCam> this is not assigned to to anyone
19:19:18 <rloo> NobodyCam: that looks easy to fix. (appearances can be deceiving). I'll look into it.
19:19:27 <NobodyCam> loks like haomeng was looking in to it
19:19:53 <NobodyCam> rloo: can you ping Haomeng
19:20:03 <rloo> NobodyCam: yeah, ok, i'll ask him. looks like he couldn't reproduce.
19:20:06 <NobodyCam> just to make sure he's not on it
19:20:13 <NobodyCam> ya
19:20:26 <rloo> NobodyCam: yup, will check with Haomeng about it.
19:20:34 <NobodyCam> #action rloo looking at https://bugs.launchpad.net/bugs/1262912
19:20:41 <NobodyCam> rloo: Thank you
19:21:24 <NobodyCam> and another Haomeng bug:
19:21:25 <NobodyCam> Race when associating instance_uuid
19:21:25 <NobodyCam> #link https://bugs.launchpad.net/bugs/1244541
19:21:50 <NobodyCam> I will see if I can follow up with him too
19:22:19 <NobodyCam> and the last bug to go over:
19:22:19 <NobodyCam> Update node reservation by user causes unbreakable lock
19:22:20 <NobodyCam> #link https://bugs.launchpad.net/bugs/1250348
19:22:51 <NobodyCam> Yuriy is working on that ... so I will try and get with him tomorrow or wed.
19:23:51 <lucasagomes> there's a patch waiting for review for that
19:23:52 <NobodyCam> as we progress to graduation here a link to read over.
19:23:56 <NobodyCam> #link https://review.openstack.org/#/c/59454/2/reference/incubation-integration-requirements
19:23:59 <lucasagomes> I'll take another look at it as well
19:24:00 <lucasagomes> #link https://review.openstack.org/#/c/55549/
19:24:52 <NobodyCam> lucasagomes: I too will take another look after the meeting
19:25:25 <NobodyCam> any thing else from anyone on BP's or bugs?
19:26:00 <NobodyCam> if not we'll move on to :
19:26:02 <NobodyCam> #topic Integration and testing
19:27:31 <NobodyCam> I think most of the people working on this are still on vacation so, are threre any question on testing?
19:28:18 <lucasagomes> hmm, have you started testing the deployment right?
19:28:41 <NobodyCam> I have not, hope to getting to that this week
19:28:47 <NobodyCam> #link https://etherpad.openstack.org/p/IronicDevstackTesting
19:28:54 <NobodyCam> has some info on it
19:29:24 <lucasagomes> ah great :)
19:29:54 <NobodyCam> I will be working up a dnsmasq link and instructions for manually building the tftp dir for some basic tests
19:30:15 <NobodyCam> dnsmasq link == command line command
19:30:59 <NobodyCam> with out over questions we can jump in to :
19:31:02 <NobodyCam> #topic Python-IronicClient
19:31:24 <NobodyCam> lots of great work on the cli at the end of last week
19:31:40 <NobodyCam> we are really close to being able to deploy
19:32:06 <NobodyCam> lucasagomes: anything you think needs to be pointed out about the cli?
19:32:45 <lucasagomes> nice, you'll need that patch adding the deploy trigger to the cli libs for ur deploy tests?
19:33:15 <NobodyCam> ya !!
19:33:47 <lucasagomes> right, maybe we should get lifeless to review that patch and +A
19:33:59 <NobodyCam> that actually leads us nicly to
19:34:00 <NobodyCam> #topic Nova-driver
19:34:08 <lucasagomes> yup
19:34:37 <NobodyCam> I have ofc totaly lost my place over the holiday
19:34:41 <lucasagomes> I reviewed the driver before my vacations, need to review it again
19:34:49 <NobodyCam> and am getting myself back into the grove
19:35:31 <NobodyCam> I am working on a static map of driver required fields
19:35:58 <NobodyCam> so that the nova driver knows what to add for a deploy
19:37:05 <lucasagomes> right, what's working on the driver already?
19:37:10 <NobodyCam> we are also attaching nova's vif data model to the port so that don's neutron patch has the ata he needs to work woth
19:37:14 <lucasagomes> is it possible to power on a vm with the ironic driver for nova?
19:37:15 <NobodyCam> with even
19:37:36 <lucasagomes> I mean, using nova as an endpoint for ironic
19:37:56 <NobodyCam> lucasagomes: yes nova driver should be able to power on / off
19:38:05 <lucasagomes> sweet
19:38:08 <NobodyCam> :)
19:38:10 <ifarkas> NobodyCam, a question regarding the deployment workflow: what is needed to test it in its current form? Only the ironic driver in nova?
19:38:53 <NobodyCam> and the ironic client
19:39:03 <ifarkas> sure
19:39:43 <NobodyCam> ifarkas: here is the DIB (disk image builder) element I use to create my test env.. https://github.com/NoBodyCam/ironic-element
19:39:47 <NobodyCam> #link https://github.com/NoBodyCam/ironic-element
19:40:28 <ifarkas> NobodyCam, cool, thanks!
19:40:36 <NobodyCam> and a walk thru of using it: here
19:40:39 <NobodyCam> #link https://wiki.openstack.org/wiki/Ironic#Using_Disk_Image_Builder
19:41:12 <NobodyCam> any other question / comments on the nova driver
19:41:13 <NobodyCam> ?
19:41:52 <NobodyCam> if not we'll jump over to:
19:41:53 <NobodyCam> #topic API discussion
19:42:22 <lucasagomes> off the top of my head, idk if there's something to discuss bout the API
19:42:31 <NobodyCam> I think we landed the make chassis not manadtory?
19:42:39 <lucasagomes> yup
19:42:43 <lucasagomes> it;s now optional
19:43:01 <NobodyCam> awesome ness
19:43:11 <lucasagomes> #link https://review.openstack.org/#/c/64701/
19:43:48 <NobodyCam> ok I had to of skipped something
19:43:58 <NobodyCam> we are at FFT
19:44:19 <NobodyCam> humm
19:44:21 <NobodyCam> #topic Food for Thought / Open Discussion
19:44:32 <NobodyCam> open floor
19:44:46 <lucasagomes> right, anyone is familiar with taskflow here?
19:44:53 <lucasagomes> I was thinking about the ramdisk agent
19:45:26 <lucasagomes> in the HK summit kinda talked about the deploy agent to poll "what's next to execute" from the Ironic API
19:45:46 <NobodyCam> lucasagomes: do we know how the ramdisk will talk back to ironic?
19:45:46 <lucasagomes> and I was taking a look if taskflow would be suitable for creating the workflow for the ramdisk
19:45:54 <lucasagomes> anyone has some thoughts about it?
19:46:13 <lucasagomes> NobodyCam, I think he will do it via the Ironic API endpoint
19:46:18 <lucasagomes> it will POST things to the api
19:46:52 <NobodyCam> how about any auth issues
19:46:58 <lucasagomes> via the vendor passthru
19:47:06 <NobodyCam> or some kinda of allowed acl ?
19:47:24 <lucasagomes> yea, I don't know exactly how it's going to work
19:47:32 <lucasagomes> I think there were some discussion about it
19:47:34 <lucasagomes> for e.g
19:47:41 <lucasagomes> passing a auth key via kernel cmd line
19:47:45 <lucasagomes> but it's limited and won't work
19:48:19 <NobodyCam> lucasagomes: sounds like we'll need a ether pad for options
19:48:26 <lucasagomes> could use the ftp as well so the ramdisk would suck it from there
19:48:29 <lucasagomes> yea
19:48:49 <lucasagomes> there's some ways to do it, and I know people have discussed some
19:48:55 <NobodyCam> we could build auth in to a file on tftp dir
19:48:58 <NobodyCam> ya
19:49:00 <lucasagomes> yea
19:49:05 <lucasagomes> and the ramdisk would grab it from there
19:49:13 <NobodyCam> ya,
19:49:26 <lucasagomes> it's openfloor, if people has others ideas on how to do it please
19:49:32 <NobodyCam> so there are many options we'll start a epad and explor them
19:49:40 <lucasagomes> +1
19:49:41 <NobodyCam> yes please jump in
19:50:09 <NobodyCam> any thing else?
19:50:15 <NobodyCam> we have 10 minutes
19:50:53 <NobodyCam> if not we can head out early and grab some lunch
19:51:55 <NobodyCam> lucasagomes: I know its getting late for you today, let hookup on the ramdisk auth subject tomorrow am
19:52:06 <lucasagomes> NobodyCam, cool
19:52:10 <lucasagomes> works for me
19:52:29 <NobodyCam> so if thats it we can call it a early meeting.
19:53:06 <NobodyCam> Thank you every one. we should have all the vacationers back for hte next meeting
19:53:24 <lucasagomes> cheers
19:53:32 <NobodyCam> Thank you all,
19:53:35 <ifarkas> Thanks and bye!
19:53:47 <NobodyCam> :)
19:53:49 <NobodyCam> #endmeeting