18:59:40 <NobodyCam> #startmeeting ironic
18:59:41 <openstack> Meeting started Mon Jul  1 18:59:40 2013 UTC.  The chair is NobodyCam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:59:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:59:45 <openstack> The meeting name has been set to 'ironic'
18:59:56 <NobodyCam> here's an agenda
18:59:57 <NobodyCam> #link https://wiki.openstack.org/wiki/Meetings/Ironic
19:00:06 <NobodyCam> Who's here today
19:00:36 <NobodyCam> for the Ironic Meeting
19:01:13 * martyntaylor is here
19:01:16 <GheRivero> hi all
19:01:31 <anteaya> o/
19:01:44 <NobodyCam> hey hey martyntaylor GheRivero anteaya
19:01:51 <anteaya> :D
19:02:06 <NobodyCam> ok so no devananda this week
19:02:15 <martyntaylor> NobodyCam: howdy, yea I gathered :
19:02:23 <romcheg> Morning all
19:02:26 <NobodyCam> he off at some pycon
19:02:35 <NobodyCam> hey romcheg :) welcome
19:02:55 <NobodyCam> so first up on the agenda
19:03:03 <NobodyCam> #topic API implementation and refactoring
19:03:30 <NobodyCam> we have this review
19:03:32 <NobodyCam> https://review.openstack.org/#/c/35126/
19:03:38 <romcheg> #link https://review.openstack.org/#/c/35126/
19:03:58 <NobodyCam> :)
19:04:00 <romcheg> I faced a problem with pep8 and import loop
19:04:19 <martyntaylor> romcheg: by the looks of this you need review
19:04:27 <NobodyCam> ya I saw the comment.
19:05:01 <romcheg> opensack-dev was very unwelcome in helping with that :D
19:05:32 <NobodyCam> romcheg: can you post a link to a log of the loop.. so that we can take a look at what you are seeing
19:05:46 <NobodyCam> maybe just as a comment to the review?
19:06:12 <martyntaylor> yeah it would be good to figure out how the loop is happening
19:06:53 <anteaya> romcheg this error is a tad specific to ironic, so most folks in -dev wouldn't have much guidance for the fix
19:06:54 <NobodyCam> we could get some more eyes on it,
19:07:03 <martyntaylor> I guess node is dependent on something that we explicitly import?
19:08:04 <romcheg> http://paste.openstack.org/show/39409/
19:08:11 <romcheg> that's the description
19:10:58 <NobodyCam> okay, lets move on. to the next topic and loop back if we have time else we can go over in Ironic room
19:11:08 <NobodyCam> thank you romcheg
19:11:17 <NobodyCam> #topic API checking of keystone auth token
19:12:28 <NobodyCam> not sure we actually got a action itom for this one
19:12:32 <NobodyCam> last week
19:12:49 <romcheg> I can check that this week
19:13:26 <NobodyCam> Thank you romcheg
19:13:29 <romcheg> No, there was no action for keystone tokens last time
19:13:48 <romcheg> Better create one this time
19:13:49 <NobodyCam> #action romcheg check in to API checking of keystone auth token
19:14:16 <NobodyCam> anything else on this one?
19:14:44 <NobodyCam> moving on...
19:14:45 <NobodyCam> #topic RPC implementation for lock-aware API calls
19:14:45 <romcheg> I think we can move on
19:15:03 <NobodyCam> #link https://review.openstack.org/#/c/34115/
19:15:13 <NobodyCam> is what devananda has up.
19:15:30 <NobodyCam> ofc he's not here to add any comments
19:15:56 <romcheg> However this should be rebased onto that refactoring i guess
19:15:57 <NobodyCam> :-p do we have any discission
19:16:21 <romcheg> *that API refactoring
19:16:22 <NobodyCam> ya.. deva's just been swamped this week
19:16:41 <NobodyCam> * last week
19:17:39 <romcheg> I think that's all on RPC sfuff
19:17:44 <NobodyCam> ya
19:17:46 <NobodyCam> #topic PXE driver and Image utils refactoring
19:17:47 <romcheg> That's a shame :)
19:17:57 <GheRivero> no movement on the python-glanceclient side, so if nothing changes, will ove it into ironic to have it working and will try to sync menawhile
19:18:02 <NobodyCam> GheRivero: your up? any updates
19:18:05 <NobodyCam> :)
19:18:34 <GheRivero> and the pxe driver is waiting for it
19:18:36 <NobodyCam> +1 ya that can at least get us moving
19:18:50 <GheRivero> i have a ironic version working
19:19:00 <NobodyCam> can we add a bug to remove once the sync is done just to keep track?
19:19:01 <GheRivero> but without tests
19:19:08 <GheRivero> yeah, sure
19:19:37 <NobodyCam> :) and it's looking really good Ghe
19:19:39 <NobodyCam> :)
19:19:44 <GheRivero> will prepare for tomorrow to have time to review and approved by the end of week
19:19:56 <NobodyCam> w00t!!!
19:20:04 <NobodyCam> Thank you Ghe :)
19:20:23 <NobodyCam> ieek
19:20:26 <NobodyCam> fyi
19:20:31 <NobodyCam> #link https://review.openstack.org/#/c/33616/
19:20:32 <romcheg> GheRivero: great!
19:20:54 <NobodyCam> wow we are cooking thru this meeting
19:21:11 <NobodyCam> any thing eles on PXE patch?
19:21:21 <GheRivero> not from my side
19:21:35 <romcheg> let's move on
19:21:44 <NobodyCam> moving on...
19:21:46 <NobodyCam> #topic Ironic standup / D.I.B. element status
19:21:54 <NobodyCam> oh wait that's me
19:21:56 <NobodyCam> :)
19:22:21 <NobodyCam> ok we are getting I do have a element that can stand up ironic services
19:22:28 <NobodyCam> api and "manager"
19:23:15 <NobodyCam> holding off on submitting untill the manage to conductor patch lands (or ???)
19:24:23 <NobodyCam> I found a couple of issues in other elements that I have some patches out for that are also holding me up for submitting but I am working them thru the system now
19:24:50 <NobodyCam> with that ... I hope to have a draft up by eow this week.
19:25:31 <NobodyCam> questions on the ironic DIb element?
19:26:04 <anteaya> good work, NobodyCam
19:26:16 <NobodyCam> :) *(BLUSH)*
19:26:27 <NobodyCam> moving on...
19:26:29 <NobodyCam> #topic open discussion
19:26:59 <romcheg> To be fair, does not look like we had a very productive week :(
19:27:04 <NobodyCam> wanted to thank everyone for all the awesome work!!!
19:27:46 <anteaya> romcheg: things tend to go in cycles
19:28:10 <anteaya> sometimes we have a lull in preparation for a new influx of code
19:28:25 <anteaya> and yes, ironic is really growing quickly
19:28:28 <NobodyCam> no it was not the most productive week.. but things are moving forward I think.
19:28:34 <NobodyCam> yes!
19:29:09 <romcheg> agree
19:29:45 <NobodyCam> did we want to take any time to look at teh looping issue, or is that better for the iRonic room
19:31:13 <anteaya> better for the room I think
19:31:18 <romcheg> +1
19:31:34 <NobodyCam> ok then we can move back to our little room and end the meeting early,
19:31:42 <NobodyCam> last call?
19:32:13 <NobodyCam> thank you everyone for putting up with my first meeting hosting :)
19:32:16 <romcheg> let's go the the room!
19:32:19 <anteaya> you did a great job
19:32:25 <dkehn> NobodyCam, awesome
19:32:25 <romcheg> Yes, thank you
19:32:37 <NobodyCam> and with that
19:32:41 <NobodyCam> #endmeeting