16:01:16 <eglute> #startmeeting interopwg
16:01:16 <openstack> Meeting started Wed Aug  2 16:01:16 2017 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:20 <openstack> The meeting name has been set to 'interopwg'
16:01:30 <eglute> Hello Everyone!
16:01:34 <eglute> #topic agenda
16:01:38 <hogepodge> hi!
16:01:41 <eglute> #link https://etherpad.openstack.org/p/InteropVertigo.10
16:01:47 <eglute> #chair hogepodge
16:01:48 <openstack> Current chairs: eglute hogepodge
16:01:58 <markvoelker> o/
16:02:00 <eglute> #chair markvoelker
16:02:00 <openstack> Current chairs: eglute hogepodge markvoelker
16:02:11 <catherineD> o/
16:02:37 <eglute> Anyone else here for interop wg meeting?
16:02:49 <eglute> please update agenda as needed: https://etherpad.openstack.org/p/InteropVertigo.10
16:03:04 <mrhillsman> o/
16:03:16 <mguiney> o/
16:04:04 <eglute> #topic PTG
16:04:30 <eglute> reminder, we will be at PTG, please add your name to the etherpad if you are planning on attending: #link https://etherpad.openstack.org/p/InteropDenver2017PTG
16:04:38 <eglute> also please add suggested topics
16:05:22 <eglute> #topic 2017.08 Guideline
16:05:31 <catherineD> eglute: I assume Interop-wg and Refstack will share the same room as we did last time?
16:05:38 <eglute> catherineD correct!
16:05:51 <eglute> at least, i think that's what i requested
16:06:12 <catherineD> great so we will use the same etherpad https://etherpad.openstack.org/p/InteropDenver2017PTG
16:06:24 <eglute> sounds good!
16:06:32 <eglute> yes, on the schedule we are together
16:06:34 <catherineD> also do we know the head count so far?
16:07:06 <eglute> no, that's why I am asking people to add themselves to the list
16:07:10 <catherineD> the etherpad has 4 names so far
16:07:13 <eglute> https://etherpad.openstack.org/p/InteropDenver2017PTG
16:07:21 <eglute> right, i hope there will be more :)
16:07:26 <hogepodge> Six now :-D
16:07:47 <catherineD> ic thx :-)
16:07:47 <eglute> catherineD are you going to attend?
16:08:28 <catherineD> eglute: yea waiting for travek approval
16:08:43 <eglute> hope you get it catherineD
16:08:50 <catherineD> just update the ehterpad
16:09:01 <eglute> thanks catherineD
16:09:11 <catherineD> eglute: thank YOU!
16:09:26 <eglute> hogepodge do you have edit access to this? https://docs.google.com/spreadsheets/d/1xmOdT6uZ5XqViActr5sBOaz_mEgjKSCY7NEWcAEcT-A/edit#gid=397241312
16:09:39 <eglute> or anyone? need to add ehterpad link
16:10:06 <Rockyg> o/
16:10:46 <mrhillsman> eglute nope
16:11:05 <catherineD> strange that everyone appears as anonymous even that I am login at gmail
16:11:29 <catherineD> eglute: nope for me too on https://docs.google.com/spreadsheets/d/1xmOdT6uZ5XqViActr5sBOaz_mEgjKSCY7NEWcAEcT-A/edit#gid=397241312
16:11:48 <eglute> catherineD same here! i dont understand how that works.
16:12:18 <eglute> ok, i will find someone with access later to get that updated
16:12:23 <eglute> anything else on PTG?
16:12:35 <mrhillsman> kendall nelson can update it eglute
16:12:50 <eglute> catherineD please ask RefStack people to use the etherpad :)
16:12:51 <catherineD> mrhillsman: I think so
16:13:02 <eglute> mrhillsman thanks, i will email her after the meeting!
16:13:05 <catherineD> catherineD: will do
16:13:07 <mrhillsman> very welcome
16:13:20 <eglute> anything else on PTG?
16:13:38 <eglute> #topic 2017.08 Guideline
16:14:05 <eglute> so i think we still need to add all the aliases to this guideline, i have not had a chance to look
16:14:23 <eglute> any volunteers to review the differences between next.json and 2017.08?
16:14:47 <hogepodge> I can do it alongside other work I have on this today
16:14:57 <markvoelker> Luz had a patch in last week to reconcile some of those
16:15:22 <markvoelker> https://review.openstack.org/#/c/485438/
16:15:23 <eglute> thanks hogepodge
16:15:48 <eglute> oh thats right. I think we just need to confirm that none slipped
16:15:51 <eglute> thanks to LuzC for doing the work!
16:16:03 <eglute> anything else on 2017.08?
16:17:13 <markvoelker> eglute: do we have a timeslot at the BoD meeting in Denver?
16:17:14 <mrhillsman> have to run but will catch up on the logs
16:17:29 <eglute> markvoelker not yet, but i will ask for it
16:17:36 <markvoelker> thanks
16:17:38 <eglute> also there is a meeting this month as well
16:17:51 <eglute> so i will ask the board to approve the 2017.08 guideline
16:18:02 <markvoelker> ++
16:18:13 <hogepodge> next in 2.0 format?
16:18:25 <catherineD> hogepodge: no
16:18:40 <eglute> hogepodge i think it needs to be converted...
16:18:54 <markvoelker> I think we'd agreed before that 2017.08 would be in 1.x but we should shift next.json over to 2.0.
16:19:07 <catherineD> please do not add any json with 2.0 format until https://review.openstack.org/#/c/484625/  is merged at RefStack
16:19:09 <hogepodge> ah, ok
16:20:53 <eglute> anything else on the 2017.08?
16:22:00 <eglute> #topic Add get catalog capability as advisory
16:22:09 <eglute> #link https://review.openstack.org/#/c/485415/
16:22:16 <eglute> please review, everyone
16:23:21 <eglute> #topic Schema 2.0
16:23:46 <hogepodge> thanks to luzC and mguiney for making that possible!
16:23:47 <eglute> #link https://review.openstack.org/#/c/430556/ was merged
16:23:48 <eglute> thank you hogepodge for working on it!!!
16:23:54 <eglute> yes, thank you all!
16:23:58 <hogepodge> haha things for finishing it off eglute
16:24:10 <eglute> yeah, i had the hardest part ;) :D
16:24:46 <eglute> anyways, next!
16:24:52 <eglute> #topic Extension programs
16:24:58 <eglute> hogepodge i think thats you correct
16:25:17 <hogepodge> yes
16:25:29 <hogepodge> I have links to the documents that designate and heat provided
16:26:07 <hogepodge> #link Designate https://etherpad.openstack.org/p/DNS-InterOp-Capabilities
16:26:19 <hogepodge> #link Heat https://docs.google.com/document/d/1pSLeUm2rc8tjGQiMMAloGgOl_U1LHrxgsyJbbC2YEJA/edit
16:26:57 <hogepodge> These are the two that I want to get up for advisory before the next meeting. Time is short, but my goal is to get them up for review in before end of day tomorrow
16:27:11 <hogepodge> To present to the board as advisory.
16:27:20 <eglute> hogepodge next meeting this month or in september
16:27:51 <hogepodge> August board meeting, along with 2017.08 guideline. Although I suppose we could ask for more runway and do September
16:27:57 <eglute> will these be in schema 2.0?
16:28:05 <hogepodge> Yes
16:28:08 <mguiney> awesome
16:28:19 <hogepodge> They have to be, since 1.x doesn't have the necessary mechanics
16:28:30 <eglute> hogepodge i think this month is doable.
16:28:38 <eglute> if you submit the patches :)
16:28:57 <eglute> in the links provided, anything controversial in your opinion?
16:29:10 <hogepodge> haha yes, I have been unreliable in my time estimates. No excuses on a big push today though. ;-)
16:29:21 <markvoelker> Do you happen to recall off the top of your head what resources are covered in heat_integrationtests.scenario.test_base_resources.BasicResourcesTest.test_base_resources_integration?  If not I'll go look, that just seems the mostly likely spot for conversation to occur.
16:29:51 <hogepodge> I don't
16:29:52 <zhipeng> do we have the heat patch on the gerrit ?
16:30:29 <Rockyg> looks like just google at the moment, zhipeng
16:31:00 <hogepodge> when the reviews are up I'll notify the dev and interop mailing lists
16:31:03 <markvoelker> Ok, I'll go pick at it then.  Just want to see what we're testing there and how it compares to what we're testing in Powered.
16:31:30 <hogepodge> yes. It's a scenario test too, so we will want to think about if it should be admitted
16:33:03 <hogepodge> that's all I have at the moment
16:33:35 <eglute> thanks hogepodge
16:33:52 <eglute> so do you think you will have these in a gerrit today/tomorrow?
16:35:06 * eglute wishes she could see people type
16:35:47 <eglute> #action hogepodge to put DNS and heat extensions into gerrit patches
16:35:55 <hogepodge> yes
16:36:19 <eglute> hogepodge could you please send out email to mailing list(s) once they are in patches? would like broader community review
16:36:29 <hogepodge> yes
16:36:41 <eglute> thank you hogepodge
16:37:29 <eglute> #topic Vertical Programs
16:37:41 <eglute> any updates on these? or postpone to PTG?
16:38:35 <markvoelker> Not much to update here as we've deferred most of this to PTG.  I'll come to Denver with a list of some potential capabilities, but I expect this is one where we'll need to start pretty small and gradually build up.  "NFV" is just a really big surface area.=)
16:41:47 <eglute> sorry, my internet went on a brake
16:42:29 <eglute> anyways, i need to update the draft completely, i will work with catherineD and hogepodge and markvoelker on it.
16:42:58 <catherineD> eglute: that is a also a good discussion for the PTG
16:43:02 <eglute> catherineD just to be clear, we are asking taht people submit subunit results to refstack, correct?
16:43:12 <catherineD> yes
16:43:30 <hogepodge> mguiney has a review up for it
16:43:32 <catherineD> eglute: I think you were thinking about a complete set of API test?
16:43:34 <hogepodge> #link https://review.openstack.org/#/c/480298/
16:44:12 <eglute> thank you hogepodge  and mguiney
16:44:15 <hogepodge> I can understand wanting more test data, but it's difficult to define "complete" outside of what is required by interop wg
16:44:16 <catherineD> Since the initial decsion to upload only passing data is made by the DefCore team
16:44:42 <catherineD> It would be nice to have Interop-WG's stand for the revise decision
16:44:54 <eglute> so looking at the refstack patch, subunit results will be optional?
16:44:57 <catherineD> RefStack will take care of the technical stuff
16:45:09 <catherineD> yea
16:45:16 <eglute> we can start with optional and have a date when it will become mandatory
16:45:25 <hogepodge> eglute: +1
16:45:30 <catherineD> but the fact that this will be the first time ever RefStrack provide such feature
16:46:04 <catherineD> eglute: hogepodge: whatever the decision just need a position statement from the Interop-WG
16:46:06 <hogepodge> optional would solve a big problem that I have with helping out vendors who need me to look at underlying test issues
16:46:23 <hogepodge> eglute: I can work with you to redraft your statement
16:46:31 <eglute> catherineD thanks, i am ok with interop wg saying that they will be mandatory starting at some date and optional as soon as refstack implements
16:46:36 <eglute> hogepodge thank you
16:46:37 <catherineD> since the initial decision was as requested by the DefCore
16:46:43 <catherineD> tam
16:46:45 <eglute> catherineD also sent some comments too
16:47:06 <catherineD> eglute: Thank you!
16:47:18 <eglute> what do others think on making subunit results optional/mandatory?
16:47:58 <markvoelker> Mandatory is hard, but I'm a little afraid optional means we just won't get any results.
16:48:21 <Rockyg> optional is fine.  Manadtory would need board approval and our submitting to board
16:48:34 <markvoelker> I'm not opposed to optional, but I think we need some clear guidance...e.g. instructions on how to configure it, maybe even a warning if you run it configured for a subset?
16:48:49 <hogepodge> I don't think it's hard. I think it's necessary. We already have the data, it can be securely transmitted and stored, and it removes the major avenue for potential cheating.
16:48:53 <Rockyg> carrot for optional could be help from hogepodge
16:48:55 <catherineD> The main concern is about privacy of the data
16:49:07 <Rockyg> no subunit, really hard to help, plus lower priority
16:49:19 <hogepodge> that's a false concern, we've gone to great lengths to debunk that
16:49:47 <catherineD> that is the main reason DefCore based on to make the decision at the time
16:49:55 <hogepodge> transmitted over ssl, on database controlled by infra with appropriate NDAs, tempest subunit does not leak sensitive information
16:50:02 <catherineD> it could be change now .. but it needs to be documented
16:51:11 <catherineD> privacy in the aspect of involuntary or unknowly reveal of privacy data ...
16:51:15 <eglute> ok, so to start with, we will have it optional for now, and will try to address any concerns as they arise
16:51:48 <eglute> since data would be available only to foundation, hopefully thats not too big of an issue
16:52:31 <hogepodge> I can write up a patch if it satisfies a desire for documentation, but this is a conversation we keep having in the meetings.
16:52:40 <hogepodge> I'll formalize it.
16:52:48 <catherineD> hogepodge: ++++
16:52:50 <eglute> thank you hogepodge
16:53:20 <catherineD> hogepodge: I saw a speaker section at ths summit for the topic ... did you submit that?
16:53:24 <eglute> #action hogepodge write up a documentation patch for optional subunit results
16:54:16 <catherineD> https://www.openstack.org/summit/sydney-2017/vote-for-speakers#/19389
16:54:47 <eglute> catherineD interesting, wonder why no speaker info
16:55:32 <eglute> catherineD i would have assumed it was either you or hogepodge
16:55:34 <catherineD> maybe because it is an upstream session?
16:56:08 <catherineD> not me ... However, I think it would be a good discussion
16:56:36 <Rockyg> yeah. maybe markvoelker ?
16:56:44 <hogepodge> I think that's mguiney
16:56:49 <markvoelker> not me
16:57:00 <eglute> heh, thanks mguiney
16:57:12 <Rockyg> ah. that would be good.
16:57:16 <eglute> good topic, glad it is someone from this group
16:57:17 <catherineD> yea thanks
16:57:46 <catherineD> I voted for it ..
16:58:01 <eglute> anything else regarding subunit results?
16:58:11 <eglute> almost out of time too
16:58:41 <eglute> if not, thanks everyone!
16:59:13 <eglute> if there is something we haven't covered, ping me on interop channel
16:59:17 <eglute> #endmeeting