16:00:26 <eglute> #startmeeting interopwg
16:00:27 <openstack> Meeting started Wed Jun 28 16:00:26 2017 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:31 <openstack> The meeting name has been set to 'interopwg'
16:00:40 <eglute> #topic agenda
16:00:43 <eglute> #link https://etherpad.openstack.org/p/InteropVertigo.6
16:01:01 <eglute> Hello Everyone, please check the agenda and update as needed
16:01:12 <luzC> o/
16:01:32 <eglute> let us know if you are here for interop meeting o/
16:01:44 <hogepodge> o/
16:01:46 <Rockyg> o/
16:02:36 <mguiney> o/
16:02:54 <eglute> #chair hogepodge
16:02:55 <openstack> Current chairs: eglute hogepodge
16:03:22 <eglute> #topic meeting next week
16:04:07 <eglute> Tuesday next week is a holiday in the US, so i propose we cancel the meeting next week
16:04:32 <eglute> any disagreement?
16:05:19 <Rockyg> yay!
16:05:20 <hogepodge> +1 on canceling
16:05:33 <eglute> heh, i was worried there for a bit :D
16:05:56 <eglute> #topic Info: Denver PTG
16:06:02 <catherine_d|1> o/
16:06:17 <eglute> just a reminder to plan your travels to Denver PTG
16:06:24 * eglute still needs to book travel
16:06:39 <eglute> #2017.08 Guideline
16:06:43 <eglute> #topic 2017.08 Guideline
16:07:03 <eglute> #link https://review.openstack.org/#/c/472848/
16:07:07 <eglute> reviews welcome
16:07:17 <eglute> also still a couple outstanding patches
16:07:26 <eglute> #link https://review.openstack.org/#/c/467528/
16:07:59 <eglute> mguiney seems like that patch is on hold for now?
16:08:52 <hogepodge> I think it will be resolved soon.
16:09:10 <hogepodge> One small update will get it passing the gate.
16:09:22 <eglute> thanks hogepodge!
16:09:23 <mguiney> we just need to resolve the disagreement on whether it should eventually pull from the website
16:09:39 <mguiney> which is why i hadn't pushed the new patch yet
16:10:40 <eglute> mguiney do you need additional reviews on that?
16:11:17 <eglute> your last comment says you will have a discussion in our meeting
16:11:22 <mguiney> i would definitely love more feedback, if anyone else has thoughts on the matter
16:11:39 <mguiney> yes, i was planning on adding it to notes for this patch, but it slipped my mind
16:11:43 <mguiney> (apologies)
16:11:57 <hogepodge> I can leave a comment, but I tend to agree with mtreinish that external access is a bad idea for a test suite
16:12:22 <mguiney> i thought that sounded like it made sense
16:12:30 <mguiney> i'll push the patch later today, then
16:12:45 <hogepodge> and we're so close to passing the gate, even if it's held for more discussion I'd like to see that. :-D
16:12:52 <eglute> whats the alternative?
16:13:37 <mguiney> pulling from a yet-to-be-finished json file rather than hardcoding standardized values
16:14:08 <eglute> thanks mguiney. let us know if you need some help
16:14:45 <mguiney> can do!
16:15:01 <eglute> anything else on this patch?
16:15:53 <mguiney> nope!
16:15:58 <eglute> thanks mguiney!
16:16:10 <eglute> another patch for 2017.08 is this: https://review.openstack.org/#/c/475906/
16:16:18 <eglute> please review, but it looks good to me
16:16:42 <eglute> anything else on the new guideline?
16:17:01 <eglute> #topic Mandatory submission of test results
16:17:22 <eglute> hogepodge any updates?
16:18:27 <hogepodge> I'd like for the wg to give guidance on this, refstack team is pushing back
16:18:38 <eglute> hogepodge can you elaborate
16:18:43 <hogepodge> for now I'd like the option to send up the subunit files, visible only to foundation staff
16:18:59 <hogepodge> with the possibility of requiring them in the future
16:19:19 <hogepodge> it's way to easy to falsify test results, and no personal data is sent with the subunit output
16:19:43 <eglute> catherine_d|1 what is your opinion on this
16:19:45 <hogepodge> and it would be held under our privacy guidelines regardless, only accessible to authorized staff
16:20:34 <Rockyg> what does refstack see as the problem?
16:20:43 <catherine_d|1> Just to clarify ... Refstack team does not push back just want to state the background for discussion
16:21:21 <catherine_d|1> Rockyg: please see RefStack topic on line 40
16:21:49 <eglute> #topic RefStack and test results
16:22:21 <eglute> we have time to discuss this today, as Mark is out on vacation and no updates on vertical programs
16:23:07 <luzC> I agree with Chris about the usefulness of the file
16:23:13 <eglute> I am ok with foundation storing the results, but we need to figure out how to officially ask for them
16:23:23 <catherine_d|1> Many of us was not on the project since day one ... it is now the right time to revisit ..
16:23:58 <eglute> catherine_d|1 correct... and i do remember the privacy concerns
16:24:37 <luzC> also not sure if refstack would need an actual legal disclaimer or something... because of the potential content of the file - out of refstack control
16:26:19 <eglute> we could ask foundation's legal team for help with the disclaimer i am sure
16:26:48 <eglute> but at this point, if we want the full test results, we would need to implement something that asks for them
16:26:53 <catherine_d|1> eglute: ++ since foundation actually own the content once it is uploaded
16:27:07 <eglute> hogepodge catherine_d|1 have you received any full results without asking for them?
16:27:21 <catherine_d|1> eglute: nope
16:27:30 <eglute> so yeah, i think we need to ask for them
16:27:37 <eglute> and make it easy to submit
16:27:47 <hogepodge> eglute: I ask for subunit results all the time when I'm working with companies on getting their products tested
16:27:53 <catherine_d|1> the full results is process by RefStack to generate the JSON file at the client side
16:28:40 <hogepodge> so it's often being sent in plaintext to email anyway, an optional upload to refstack would give me a data store and give them a secure channel to transmit data
16:28:40 <eglute> we could have an option for people to opt out of submitting full results, but ask for full by default.
16:28:44 <catherine_d|1> once the decision is made and document RefStack will add this feature
16:28:59 <hogepodge> To start, I'd rather it be opt-in
16:29:04 <catherine_d|1> documented
16:29:49 <eglute> ok, i am in favor of opt-in, and submit the results through refstack.
16:30:21 <luzC> +1
16:30:54 <eglute> i dont think this will solve the issue of falsified results, but i would like to start with officially asking for them results
16:30:55 <Rockyg> I don't think we need board approval for opt in.  We would for opt out
16:31:23 <Rockyg> But should get foundation lawyers to review for any needed disclaimers.
16:31:42 <catherine_d|1> what does opt in mean in for  RefStack?
16:32:00 <catherine_d|1> option for upload?
16:32:04 <eglute> i do not think we need board approval for this at all, but we should send out emails to mailing lists about the change.
16:32:07 <eglute> catherine_d|1 correct
16:32:49 <eglute> catherine_d|1 this would be additional feature for refstack, in addition to what you currently have
16:33:20 <hogepodge> catherine_d|1: yes, a flag to send the subunit file to the server
16:33:22 <eglute> how you implement that, i think it is up to refstack's team
16:34:08 <catherine_d|1> For RefStack this is a change to its  design principle, it would be nice that we can cite some document somewhere suggested the chance ( an email to the community would be fine ...)
16:34:40 <eglute> catherine_d|1 would you like me and hogepodge to draft up such an email?
16:34:42 <catherine_d|1> chance --> change
16:34:56 <catherine_d|1> eglute: that would work ..
16:35:08 <Rockyg> ++
16:35:25 <eglute> #action eglute and hogepodge to write an email regarding the change for RefStack + full results
16:35:39 <eglute> anything else on this?
16:35:54 <catherine_d|1> since this concern was discussed at lenght before ... something to show that this decision is revised would be nice
16:36:46 <eglute> catherine_d|1 noted :) we will try to do so. will have you review email before sending out
16:37:06 <catherine_d|1> eglute: thanks
16:37:20 <hogepodge> schedule a vote for a few weeks out? give time for community review (esp mark, since he's not here)
16:37:22 <eglute> anything else on this?
16:37:54 <catherine_d|1> nope for me
16:37:59 <eglute> a vote on refstack results?
16:38:37 <hogepodge> if not a vote, a formal decision by the wg, and you and mark as the chairs of the wg
16:38:49 <catherine_d|1> hogepodge: ++++
16:38:54 <Rockyg> I also epect once the email goes out, we might want to add a sentence or two to the right defcore doc.
16:39:38 <eglute> #action markvoelker hogepodge eglute to send out formal decision after email has gone out
16:39:49 <Rockyg> ++
16:40:14 <eglute> #action eglute hogepodge markvoelker catherine_d|1 update official interop docs to reflect the change
16:40:49 <catherine_d|1> lots of thing we can do at RefStack... once this is a green light
16:41:06 <catherine_d|1> we may get rid of the JSON file now that we have the raw data
16:41:27 <eglute> thank you catherine_d|1
16:41:32 <catherine_d|1> RefStack will take care of that
16:42:00 <eglute> right, we would like to leave implementation details to the RefStack team
16:42:15 <eglute> anything else?
16:42:28 <Rockyg> catherine_d|1, yeah, but we can't do that until subunit file is required
16:42:34 <Rockyg> :)
16:42:38 <eglute> #topic open floor
16:42:45 <catherine_d|1> Rockyg: absolutely
16:42:47 <eglute> any other discussions today?
16:42:54 <hogepodge> v2 schema is in progress
16:43:10 <eglute> thank you hogepodge! I left it off the agenda
16:43:12 <hogepodge> Some items of note as I've worked it up
16:43:18 <eglute> #topic schema 2.0
16:43:33 <eglute> #action everyone please review schema 2.0
16:43:44 <hogepodge> I'm allowing any data folks want in the metadata section. Should be useful for non-board guidelines to put relevant info in there
16:43:51 <eglute> #link https://review.openstack.org/#/c/430556/
16:43:58 <eglute> +1
16:44:04 <hogepodge> I've also broken out the section for scoring criteria (to allow other orgs to define their own criteria)
16:44:28 <eglute> +1
16:44:51 <hogepodge> And I moved the openstack board approval info to it's own subobject in the metadata. Again, to not force non-interopwg users to follow that process
16:45:22 <eglute> +1
16:45:24 <Rockyg> Cool.  Great thinking/foresight
16:45:25 <hogepodge> I'm trying to do qa and documentation as I go along, but everything is in a wip in state. Still, take a look and leave comments
16:45:34 <Rockyg> I'll have to review, now.
16:45:53 <eglute> thank you hogepodge, i really like it so far
16:46:07 <hogepodge> catherine_d|1: of note for you, I'm trying to be consistent in how I name things, so refstack parsing should be aware of it
16:47:21 <eglute> anything else on schema 2.0?
16:47:41 <hogepodge> nope, hoping to be done with it before our next meeting
16:47:48 <eglute> nice, thanks again hogepodge
16:47:51 <eglute> #open floor
16:47:56 <eglute> anything else for today?
16:48:13 <eglute> if not, we can end early!
16:48:27 <eglute> thanks everyone and see you all in 2 weeks!
16:48:31 <eglute> #endmeeting