16:01:03 <eglute> #startmeeting interopwg
16:01:04 <openstack> Meeting started Wed May 31 16:01:03 2017 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:08 <openstack> The meeting name has been set to 'interopwg'
16:01:09 <markvoelker> o/
16:01:14 <eglute> #chair markvoelker
16:01:15 <openstack> Current chairs: eglute markvoelker
16:01:22 <eglute> hello everyone!
16:01:26 <eglute> #topic agenda
16:01:39 <eglute> #link https://etherpad.openstack.org/p/InteropVertigo.2
16:01:45 <eglute> please update agenda as needed
16:02:07 <hogepodge> o/
16:02:13 <eglute> raise your hand if you are here for interop meeting :)
16:02:15 <mguiney> o/
16:02:37 <catherine_d|1> o/
16:02:49 <eglute> #topic 2017.08 Guideline
16:03:10 <eglute> thanks everyone that helped with scoring, all scoring patches were merged
16:03:55 <eglute> i think what is left is creating the actual 2017.08.json
16:04:19 <eglute> we can do that after the latest flagging/removing tests patches get merged
16:04:41 <eglute> any other comments on 2017.08?
16:05:30 <eglute> #topic Add aliases for test_volumes_list
16:05:39 <hogepodge> mguiney: has some patches up for keystone that may impact the guideline
16:05:45 <eglute> oh that one is abandoned now, nevermind then.
16:06:00 <hogepodge> actually testing for capabilities that we would want to have as advisory
16:06:05 <eglute> thanks hogepodge and mguiney
16:06:53 <eglute> ok! i saw mguiney added them to the agenda, thank you
16:07:04 <mguiney> (sorry for the late addition)
16:07:31 <eglute> np, thank you!
16:08:00 <Rockyg> o/
16:08:16 <eglute> actually lets move them up on the agenda, since they relate to 2017.08
16:08:35 <eglute> #topic non-admin token validation test
16:08:43 <eglute> #link https://review.openstack.org/#/c/467493/
16:09:16 <eglute> so if these tests get merged, does that mean we will be adding new capabilities to 2017.08?
16:09:50 <mguiney> I think that is the goal, yes
16:10:31 <mguiney> because both of these capabilities are testable without admin capabilities
16:10:44 <eglute> i think technically it would be a tad late for our timeline, but i think i am ok with that. What do others think?
16:11:12 <hogepodge> It's something we've talked about and worked on, so I'd be fine with it
16:11:31 <hogepodge> It's not like we're adding capabilities that didn't exist in OpenStack beforehand, they just weren't tested in a way we could use
16:11:45 <eglute> i agree hogepodge
16:12:03 <markvoelker> Yeah, I think I'm ok with this.  For reference, this was discussed in https://review.openstack.org/#/c/456774/ back in April I beleive
16:12:19 <hogepodge> They are also widely used and critically important capabilities.
16:12:26 <eglute> markvoelker correct
16:12:55 <eglute> mguiney would you create a new patch for keystone once these tests get merged?
16:13:34 <eglute> seems like i merged the keystone patch too soon
16:13:53 <mguiney> for the keystone scoring? yes, I will absolutely be able to do that
16:14:08 <eglute> great, thank you mguiney
16:14:31 <eglute> #action mguiney create new keystone scoring patch with added tests once the new tests get merged
16:15:23 <eglute> #topic catalog standardization test
16:15:32 <eglute> #link https://review.openstack.org/#/c/467493/
16:16:25 <eglute> mguiney would this test be also added if it merges?
16:16:36 <eglute> added to the new guideline that is
16:16:45 <mguiney> that would be the other keystone patch! theres a bit more work i still need to do on that one, but if anyone has feedback i'd love to hear it
16:16:54 <mguiney> *keystone test patch
16:16:59 <eglute> thank you mguiney!
16:17:17 <markvoelker> Hmm, same link?
16:17:43 <eglute> heh, markvoelker is right. mguiney?
16:17:53 <markvoelker> Those links both go to the non-admin token test.  I think the second one we wanted to discuss was the catalog standardization stuff.
16:18:10 <mguiney> oh dear
16:18:12 <mguiney> hold on
16:18:16 <mguiney> https://review.openstack.org/#/c/467528/
16:18:29 <mguiney> is the catalog standardization test
16:18:31 <markvoelker> that's the one
16:20:06 <eglute> mguiney in your comments you state that "This test may belong as an "admin" capability"
16:20:31 <eglute> do you know yet whether it will require admin?
16:20:52 <mguiney> that would be because the catalog inly exposes part of the catalogs if the user only has the access to see some of the services
16:22:05 <eglute> ok, so if the test is admin, then we would not be adding to keystone capabilities
16:22:16 <mguiney> yeah, that would make sense
16:22:28 <hogepodge> Two tests might be appropriate then, one that checks admin-only services and one that checks non-admin services
16:22:50 <hogepodge> Because it's still something we want to check for. Not having nova or keystone publicly available would be a problem, for example.
16:23:03 <mguiney> that would make sense
16:23:19 <markvoelker> ++, the services we're including in guidelines should be available to non-admin users.
16:23:32 <eglute> agree... if we have one non-admin test, that can be added
16:24:12 <eglute> so if the test is added in time, would that also add new capability? i need to look :)
16:24:22 <mguiney> the one i have up, when smoothed out a little, should work as the nonadmin test
16:24:44 <markvoelker> eglute: yes, this would be a new capability (so advisory at best)
16:25:29 <eglute> ok, so do we need a deadline until when advisory capabilities can be added to 2017.08?
16:25:40 <catherine_d|1> eglute: markvoelker: should the capability be existing for more than 2 releases?
16:26:05 <eglute> catherine_d|1 yes... is this new?
16:26:19 <markvoelker> catherine_d|1: Yes, the capability being tested needs to apply to all releases covered in the guideline.
16:26:27 <hogepodge> It's tricky. Catalogs have existed from the beginning, but the enforcement is new.
16:26:31 <Rockyg> catherine_d|1, good point.  but another reason for advisory.  Let folks know it's coming as tehy upgrade
16:26:42 <hogepodge> The enforcement tries to catch common variants
16:26:49 <markvoelker> TEchnically there's nothing the test uses that hasn't been in Keystone forever
16:27:01 <markvoelker> So I'd think it's a good idea to make it advisory sooner rather than later
16:27:34 <markvoelker> Weeeellll...actually that's not quite true since it's using v3 of the API, which hasn't been there forever.  But you get the point. =)
16:27:42 <eglute> works for me!
16:27:47 <catherine_d|1> usually capabilities in the advisory section will be candidated for required in the next JSON ...
16:27:49 <eglute> lets add it as advisory if we can
16:28:56 <eglute> anything else on this topic?
16:28:57 <catherine_d|1> does that meet the 2 releases requirement?  Just want to see how this stack up against our own policy for consistency
16:29:29 <markvoelker> catherine_d|1: The API's being used here have been available for many, many releases now.  So there's nothing new on that front.
16:29:38 <markvoelker> What's new is that we're enforcing particular values in the catalog
16:29:51 <markvoelker> So it will not fall afoul of the 2-release requirement
16:30:14 <markvoelker> It's more a matter of how fast we can get feedback as to whether this would trip anyone up.
16:30:17 <catherine_d|1> that is good then
16:30:33 <hogepodge> policy vs capability
16:30:48 <Rockyg> ++
16:31:08 <hogepodge> This should be communicated on the interop and dev mailing lists
16:31:16 <hogepodge> Let's not surprise anybody.
16:31:21 <Rockyg> and ops?
16:31:29 <hogepodge> yes, ops too. thanks Rockyg
16:31:49 <markvoelker> I would even be willing to put a note in the goodline to the effect of "this is one we'll wait on for two full cycles before we switch to required since it arrived late", but I'd like to start getting the feedback soon.
16:32:01 <markvoelker> * s/goodline/guideline/
16:32:19 <eglute> we can't communicate until 2017.08.json is created
16:32:32 <eglute> so we need a deadline for adding things to next.json
16:33:10 <Rockyg> I think the user commitee ml, also, with all the vertical affinities in the subject -- lcoo, ldt, etc
16:33:13 <zhipeng_> btw, if we decides to put heat and designate on "addon"
16:33:26 <zhipeng_> do we need the tests to be added as well ?
16:33:43 <eglute> zhipeng_ yes, add-ons would also have tests
16:33:59 <Rockyg> zhipeng_, yes, we do.  we should at least get them in as advisory.
16:34:14 <zhipeng_> so that would mean the same deadline , right ?
16:34:27 <eglute> markvoelker hogepodge what deadline do you have in mind for changes to next.json
16:34:39 <markvoelker> zhipeng_: Not necessarily.  What we're creating here is the OpenStack Powered guideline, not add-on guidelines.
16:34:41 <eglute> is 2 weeks enough?
16:35:01 <hogepodge> This should be considered as a side project to the Powered guideline.
16:35:11 <zhipeng_> so add-ons would be another guideline based upon schema 2.0 ?
16:35:12 <hogepodge> Let's not tie them tightly together.
16:35:22 <markvoelker> zhipeng_: basically, yes.
16:35:23 <zhipeng_> ok got it :)
16:35:35 <zhipeng_> but still it needs to be ran before the board ?
16:35:48 <eglute> zhipeng_ correct, everything is board approved
16:35:53 <markvoelker> eglute: June 8 is when testing is supposed to start, which is approximately one week from now...is that enough time?
16:36:07 <hogepodge> That seems like the safest way forward. I can try to get a major update done soon. I have minor surgery tomorrow, but should be able to give it full attention on Monday and Tuesday.
16:36:14 <eglute> mguiney do you think 1 week is enough for all the changes?
16:36:47 <mguiney> as i mentioned, the catalog test is not as close to ready as the other one, but i can certainly try and getthat ironed out
16:37:25 <eglute> mguiney ok, if it is not ready in 1 week (or almost ready) it may have to be pushed out to the next guideline
16:37:50 * mguiney nods
16:37:53 <mguiney> that makes sense
16:38:07 <eglute> thank you mguiney for your work!!
16:38:16 <eglute> anything else on this?
16:39:20 <eglute> thanks everyone!
16:39:41 <eglute> #action eveyrone review patches https://review.openstack.org/#/c/467493/ and https://review.openstack.org/#/c/467528/
16:39:55 <eglute> #topic Create tools to increase ease of scoring
16:40:01 <eglute> #link https://review.openstack.org/#/c/458716/
16:40:17 <eglute> thanks to luzC for reviewing!
16:40:34 <eglute> if luzC and others are good with the latest changes, we can merge this patch later this week
16:41:27 <eglute> any other comments on the tool?
16:42:10 <markvoelker> Just a nit that it would be nice to add some inline help like we have in the other scripts
16:42:19 <markvoelker> We can do that in a follow-up if you like though.
16:42:30 <eglute> thanks markvoelker for reviewing it
16:42:42 <mguiney> ahhhh yes that would be a good idea
16:42:54 <mguiney> i can do that and push the patch asap
16:43:09 <eglute> thanks mguiney!
16:43:12 <eglute> anything else?
16:43:54 <eglute> #topic Add Aliases For VolumeV2 Test Cases Part 1
16:44:08 <eglute> #link https://review.openstack.org/#/c/462860/
16:44:17 <zhipeng_> lucZ helped review the patch
16:44:28 <eglute> zhipeng_ are you able to fix it?
16:44:39 <zhipeng_> and I will update it before the end of the week, see if multiple aliases pass the CI
16:44:43 <zhipeng_> yes I think so
16:44:53 <zhipeng_> it is just so many lines lol
16:44:57 <eglute> zhipeng_ thanks! and thanks to luzC for reviewing it!
16:45:10 <eglute> zhipeng_ if it helps, break it up in several patches
16:45:26 <zhipeng_> yep I already break it to two :)
16:45:39 <eglute> thank you zhipeng_!
16:46:05 <eglute> and thank you for working on this!
16:46:06 <eglute> anything else on this patch?
16:46:26 <eglute> #topic Remove test_delete_active_server
16:46:31 <eglute> #link https://review.openstack.org/#/c/463944/
16:47:12 <eglute> markvoelker reviewed it this morning, so we will give time for updates
16:47:39 <markvoelker> I'll just note here that the related patch in tempest is still undergoing some discussion as well
16:48:09 <eglute> #link https://review.openstack.org/#/c/463942/
16:48:16 <markvoelker> I think gist of it is that the same functionality in the test that's being proposed for removal is covered elsewhere...but in a less atomic way.
16:49:06 <markvoelker> I haven't had a chance to look at the other tests that cover this functionality yet though (E_TOO_MUCH_BIZ_TRAVEL)
16:49:57 <markvoelker> It would be great if folks can take a look though--removing this test from tempest isn't necessarily a foregone conclusion yet, and it might actually work out better for us if it stays.
16:50:05 <eglute> thanks markvoelker... there is always so much to do.
16:50:19 <eglute> +1
16:51:40 <Rockyg> Losing interop test coverage is never good.
16:51:48 <eglute> Rockyg agreed
16:51:56 <eglute> #topic Remove duplicated testcase test_get_private_image
16:52:01 <eglute> #link https://review.openstack.org/#/c/454489/
16:52:05 <eglute> more test removal
16:52:14 <eglute> but only in an old guideline
16:52:27 <eglute> so not sure that it is relevant still, i think not
16:53:01 <markvoelker> Yeah, I'd prefer we not start going back and updating guidelines that really can't be used anymore...just makes more work for no particular end, IMHO.
16:53:09 <eglute> should we be archiving old guidelines?
16:53:18 <hogepodge> I'm convinced by Mark's argument.
16:53:24 <markvoelker> We already mark them as superseded
16:53:24 <eglute> me too!
16:53:41 <markvoelker> By archive you mean stick them in a separate directory or something?
16:54:05 <eglute> markvoelker yes
16:54:34 <eglute> as for this patch, i think we need to abandon it
16:54:38 <hogepodge> catherine and the refstack team are ok with updated to account for that, I'd be ok with it.
16:54:52 <hogepodge> (if)
16:55:00 <markvoelker> I think I proposed that a year or two ago and we decided against it....I'd have to find that patch to remember the context though.
16:55:16 <eglute> hogepodge is right... refstack might still pull the old guidelines
16:55:27 <eglute> markvoelker may have been refstack related?
16:55:37 <markvoelker> could be
16:55:42 <Rockyg> we'll give you a week, markvoelker to find that patch ;-)
16:56:15 <eglute> ok, we can save this discussion for later, since only 4 min left
16:56:22 <Rockyg> But, refstack could pull from the archive for old stuff
16:56:46 <Rockyg> good separation
16:56:54 <Rockyg> good hygiene
16:56:58 <eglute> #topic Flagging Regarding Public Cloud Subnet
16:57:03 <markvoelker> Rockyg: already done...the discussion was in this patch: https://review.openstack.org/#/c/202345/
16:57:23 <eglute> #link https://review.openstack.org/#/c/460372/
16:57:27 <markvoelker> (see Rob's comments on patchset 7)
16:57:32 <Rockyg> >P markv
16:58:58 <eglute> thanks markvoelker for digging that up... i have forgotten all about it
16:59:05 <eglute> regarding flagging subnets
16:59:09 <eglute> any comments?
16:59:17 <eglute> everyone, please review
16:59:59 <eglute> also, please review https://review.openstack.org/#/c/463263/
17:00:11 <eglute> and we are out of time
17:00:25 <eglute> thanks everyone, if needed, i will be in the interop irc later today
17:00:28 <eglute> #endmeeting