16:01:29 <eglute> #startmeeting interopwg
16:01:30 <openstack> Meeting started Wed May  3 16:01:29 2017 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:33 <openstack> The meeting name has been set to 'interopwg'
16:01:43 <eglute> #topic agenda
16:01:55 <eglute> Hello Everyone! Today's agenda: https://etherpad.openstack.org/p/DefCoreRoble.22
16:02:04 <eglute> please add/update as needed!
16:02:36 <eglute> Who is here today for interop wg meeting?
16:02:38 <Rockyg> o/
16:02:42 <mguiney> o/
16:03:03 * eglute waves
16:03:16 * mguiney waves back
16:03:22 <eglute> markvoelker is not able to attend today
16:03:38 <catherineD> o/
16:04:14 * eglute wonders if people are getting ready for the summit or already in Boston
16:04:32 <eglute> #link https://etherpad.openstack.org/p/DefCoreRoble.22
16:04:55 <eglute> #topic 2017.08 Guideline
16:05:21 <eglute> we still need final reviews for some scoring patches
16:05:21 <hogepodge> o/
16:05:26 <Rockyg> not there yet, unless they're at the Red Hat summit there this week
16:06:07 <eglute> nova: #link https://review.openstack.org/#/c/456753/
16:06:14 <eglute> thanks hogepodge for updating
16:07:03 <hogepodge> was there anything else I was missing on it?
16:07:10 <eglute> i dont think so
16:07:31 <eglute> we just need a few more eyes to look at it, and if good, i will merge it this week
16:08:21 <eglute> everyone, please review #link https://review.openstack.org/#/c/456753/
16:08:38 <eglute> Cinder was merged, thanks eveyrone!
16:09:04 <eglute> Glance was also merged :)
16:09:12 <eglute> Neutron requires an update from markvoelker
16:09:14 <hogepodge> we need to update cinder based on feedback from huawei
16:09:56 <eglute> who could do that?
16:10:18 <eglute> hogepodge, Rockyg?
16:11:10 <mguiney> I could, if nobody else has time
16:11:19 <eglute> thank you mguiney
16:11:35 <Rockyg> hmm.  might be able to.  but if mguiney does, i'll review
16:11:42 <eglute> hogepodge you mean update to flag  os-attach/os-detach APIs?
16:11:59 <Rockyg> and get zhipeng to, also.
16:12:06 <hogepodge> yes, the capabilities in next should be updated
16:12:08 <zhipeng> yes I could help :)
16:12:18 <eglute> ok, thank you.
16:12:38 <eglute> #action zhipeng will update cinder capabilities in next.json to flag  os-attach/os-detach APIs
16:13:59 <eglute> anything else regarding cinder?
16:14:06 <zhipeng> for next.json, shall I just remove os-attach/detach
16:14:10 <zhipeng> or flag them ?
16:14:14 <Rockyg> review the updates.
16:15:16 <eglute> i think we should remove them from next.json
16:15:19 <eglute> what do you think hogepodge
16:15:36 <hogepodge> zhipeng: two patches, one for the flag, one to update the capabilities and scoring for next (since we're in that phase)
16:16:11 <eglute> flag for current guidelines, correct?
16:16:14 <zhipeng> okey can I count help on the updating scoring from mguiney?
16:16:21 <catherineD> remove should come after deprecate right?
16:16:40 <mguiney> yep! i can help update the scoring
16:16:53 <zhipeng> ye by remove I mean remove from required to another category
16:17:01 <eglute> catherineD is right, cant remove immediately if they are required.
16:17:08 <eglute> flag/deprecate/remove
16:17:16 <catherineD> I don't think you can remove from require
16:17:26 <hogepodge> next doesn't need the flag, though
16:17:27 <catherineD> you flag it in require
16:17:31 <hogepodge> which is why it's two patches
16:18:00 <zhipeng> so move out of required in the next.json, flag them in 2016.08 and 2017.01
16:18:05 <zhipeng> is it ok ?
16:18:17 <zhipeng> and mguiney do the update on the capabilites and scoring
16:18:50 <eglute> zhipeng in next.json move to deprecated
16:18:55 <hogepodge> yeah, sounds good
16:19:02 <zhipeng> got it
16:19:11 * mguiney nods
16:19:15 <zhipeng> and again big hugs and thanks to mguiney for help :)
16:19:27 <eglute> yes, thank you mguiney for your help :)
16:19:32 <eglute> anything else on cinder?
16:20:16 <eglute> in that case, keystone
16:20:33 <eglute> #link https://review.openstack.org/#/c/456774/
16:22:34 <hogepodge> we need to get that test updated so we can update that capability
16:22:35 <mguiney> I talked to cmurphy from keystone last night, and it looks like she took a look
16:22:49 <eglute> thank you mguiney for checking
16:22:54 <hogepodge> it looks like the docs are wrong, and validating a token is pretty important
16:23:02 <eglute> hm
16:23:30 <eglute> so luzC is probably wont be updating this anymore, as she is moving to work on non-openstack things.
16:23:37 <eglute> can someone else take this over?
16:23:49 <mguiney> i can!
16:24:30 <eglute> thank you mguiney!!!
16:24:37 <eglute> #action mguiney update keystone patch
16:24:43 <mguiney> i have some extra time on my hands this week to work on things. Should we be concerned with the fact that the docs are incorrect
16:24:56 <mguiney> ?
16:25:02 <eglute> i think if you can submit a docs patch, that would be good too
16:25:08 <eglute> or at least file a bug?
16:25:16 <mguiney> can do
16:25:36 <eglute> thank you mguiney
16:25:43 <eglute> anything else on keystone?
16:26:34 <eglute> in that case, moving on
16:26:38 <eglute> #topic Flagging os-attach/os-detach APIs in the volume API
16:27:03 <eglute> thought i think we already discussed this
16:27:05 <eglute> if you have any comments, please respond to the mailing list thread: #link http://lists.openstack.org/pipermail/interop-wg/2017-April/000116.html
16:27:13 <eglute> any additional comments?
16:27:58 <eglute> #topic Flagging Regarding Public Cloud Subnet
16:28:07 <eglute> #link https://review.openstack.org/#/c/460372/
16:28:08 <zhipeng> okey this one is from me
16:28:15 <zhipeng> thx eglute
16:28:25 <eglute> can you provide a summary zhipeng
16:28:26 <zhipeng> so this is a flagging request patch
16:29:06 <zhipeng> like stated in the commit msg
16:29:20 <zhipeng> the current update_port with sec group test case
16:29:34 <zhipeng> requires to create subnets under one l2 network
16:29:50 <zhipeng> which is a rare case for public cloud that implements IPv4 in general
16:30:00 <eglute> and it is just two tests that are being flagged, correct?
16:30:02 <zhipeng> (if I understand the test case correctly)
16:30:05 <zhipeng> yes
16:30:22 <zhipeng> update port with sec group, and update port with two sec group
16:30:54 <eglute> so the capability stays in this case
16:31:06 <zhipeng> oh yes
16:31:10 <eglute> any comments on flagging these two tests?
16:31:18 <zhipeng> just flagging two specific test cases
16:32:10 <eglute> capability is networks-l2-CRUD, and has lots of other tests
16:32:20 <zhipeng> yep
16:32:32 <zhipeng> and I just saw catherine's comment
16:32:41 <eglute> if everyone could review the patch, that would be great. let us know if there are any objections!
16:32:42 <zhipeng> and will update based upon her comment
16:32:55 <zhipeng> yes plz help review the patch
16:33:15 <eglute> #action everyone review #link https://review.openstack.org/#/c/460372/
16:33:19 <catherineD> Just review patch
16:33:39 <eglute> thank you catherineD
16:34:01 <eglute> anything else on this topic?
16:34:40 <eglute> #topic summit
16:34:58 <eglute> please add your topics for the summit here: #link https://etherpad.openstack.org/p/InteropWGBostonSummit
16:35:28 <eglute> there are a lot of interop sessions.
16:35:40 <eglute> interopwg is thursday morning, we have a double time slot
16:36:01 <eglute> i will be sending out calendar invites, hope that helps :)
16:36:57 <Rockyg> that would be *very* useful
16:37:23 <eglute> thanks Rockyg, i will send them out. I will even try to get time zones correct :)
16:37:39 <eglute> anything else about summit?
16:38:32 <eglute> #topic defcore CSV tool
16:39:00 <mguiney> so this is a small little tooling script for loading csvs into scoring.txt
16:39:05 <eglute> #link https://review.openstack.org/#/c/458716/
16:39:57 <eglute> mguiney how is this different from teh current script?
16:40:05 <eglute> functionality wise?
16:40:20 <mguiney> different than which current script?
16:40:39 <eglute> https://github.com/openstack/interop/blob/master/working_materials/tabulate_scores.py
16:40:56 <eglute> it does update the csv file
16:40:56 <mguiney> so tabulate_scores retabulates and outputs a csv
16:41:33 <eglute> i thought that tabulate_scores also retabulates
16:41:41 <mguiney> however, if you modify that resulting csv, and use the new tool, it loads the new scorings back into scoring.txt
16:42:01 <eglute> oh ok
16:42:28 <eglute> perhaps you could update message or script with sample usage/input/output so it is clear?
16:42:28 <mguiney> it's just a convenience thing for anyone who would prefer to do their actual scoring in a spreadsheet tool
16:42:40 <mguiney> ah, yes. I can do that.
16:42:45 <Rockyg> ++
16:42:50 <eglute> that would be great, thank you mguiney
16:43:00 <eglute> anything else regarding this script?
16:43:06 <mguiney> nope!
16:43:08 <eglute> thank you mguiney for working on it!!
16:43:56 <eglute> #topic storyboard
16:44:13 <eglute> we have a few old items in the storyboard #link https://storyboard.openstack.org/#!/project/877
16:44:28 <eglute> and also we discussed about coming up with a list of tests to write
16:45:00 <Rockyg> Yes.  I went looking for those tasks...
16:45:04 <eglute> if anyone has some free time and willing to take this on, we all would appreciate it!
16:45:12 <eglute> Rockyg what did you find
16:46:42 <Rockyg> I found the old stuff.  I tried to add a bug task to storyboard, but I don't think it worked.
16:47:11 <Rockyg> I hit a storyboard bug trying to get to the interopproject :-/
16:47:11 <eglute> Rockyg why dont you think it worked? bug? or something else?
16:47:35 <eglute> :(
16:48:00 <eglute> Rockyg did you talk to anyone about it yet
16:48:32 <hogepodge> Rockyg: can you reach out to diablo_rojo for help on that?
16:49:12 <Rockyg> So, what I'm seeing today is very different from what I saw yesterday.  I think I got into some weird in-between state.  Where all the projects weren't loading.  Which is also why I couldn't file the bug.
16:49:36 <Rockyg> I'll see what state it's in on my work computer and try to track the issue down and file it.
16:50:06 <diablo_rojo> Rockyg, if the problem persists let us know in #storyboard and we will make a story to fix it :)
16:50:35 <eglute> thanks diablo_rojo!
16:51:04 <eglute> Rockyg, hope you are able to load things into storyboard
16:51:05 <eglute> do you have a list of tests already to load?
16:51:31 <Rockyg> me, too.
16:52:22 <eglute> anything else regarding storyboard?
16:52:34 <eglute> #topic open discussion
16:52:46 <eglute> anything else?
16:52:52 <zhipeng> ah just remember one thing
16:52:58 <eglute> zhipeng go ahead
16:53:12 <zhipeng> we found that when we use the latest Tempest
16:53:28 <zhipeng> the volumev2 relted test case's names are changed
16:53:40 <zhipeng> so may be we need a patch for adding the aliases ?
16:54:02 <eglute> #action zhipeng to add patch adding aliases for changed tests for volumev2
16:54:05 <eglute> thanks zhipeng
16:54:06 <zhipeng> I report a bug firstly in refstack, then I found out that maybe it is the guideline need fixing
16:54:28 <eglute> yes, in this case we add aliases to tests
16:54:37 <eglute> so if you could submit a patch, that would be great
16:54:45 <zhipeng> okey thx
16:55:03 <eglute> thank you zhipeng!!
16:55:10 <eglute> anything else?
16:55:59 <eglute> in this case, thanks everyone!
16:56:06 <eglute> I hope to see you all in Boston!
16:56:17 <eglute> and no regular meeting next week :)
16:56:18 <zhipeng> c yall in Boston :)
16:56:35 <eglute> #endmeeting