16:00:22 <markvoelker_> #startmeeting interopwg
16:00:22 <openstack> Meeting started Wed Feb 15 16:00:22 2017 UTC and is due to finish in 60 minutes.  The chair is markvoelker_. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:27 <openstack> The meeting name has been set to 'interopwg'
16:00:31 <markvoelker_> #chair hogepodge
16:00:32 <openstack> Current chairs: hogepodge markvoelker_
16:01:00 <markvoelker_> 'morning folks!
16:01:07 <markvoelker_> #link https://etherpad.openstack.org/p/DefCoreRoble.13 Today's agenda
16:01:13 <catherineD> o/
16:01:21 <markvoelker_> #info eglute is away today
16:01:24 <hogepodge> o/
16:01:31 <mguiney> o/
16:01:49 <luzC> o/
16:02:05 <markvoelker_> Please do have a look at the agenda.
16:02:15 <markvoelker_> #topic PTG
16:02:25 <markvoelker_> The PTG is almost upon us!
16:03:02 <markvoelker_> #link https://etherpad.openstack.org/p/RefStackInteropWGAtlantaPTG Joint Interop WG/Interop Challenge/RefStack PTG etherpad
16:03:31 <markvoelker_> As you're all aware, we're sharing space with a couple of other groups in Atlanta.
16:03:53 <markvoelker_> I'd like to finish nailing down our work sessions in the next day or so, so if you've got any last minute additions, please get them on the pad immeidately.
16:04:44 <catherineD> The OPNFV team would like to know on which date and time slot for this topic
16:04:52 <hogepodge> There is the possibility of spilling out into other space if we need it.
16:05:08 <markvoelker_> Any immediate items we need to discuss about the PTG?
16:05:16 <markvoelker_> *other
16:05:35 <hogepodge> #link https://ethercalc.openstack.org/Pike-PTG-Discussion-Rooms
16:05:37 <markvoelker_> catherineD: duly noted, I'll nail that down shortly
16:05:55 <catherineD> thx
16:06:00 <aimeeu> thanks markvoelker_ and  catherineD
16:07:01 <markvoelker_> Quick scheduling note: I know some folks are flying in Monday morning rather than Sunday night.  Anyone here in that boat that might miss early-Monday sessions?
16:07:45 * markvoelker_ hears none
16:07:50 <markvoelker_> Ok, good
16:08:15 <markvoelker_> Moving on then...
16:08:30 <markvoelker_> #topic Flagging two network-l2-CRUD capabilities
16:09:03 <markvoelker_> #link https://review.openstack.org/#/c/422715/
16:09:06 <markvoelker_> This has now merged
16:09:49 <markvoelker_> #topic Flag tests that require second set of user credentials
16:10:00 <markvoelker_> #link https://review.openstack.org/#/c/428847/ Flag tests that require second set of user credentials
16:10:45 <markvoelker_> I've gotten a little bit of offline feedback on this one that centers around the idea of things that are hard to verify without a second account
16:10:55 <markvoelker_> We've discussed this a bit in the past, too
16:11:36 <markvoelker_> For example: ACL's.  It's easy to test basic CRUD operations with a single account, but testing the functionality is harder without a second account
16:12:16 <markvoelker_> (e.g. you  may want to test that User B can't read User A's stuff, so you need A to create the ACL and B to verify that B can't read A's object)
16:12:54 <markvoelker_> The other side of the coin is that tests requiring multiple accounts make it harder for end-users to verify interoperability
16:13:26 <markvoelker_> (and arguably the API is what we're testing rather than feature functionality)
16:13:51 <markvoelker_> Do we want to spend some time on this at the PTG, or...?
16:14:28 <hogepodge> It's possible to capture a multi-user feature in the 2.0 schema
16:15:11 <hogepodge> So yes, PTG discussions would be good to see if we want to expand the scope of interop testing and have a method for identifying more advanced capabilities through some sort of classification method
16:15:48 <luzC> agree
16:15:57 <catherineD> I think we need consistency of what we do either way
16:16:06 <markvoelker_> hogepodge: I suspect we'll at least lightly touch on this in some of the discussions about add-on and vertical programs anyway, so seems like a decent topic
16:16:47 <luzC> also is there an easy way to id if test cases require more than one set of credentials? is there many test cases that requires multiple users?
16:16:49 <catherineD> cuirently we advise peopel to test with one user and these tests won't pass
16:17:27 <markvoelker_> catherineD: ++, the current precedent is definitely single-user
16:17:39 <markvoelker_> And on that ground I'm supportive of the current patch
16:17:55 <hogepodge> I suggest we stick single user for now, consider multiple for the 2017.08ish guideline
16:18:02 <markvoelker_> luzC: the usual way I find them is to run the tests with just one set of credentials configured. =)
16:18:05 <catherineD> ++
16:18:53 <markvoelker_> Ok, I'm hearing that this is something that folks want to talk about in ATL, so I'll add it to our topic list
16:19:02 <catherineD> at PTG if we decide otherwise .. weneed to change our recomendation in tempest configuration
16:19:20 <markvoelker_> If folks could kindly review the existing patch please, we'll see about landing it soonish
16:19:38 <markvoelker_> (that link again: https://review.openstack.org/#/c/428847/ )
16:20:13 <markvoelker_> #action markvoelker to add discussion of multi-user tests to PTG topic list
16:20:22 <markvoelker_> OK, anything else on this?
16:20:51 <catherineD> nope
16:20:54 <markvoelker_> #topic Glance change: Implement and Enable Community Images
16:21:21 <markvoelker_> Implement and Enable Community Images
16:21:23 <markvoelker_> #link https://review.openstack.org/#/c/369110/
16:21:46 <markvoelker_> I don't think there's anything much to say on this one this week other than to ask if anyone who's begun testing has hit any snags as a result of it
16:22:02 <markvoelker_> (I'm not aware of anyone having issues yet)
16:22:36 <markvoelker_> OK, so far so good then.  =)
16:22:40 <markvoelker_> #topic Name change
16:22:58 <markvoelker_> I've posted the initial governance and infra patches
16:23:18 <markvoelker_> #link https://review.openstack.org/433414 Infra patch to change DefCore -> InteropWG
16:23:34 <markvoelker_> #link https://review.openstack.org/433415 Governance patch to change DefCore -> InteropWG
16:23:53 <markvoelker_> I also added the name change to the Infra agenda: https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Upcoming_Project_Renames
16:24:10 <markvoelker_> I don't really expect to see much motion on these until after everyone is back from the PTG, but we'll keep an eye on them
16:25:00 <markvoelker_> We also had a note to deal with Launchpad
16:25:29 * markvoelker_ cannot remember who was going to tackle that...
16:25:46 <hogepodge> we've also talked about just switching to storyboard
16:26:02 <markvoelker_> Oh right.  Which is PTG topic too, actually.
16:26:05 <hogepodge> diablo_rojo: says it's active and maintained
16:27:28 <markvoelker_> catherineD: Is there anything else I need to do to keep you guys informed about the rename patches since RefStack will need some adjustments too?
16:27:56 <markvoelker_> Not sure if you wanted to make refstack change patches dependent on the infra change, or...
16:28:26 <catherineD> LuzC did have a patvh for RefStack
16:28:33 <markvoelker_> #link https://review.openstack.org/#/c/390881/ Change doc references from DefCore to Interop Working Group
16:29:04 <catherineD> I think we are covered
16:29:06 <luzC> I can make it dependent on
16:29:19 <markvoelker_> Yes, it might be easiest to make 390881 depend on 433414, but I'll leave that up to you guys. =)
16:29:44 * markvoelker_ probably needs to make the governance patch depend on the infra patch too
16:30:42 <markvoelker_> Ok, I think that about covers it for the name change.  ANything else on this topic today?
16:31:25 <markvoelker_> #topic New components/add-on programs
16:32:15 <markvoelker_> #link https://review.openstack.org/#/c/430556/ Initial work 2.0 schema
16:32:49 <markvoelker_> I haven't been able to spend much time on this one yet unfortunately, but I see there's been some initial feedback from others
16:32:58 <markvoelker_> hogepodge: anything you want talk about regarding this one today?
16:33:01 <hogepodge> I've updated the document to be essentially complete
16:33:21 <hogepodge> Pending review and design at ptg, of course
16:33:29 <hogepodge> Plus documentation, schema, etc
16:33:42 <hogepodge> But, essentially, I'm viewing the guideline as a collection of objects
16:33:50 <hogepodge> Where some objects are composed of other objects
16:34:00 <hogepodge> Major changes are creation of metadata
16:34:36 <hogepodge> Composing programs of both capabilities and designated sections (the designated sections were kind of weirdly tacked on the 1.x version)
16:35:03 <hogepodge> #link https://review.openstack.org/#/c/430556/
16:35:59 <hogepodge> Now is the time to start asking for feature requests. Like a mechanism for categorizing capability types (admin vs non-admin, single vs multi user, for example)
16:36:14 <markvoelker_> hogepodge: You read my mind. =p
16:36:16 <hogepodge> I'm thinking we should be strict on checking, except for metadata
16:37:00 <hogepodge> I'd like us to walk away from ptg with a strong working doc, then refine and complete a draft to present to the board before Boston
16:37:08 <markvoelker_> I'm going to try to schedule the discussions on vertical programs and such before the schema discussion so we can have a more informed view of the schema
16:37:21 <hogepodge> excellent
16:37:27 <luzC> ++
16:37:45 <mguiney> ++
16:37:54 <hogepodge> I would not be surprised if we learned a ton this year then had to revise to 3.0 for vertical programs.
16:37:57 <catherineD> markvoelker_: for the schedule it makes sense to have the schema discussion before the OPNFV discussion ...
16:38:25 <catherineD> that pretty much put OPNFV discussion to Tues morning ...
16:39:21 <catherineD> I see that OPNFV maybe one of the new use case using the new schema
16:39:23 <markvoelker_> catherineD: actually I was thinking the reverse.  Wouldn't it make more sense to have the OPNFV discussion first so we have a better idea about tests and things that a vertical program might need before we talk about the schema?
16:39:42 <markvoelker_> E.g. so we can suggest additions to what hogepodge has laid out if necessary?
16:40:01 <catherineD> or we can see how the schema apply to the vertical program?
16:40:15 <catherineD> sounds like chicken and egg ?
16:40:45 <hogepodge> catherineD: we can go to opnfv with the current doc and get feedback. we have a seed
16:41:07 <markvoelker_> Could be. =)  My thinking was to get requirements for programs like NFV ironed out first and then turn them into a schema, but I'm open to POCing a schema first and then looking at requirements to see if they match if folks think it's a better flow.
16:41:46 <hogepodge> markvoelker_: +1
16:42:23 <catherineD> aimeeu:  is at this meeting ... maybe he can provide the requirements
16:43:21 <aimeeu> catherineD  I can pass on specific questions to the OPNFV team if that's what you need (i'm relatively new to OPNFV)
16:45:07 <markvoelker_> So let's say feedback on the existing patch *before* the PTG would be very timely. =)  Once we get there we'll work through requirements and then discuss necessary changes
16:45:47 <catherineD> markvoelker_: ++
16:46:28 <markvoelker_> For anyone wanting to participate in the verticals discussion, a couple of things to think about prior to traveling:
16:47:00 <markvoelker_> 1.) Existing test requirements (in Tempest vs not, single user vs multi, admin vs non-admin)
16:47:34 <markvoelker_> 2.) Types of tests necessary for vertical programs (e.g. we might need performance tests or resilience tests for some verticals, for example)
16:48:44 <markvoelker_> Anything else on this topic today?
16:49:31 <markvoelker_> #topic open discussion
16:50:10 <markvoelker_> #info There will be no InteropWG IRC meeting next week on account of the PTG
16:50:40 <markvoelker_> Anything else folks want to talk about today?  The floor is open. =)
16:51:35 <zhipeng> will we discuss adding more capabilities (e.g Heat) during the PTG ?
16:52:23 <markvoelker_> zhipeng: Yes, refer to https://etherpad.openstack.org/p/RefStackInteropWGAtlantaPTG
16:52:31 <markvoelker_> zhipeng: This will come up in a couple of different ways
16:52:59 <markvoelker_> zhipeng: The dicussion of add-on programs and the new schema may drive part of it (if some programs become add-ons rather than being required under existing programs)
16:53:58 <markvoelker_> Anything else today?
16:54:09 <zhipeng> thx markvoelker_ :)
16:54:15 <markvoelker_> zhipeng: sure thing!
16:54:50 <markvoelker_> OK, if nothing further we'll end a couple of minutes early today.  Hope to see many of you in Atlanta next week!
16:55:00 <markvoelker_> #endmeeting