16:01:22 <markvoelker> #startmeeting interopwg
16:01:23 <openstack> Meeting started Wed Jan 11 16:01:22 2017 UTC and is due to finish in 60 minutes.  The chair is markvoelker. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:28 <openstack> The meeting name has been set to 'interopwg'
16:01:31 <markvoelker> #chair eglute hogepodge
16:01:32 <openstack> Current chairs: eglute hogepodge markvoelker
16:01:40 <eglute> o/
16:01:55 <CatherineD1> O/
16:02:11 <markvoelker> #link https://etherpad.openstack.org/p/DefCoreRoble.8 Today's agenda
16:02:24 <shamail> Hi everyone.  I am here I am double-booked today so partially looking at the chat (please use mention if I am needed)
16:02:58 <hogepodge> o/
16:03:08 <markvoelker> #topic Finishing up 2017.01
16:03:26 <markvoelker> We have a handful of patches left that really need to land this week if they're going on.
16:03:28 <markvoelker> *in
16:03:49 <markvoelker> Probably the biggest concern is what to do with the Cinder v2->v3 stuff
16:04:02 <markvoelker> #link https://review.openstack.org/#/c/408427/ Cinder patch
16:05:21 <hogepodge> Did we reach a consensus last week?
16:05:45 <shamail> I looked at the change and didn’t see any new comments specifying the agreed upon direction
16:06:25 <hogepodge> markvoelker: eglute: do you think we've reached a consensus direction?
16:06:47 <markvoelker> hogepodge: I thought we had last week, but there were still some concerns discussed. =)
16:06:47 <luzC> o/
16:07:12 * eglute looks back at chat history
16:07:47 <markvoelker> My inclination is to land it as-is since it's advisroy, and potentially work with the existing fields in the schema as a follow-up
16:08:17 <markvoelker> IF we feel the need to add to the schema to more explicitly call out the versioning that's fine (it's a bit late in the game though)
16:09:02 <eglute> i agree with markvoelker. let us know if you disagree
16:10:49 <eglute> hogepodge you ok with this?
16:11:46 <hogepodge> eglute: markvoelker yes
16:12:20 <eglute> anyone else have other opinions?
16:12:43 <markvoelker> Ok then, please register your +/-1/2's in gerrit and we'll put this to bed.
16:12:54 <shamail> thanks.
16:13:18 <markvoelker> #link https://review.openstack.org/#/c/385781/ Nova patch
16:13:23 <eglute> thank you shamail!
16:14:09 <markvoelker> I think shamail's latest patchset on this took care of the last nits so I think we're ready to roll barring any further discussion
16:14:12 <shamail> I updated the Nova patch to fix the Foundation bit right before this meeting.
16:14:18 <shamail> yeah  :)
16:14:25 <Rockyg> o/
16:14:50 <hogepodge> typos in the swift patch were updated too, so that looks good to go. thanks eglute
16:15:14 <eglute> thanks hogepodge no idea how that fatfinger ended up there
16:15:18 <eglute> good catch
16:16:05 <markvoelker> Ok, so hearing no dissent here, let's get those gerrit votes in
16:16:23 <markvoelker> #link https://review.openstack.org/#/c/398428/ Swift patch
16:17:20 <markvoelker> Looks like the last nits have been dealt with here too...any last comments before we land it?
16:18:13 <markvoelker> Ok then, I think that about finishes off 2017.01. =)
16:18:32 <markvoelker> Once these merge I'll put up a patch to create the new document from next
16:18:39 <eglute> thanks markvoelker
16:18:52 * garloff congratulates us to finalize 2017.01 :-)
16:19:16 <markvoelker> eglute: just to confirm, are we on the BoD agenda?
16:19:39 <eglute> i will confirm! there was no call for agenda items yet
16:19:40 <garloff> Jan24?
16:20:20 <markvoelker> eglute: thanks
16:20:23 <markvoelker> garloff: yes
16:20:34 <eglute> #link https://wiki.openstack.org/wiki/Governance/Foundation/24Jan2017BoardMeeting
16:20:39 <markvoelker> Ok, that brings us to....
16:20:49 <markvoelker> #topic PTG
16:20:59 <markvoelker> #link https://etherpad.openstack.org/p/InteropWGAtlantaPTG  Etherpad for PTG Topics
16:21:29 <markvoelker> Please be aware that we're sharing space with RefStack and the interop challenge folks, so we may need to keep things trim
16:21:58 <markvoelker> I'd like to finalize a list of topics by the end of tomorrow so I can coordinate with catherine and Brad on who has the floor when
16:22:21 <markvoelker> So:
16:22:40 <markvoelker> #action Call for PTG agenda items closes tomorrow, please add ideas to https://etherpad.openstack.org/p/InteropWGAtlantaPTG
16:23:00 <markvoelker> (if you haven't already...we've had the pad open for a couple of weeks now)
16:23:15 <eglute> i think New components/add-on programs is a big one
16:23:50 <markvoelker> We definitely have plenty of interesting topics to talk about. =)  Pity we don't have more time/space.
16:24:26 <markvoelker> Also, if you're planning to come to the PTG, please drop your name in the top of the etherpad there just to give us idea of who will be there
16:24:58 <hogepodge> Yeah, I'm not sure the PTG format is really a great place for us to be meeting. Seems to constrained by TC needs and rules.
16:25:21 <hogepodge> But, we should give it a try and see how it works out this time around.
16:25:32 <gema> +1
16:25:39 <markvoelker> As a reminder, we (Interop WG, RefStack, interop challenge) have the room Monday-Tuesday for those making travel plans
16:25:41 <gema> we can always go back to the old 3 day long format
16:25:52 <gema> it was rather productive
16:26:17 <markvoelker> Anything folks want to discuss about the PTG planning right now?
16:26:20 <eglute> agree.. also we need to see if we want to be recognized as separate official project for PTGs
16:26:55 <eglute> i am interested to see how this PTG will go
16:27:36 <eglute> do we need to set up some time with Heat/Ceilometer folks?
16:28:19 <eglute> or any other project? since they are going to be there
16:28:34 <hogepodge> I'll be at the PTG until Friday noon, so I can meet with other groups as needed
16:28:40 <eglute> if you can think of other todo items for 2017.08
16:28:54 <garloff> eglute: Do we consider heat to become part of DefCore (or some DefCore+)?
16:29:14 <hogepodge> agree on the add ons, which is in part dependent on the 2.0 schema that I haven't put enough work in to
16:29:29 <eglute> garloff yes we been talking about it, but heat is not ready because of how their tests are setup
16:29:47 <garloff> then let's meet ...
16:30:09 * garloff acknowledges is easy to say -- will most likely not be able to make it to ATL
16:30:19 <hogepodge> one of the heat issues is that the api is pretty basic, and is meant to manage the template payloads which is its own language, not covered by tempest api tests
16:30:28 <eglute> garloff we met with them in barcelona, and they committed to doing some work to change this, so we need to follow up and see where they are at
16:31:11 <garloff> hogepodge: the issue being that tempest framework does not match well testing the payloads, jsut API behavior?
16:31:59 <eglute> heat team was going to work on new tests and switch to gabi? or something like that.
16:32:29 <hogepodge> garloff: yeah, and heat is dependent on what other projects are installed and what capabilities they have enabled
16:32:53 <markvoelker> garloff: weak attempt at summary: For heat, the API isn't the main source of end user interoperability--it's the heat templates and the resources they provide (which in turn depend on what API's from other projects are supported on the cloud)
16:33:17 <garloff> hogepodge: so any realistic heat testcase actually is testing a dozen things in one test which is not how you want testing to work
16:33:27 <garloff> markvoelker: understood
16:34:21 <garloff> tough one -- but we will need to somehow find a handle -- I perceive heat as relevant in customer discussions
16:34:28 <markvoelker> We can and should test some of the heat API's if we add them to a guideline or create a program for them...but that alone is likely insufficient to be very useful.
16:35:16 <eglute> starting with discovery apis would be good. if i remember correctly, thats what we discussed with the heat team in barcelona
16:35:20 <garloff> markvoelker: or we push this to the interop challenge WG?
16:35:27 * eglute goes looking for a time machine
16:35:36 <markvoelker> eglute: if we want to talk to the heat folks at the PTG, I'd suggest we do it in their meeting room (since we're splitting ours 3 ways) or in the hallway/coffee shop track
16:35:48 <eglute> i agree
16:35:58 <markvoelker> That said, I'm going to have to depart Wednesday evening due to another obligation. =)  But I think we're mostly just checking in here.
16:36:37 <eglute> here are some short notes on heat: https://etherpad.openstack.org/p/DefCoreBarcelona
16:36:56 <eglute> yeah, just checking in to see if they made progress on gabbi stuff
16:37:40 <eglute> gabbi patch is being updated, so they are working on it
16:37:44 <eglute> https://review.openstack.org/#/c/348076/
16:38:19 <markvoelker> OK, anything else on PTG stuff?
16:38:49 * catherineD sorry my internet on the bus is not good ..
16:39:00 <eglute> same with ceilometer- need to get a status of where they are at with their apis
16:39:00 * catherineD now in the office
16:39:12 <catherineD> about the Heat subject ...
16:39:59 <catherineD> if we think that for Heat it is the resources that is important .. does it make sense to include Heat in DefCore?
16:41:29 <eglute> what do you mean catherineD? as a capability?
16:41:30 <hogepodge> It would me nice to have a way to indicate a cloud has an interoperable heat
16:41:47 <catherineD> eglute: yes ..
16:41:53 <hogepodge> it's becoming a more reliable and important project
16:41:54 <garloff> catherineD: If DefCore is about InterOp, then using heat templates from one cloud in another one is a valid expectation, no?
16:42:00 <Rockyg> What would be great would be a hot validator that all could use  ;)
16:42:08 <hogepodge> s/me/be
16:42:48 <catherineD> hogepodge:If I remember correctly (we need to confirm again) ... the Heat tean thinks of resources as "content" not API
16:43:27 <catherineD> I think Heat is a good subject for PTG discussion about must pass tests ... should they be Heat API or resources
16:43:29 <hogepodge> catherineD: yeah, you've definitely done most of the work there and have a better understanding of their pov than I do
16:43:30 <garloff> catherineD: it's all about the payload (the .yaml) ...
16:44:13 <markvoelker> Right, I think the idea here is that (assuming heat meets criteria) we still may want to include it in Guidelines at some point (this might say "if the cloud has a Powered logo, you know it has a heat API and you can push stacks to it").  But API's alone may not be sufficient, and heat's a bit unique in that regard.
16:44:18 <hogepodge> in some ways, passing other capabilities should help guarantee the minimum available for heat templates
16:44:19 <catherineD> garloff: the discussion is about the API that execute the template or the template itself
16:44:26 <eglute> catherineD are you going to be in atlanta?
16:44:35 <hogepodge> so just having the heat api tested and working along with the other project apis could be sufficient
16:44:53 <catherineD> eglute: I am waiting for travel approval ... will put my name in as soon as I get it
16:44:54 <markvoelker> I don't think it's a question of either we focus on the templates or we focus on the API.  It's an "and".
16:45:14 <catherineD> hogepodge: yea that is what the Heat team's direction ..
16:45:16 <eglute> catherineD ok!
16:45:30 <eglute> could someone reach out to heat team and setup a time for us to meet?
16:45:45 <garloff> catherineD: the heat API is trivial while the template definition/content is not, yes
16:46:00 <catherineD> garloff: absolutely
16:46:38 <catherineD> I do not think we should and can spec content in general
16:46:49 <gema> garloff: isn't the template definition the entry parameter of the API?
16:47:17 <gema> or the template, rather, once defined
16:47:27 <hogepodge> I can schedule a meeting with heat team at ptg
16:47:35 <garloff> gema: sure, you submit the template via API and then expect the platform to do a lot of complex stuff ;-)
16:48:03 <gema> garloff: fair enough, we just need to make sure that for certain template configurations, heat behaves the same in all the different clous
16:48:06 <gema> clouds
16:48:09 <gema> so the end user can expect the same
16:48:52 * markvoelker glances at the clock and suggests we move on and discuss more in ATL
16:48:56 <gema> sorry :)
16:49:14 <gema> yep yep
16:49:19 <garloff> gema: Challenges I see are that (a) one typical heat template would test many many different things in one test and (b) we need to measure with probably many tests that what we asked heat to do was successful
16:49:22 <markvoelker> Nono, good discussion, we're just down to 10 minutes. =)
16:49:30 <catherineD> sorry to bring the Heat subject back .. but agree with markvoelker: that it should be a subject at PTG
16:49:54 <markvoelker> #topic User survey
16:49:56 <eglute> catherineD could you please reach out to Heat team and setup a time for us to meet wit hthem?
16:50:03 <markvoelker> (skipped the name change topic just briefly since I think this is quick)
16:50:18 <catherineD> eglute:  hogepodge: just indeicates that he will do so ..
16:50:39 <markvoelker> eglute: would you like to fill folks in on the outcome of the user survey question discussion?
16:50:41 <hogepodge> #action hogepodge set up meeting with heat team at ptg
16:50:48 <eglute> oh i missed it thanks!!!
16:51:09 <eglute> Yes, user survey: looks like we are getting TWO questions!
16:51:49 <eglute> let me find the link to questions
16:53:12 <eglute> cant find the etherpad right now, but this is what we submitted:
16:53:14 <eglute> 1.) (short answer format)  Do you use the OpenStack Powered program or Interoperability Guideline compliance as a factor in your OpenStack procurement process?  Why or why not?
16:53:21 <eglute> as first question
16:53:36 <eglute> and second one that will most likely also be included:
16:53:39 <hogepodge> #link https://etherpad.openstack.org/p/interopwg_user_survey_question
16:53:41 <eglute> 2.) (multiple choice, select all that apply) What do you consider to be the biggest challenges to achieving interoperability between OpenStack clouds?
16:54:20 <eglute> let me know if you would like me to paste all the answers to the second question
16:54:42 <gema> reading on the etherpad
16:55:04 <eglute> https://etherpad.openstack.org/p/interopwg_user_survey_question
16:55:09 <eglute> oh thanks hogepodge
16:55:13 <eglute> i was too slow
16:56:35 <eglute> hopefully answers to these will help us out going forward
16:56:42 <gema> sounds good indeed
16:57:38 <eglute> and i am looking at the survey that is being built, and i see both questions there
16:57:54 <eglute> there is a refstack question there as well:
16:58:19 <eglute> "I'm interested in helping our interoperability testing efforts by checking my cloud capabilities with RefStack."
16:58:30 <hogepodge> two minutes, anything else?
16:58:53 <catherineD> the question list on https://etherpad.openstack.org/p/interopwg_user_survey_question looks good ..
16:59:26 <markvoelker> Just FYI, a couple of those last 2017.01 patches will need rebasing
16:59:38 <eglute> thanks catherineD, we went only with the first 2
16:59:51 <eglute> markvoelker ok!
17:00:07 <markvoelker> And with that, we've run out the clock.  Thanks folks!
17:00:11 <markvoelker> #endmeeting