16:05:33 <eglute> #startmeeting interopwg
16:05:34 <openstack> Meeting started Wed Dec 14 16:05:33 2016 UTC and is due to finish in 60 minutes.  The chair is eglute. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:05:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:05:38 <openstack> The meeting name has been set to 'interopwg'
16:05:39 <markvoelker> thanks eglute
16:05:58 <eglute> #chair markvoelker
16:05:59 <openstack> Current chairs: eglute markvoelker
16:06:05 <eglute> #topic next week
16:06:26 <catherineD> I won't be able to attned next week meeting
16:06:32 <shamail> I will not be able to meetings until 1/4
16:06:34 <eglute> #link beginning of this meeting:  http://eavesdrop.openstack.org/meetings/defcore/2016/defcore.2016-12-14-16.01.html
16:06:47 <markvoelker> I'll be able to make the meeting next week, but sounds like I'll be in the minority...
16:07:17 <eglute> i can make it as well, but we might not have quorum
16:07:34 <luzC> I'll be out until 1/4
16:07:38 <eglute> and the 28th is out as as well
16:07:41 <gema> o/
16:07:50 <gema> I am out until the 9th of Jan :D
16:07:56 <eglute> luzC are you back on 1/4?
16:07:59 <gema> but I will come to the meeting if you guys have it on the 4th or so
16:08:14 <eglute> I think we should try have a meeting on 1/4
16:08:22 <gema> +1
16:08:22 <markvoelker> eglute: ++ for 1/4
16:08:36 <markvoelker> We need to finish up the 2017.01 guideline, so I think it's important.
16:08:44 <eglute> ok, that is settled then, next meeting on 1/4
16:08:50 <eglute> other comments?
16:09:01 <eglute> #topic PTG
16:09:20 <markvoelker> #info No meetings for the rest of December.  Meetings resume 1/4/2017.
16:09:28 <eglute> just a reminder, that we have space at PTG
16:09:29 <eglute> please start adding topics to #link https://etherpad.openstack.org/p/InteropWGAtlantaPTG
16:09:42 <luzC> eglute yes
16:09:47 <garloff> thanks, @markv
16:10:30 <eglute> #topic 2017.01 guideline
16:10:53 <eglute> shamail thanks for submitting cinder patch
16:11:01 <shamail> You’re welcome
16:11:04 <Rockyg> ++
16:11:05 <eglute> #link https://review.openstack.org/#/c/408427/
16:11:26 <Rockyg> it gets easier the more you do ;)
16:11:39 <eglute> i looked at scoring, looked like the new capabilities didnt get scored high enough
16:11:42 <eglute> to be added
16:11:50 <shamail> As you mentioned in the review, none of the capabilities scored high enough to be actually considered advisory but I added them based on the conversations
16:11:56 <markvoelker> eglute: that was my take when I looked at it this morning too
16:11:58 <shamail> v3 currently is not used in SDKs or tools
16:12:07 <shamail> so that gives it a major ding
16:12:56 <Rockyg> advisory might get the sdk project to start implementing code with them ;-)
16:12:58 <eglute> if they are not scored high enough we can't add them i dont think
16:13:18 <markvoelker> So this is one of those API-transition periods, really
16:13:23 <shamail> volumes-list-api-versions doesn’t qualify either and this one has another issue, there is no tempest test
16:13:37 <markvoelker> E.g. if we take "future direction" away from the v2's, some of them wouldn't make the cutoff either.
16:13:40 <shamail> I had to add “tempest.api.volume.NEED_TEST” to make sure the json doesn’t break
16:13:45 <markvoelker> But v3 is basically v2 plus microversions
16:13:47 <eglute> also, "complete" also was not set
16:13:53 <shamail> markvoelker: +1
16:14:00 <markvoelker> So tools that work with v2 work with v3 too for the most part
16:14:08 <markvoelker> (they just have to actually call the v3 endpoint)
16:14:45 <eglute> so would it be worth re-scoring them with tools set to 1?
16:14:46 <garloff> markvoelker: which they get from the catalog, so they may not even notice ...
16:14:58 <eglute> garloff that is a good point
16:15:01 <markvoelker> garloff: well, some do, some don't. =)
16:15:06 <shamail> exactly markvoelker
16:15:07 <markvoelker> Some are manually configured
16:16:11 <markvoelker> To me it feels like a reasonable transition here is to make these advisory now so people are aware of the transition to v3.  We can decide in the next Guideline whether they're really ready to become required
16:16:24 <eglute> markvoelker +1
16:16:44 <eglute> would be good to make that note somewhere
16:16:58 <eglute> so that we need to re-score them before making them required
16:16:59 <markvoelker> I think we'd also discussed leaving a comment/note in the Guideline somewhere explaining the v2/v3 transition
16:17:23 <markvoelker> (that could also be published somewhere in more detail and more plain-English-y like on the interop webpage)
16:17:27 <shamail> That sounds reasonable
16:17:28 <eglute> does schema allow for notes?
16:17:31 <garloff> markvoelker: I would expect all tools to use the catalog for discovery -- would be more concerned about tools that check for known versions and error out if they find an unexpected one
16:18:13 * garloff is wondering why the switch to microversions can not be done without v2->v3 transition
16:18:23 <markvoelker> eglute: yes, we just have to be a bit creative
16:18:36 <markvoelker> e.g. the Guidance section of designated sections, or the capability names, or....
16:18:59 <Rockyg> markvoelker, I agree we need to signal to dev the need to advance.  We might also want to start a ml thread and/or blog post?
16:19:05 <markvoelker> er, description field, not name field. But you get the point.
16:19:28 <eglute> #action shamail markvoelker to get creative and leave notes on cinder about v3
16:19:43 <shamail> Thx
16:20:00 <markvoelker> garloff: well, unfortunately reality is that the endpoints are manually configured in some cases.  E.g. devs have a config entry for their tool to set endpoints.
16:21:22 <markvoelker> shamail: I'd suggest we use the "description" field for the time being. So for example: https://github.com/openstack/defcore/blob/master/2016.08.json#L420
16:21:58 * garloff imagines a customer entering 20 endpoints for an installation that includes some of the BigTent projects ...
16:22:17 <shamail> Sounds good markvoelker, I’ll add a note to the scoring results and update the description to highlight the transitory nature.
16:22:35 <eglute> thank you shamail!
16:22:39 <eglute> anything else on cinder?
16:23:17 <markvoelker> garloff: I've literally seen it done. =)  But usually those sorts of things are only dealing with a few operations and don't need to touch 20 projects (in my experience anyway).  Painful, but there it is...
16:23:28 <eglute> in that case moving on to swift
16:23:31 <eglute> #link https://review.openstack.org/#/c/398428/
16:23:53 <eglute> i updated the scoring based on markvoelker comments
16:24:38 <eglute> objectstore-container-metadata is used by both fog and jclouds as far as i could tell
16:24:45 <markvoelker> eglute: I haven't looked at it since the new patchsets went up last night, but will do today
16:24:52 <eglute> thank you markvoelker
16:25:02 <eglute> everyone, would appreciate your feedback
16:25:28 <eglute> right now, we are looking to add 2 new capabilities to swift as advisory
16:25:31 <eglute> objectstore-info-reques and objectstore-container-metadata
16:26:17 <eglute> any comments/questions on swift?
16:26:34 <eglute> in that case, onto nova!
16:26:38 <eglute> #link https://review.openstack.org/#/c/385781/
16:26:40 <eglute> thanks shamail
16:26:56 <eglute> shamail i have not looked at the new patch yet
16:27:10 <shamail> Moved capabilities to advisory, fixed the HEAD lines that got mixed in there
16:27:27 <eglute> but looks like we are adding 3 new advisory
16:27:41 <eglute> shamail i think you need to remove deprecated nova parts as well
16:27:49 <shamail> Adding two news ones and one that was there at some point but vanished
16:28:19 <shamail> "compute-auth-create", "compute-auth-get"?
16:28:39 <shamail> etc.
16:28:53 <shamail> eglute: Remove the ones that were already listed as depreciated in next.json?
16:29:28 <eglute> move deprecated to removed, remove removed
16:29:34 <eglute> does that make sense?
16:30:06 <shamail> Sure does
16:30:07 <garloff> sounds logical to me
16:30:52 <eglute> thank you shamail! also commented on the patch
16:31:01 <shamail> thanks!
16:31:28 <eglute> otherwise it looks good, 3 new capabilities
16:31:39 <eglute> any other comments or questions on nova?
16:32:32 <eglute> if not, looks like we covered everything for 2017.01 guideline that was outstanding
16:32:46 <eglute> any other comments on the guideline?
16:33:01 <eglute> #name change
16:33:28 <eglute> thanks everyone who worked on the name change!
16:33:29 <eglute> hopefully everyone subscribed to the new mailing list
16:33:37 <eglute> if not, please do so!
16:33:47 <eglute> #link http://lists.openstack.org/cgi-bin/mailman/listinfo/interop-wg
16:34:01 <eglute> #action everyone subscribe to the new mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/interop-wg
16:34:39 <eglute> and i think everyone here already joined the new irc channel
16:34:59 * markvoelker thinks it's time to remove the old one now
16:35:27 <eglute> markvoelker any ideas how to remove it?
16:35:42 <markvoelker> eglute: yeah, I can handle that
16:35:49 <eglute> cool, thank you markvoelker
16:36:13 <eglute> how about github repo?
16:36:36 <eglute> how can we rename that? is there a process?
16:36:53 <markvoelker> eglute: I suggest we finish off 2017.01 before we do that.  Otherwise we'll have a bit of a mess with in-flight scoring patches
16:37:03 <eglute> markvoelker oh good point
16:37:31 <eglute> #action move github repo after 2017.01 passes
16:37:56 <Rockyg> ++
16:38:11 <eglute> markvoelker you still have a couple outstanding writing things for rename, but no rush on that unless you are already done
16:38:17 <Rockyg> and yes, the process is to submit a patch to infra.
16:38:33 <eglute> thanks Rockyg
16:38:55 <markvoelker> eglute: I'm close. =)  Probably next week.
16:38:56 <eglute> anything else on the renames?
16:39:02 <eglute> thank you markvoelker!
16:39:37 <eglute> #topic Documenting how projects can become part of Guidelines
16:39:45 <eglute> markvoelker is this also next week/after holidays?
16:40:10 <markvoelker> Probably after the holidays.  It's on the backburner in favor of the rename and 2017.01 stuff
16:40:29 <eglute> :)
16:40:33 <eglute> sounds good to me
16:40:40 <eglute> #topic update co-chair election process
16:41:16 <eglute> At the beginning of the year i submitted a patch on co-chair election process that was less than ideal
16:41:24 <eglute> #link https://github.com/openstack/defcore/blob/16668dddea39725088040fdef5404a656b24a606/doc/source/process/2016A.rst#guidelines-review-phase-b
16:41:33 <eglute> regarding timing and how the elections happen
16:41:58 <eglute> for B4.5: "One DefCore CoChair needs to be elected by DefCore working group. Election quorum is composed of attendees present during the election meeting."
16:42:12 <eglute> this section needs to be changed to be a bit more vague
16:42:34 <gema> eglute: isn't the usual process to do email elections?
16:42:41 <eglute> gema correct
16:42:49 <eglute> thats what we ended up doing
16:43:01 <eglute> so that is why we need to change the process document
16:43:11 <gema> then let's make it email election, it is fairer than being able to make it to a meeting, I think
16:43:21 <Rockyg> Could use the definition of AUCs
16:43:28 <eglute> i will try to submit a better patch
16:43:29 <eglute> gema i agree
16:43:36 <eglute> Rockyg do you have a link to that
16:44:02 * gema imagines Rockyg going through her email at the speed of light
16:44:12 * eglute laughs
16:44:32 <shamail> http://governance.openstack.org/uc/reference/charter.html (See the AUC section)
16:44:46 <shamail> saved you some searching Rockyg!
16:44:47 <Rockyg> Lol
16:44:48 <gema> haha
16:45:08 <eglute> well, in any case, i welcome all input on the election process. i will try to make it as close to the other OpenStack elections as possible
16:45:12 <eglute> thank you shamail!
16:45:12 <Rockyg> Thanks shamail !  Especially since he is one of the authors
16:45:54 <shamail> you’re welcome Rockyg :)
16:46:08 <gema> shamail: +1
16:46:17 <eglute> we still have one more topic, so lets move on to RefStack, since elections are not happening this year :)
16:46:25 <eglute> #topic RefStack
16:46:30 <eglute> go ahead catherineD
16:46:48 <catherineD> Thanks eglute:
16:47:12 <catherineD> So the https://refstack.openstack.org/#/ was updated last Friday ...
16:47:48 <catherineD> it now provide vendor/product registration process ... also allow Foundation admin to mark/unmark a test as verified
16:48:05 <markvoelker> neat
16:48:38 <eglute> nice
16:48:48 <catherineD> the vendor/product info at this first phase is only available privately ... so the users can have a look of how it will look like
16:49:21 <catherineD> we will make those info pubilicly available sometime after the PTG
16:50:18 <gema> catherineD: great! I will probably go through the process of registering us soon
16:50:20 <catherineD> everyone please take a look ... and log comment, request, bug report in RefStacl launchpad
16:50:31 <eglute> nice job RefStack team! thank you catherineD!
16:50:32 <catherineD> gema: great thanks ...
16:51:26 <catherineD> eglute: thank you I will let the RefStack team know
16:51:27 <eglute> anything else catherineD?
16:51:34 <eglute> :)
16:51:46 <catherineD> pay attention to the https://refstack.openstack.org/#/user_results  once you log in
16:52:04 <eglute> ok!
16:52:10 <catherineD> this is how the test record will look like on a verified test results
16:52:16 <catherineD> that is all
16:52:28 <Rockyg> kewl
16:52:42 <eglute> thank you catherineD!
16:52:49 <eglute> #topic open floor
16:52:59 <eglute> anything else folks?
16:53:38 <eglute> in that case, we can end early!
16:53:54 <markvoelker> happy holidays everyone!  See you in January..
16:53:56 <eglute> Everyone, please review outstanding patches
16:54:00 <eglute> thank you for a great year!
16:54:02 <markvoelker> (and in gerrit before then, right????)
16:54:13 <eglute> right markvoelker!
16:54:21 <catherineD> Happy holidays!
16:54:31 <eglute> Happy Holidays everyone!
16:54:31 <shamail> Thank you everyone, Happy Holidays!
16:54:54 <eglute> #endmeeting