01:30:02 <mafei> #startmeeting interop_challenge
01:30:03 <openstack> Meeting started Wed Feb  8 01:30:02 2017 UTC and is due to finish in 60 minutes.  The chair is mafei. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:30:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
01:30:06 <openstack> The meeting name has been set to 'interop_challenge'
01:30:21 <mafei> Ok,我们开始会议,今天都谁在互操作的会上?打个招呼吧
01:30:38 <mafei> 我们今天会议的议题如下:
01:30:45 <mafei> #link https://etherpad.openstack.org/p/interop-challenge-china-meeting-2017-02-08
01:31:07 <mafei> 第一个议题:
01:31:14 <mafei> #topic Happy Chinese new year
01:31:23 <mafei> 新的一年,祝大家新年快乐,鸡年大吉
01:31:26 <tongli> o/
01:31:35 <Lixiang-ZTE> o/
01:31:47 <kongwei> o/
01:31:47 <xietaotao> 大家新年快乐:)
01:32:05 <mafei> 下一个议题:
01:32:08 <WangChangJin> 新年快乐
01:32:10 <mafei> #topic What about the deployment of the LAMP workload
01:32:12 <tongli> @mafei, @Lixiang-ZTE, @xietaotao, happy Chinese New Year folks. very happy to see everyone here.
01:32:19 <t2cloud> 大家新年快乐!
01:32:30 <Lixiang-ZTE> 新年快乐~
01:32:50 <mafei> 1月份的训练营上希望大家在年前完成LAMP的部署,不知道各家是否完成部署?或者计划何时完成?
01:33:27 <mafei> 麻烦回复xx公司已完成,或者xx公司计划何时完成
01:34:25 <daisyguo> good morning
01:34:41 <t2cloud> 云途腾己完成
01:34:44 <mafei> ok
01:34:47 <mafei> good
01:34:48 <tianquan> 因年底冲刺项目有拖延,北京云英计划本周日(2月12日)前完成
01:34:55 <xietaotao> 浪潮已完成。
01:35:03 <mafei> 好的,加油
01:35:46 <mafei> 因为今天我们将开始下一个workload,所以还请大家往前赶
01:35:55 <daisyguo> 早上好
01:36:04 <mafei> 早上好daisy
01:36:33 <mafei> 中兴结果呢?
01:36:43 <mafei> @kongwei
01:36:49 <tongli> 我记得有家公司会提交一个patch to fix the problem with the root access.
01:37:02 <tongli> I have not see the patch, can we get that patch submitted?
01:37:17 <mafei> 好像是云途腾吧
01:37:32 <tongli> when install wordpress tool, if use root, it fails without an option.
01:37:40 <kongwei> zte 已经完成lamp测试
01:37:49 <tongli> it should be a very simple patch. can someone please submit the patch?
01:37:51 <mafei> @kongwei,ok
01:38:17 <t2cloud> 关于root access,刚测试完,马上会提交
01:38:20 <mafei> 烽火呢?
01:38:30 <mafei> 情况如何?
01:38:43 <mafei> ok,@t2cloud
01:38:46 <tongli> @t2cloud, great. great. add my name to the reviewer, so that I can review it quickly.
01:39:27 <mafei> 好的,大家都加油
01:39:31 <fiberhome-joycc> 烽火这边测试人员年前在客户现场忙其他项目,现在正在测试,计划本周内完成
01:39:35 <mafei> 下一个议题:
01:39:46 <t2cloud> @tongli  ok
01:40:00 <mafei> ok,@fiberhome-joycc
01:40:04 <mafei> #topic Decide when to finish the deployment of  the dockerswarm workload
01:40:22 <mafei> 下一步我们计划部署dockerswarm,大家认为需要多长时间?两周是否可以?
01:41:05 <tongli> since we will be working on kubernetes, is it absolutely necessary to run the dockerswarm workload? @mafei.
01:41:21 <tongli> I mean kubernetes workload, I am writing it right now.
01:42:57 <tongli> are we having people dropping off?
01:43:07 <mafei> 我觉得可以同步进行
01:43:18 <tongli> @mafei, sure, that is fine.
01:43:21 <mafei> i am here
01:43:34 <mafei> 其他人意见呢
01:43:36 <tongli> I saw that Liwei and wenwen both left.
01:44:09 <mafei> maybe the network is bad @tongli
01:45:11 <tongli> ok.
01:45:15 <Daisy> I'm here
01:45:29 <Daisy> tongli: Docker swarm的难度有多大?
01:45:48 <tongli> @Daisy, easier than lampstack.
01:45:55 <Daisy> ok
01:45:56 <tongli> it is relatively smaller.
01:46:12 <tongli> @mafei, probably run it to get a feeling about.
01:46:24 <kongwei> docker测试是否也需要连接互联网?
01:46:44 <xietaotao> dockerswarm 依赖coreos,国内拉取coreos会不会很痛苦哦?
01:46:44 <tongli> sorry guys, input Chinese from my side is slow, hope that using English is ok with everyone, if not, I will try to type in Chinese.
01:46:56 <Daisy> tongli: 我想mafei可能是想多测一个workload,k8s和nfv还在开发过程中。
01:47:18 <kongwei> 测试的结果怎么提交到社区啊?
01:47:24 <mafei> @Daisy, that`s right
01:47:39 <Daisy> tongli: 如果k8s开发完毕,可以给大家测试了,那么直接测k8s也可以。
01:47:43 <tongli> @xietaotao, you only need to get coreos image once and place it in your glance, one time, you do not have to do it everytime you run the workload.
01:48:16 <xietaotao> @tongli, OK
01:48:27 <tongli> @Daisy,@mafei, it is ok to run dockerswarm now, try it and see.
01:48:52 <mafei> 因为k8s和NVF还在开发阶段,所以我们还是先去跑一下dockerswarm
01:49:01 <Daisy> mafei: dockerswarm这个大家都没有做过,不知道2周能不能完成。
01:49:12 <mafei> 一是可以找一下感觉,二来也可以为4月份的展示做一个储备
01:49:34 <mafei> 如果没有问题,我们就安排2周左右的时间来进行部署
01:49:38 <mafei> ok?
01:49:40 <tongli> @mafei, good idea.
01:49:54 <xietaotao> @mafei, 好的
01:50:02 <tongli> @Daisy, 2 weeks should be enough.
01:50:17 <Daisy> 好的,同意。
01:50:29 <mafei> ok
01:50:31 <t2cloud> 好的
01:50:36 <mafei> 下一个议题:
01:50:48 <fiberhome-joycc> OK
01:50:51 <mafei> #topic Decide who to develop the k8s and NFV workload
01:51:33 <Daisy> 我记得春节之前的会上讨论过这个。
01:51:40 <mafei> k8s和NFV两个workload正在开发中
01:51:52 <mafei> 还有谁要参与其中
01:51:54 <Daisy> tongli: 能讲讲k8s的进展吗?
01:52:11 <kongwei> zte在做nfv的工作了
01:52:17 <mafei> good
01:52:23 <mafei> @kongwei
01:52:34 <kongwei> :)
01:52:47 <mafei> 其他公司呢
01:52:51 <Lixiang-ZTE> ZTE非常愿意做NFV相关的workload
01:53:05 <tongli> @Lixiang-ZTE, great. thanks a lot.
01:53:13 <tongli> can you describe the flow?
01:53:16 <mafei> cloudin云英
01:53:16 <mafei> 浪潮
01:53:24 <mafei> 中国移动苏研
01:53:27 <tongli> such as this for lampstack.
01:53:58 <tongli> 1. Provision VMs, 2. create security group, rules, 3, install related software, 4 , setup database etc.
01:54:24 <tongli> now for NFV, what is the use case or scenarios, can you describe it?
01:54:33 <Lixiang-ZTE> @tongli 具体内容现在@kongwei 和 @WangChangJin在做工作
01:55:17 <Daisy> Liwei: 我们正在讨论nfv,你那边有什么新的进展吗?
01:55:20 <tongli> @Lixiang-ZTE, ok, if you can ask them to just create that flow, that will be nice.
01:55:36 <Lixiang-ZTE> @
01:55:43 <WangChangJin> NFV的场景,我有两个提议
01:56:14 <WangChangJin> 1.VNF基于ZTE的网元来进行构造
01:56:29 <Lixiang-ZTE> @tongli 另外有个问题还请帮忙。我们按照openstak interop challenge页面的要求发邮件请求加入,但是没收到回应。你看能否麻烦你这边知会社区一下接纳我们的申请?
01:56:30 <Lixiang-ZTE> 谢谢
01:57:04 <WangChangJin> 大家认为如何?
01:57:09 <tongli> oh, @Lixiang-ZTE, you mean that you tried to subscribe to the mailing list and there was no response?
01:57:26 <kongwei> yes
01:57:39 <Daisy> WangChangJin: 我只看到一个提议。1.VNF基于ZTE的网元来进行构造 另外一个是什么?
01:57:42 <Lixiang-ZTE> 孔炜请求的,但是没收到回应
01:57:52 <tongli> @Lixiang-ZTE, ok. will check into that.
01:58:01 <Lixiang-ZTE> thank you very much!
01:58:05 <kongwei> 我已经收到订阅邮件了。但是有个申请被拒绝
01:58:33 <tongli> which part was rejected?
01:59:30 <mafei> NFV现在应该华为、移动、中兴都可以参与
01:59:36 <mafei> 国内的SDN/NFV联盟的互操作工作组也有这方面的意向,还在沟通中,但是觉得NFV是一个比较大的框架,最好先做哪个层次的脚本,需要评估可行性。
01:59:42 <mafei> 看看李彤的想法吧
01:59:46 <mafei> from  liwei
02:00:11 <tongli> @mafei, I think we start with small and easy one, can have many revisions.
02:00:27 <tongli> but the small and easy one should represent typical use case.
02:00:52 <kongwei> 我发了一封邮件“zte want to join the interop challenge” 想把我们测试的内容提交到社区。这个邮件被rejected了@tongli
02:01:08 <WangChangJin> NFV最简单的场景也比LAMP复杂的多,这个大家要有心理准备,呵呵
02:01:17 <tongli> the problem is that I do not know what is the typical use case as I have no NFV experiences, I think we rely on experts here in this channel
02:01:41 <tongli> @kongwei, if your subscription is in the process queue, the email will be rejected.
02:01:42 <hongliang> 大家好,我是EasyStack的,很高兴和大家一起交流
02:01:54 <Lixiang-ZTE> WangChangJin is this kind of expert :-)
02:02:00 <Daisy> hongliang: 欢迎
02:02:10 <mafei> @tongli   i agree
02:02:25 <kongwei> @tongli 那么是不是需要重新发邮件申请啊?
02:02:27 <tongli> @kongwei, give it couple of days, you should receive an email on if the subscription is accepted or not.
02:02:31 <tongli> then send the email again.
02:02:40 <WangChangJin> LAMP部署完成后,可以让大家有个直观的感受最终的结果
02:02:45 <mafei> 欢迎@hongliang
02:02:54 <tongli> @hongliang, welcome.
02:02:56 <kongwei> 好的。十分感谢@tongli
02:03:11 <WangChangJin> NFV部署后,如果做不到端到端,直观用户感受很难体验
02:03:31 <Daisy> 那就通过社区的邮件列表继续nfv的细节的讨论?
02:03:32 <liuhaijie> I've been working in Ericsson for 7+ years, and 3 years PC/NFV experience. I may share my effort if needed.
02:03:40 <tongli> @kongwei, 不用客气。we are all brothers and sisters. I feel very much at home.
02:04:05 <mafei> nice  @liuhaijie
02:04:11 <tongli> @liuhaijie, that will be awesome.
02:04:36 <Daisy> 我来记录action item吧。
02:04:44 <tongli> @liuhaijie, if you can provide some work flow (use case), then we can have some discussions in this work group.
02:05:05 <mafei> ok,@Daisy
02:05:09 <tongli> I think we should just write #action
02:05:20 <Lixiang-ZTE> 我觉得最好能实现一个打通电话的场景。这个利于演示。
02:05:30 <tongli> #action T2Cloud submit the patch to fix root access issue on lampstack
02:05:37 <mafei> ok
02:05:53 <Lixiang-ZTE> 去年summit上OPNFV那个拿大剪刀剪光纤的效果很好,哈哈。
02:06:02 <tongli> #action Liuhaijie to provide some details on NFV use cases or at least thoughts since his expereiences in the past.
02:06:16 <Lixiang-ZTE> interop如果有也有实际的电话业务演示感觉会更令人感兴趣
02:06:29 <liuhaijie> @tongli there is a white paper from ITU, regarding to NFV use case. I can share it later.
02:06:30 <tongli> I think when we do something like that, it automatically list these things in a file we can later refer to.
02:06:33 <Daisy> #action all to start dockerswarm testing and update progress in the next meeting
02:07:29 <mafei> any other action?
02:07:30 <tongli> @liuhaijie, yes, that is nice, but if you can take the typical use case out and share with folks, that will be nicer. you know people are very busy.
02:07:50 <tongli> #action each company should run dockerswarm and complete within two weeks.
02:08:00 <mafei> ok
02:08:16 <liuhaijie> For a phone call, we need much more functions in telecom, i.e., packet core, eNode B, etc. It need strong support from telecom companies.
02:08:27 <tongli> btw, Boston summit will have another big interop show, do not know what yet.
02:08:33 <mafei> #action
02:08:37 <tongli> that is the latest news I got.
02:09:07 <tongli> any good ideas will be appreciated very much.
02:09:09 <liuhaijie> @tongli understood, i'll figure out some 'typical' cases.
02:09:43 <Daisy> #action CloudIn and FiberHome to finish LAMP test by this week
02:09:43 <tongli> that will be the message also for ZTE brothers and sisters.
02:10:25 <Daisy> tongli: glad to see there will be another interop show in Boston. Our Chinese companies can join the show.
02:10:26 <Lixiang-ZTE> only brothers now , hahah
02:10:57 <tongli> @Daisy, absolutely, I would love to see all these telecom companies to be represented on the stage.
02:11:03 <tongli> that will be absolutely awesome.
02:11:17 <tongli> of course, other players as well.
02:11:47 <tongli> the more, the merrier
02:11:47 <Daisy> shall we move to next topic ?
02:11:51 <mafei> ok
02:12:00 <mafei> 下一个议题:
02:12:07 <mafei> #topic Discuss how to write the white paper about openstack interop
02:12:24 <mafei> 互操作的白皮书
02:12:26 <Daisy> 白皮书,先从目录开始吧?
02:12:45 <mafei> 我梳理了一个框架
02:12:56 <mafei> 大家可以提提意见
02:12:56 <Daisy> mafei: awesome
02:13:03 <mafei> 一、openstack互操作简介
02:13:31 <mafei> 二、开展openstack互操作目的
02:13:37 <mafei> 三、开源社区互操作情况
02:13:43 <mafei> 四、互操作应用场景
02:13:49 <mafei> 五、互操作遇到的问题
02:14:05 <mafei> 1.1 什么是openstack互操作
02:14:18 <mafei> 1.2 openstack互操作的内容
02:14:38 <mafei> 4.1 LAMP
02:14:44 <mafei> 4.2 dockerswarm
02:14:49 <mafei> 4.3 k8s
02:14:53 <mafei> 4.4 NFV
02:14:59 <mafei> 4.5 其他
02:15:15 <mafei> 看看有何意见
02:15:36 <tongli> good start @Daisy, thanks.
02:16:05 <tongli> we probably can add that these work loads will be very much targeting the Openstack certification processes.
02:16:27 <mafei> 另外,大家如果对那部分感兴趣,也可以参与一下
02:16:39 <tongli> these word should be part of the purposes of the interop challenge effort.
02:16:56 <Daisy> mafei: 看起来不错。
02:18:34 <mafei> 其他人有无意见
02:18:44 <tongli> @mafei, thanks for putting it together, looks nice. maybe add some part like lesson's learnt
02:19:04 <Daisy> tongli: good suggestion
02:19:05 <tongli> these section normally are valuable to service providers.
02:19:31 <Daisy> "五、互操作遇到的问题"改为“五、互操作遇到的问题及建议”?
02:19:34 <mafei> sorry, what about  lesson's learnt
02:19:46 <tongli> @mafei, plus, we already have a document in the current project, you can simply copy and paste (maybe translate).
02:19:52 <mafei> ok,daisy
02:20:09 <tongli> this is good because we are all part of the interop challenge, so there is no stealing material problem.
02:20:13 <mafei> good, tongli
02:20:27 <mafei> ok
02:20:37 <Daisy> mafei: 就是一些互操作性的经验和最佳实践的分享
02:20:48 <mafei> ok
02:20:52 <Daisy> mafei: litong说社区里面有一些英文文档了。可以参考
02:21:05 <mafei> 恩  明白
02:21:30 <mafei> 我们还有十分钟
02:21:35 <Daisy> 没有意见就下一个话题了?
02:21:42 <mafei> 最后一个议题
02:21:47 <Lixiang-ZTE> 我觉得是否可以不需要4.5其他?如果我们有openstack社区中没有的场景,就按场景分类单列。
02:21:58 <mafei> ok
02:22:01 <mafei> good
02:22:02 <Lixiang-ZTE> 防止其他这节成为大杂烩
02:22:18 <mafei> 好主意
02:22:19 <mafei> #topic Discuss how to show the interop challenge on the global cloud computing summit in April
02:22:21 <Daisy> 好,同意。
02:22:35 <mafei> 讨论下4月份峰会的演示
02:22:44 <Daisy> 希望能够邀请到重量级的嘉宾来主持这个部分。
02:22:53 <mafei> 我们也计划邀请openstack基金会的高层过来主持,但这取决于我们可以展示的东西和效果
02:23:07 <Daisy> mafei: 也取决于这个会议的规模
02:23:10 <tongli> @mafei, yes, agree
02:23:30 <mafei> 集思广益
02:23:52 <mafei> tongli,你有何建议
02:24:00 <Lixiang-ZTE> 谁厉害把jonathan抓来  :-D
02:24:33 <mafei> 首先得看我们也展示的东西
02:24:43 <mafei> 先自身强
02:24:49 <Daisy> LAMP不适合再演示一遍了。如果K8s或者NFV能够完成,我感觉新的usecase比较好。
02:25:10 <mafei> k8s或NVF时间上是否来得及
02:25:19 <Lixiang-ZTE> 具体4月什么时候?
02:25:26 <Daisy> 4月19日20日
02:25:32 <mafei> 4月19-20日
02:25:40 <Lixiang-ZTE> NFV感觉会太紧张
02:25:42 <tongli> k8s is an cadidate, but I think number of people attending is the most important factor.
02:25:54 <Daisy> Boston峰会在这个之后一个月,不知道峰会上打算演示什么。
02:26:09 <tongli> @Daisy, do not know yet.
02:26:14 <mafei> 4月份的峰会规模在3000-4000好像
02:26:32 <Daisy> mafei: wow, amazing number
02:26:52 <Lixiang-ZTE> @mafei 这么大啊?
02:26:57 <Lixiang-ZTE> 没想到
02:27:01 <Daisy> k8s大约什么时间能够给大家测试?
02:27:14 <Daisy> tongli: k8s大约什么时间能够开始给大家测试?
02:27:43 <mafei> 我们的演示安排在主会场上
02:27:49 <mafei> 应该是第二天上午
02:27:56 <mafei> 也就是20日上午
02:28:05 <tongli> @Daisy, do not know yet, I have few issues to resolve first.
02:28:21 <tongli> I am hoping I can resolve these issues in next couple of weeks.
02:28:27 <Daisy> tongli: ok
02:28:39 <Daisy> 我想大家至少需要提前一个半月开始测试吧?
02:29:26 <mafei> 时间快要到了,我们是否可以继续讨论
02:29:55 <Daisy> mafei: 没人占会议室就可以继续讨论。
02:30:08 <mafei> 或者,我们下周三在讨论峰会演示的话题
02:30:20 <Daisy> 这个会议是一周一次吗?
02:30:37 <mafei> 好像是一周一次的
02:30:41 <Daisy> 哦。
02:30:42 <Daisy> ok
02:31:07 <tongli> it was reserved once a week, but I think we decided to have it every other week.
02:31:10 <fiberhome-joycc> ok
02:31:14 <tongli> we are free to use it every week though.
02:31:46 <tongli> #action decide who to update the wiki page
02:32:05 <mafei> 峰会的演示确实需要好好讨论下,大家也可以在这周内思考下如何演示会更好
02:32:10 <tongli> I think Daisy has been doing that, I prefer an non-ibmer does that for us.
02:32:32 <Daisy> tongli: 有什么需要更新的啊?我可以去做。:)
02:33:08 <tongli> the meeting information & the etherpad link need to be updated each week.
02:33:14 <tongli> like time, etc
02:33:24 <Daisy> 我去做吧。一回生两回熟。
02:33:38 <mafei> 原计划我们想二周一次会
02:34:06 <mafei> 但是峰会的事还没有讨论好,所以我们是否下周继续讨论
02:34:26 <Daisy> mafei: 会后你可以试一下看能不能更新wiki,如果能的话,以后你可以直接去更新。
02:34:50 <mafei> 如何更新?
02:34:59 <Daisy> 会后跟你说。
02:35:02 <mafei> 好的
02:35:10 <mafei> 那好吧,今天的会议就到这儿吧
02:35:16 <mafei> 感谢大家的参与
02:35:22 <tongli> @Daisy,@mafei, need to end the meeting I think.
02:35:29 <mafei> i
02:35:32 <Daisy> 谢谢@mafei, @tongli, all
02:35:36 <mafei> i know
02:35:43 <tongli> @mafei, great.
02:35:45 <mafei> tongli, good night
02:35:46 <tongli> Thanks a lot.
02:36:03 <mafei> #endmeeting