14:00:54 <topol> #startmeeting interop_challenge
14:00:55 <openstack> Meeting started Wed Dec 14 14:00:54 2016 UTC and is due to finish in 60 minutes.  The chair is topol. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:58 <openstack> The meeting name has been set to 'interop_challenge'
14:01:15 <topol> Hi everyone, who is here for the interop challenge meeting today?
14:01:15 <topol> The agenda for today can be found at:
14:01:15 <topol> #link https://etherpad.openstack.org/p/interop-challenge-meeting-2016-12-14
14:01:17 <topol> We can use this same etherpad to take notes
14:01:25 <tongli> o/
14:02:31 <tongli> seems just you and me.
14:02:39 <skazi> hi
14:02:52 <topol> hopefully folks saw the email/meeting invite with the time change and meeting channel change
14:02:54 <skazi> where is the interop meeting today?
14:03:05 <topol> skazi its supposed to be here
14:03:32 <skazi> the mail says both #openstack-meeting-cp (in text) and #openstack-meeting-5 (in url)
14:04:12 <skazi> at least this is what I got in my invite
14:04:20 <tongli> @skazi, hmmm, I thought that  I changed both.
14:04:33 <gema> o/
14:04:36 <topol> skazi was that my email?
14:04:55 <skazi> I see tongli in From
14:05:00 <tongli> @skazi, this is the email.
14:05:06 <tongli> Interop Challengers, we will continue our regular meeting on IRC Wednesday.
14:05:06 <tongli> Important changes:
14:05:06 <tongli> 1. Our meeting time has been changed to UTC 1400. From this point on, we will be always using UTC 1400.
14:05:07 <tongli> 2. Our meeting channel has been moved to openstack-meeting-5.
14:05:09 <tongli> 3. The mailing list has been moved to interop-wg@lists.openstack.org
14:05:11 <tongli> Here is the link for the etherpad. Please find more information on the pad.
14:05:13 <tongli> https://etherpad.openstack.org/p/interop-challenge-meeting-2016-12-14
14:05:15 <tongli> Date/Time: Wednesdays at 1400UTC
14:05:17 <tongli> Meeting at IRC channel: #openstack-meeting-5
14:05:19 <tongli> IRC Web link if you are not using IRC client: http://webchat.freenode.net/?channels=openstack-meeting-5
14:05:21 <tongli> wiki: https://wiki.openstack.org/wiki/Interop_Challenge
14:05:26 <topol> I just put a message in openstack-meeting-cp that we are here
14:05:31 <tongli> I do not see where it shows -cp. please let me know so that I can update.
14:05:38 <skazi> tongli: I mean the usual calendar events
14:06:03 <skazi> it contains:
14:06:06 <skazi> (...)
14:06:07 <skazi> Meeting channel is at #openstack-meeting-cp on Wednesday UTC 1400
14:06:07 <skazi> http://webchat.freenode.net/?channels=openstack-meeting-5
14:06:08 <tongli> @skazi, let me double check, I thought I changed everywhere.
14:06:10 <skazi> (...)
14:06:15 <tongli> sorry for confusions.
14:06:24 <gema> I got the update
14:06:38 <tongli> @skazi, I saw it, I missed one place.
14:06:42 <skazi> btw, I got unsubscribed from defcore mailing list somehow (automatically?)
14:06:50 <gema> skazi: we are changing mailings
14:06:59 <topol> skazi we have a new mailing list
14:07:01 <gema> and gave people the chance to join the other one if they are still interested
14:07:05 <gema> skazi: check the history
14:07:21 <skazi> gema: OK, thx, I missed it somehow :(
14:07:29 * gema will find it
14:07:52 <gema> skazi: http://lists.openstack.org/cgi-bin/mailman/listinfo/interop-wg
14:07:59 <skazi> gema: thx
14:08:08 <gema> np
14:08:31 <topol> nobody seems to be hanign out in openstack-meeting-cp
14:09:10 <tongli> @topol, good thing, either moved here or may be one hour late.
14:09:23 <gema> I vote for the one hour late
14:09:25 <topol> I don't think we have enough people for a quorum :-(
14:09:31 <tongli> since the mailing list has also been changed, the changing notes may not reach everyone.
14:09:32 <gema> been fighting instincts today :)
14:09:40 <gema> topol: what is happening over Xmas?
14:09:46 <gema> are we still having the meeting?
14:09:59 <topol> gemam we are gonna take a break until Jan 4 :-)
14:10:06 <gema> topol: good :D
14:10:29 <topol> but we were just hoping today to close on what the priority workloads should be
14:10:58 <gema> yep
14:11:11 <tongli> we have 19 votes.
14:11:25 <gema> where is the voting? I missed last week
14:11:40 <gema> ahh doodle, will vote
14:11:41 <topol> yes, but not enough folks in the meeting to have a discussion
14:11:49 <tongli> http://doodle.com/poll/cpxbnhgp66ckb8gt
14:11:50 <gema> fair enough
14:11:58 <tongli> @gema, you can vote now.
14:12:03 <gema> will do, thanks
14:12:38 <tongli> from the votes so far, Kubernetes is the winner.
14:12:52 <tongli> NFV behind that, then hybrid cloud.
14:13:10 <tongli> looks we are doing Kubernetes & NFV as of now.
14:13:47 <gema> yep, they all sound interesting, though
14:14:17 <tongli> yes. they are all nice ones. I can copy the results to our wiki after this meeting.
14:14:19 <topol> so the question on NFV is do we have something to get started on as a worload
14:14:36 <topol> Yay markvoelker
14:15:04 <markvoelker> hi gang--running a little behind today on account of some contractors showing up early. =)
14:15:13 <topol> no worries
14:15:17 <tongli> @topol, that one is most fluid, we need a NFV guy to shed some lights for defining a scenario or use case.
14:15:25 <topol> let me start going thru the procedural stuff. its short
14:15:48 <topol> #topic review action items from previous meeting
14:15:48 <topol> #link http://eavesdrop.openstack.org/meetings/interop_challenge/2016/interop_challenge.2016-12-07-15.01.html
14:15:58 <topol> tongli to push the our postmortem doc as a patch to the new repo!
14:16:07 <topol> tongli this is done correct?
14:16:08 <tongli> @markvoelker, you have not voted yet.
14:16:30 <topol> that ironic given he created the poll :-)
14:16:30 <tongli> @topol, yes, got a review and addressed the issue, patch set 3 as of today.
14:16:43 <topol> great thanks tongli
14:16:47 <markvoelker> tongli: I'll check out the patch today
14:16:52 <topol> markvoelker to create doodle poll and post to ML.
14:16:56 <markvoelker> thanks for iterating on the previous comments
14:17:11 <topol> doodle poll is clearly done! THANKS markvoelker
14:17:24 <topol> topol ask ttx about flex space
14:17:28 <tongli> @markvoelker, mostly just copy & paste and reformat, also added what I learned from.
14:17:30 <markvoelker> Regarding the doodle poll: I think we've gotten most of the responses we're going to get.  We had no responses in about 4 days until one more came in this morning
14:17:38 <tongli> hope that the structure is ok.
14:18:12 <tongli> @markvoelker, agreed.
14:18:23 <topol> ttx said:
14:18:26 <tongli> cloest one to NFV sits at 6, so.
14:18:27 <topol> 11:45 ttx: actually InteropWG has a room
14:18:27 <topol> 11:45 ttx: together with RefStack
14:18:46 <topol> ttx: so you can use that space on Monday-Tuesday
14:18:46 <topol> 11:46 ttx: otherwise there will be room for extra meetings anyway
14:19:42 <topol> so it looks like we have lots of options for having discussions during PTG.  Just will need to decide how much time we want to allocate at PTG for interop discussions
14:20:02 <topol> K, onto todays agenda.
14:20:20 <topol> #topic logistics
14:20:38 <topol> We have made some logistic changes:
14:20:38 <topol> Meeting is now at UTC 1400, we won't care about the day light saving time.
14:20:38 <topol> Meeting channel is now at openstack-meeting-5. Thanks to shamail for all the hard work to get us this channel and time slot.
14:20:40 <topol> Mailing list is also changed to interop-wg@lists.openstack.org
14:20:42 <topol> We are skipping the next two weeks, the next meeting will be Jan. 4th, 2017.
14:21:02 <topol> #topic Review doodle poll results
14:21:02 <topol> Decide which two work loads we will finish based on the doodle pool.
14:21:02 <topol> The link to the doodle pool. http://doodle.com/poll/cpxbnhgp66ckb8gt
14:21:20 <topol> So I got  us to the meat of the agenda for today :-0
14:21:37 <topol> Looks like Kubernetes was top choice
14:21:40 <tongli> yeah. right back at the doodle pool.
14:22:05 <tongli> 22 votes now.
14:22:33 <topol> Looks like NFV is a strong second.
14:22:37 <markvoelker> yeah, feels like Kubernetes and NFV were both clear favorites.  Do we want to shoot for both?
14:22:52 <topol> Results are pretty definitive... Anyone demand a recount :-)
14:23:08 <tongli> we have more developers this time around, we should be able to do that. I do not mind start thinking about kubernetes.
14:23:14 <tongli> I can start working on that one.
14:23:22 <eeiden> We also have the NFV workload that we (att) developed a little too late for the last challenge! Should be pretty ready-to-go.
14:23:22 <tongli> someone else can start doing NFV.
14:23:23 <topol> markvoelker, I think we should start with both
14:23:33 <eeiden> We were running into a little issue during the recent changes in Lampstack but those should be fixed shortly.
14:23:45 <tongli> @eeiden, yes, yes.
14:23:47 <topol> eeiden, cool. did that ever get uploaded to the repository?
14:23:50 <tongli> we should look at that one.
14:24:01 <tongli> @topol, no.
14:24:04 <eeiden> https://git.opnfv.org/models/tree/tests/utils/ansible-setup.sh
14:24:05 <eeiden> https://git.opnfv.org/models/tree/tests/vLamp_Ansible.sh
14:24:13 <eeiden> here currently ^
14:24:13 <tongli> I did not see it in our repo.
14:24:20 <topol> tongli ++ I definitely was hoping with NFV we would not have to start from scratch
14:24:40 <tongli> @topol, I will take a look at that and see if we can move over.
14:24:44 <topol> eeiden can you push it up to our new repo?
14:24:51 <tongli> seems it is also using ansible.
14:24:55 <tongli> great. I will take a look.
14:25:12 <eeiden> sure!
14:25:19 <topol> yes, ansible is a popular choice
14:25:29 <tongli> @eeiden, all ATT copyright at the top.
14:25:53 <eeiden> ooh right thanks for pointing that out
14:25:59 <topol> so markvoelker and others we don't have a ton of people at todays meeting but I think the doodle poll speaks clearly for all of us
14:26:29 <tongli> @eeiden, any sort of document?
14:26:29 <eeiden> I'll talk to others and get it pushed up asap once I'm positive it's working
14:26:47 <topol> so everyone okay with us picking both workloads as two to start with?
14:26:51 <tongli> like how to get it started, use what kind of image, etc.
14:26:56 <markvoelker> topol: ++
14:27:06 <tongli> @eeiden, good.
14:27:19 <tongli> @topol, +1
14:27:20 <eeiden> all documentation currently at the top of vLamp_Ansible.sh but we'll get it into a readme
14:27:24 <tongli> aim high.
14:27:37 <tongli> @eeiden, great.
14:27:48 <tongli> you know where our new repo is, right?
14:28:08 <tongli> https://github.com/openstack/interop-workloads
14:28:12 <eeiden> yep!
14:28:15 <eeiden> thank you
14:28:18 <tongli> it is also documented on the wiki page.
14:28:37 <tongli> ngv should sit at this path.
14:28:52 <topol> #agreed Kubernetes and NFV will be our top priority workloads for this round of the interop challenge
14:28:57 <tongli> workloads/ansible/shade/nfv
14:29:06 <tongli> I assume this uses shade.
14:29:18 <topol> #action, eeiden to push up the NFV workload to new repo as soon as possible
14:29:24 <eeiden> it does
14:29:31 <topol> #action tongli to start on kubernetes
14:29:37 <tongli> great, then the path should be correct.
14:30:01 <topol> #action all hopefully folks join in on one of the two workloads. Or both :-)
14:30:17 <tongli> @topol, both , both, both, both.
14:30:32 <tongli> everybody will have to run both, I assume.
14:30:44 <topol> tongli, yes let's plan on that
14:30:54 <topol> #agreed everyone to run both workloads
14:30:55 <tongli> I have found some bugs in the existing workloads.
14:31:16 <tongli> I can no longer run them successfully due to mysql version changes.
14:31:17 <topol> #topic Where do we track bugs
14:31:38 <tongli> @topol, perfect, so where do we track bugs?
14:32:07 <topol> like other projects can we get a bugzilla?
14:32:13 <tongli> @gema, @shamail?
14:32:33 <topol> er launchpad :-)
14:32:40 <gema> launchpad sounds good to me
14:32:43 <gema> like other projects?
14:32:44 <markvoelker> It's pretty easy to set up a launchpad project.
14:32:53 <tongli> should be exactly like other projects.
14:32:57 <luzC_> sounds good to me too
14:33:56 <tongli> @topol, I will screen shot the doodle pool and place it at the end of the wiki page.
14:34:11 <tongli> so that will mark the closure of the pool and record the results.
14:34:15 <tongli> u ok with that?
14:34:35 <topol> tongli, sounds good
14:34:52 <tongli> how about every one else?
14:34:57 <gema> +1
14:35:06 <tongli> still do not see mark's vote though.
14:35:16 <topol> so we need to figure out how to get a launchpad bug project for our project like all the other projects have
14:35:24 * markvoelker closes the doodle poll to show final results
14:35:36 <topol> markvoelker THANKS
14:36:18 <topol> tongli can you check with someone from infra on how we get ourselves a launchpad bug project
14:36:58 <markvoelker> topol: anyone can register an LP project.  There are a few bits to tie it into the openstack gerrit system though.
14:37:12 <gema> http://docs.openstack.org/developer/fuel-docs/plugindocs/fuel-plugin-sdk-guide/create-environment/launchpad-project.html
14:37:12 <tongli> @topol, sure, I have not done this before, have no clue, hoping someone else can give me a pointer at least.
14:37:22 <markvoelker> tongli: topol: refer to http://docs.openstack.org/infra/manual/creators.html
14:37:23 <topol> tongli check with fungi?
14:37:35 <tongli> ok.
14:37:57 <markvoelker> There are instructions there fore pretty much everything I believe.
14:38:05 <gema> http://docs.openstack.org/infra/manual/creators.html
14:38:12 <gema> so we need to  call it as our git repo
14:38:16 <gema> that's the recommendation
14:38:25 <gema> https://launchpad.net/projects/+new
14:38:32 <gema> ^ this is where you create it
14:38:39 <topol> gema, markvoelker thanks
14:38:51 <luzC_> +1
14:38:54 * markvoelker has to run over to his kids' school so will be dropping off
14:38:57 <tongli> ok, I will try that after this meeting.
14:39:07 <topol> #action tongli to create lauchpad for our repo
14:39:10 <gema> np
14:39:17 <gema> then you can either add people to the project
14:39:20 <gema> or you can have a team
14:39:21 <tongli> @markvoelker, see you after new year.
14:39:22 <topol> markvoelker I think we are pretty much done
14:39:24 <gema> and make that team the maintainer of the project
14:39:26 <gema> :D
14:39:38 <gema> and the team can have all of us
14:39:42 <topol> #topic Contribute to the lesson's learned document.
14:39:43 <gema> with some admins
14:39:49 <topol> please contribute to this :-)
14:40:06 <gema> can you share the link again?
14:40:10 <topol> have a great hliday break markvoelker
14:40:13 <tongli> @topol, review and add stuff to the doc.
14:40:22 <topol> holiday
14:40:30 <tongli> holidays!!!
14:40:30 <gema> found it :D
14:40:41 <gema> #link https://review.openstack.org/#/c/409847/
14:40:48 <topol> #action all review and add stuff to the lessons learned doc
14:41:22 <topol> #action topol create a short blog article to update everyone on the status of the interopchallenge
14:41:38 <tongli> @topol, good action.
14:41:54 <gema> tongli: just because it is not for you? :D
14:42:09 <tongli> @gema, do not say that loud.
14:42:11 <topol> gema exactly!!!
14:42:15 <gema> haha
14:42:17 <topol> see I tookone
14:42:36 <topol> #topic open discussion
14:43:24 <topol> we are on holiday break. Next meeting is not until January 4th!!!
14:43:32 <tongli> no meetings in next two weeks but please working/thinking about the new two workloads.
14:43:39 <gema> have a good one, everyone! Merry Christmas :D
14:43:59 <gema> tongli: workloads and turkey, got it ;)
14:44:07 <topol> gema ++++
14:44:24 <tongli> @gema, haha. awesome. that is the plan.
14:44:49 <topol> I wish everyone a wonderful holiday break and thanks to everyone for what they have contributed to the interop challenge.  This has been a great community effort!!!
14:45:03 <skazi> +1
14:45:07 <luzC_> happy holydays
14:45:08 <gema> thank you for your patience, topol and tongli
14:45:16 <topol> And we will have a great 2017
14:45:19 <luzC_> gema +1
14:45:22 <gema> luzC_: feliz Navidad!
14:45:35 <luzC_> :D igualmente
14:45:51 <topol> Okay Im gonna give folks 5 mintues back!
14:45:57 <topol> #endmeeting