14:00:10 <shamail> #startmeeting interop_challenge
14:00:13 <openstack> Meeting started Wed Aug  3 14:00:10 2016 UTC and is due to finish in 60 minutes.  The chair is shamail. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:17 <openstack> The meeting name has been set to 'interop_challenge'
14:00:23 <shamail> #link https://etherpad.openstack.org/p/interop-challenge-meeting-2016-08-03
14:00:24 <catherineD> o/
14:00:28 <shamail> #chair topol
14:00:29 <brunssen> o/
14:00:34 <openstack> Current chairs: shamail topol
14:00:38 <rohit404> o/
14:00:40 <gema> o/
14:00:42 <rockyg> o/
14:00:44 <eglute> eglute o/
14:00:58 <MarkBaker> o/
14:01:05 <topol> o/
14:01:14 <hj-hpe> o/
14:01:23 <topol> So we have the conf call open to see if folks need help getting on the irc channel
14:01:50 <topol> we have an agenda at https://etherpad.openstack.org/p/interop-challenge-meeting-2016-08-03
14:02:11 <leong> o/
14:02:12 <hj-hpe> Greetings, my name is Hank Janssen and I work for Hewlett Packard Enterprises. I have been asked to join/lurk.  I am on IRC (as you can see) do I need the cons call as well?
14:02:46 <topol> meeting will be on IRC. conf call just to help new folks onto irc
14:03:03 <hj-hpe> Than I am in business. Thank you
14:03:54 <esker> interop discussion here or on openstack-meeting / openstack-meeting-alt ?
14:04:33 <shamail> Hi esker, it is here.
14:04:38 <hogepodge> O/
14:04:59 <esker> shamail: thx
14:05:19 <shamail> np
14:05:49 <tongli> it worked now.
14:05:51 <tongli> had to quit limechat , then come back in.
14:05:56 <topol> lets get started
14:06:02 <eeiden> o/
14:06:09 <topol> shamail you want to do the meeting commands for us
14:06:23 <topol> first topic on the agenda
14:06:46 <shamail> topol: sure
14:06:46 <topol> #topic other tools
14:07:15 <topol> I dont think I have authority on this channel to set the topic
14:07:21 <shamail> #topic other tools
14:07:24 <shamail> You are chair
14:07:29 <shamail> it just isn’t showing it
14:07:41 <MarkBaker> use a /
14:08:52 <topol> did anyone want to propose other tools for running the workloads
14:09:06 <brunssen> o/
14:09:25 <topol> my view is if you have these tools so that everyone can try them I think thats what's necessary
14:09:27 <leong> have u run the "startmeeting" command?
14:09:49 <shamail> Can we start with a brief overview of which tools have been submitted thus far?
14:09:58 <topol> agreed
14:10:08 <shamail> hi leong: started it already as ‘interop_challenge’
14:10:20 <topol> so far all we have is an example using terraform
14:10:45 <rockyg> Do we want to include the tools that the app group is using, such as libcloud, etc?
14:10:55 <topol> MarkBaker were you the one that mentioned this topic?
14:11:00 <shamail> We have also discussed the possibility of using the Heat templates created as a part of the Reference Architecture for EWG
14:11:17 <MarkBaker> topol - I raised this agenda item. So I wanted to know if Red hat folks want to propose Ansible, or Ubuntu folks want to propose Juju, what is the process?
14:11:30 <leong> ok shamail
14:11:39 <MarkBaker> AFAIk terraform is not common to all distributions
14:11:49 <topol> MarkBaker I think the process is code talks.  submit it for all of us to try?
14:11:52 <markvoelker> My thinking is that any commonly-used tool with running code that's reasonably easy for folks to run should be fine...Heat, Terraform, Ansible, Fog all seem like reasonable candidates
14:12:03 <hogepodge> +1
14:12:09 <topol> markvoelker +1
14:12:43 <markvoelker> As topol notes, I think it's mostly a matter of "if we have a [terraform|heat|etc] workload, how do we submit it for the group to consider?"
14:13:00 <MarkBaker> markvoelker, agreed
14:13:02 <tongli> hi brad.
14:13:07 <markvoelker> E.g. are we just putting them in an etherpad somewhere?
14:13:07 <shamail> markvoelker: +1.  The requirements should be commonly-used tool, easily accessible by all, and documented instructions on how to use/deploy
14:13:36 <topol> so we have tongli to help try anything that anyone submits
14:14:01 <rockyg> Apps ecosystem have the "first app" running in shade and fog.
14:14:06 <markvoelker> topol: So if I have a workload I think we might want to use for the challenge, just email it to tongli?
14:14:07 <rockyg> I think they also have heat.
14:14:11 <tongli> https://github.com/kennjason/osops-tools-contrib
14:14:19 <tongli> are we using this repository?
14:14:39 <shamail> I thought we were going to use the OpenStack repo: https://github.com/openstack/osops-tools-contrib?
14:14:49 <leong> the EWG is working on a series of Workload Reference Architecture, with Heat as a sample code to bootstrap the "workload"
14:15:02 <markvoelker> Ok, so submit a pull request to the osops-tools-contrib repo then?
14:15:02 <topol> shamail +1
14:15:10 <topol> leong that sounds cool
14:15:24 <leong> can we collaborate together and use those workload/heat template
14:15:40 <topol> leong that sounds good to me
14:15:47 <leong> so far we have 3-tier LAMP web app, ecommerce, big-data (hadoop) and media transcoding
14:15:51 <rockyg> I think the osops-tools-contrib has a lower bar for getting through the review process.
14:15:56 <leong> the 3-tier lamp is ready for testing
14:16:03 <shamail> tongli: can you please type here so people on IRC are participating as well?
14:16:19 <shamail> We are having two conversations (one on IRC and one on phone)
14:16:41 <markvoelker> Or rather in gerrit: https://review.openstack.org/gitweb?p=openstack/osops-tools-contrib.git;a=summary
14:16:56 <topol> so action item document how folks can submit a workload
14:17:04 <markvoelker> topol: yes please. =)
14:17:15 <tongli> ok this is the url
14:17:16 <tongli> https://github.com/openstack/osops-tools-contrib
14:17:20 <wendar> The phone conversation is about who has +2 and +A on the repo.
14:17:56 <shamail> #action Document how to submit requests for new tools (markvoelker, shamail)
14:18:00 <topol> Ok action item captured.  Lets see those new workloads flow in
14:18:51 <shamail> #info Disconnecting from the phone bridge and moving to IRC only
14:19:07 <topol> shamail Yay!
14:19:22 <topol> will be irc only for all meetings after this
14:19:30 <gema> where are the objectives for this work?
14:19:34 <tongli> @topol, +1
14:19:47 <gema> feeling a bit confused and out of context
14:20:40 <topol> gema, we have a background deck we can send you. But in a nutsheel its showing all the OpenStack Clouds can run the same workloads. so its demonstrating portable workloads
14:21:13 <topol> #topic clouds readily available
14:21:16 <gema> topol: ack, a link to the deck in this meeting log would be good
14:21:20 <hj-hpe> Being the newbie here, the intent is to show workload interoperability, not cloud interoperability?
14:21:51 <MarkBaker> gema, https://drive.google.com/open?id=0B9udXv_O5_TsaktrSm5uNlAtVFZZWTZkck8xZ0ItcEprMlBj
14:21:56 <gema> MarkBaker: thanks!
14:21:59 <shamail> #link https://drive.google.com/open?id=0B9udXv_O5_TsaktrSm5uNlAtVFZZWTZkck8xZ0ItcEprMlBj
14:22:01 * markvoelker adds that to the etherpad too
14:22:03 <tongli> hmmm, I thought this is very much about interoperability.
14:22:13 <catherineD> so as of right now one workload fromalready exists in this repository (teraform/docker swarm)
14:22:13 <topol> tongli baby steps
14:22:43 <zhipeng> so the outputs would be test scripts ?
14:22:48 <shamail> #link https://github.com/openstack/osops-tools-contrib/tree/master/terraform
14:22:48 <topol> so please sets get those other workloads added and available for all to test
14:22:53 <zhipeng> or only showing test results would be fine ?
14:23:08 <catherineD> To me this project is about cloud interop at the workload level ...
14:23:18 <topol> catherineD agreed
14:23:23 <brunssen> @catherineD +1
14:23:37 <topol> okay if we go on to second topic?
14:23:38 <dwalleck> hj-hpe: My understanding is that this is interop at a user level (workload) vs API level
14:23:59 <markvoelker> topol: ++, next topic
14:24:07 <catherineD> cloud interop would include API, Image,workload ... levels  ..but this project's focus is for workload interop
14:24:11 <topol> we were asked if folks had public facing clouds that folks could use to test on
14:24:39 <topol> in our last meeting the assumption was everyone tested on their clouds whether they had an on-prem or public
14:24:51 <hj-hpe> That helps Dwalleck, thank you!
14:24:56 <tongli> can someone explain workload level a bit, please?
14:24:57 <shamail> catherineD: +1, this efforts focuses on workload mobility/portability using tools that leverage OpenStack-Powered clouds (e.g. passed DefCore)
14:24:58 <rockyg> Isn't it workload portability rather than workload interop?
14:25:10 <markvoelker> topol: Yeah, I was planning on running the tests myself on our internal lab gear
14:25:20 <zhipeng> tongli ++
14:25:23 <shamail> topol: +1
14:25:28 <MarkBaker> rockyg, +1
14:25:34 <topol> rockyg +1
14:25:48 <shamail> We should still set #topic even if its not working :)
14:26:05 <topol> #topic public cloud avail
14:26:06 <brunssen> rockyg +1
14:26:27 <tongli> @catherineD, can you tell a bit more about workload level, I do not really get what that means.
14:26:36 <rockyg> Ok.  So, to zhipeng's question.  Once we have the worloads/apps, do we also come up with some scenario tests to demonstrate they work?
14:26:46 <topol> So I dont believe we have public clouds for folks to use and everyone should test on their own infrastructures unless someone volunteeers that they have this availabke
14:27:08 <rockyg> can we ask OSIC for some resources?
14:27:30 <leong> you can put in the request to OSIC
14:27:37 <leong> but access to OSIC requires VPN
14:27:48 <topol> leong, very cool. thats good to know
14:27:59 <leong> https://osic.org/clusters
14:28:05 <markvoelker> rockyg: do we actually need them?  I was sort of under the impression that participants would run the tests on their own and report back...
14:28:15 <topol> shamail can you record that on the etherpad
14:28:24 <leong> #link OSIC Request Form https://osic.org/clusters
14:28:32 <topol> markvoelker your assumption is correct.
14:28:33 <shamail> Sure
14:28:45 <jkomg> The objective is to run this on multiple clouds, showing interop
14:28:48 <rockyg> I think we need a "neutral body" for the basic check
14:28:51 <topol> Its not required but the canonical folks asked if the option was available
14:28:59 <leong> +1 markvoelker
14:29:22 <catherineD> markvoelker: for testing .. as  understand from the last meeting , hogepodge: suggested that every clouds participated in this project should first run a complete RefStack API tests then run the tests in the interop workload (the only one exists today is teraform/docker swarm ..)
14:29:28 <jkomg> I'm willing to allow users to hit one of my test clusters if they want to run it as a "neutral body"
14:29:44 <dwalleck> (works on OSIC) So would the task be for testing the scripts used to create the workloads? Or to test portability/iterop with one of the OSIC clusters?
14:29:54 <topol> So for Barcelona and being able to show demos of the workloads running on the different clouds was what we were shooting for
14:30:25 <topol> so new topic
14:30:29 <shamail> dwalleck: I would think it would be the former (testing scripts) since the goal would be to eventually run the scripts on your own clouds/deployments
14:30:51 <markvoelker> topol: +1, I think showing the same workload running on multiple clouds is where the value is here
14:30:54 <topol> we okay to move on to which openstack versions people are using?
14:31:05 <topol> markvoelker exactly
14:31:16 <shamail> markvoelker: +1
14:31:26 <tongli> should we collect the run results.
14:31:44 <tongli> that will be kind nice if we collect these over time.
14:31:45 <topol> tongli if the worklods have those, sure
14:32:02 <topol> new topic
14:32:03 <leong> we need a place for people to download the workload scripts, and share/report back the results in a centralised place
14:32:31 * markvoelker glances at the clock
14:32:37 <tongli> Not this ? https://github.com/openstack/osops-tools-contrib
14:32:54 <topol> leong, any suggestions on what that should be? could we use the same repository?
14:32:59 <markvoelker> I agree we need some way to collect results, so how about if I volunteer to work with tongli/topol offline to come up with a plan and we'll present it next meeting?
14:33:03 <shamail> leong: the plan is to submit all scripts to https://github.com/openstack/osops-tools-contrib (we should submit the EWG RA templates here too)
14:33:08 <topol> #topic OpenStack Version
14:33:13 <leong> then what bout the results?
14:33:16 <tongli> markcoelker ++
14:33:20 <jkomg> can we just open issues against that repo for results?
14:33:26 <shamail> markvoelker: +1
14:33:42 <shamail> #action Determine where to share results (markvoelker, topol, tongli)
14:33:54 <topol> So far I have seen folks saying they are using the Mitaka version of OpenStack. Anyone planning to use a different version?
14:34:06 <leong> and maybe want to define a "result template" so that people know what to fill in
14:34:08 <tongli> Mitaka, please
14:34:15 <markvoelker> topol: I think we'll probably do Mitaka and Kilo
14:34:18 <shamail> leong: +1
14:34:56 <markvoelker> But here again, I think there's actually value in showing the same workload running on multiple versions
14:34:58 <shamail> Does it make sense to standardize on a base submission (e.g. Mitaka) and then let everyone submit other results too?
14:35:08 <shamail> Or is the goal for everyone to run against all of the agreed upon versions?
14:35:13 <tongli> ok with mitaka (optional kilo)
14:35:18 <rohit404> topol: atleast be Liberty
14:35:19 <topol> K, so action item. folks should record which version they plan to use.
14:35:27 <markvoelker> shamail: I'd argue there's more value in showing a workload running on multiple clouds, multiple versions
14:35:32 <leong> the "result repo" can include multiple "folder" with different version?
14:35:53 <leong> that's probably part of the "result template"
14:35:56 <topol> markvoelker +1
14:35:59 <shamail> markvoelker: +1, the only concern is the amount of time before the summit but this would be a more robust outcome (multiple clouds, multiple versions)
14:36:05 <tongli> seems we are asking for a new project.
14:36:28 <topol> so lets see what everyone can get running.  Ideally try and do Mitaka?
14:36:36 <tongli> multiple clouds, multiple versions can all be added over the time.
14:36:43 <tongli> starts with Mitaka.
14:36:46 <markvoelker> shamail: I think it probably works in our favor to use the products people have on the market right now (and probably also have in their labs)
14:36:51 <shamail> #action Please add which OpenStack versions you plan to run interop challenge tests against (everyone)
14:37:10 <shamail> missed “in the etherpad” in the action :)
14:37:11 <topol> K, lets see what folks decide to use
14:37:12 <zhipeng> should we only test against openstack powered platforms ?
14:37:14 <rockyg> I think for each workload, we need to create/provide a demo script.  Every cloud runs through the demo and *those* results are what we use to show interop
14:37:14 <dwalleck> fyi, the OSIC cluster is running Liberty at the moment
14:37:31 <topol> dwalleck. good to know
14:37:42 <shamail> zhipeng: +1 imo
14:37:47 <topol> My thought is we are flexible on this so its easier for folks to be successful
14:37:54 <markvoelker> topol: ++
14:38:08 <leong> +1 topol
14:38:10 <tongli> @topol, + +
14:38:11 <catherineD> markvoelker: +1 with the short time that we have  ... the workloads should what exists today ... and submit to the interop repository
14:38:18 <tongli> get started and then expand.
14:38:22 <Kenji_> topol: +1
14:38:31 <topol> yep. ok topic change
14:38:32 <tongli> can we talk about tools for this?
14:38:35 <rarcea> topol: +1
14:38:55 <shamail> topol: -1 just to go rogue
14:39:04 <shamail> jk :)
14:39:16 <topol> #topic openstack SV presentation, listing of partiicpants
14:39:40 <shamail> topol: Is there a version of this presentation that will be shared with those attending the meeting for feedback?
14:39:47 <topol> any concern  from anyone if I have a chart in my deck that lists all the folks participating in the interop challenge?
14:39:59 <rockyg> shamail, +1, oh and -2 just for the heck of it.
14:40:03 * markvoelker puts corporate hat on
14:40:08 <jkomg> there's an openstack sv presentation on this?
14:40:15 <markvoelker> topol: No concerns from me.  VMware would be happy to be included.
14:40:39 <MarkBaker> topol, fine by me
14:40:39 <topol> jkomg.  no. I have a presnetation and was just going to include about 3 charts on this
14:40:56 * shamail just saw markvoelker put away the hat again
14:41:00 <jkomg> kk
14:41:14 <topol> the charts I will use will be a subset of the deck we sent all of you for the kickoff meeting
14:41:21 <topol> so no new material
14:41:33 <topol> I just did not want to surprise anyone
14:42:13 <topol> only action item is to update the existing chart with the new participants
14:42:24 <topol> unless someone had an objection
14:42:53 <topol> okay. topic change
14:43:02 <rockyg> ++  But you might want to keep that slide open until right before the summit
14:43:40 <catherineD> topol: do we have a deadline for folk to submit workload for this project?
14:43:48 <topol> rockyg, will do.  especially with how slow my co-presenters are at getting their charts done..
14:43:57 * topol topol throws some shade
14:44:01 <topol> #topic workload testing.
14:44:37 <topol> Has anyone tried the docker swarm workload.  we have tongli to help folks if running into issues.
14:44:56 <markvoelker> topol: I haven't yet...been traveling the past couple of weeks. =)
14:45:08 <markvoelker> Will hopefully get to it next week
14:45:17 <topol> catehrD, ideally lets get workloads available for everyone to try by August 8
14:45:23 <shamail> (15 minutes left)
14:45:47 <shamail> #action Submit new workload scripts by August 8th (process TBD)… (everyone)
14:45:52 <topol> no hard deadline but everyone needs time to try and get things working
14:46:21 <topol> tongli is our roving assistance/coach/mentor
14:46:24 <rockyg> We should probably get the app ecosystem to toss in First App, also.
14:46:31 <tongli> so we are going to use terraform, is that all agreed?
14:46:34 <catherineD> Hard deadline is for submitting the worload ...
14:46:36 <topol> reach out if you are getting stuck (thanks tongli)
14:46:55 <topol> tongli if other folks have other tools that are commonly used we are okay with thise
14:46:58 <topol> those
14:47:08 <shamail> rockyg: Marcela (mbonnell) from App Eco will be contacting topol
14:47:10 <tongli> @topol, ok.
14:47:15 <topol> let's see what comes in
14:47:21 <leong> we have "heat" template ready but not terraform
14:47:30 <rockyg> Tongli, it will need to auto install with the app....
14:47:39 <topol> leong heat should be fine
14:47:46 <shamail> leong: I think we would want to submit heat templates from EWG not terraform scripts
14:48:04 <topol> at this point the requirements is can everyone run it
14:48:10 <shamail> This will allow our tool-base to expand to include Heat
14:48:11 <topol> any concerns with heat?
14:48:13 <catherineD> leong: +1 ...please submit the code ...
14:48:18 <tongli> @rockyg, terraform can install stuff onto the VM just gets created.
14:48:23 <topol> yes, code talks
14:48:28 <shamail> EWG = enterprise WG (for reference)
14:48:37 <rockyg> shamail, tongli I think the apps other than docker swarm that is already terraform would use what they already have.
14:48:48 <shamail> rockyg: +1
14:48:51 <topol> rockyg +1
14:48:56 <topol> use what you have
14:49:09 <topol> lets see if we run into issues
14:49:40 <rockyg> ++
14:49:43 <topol> so rockyg it sounds like you have an enterprise app and tongli wont have to build one?
14:49:56 <leong> also fyi apps.openstack.org also has a list of templates (heat, murano) that we can try/test, if we want to
14:49:57 <topol> rockyg what was your app again?
14:50:06 <shamail> leong: great idea
14:50:07 <rohit404> tongli: is this the workload that's all good to be tested ? https://github.com/openstack/osops-tools-contrib/tree/master/terraform/dockerswarm-coreos
14:50:11 <shamail> topol: 10 minutes left
14:50:18 <topol> shamail, thanks
14:50:28 <tongli> @rohit404, yes
14:50:39 <rockyg> I'm just thinking the EWG ref arch. stuff and the app ecosystem stuff.
14:50:43 <topol> so actions item for us to try the EWG app as our nterprise app
14:51:07 <tongli> @shamail, link to the code?
14:51:20 <topol> on the etherpad it looks like AT&T is trying to get us all an NFV app
14:51:32 <topol> so apps are looking like they are rolling in
14:51:52 <topol> I think I covered all the agenda items. did I miss any?
14:52:06 <topol> Otherwise the floor is open for any questions
14:52:23 <shamail> #topic Open
14:52:49 <shamail> Who plans to submit new workload scripts (just curious)?
14:52:56 <leong> from EWG, i will get our team to submit the 3-tier LAMP Heat template to the osops-tools-contrib repo
14:53:12 <topol> leong AWESOME!!!
14:53:19 <shamail> MarkBaker: will you be submitting a request for another tool?
14:53:24 <shamail> additional*
14:54:14 <topol> one question I have is during next weeks meeting is OpenStack SV Summit. I will not be able to attend due to that. should we cancel or  should someone lead in my absence?
14:54:26 <MarkBaker> shamail, yes I will - just need to complete testing on other OpenStacks
14:54:32 <shamail> awesome
14:54:41 <markvoelker> shamail: I'll see if I can round some up.  We've got some internally that was use for testing, just need to find out if they're ok to publicize.
14:54:46 <MarkBaker> shamail, hence my quesiton about testing resources
14:54:47 <topol> MarkBaker, excellent
14:55:00 <shamail> Awesome!  Thanks leong, MarkBaker, markvoelker
14:55:46 <topol> 5 minutes left.  any other questions or concerns?
14:56:09 <topol> and does someone want to lead the meeting next week or just cancel ?
14:56:48 <shamail> I can do it topol
14:56:51 <rockyg> If we have the deadline for apps on 8/8, we should have a meeting
14:57:04 <luzC> shamail +1
14:57:09 <topol> shamail THANKS
14:57:19 <topol> rockyg +1
14:57:56 <topol> ok.  we made great progress in this meeting. Im glad we identified more workloads. anything else before I end the meeting?
14:58:34 <topol> everyone know how to reach tongli if they run into issues?
14:58:49 <topol> tongli post your email
14:59:07 <topol> THANKS everyone for participating today!!!
14:59:10 <tongli> ahhhhhhh, ok. litong01@us.ibm.com
14:59:29 <hj-hpe> thanks all, till next time
14:59:32 <topol> and we have jkomg too
14:59:35 <tongli> thanks.
14:59:40 <topol> if you have questions
14:59:48 <topol> Thanks
14:59:58 <catherineD> so I put the current test candidates in the etherpad line 14 - 16 ... new candidates should be add there and code should  be submitted to the repository
15:00:09 <topol> #endmetting
15:00:16 <topol> #endmeeting