19:01:02 <clarkb> #startmeeting infra
19:01:03 <openstack> Meeting started Tue Mar 19 19:01:02 2019 UTC and is due to finish in 60 minutes.  The chair is clarkb. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:06 <openstack> The meeting name has been set to 'infra'
19:01:11 <clarkb> #link http://lists.openstack.org/pipermail/openstack-infra/2019-March/006296.html
19:01:21 <clarkb> #topic Announcements
19:01:33 <dmsimard> \o
19:01:38 <clarkb> I'll be AFK next week from the 25-28th
19:01:55 <ianw> o/
19:02:07 <clarkb> Also doesn't look like anyone wanted to run against me for PTL so I get to do that again
19:02:27 <corvus> clarkb: congratulations!
19:02:29 <clarkb> If you want to volunteer to chair the meeting next week let me know as I won't be able to do it
19:02:54 <clarkb> #topic Actions from last meeting
19:03:07 <clarkb> #link http://eavesdrop.openstack.org/meetings/infra/2019/infra.2019-03-12-19.01.txt minutes from last meeting
19:03:15 <clarkb> ianw: I htink you rotated those backups?
19:03:20 <clarkb> anything interesting to say about that?
19:03:31 <ianw> yes, please review
19:03:34 <ianw> #link https://review.openstack.org/644457
19:04:11 <ianw> that's all :)
19:04:16 <clarkb> the other item was project renames
19:04:25 * jroll lurks
19:04:51 <clarkb> do we want to talk about that now or during the opendev topic?
19:05:22 * dtroyer sneaks in
19:05:37 <diablo_rojo_phon> Dedicated PTL https://usercontent.irccloud-cdn.com/file/87xmHZDF/IMG_20190319_120415.jpg
19:05:47 <clarkb> we can pick it up during the opendev topic
19:05:58 <clarkb> #topic Specs Approval
19:06:06 <clarkb> There are no specs to review
19:06:18 <clarkb> #topic Priority Efforts
19:06:40 <clarkb> We've updated more servers to puppet 4 in the last week. So far the only real gotcha has been that the pip provider doesn't like the warnings that pip prints on stderr
19:07:00 <clarkb> so if pip is emitting warnings we have to fix those (last time was via upgrade of cyptography and pyopenssl
19:07:17 <clarkb> corvus: anything new on the image building front? I guess that its actually in production now?
19:07:21 <clarkb> with documentation and everything?
19:08:06 <corvus> yep, nothing substantial new there; just cleaning up a few bugs
19:09:07 <clarkb> great.
19:09:12 <clarkb> #topic Opendev
19:09:34 <clarkb> I managed to fixup the bug tracker situation in gitea
19:09:40 <clarkb> that should be all done now
19:10:10 <corvus> yay!  thanks!
19:10:32 <clarkb> Want to talk about project renames now?
19:10:42 <fungi> i've had the initial redirects change up for review for a while, looking for feedback
19:10:44 <fungi> #link https://review.openstack.org/642173 Set up legacy git redirect sites
19:10:47 <jroll> everybody wants to, judging by the ML
19:12:26 <corvus> #link mailing list thread about openstack namespaces: http://lists.openstack.org/pipermail/openstack-discuss/2019-March/003943.html
19:12:30 <corvus> jroll: that thread?
19:12:40 <jroll> sorry, yes, that one
19:13:17 <jroll> it seems we have some traction, assuming it's died down I'll do a governance change to get the general ack
19:13:20 <clarkb> ya so far I have only heard positive things
19:13:41 <jroll> when are we looking to try and get renames done?
19:13:44 <fungi> i haven't really seen any overt objections on that thread, agreed. mostly just questions
19:14:07 <clarkb> jroll: April 19 is the day we pencilled in last week
19:14:14 <fungi> same time as the switch in domain names, ideally
19:14:16 <clarkb> and we havne't run into any major issues since so that seems to still be on track
19:14:24 <jroll> cool, that seems doable
19:14:45 <corvus> jroll: what's your tl;dr read on that thread?
19:14:54 <jroll> (assuming nobody comes and splatters random colors on the shed)
19:15:07 <corvus> was it leaning toward one of your 3 options?
19:15:24 <fungi> i think it was some of option 3 and some of ttx's option 4
19:15:25 <jroll> corvus: I have to re-read to get a count, sounds like either (2) or ttx's option is the winner
19:15:27 * jroll finds that link
19:15:39 <jroll> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-March/003971.html
19:15:58 <corvus> got it, thanks!
19:16:11 <corvus> i'll be sure to read the whole thread after the meeting; i somehow missed that. sorry.
19:16:34 <jroll> now that I think about it, both of those have some nebulous naming activities to do, but I think we can meet april 17
19:16:37 <jroll> no worries :)
19:16:44 * jroll s/17/19/
19:16:45 <fungi> there's still some question as to whether team-oriented namespaces make more sense, and also what to do about projects with no representation on the openstack map diagram thingie
19:17:26 <corvus> cool, those both sound great, and i agree, that sounds plausible
19:17:48 <clarkb> dtroyer: things look good your side?
19:18:19 <dtroyer> clarkb: really quiet so far, at this point it looks like we'll just be moving to a starlingx namespace and retiring 3 or so repos
19:18:37 <fungi> and dropping the stx-prefixes, or have you decided?
19:18:50 <dtroyer> yes, dropping stx- too
19:19:46 <clarkb> I expect zuul will be ready
19:20:05 <clarkb> ready to talk about the git:// to https:// transition again?
19:20:08 <corvus> ++
19:20:14 <clarkb> I wanted to make sure that we don't get stuck in limbo on that topic
19:20:34 <corvus> yeah, i think ianw wanted a decision on that at this meeting, and i agree we should do that :)
19:20:49 <ianw> i did post about it as mentioned in the last meeting, but didn't generate as much discussion
19:20:52 <ianw> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-March/003825.html
19:21:10 <clarkb> ah it went to that list not the infra list which is probably why i missed it (I'm not great at keeping up there)
19:21:58 <ianw> sorry i figured everyone would want to have an opinion since it might touch their repos, but it was maybe a little obscure
19:22:16 <fungi> yeah, and it has a bit of a devstack-focus anyway
19:22:22 <clarkb> fwiw your proposal seems reasonable to me
19:22:24 <corvus> i think i'm with ianw and on board option 1
19:22:45 <fungi> same, option 1 for me
19:23:34 <clarkb> in that case it sounds like we can go ahead with 1) as proposed
19:23:57 <corvus> when should we actually upload the changes?  do we want to try to do that at the start of a weekend or something?
19:24:04 <ianw> given that it looks like from the prior discussion we might be doing some fairly complex namespace swizzles, i think that avoids us having to synchronize
19:24:12 <fungi> projects are sure to be putting through a ton of other changes after the transition to update domain names and project names and namespaces and stuff in their readmes and contributor docs anyway
19:24:15 <clarkb> corvus: maybe ianw can do it during his monday morning which is sunday for most of us
19:25:27 <ianw> sure, i can make it drizzle in over 24 hours
19:25:51 <corvus> ianw: i think if you do it then, you can do it all at once
19:26:09 <corvus> zuul is pretty idle over the "weekend"
19:26:53 <corvus> and hopefully that will reduce the window for copycat patches
19:26:58 <clarkb> sounds like a plan
19:27:12 <corvus> (i still can't believe that's a thing we have to consider)
19:27:34 <ianw> ok, i will set it all up in a screen on bridge.o.o and we can check it over
19:27:35 <corvus> (i mean, i believe it, i'm just... you know, wow.)
19:28:02 <clarkb> anything else opendev related?
19:28:58 <clarkb> sounds like now. Onward!
19:29:05 <corvus> oh
19:29:05 <clarkb> #topic Storyboard
19:29:11 <clarkb> should I undo?
19:29:19 <corvus> yeah, sorry one more quick thing
19:29:20 <ianw> oh, yeah, one more thing
19:29:23 <clarkb> #undo
19:29:25 <openstack> Removing item from minutes: #topic Storyboard
19:29:34 <corvus> should i send out an email announcing the date now?
19:29:59 <clarkb> corvus: ++ I don't think we have anything coming up that will prevent it at this point
19:30:09 <ianw> (for me) we agree to force merge outstanding git://->https:// changes too?  what date should we do that?
19:30:19 <fungi> yes, should reduce some further confusion over the anticipated timeframe for things
19:30:29 <fungi> the announcement i mean
19:31:00 <corvus> ianw: i'm ambivalent about that -- since i don't expect *functional* breakage, i'm less inclined to force-merge, but i don't object if folks think it's worthwhile.
19:31:21 <corvus> so, consider me a weak -1 on force-merge but happy to support it if there are other +1s
19:31:25 <clarkb> I think a deadline helps get eyeballs on it
19:32:17 <clarkb> the 12th gives people a couple weeks if we want it done ahead of time
19:32:44 <fungi> yeah, i'm honestly more concerned about the .gitreview and {.,}zuul{.d/*,}.yaml edits not lingering
19:35:09 <ianw> ok, ummm i like the idea of a deadline being a call to action -- i'll draft something in the review commit log as part of the change; i'll request comments on in a gerrit review of the scripts
19:35:17 <clarkb> ianw: sounds good
19:35:22 <clarkb> #topic Storyboard
19:35:28 <clarkb> ok anything storyboard to talk about?
19:35:34 <clarkb> diablo_rojo_phon says no
19:35:39 <clarkb> there are changes to review
19:35:52 <clarkb> mordred isn't around today but any idea how his patches for swift things are going?
19:36:56 <fungi> yeah, lots and lots of sb changes to review
19:37:03 <clarkb> sounds like they are still outstanding due to changes needed in the sdk
19:38:15 <clarkb> Lets move on since diablo_rojo_phon is eating lunch
19:38:20 <fungi> SotK just pushed up a couple of testing-related improvements as well
19:38:26 <diablo_rojo_phon> Yes please lol
19:38:45 * fungi lets diablo_rojo_phon get back to her lunch. clarkb doesn't actually get to eat though
19:38:54 <clarkb> #topic General Topics
19:39:03 <clarkb> #link https://etherpad.openstack.org/p/201808-infra-server-upgrades-and-cleanup
19:39:06 <clarkb> Server upgrades continue
19:39:15 <clarkb> AFS is completely done now which is nice to get behind us
19:39:20 <clarkb> fungi: how are wiki things?
19:39:48 <fungi> #link https://review.openstack.org/643476 Switch from PHP5 to default PHP (PHP7 on Xenial)
19:40:08 <fungi> that's needed to progress further on the wiki-dev02.openstack.org deployment
19:40:34 <fungi> if any infra-puppet-core is available to review, it's a one-character removal
19:40:52 <clarkb> I can take a look today
19:41:22 <clarkb> The last item on my list is PTG planning
19:41:28 <clarkb> #link https://etherpad.openstack.org/2019-denver-ptg-infra-planning
19:41:37 <clarkb> #link https://www.openstack.org/ptg#tab_schedule Draft schedule. We have Friday and Saturday in a shared room with the QA team.
19:41:42 <dmsimard> I added an item after PTG planning, needs refresh :D
19:41:54 <clarkb> The draft schedule has us in a room friday and saturday with the qa team
19:41:56 <corvus> clarkb: is there any chance we could shift that to thurs-friday?
19:42:06 <clarkb> corvus: we can ask, I don't actually know
19:42:25 <clarkb> I think the saturday is a conflict for fungi too
19:42:36 <clarkb> I'll investigate that
19:43:09 <fungi> yeah, the tc also wants a full day on saturday
19:43:15 <corvus> in addition to that, i would be largely idle on thursday
19:43:45 <corvus> so if we can do something on thursday and possibly friday, it's a better use of time and we dodge fungi's conflict
19:43:48 <clarkb> #action clarkb ask about infra ptg days being thursday friday
19:44:19 <corvus> if it doesn't work out, maybe we can just find a nice spot on thursday and hack on server container stuff anyway?
19:44:23 <clarkb> ++
19:44:59 <clarkb> Ok next up is dmsimard's ara github replication item
19:45:08 <dmsimard> o/
19:45:12 <clarkb> I think this is serving as a template for replication to git remotes via zuul?
19:45:33 <dmsimard> indeed, I've written a role with a job to test it: https://review.openstack.org/#/q/topic:upload-git-mirror
19:46:11 <dmsimard> It should hopefully be flexible enough to push from anywhere to anywhere over SSH
19:46:11 <corvus> dmsimard: great, thanks!  are those ready for review now?
19:46:26 <dmsimard> corvus: they are
19:46:58 <corvus> i will (re-)review them asap
19:47:02 <dmsimard> So once we set that up, should we remove ara from the gerrit github replication ?
19:47:17 <corvus> right now our replication is openstack*
19:47:39 <corvus> so it might be tricky to pull one out...
19:48:02 <dmsimard> Yeah I looked at the replication config: configuration
19:48:05 <dmsimard> er
19:48:12 <dmsimard> https://opendev.org/openstack-infra/system-config/src/branch/master/modules/openstack_project/manifests/review.pp#L238
19:48:34 <corvus> dmsimard: but....
19:48:43 <corvus> dmsimard: you could *additionally* replicate to another repo pretty easily
19:49:00 <corvus> dmsimard: like, you could replicate openstack/ara to dmsimard/just-testing-git-pushes
19:49:04 <dmsimard> right
19:49:23 <corvus> i think that would be a sufficient "production test" before we tell everyone to start using that
19:49:46 <fungi> sounds great to me
19:49:47 <dmsimard> The thing is I'd like the ability to *move* that github repo and then once it's moved, keep replicating to the new repo
19:50:09 <dmsimard> The reason for the move would be to carry stuff like watchers/stars/forks/pull requests/etc around
19:50:32 <fungi> basically asking that the namespace moves in gitea also be reflected with org transfers in github?
19:51:07 <fungi> the tricky bit (perhaps less so for you though) is that last i looked you need a common admin account in both the source and target orgs to make that work
19:51:13 <dmsimard> fungi: I don't mind where ara ends up being replicated in gitea
19:51:38 <clarkb> fungi: ya we might have to bootstrap that
19:51:46 <clarkb> fungi: but once its done we should be able to remove ourselves from all the orgs
19:51:56 <dmsimard> I'm admin in the destination org, I'm not sure I have admin in the openstack org
19:52:03 <corvus> do we have an automated way to do that transfer?
19:52:19 <dmsimard> not to my knowledge, it's a manual transfer in the github ui
19:52:24 <fungi> that's the other problem... last i looked, org transfers weren't exposed in the gh api
19:52:49 <corvus> so if we did this, we may need to perform 1500+ transfers manually through the gh web ui?
19:53:24 <corvus> i don't think that's something i can commit to.
19:53:44 <clarkb> we should double check that
19:53:49 <clarkb> because ya that will be painful
19:54:03 <dmsimard> corvus: where would those 1500+ projects be moved to ?
19:54:07 <corvus> well, it would if we did it.  but i don't think we have said that we would.
19:54:20 <corvus> it hasn't been in any of the project planning so far
19:55:02 <fungi> we've made a big point of saying we'll make sure the git urls we've been hosting continue to work and get redirected to the new domain/orgs/repos but nobody's actually asked if the same will be true of repos we're replicating to github. i know a lot of people have remotes and bookmarks to github against our recommendation, and may not realize this is going to impact them as well
19:55:25 <clarkb> its definitely something we should do if feasible
19:55:27 <corvus> dmsimard: i don't know where they will be moved to; presumably wherever their owners wish?
19:55:54 <corvus> fungi: we've said that if you aren't in the openstack* namespace, automatic replication will cease.
19:56:09 <dmsimard> corvus: fair, I went with the assumption that there was not going to be many projects in a situation similar to ara
19:56:17 <fungi> corvus: right. most projects are *currently* in the openstack namespace though
19:56:28 <corvus> dmsimard: you may have missed the opendev topic earlier
19:56:33 <fungi> ~most of the plans supported so far in the openstack-discuss ml thread will involve evicting a majority of the repositories currently in that namespace
19:56:56 <fungi> including official openstack projects
19:57:02 <corvus> yeah that ^
19:57:31 <clarkb> time check we have ~3 minutes left
19:57:40 <fungi> what would be left in the openstack namespace would either be just the ~60 service repos, or possibly nothing whatsoever
19:57:41 <corvus> dmsimard: can you look into whether there's a way to automate that?
19:57:44 <dmsimard> fungi: what does eviction imply in practice ? no more replication ? deletion of the project ? moving it elsewhere ?
19:58:06 <fungi> dmsimard: that hasn't been covered yet exactly
19:58:06 <corvus> dmsimard: it means a rename in gerrit, and whatever the project wants to do on github.
19:58:10 <dmsimard> fungi: ok so github.com/openstack will remain but only with the official official things
19:58:29 <fungi> likely a very small subset of the official official things
19:58:33 <corvus> dmsimard: that hasn't been decided yet, but that's the gist of the most likely options.
19:58:34 <fungi> and perhaps not even those
19:58:34 <dmsimard> ack
19:59:19 <dmsimard> I'll explore if there is an easy way to automate the transfer
19:59:25 <corvus> dmsimard: thanks!
19:59:39 <clarkb> And we are basically at time
19:59:42 <clarkb> thank you everyone
19:59:47 <clarkb> and yes I somehow managed to eat lunch too :)
19:59:50 <fungi> thanks clarkb!
19:59:58 <fungi> now, dessert
20:00:12 <clarkb> Find us on IRC (#openstack-infra) or on the openstack-infra@lists.openstack.org mailing list if there are things to followup on
20:00:15 <clarkb> #endmeeting