19:01:50 <pabelanger> #startmeeting infra
19:01:51 <openstack> Meeting started Tue Apr 11 19:01:50 2017 UTC and is due to finish in 60 minutes.  The chair is pabelanger. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:55 <openstack> The meeting name has been set to 'infra'
19:01:59 <pabelanger> #link https://wiki.openstack.org/wiki/Meetings/InfraTeamMeeting#Agenda_for_next_meeting
19:02:01 <pabelanger> #topic Announcements
19:02:19 <pabelanger> not much to stay here, expect I'm standing in for fungi today
19:02:36 <pabelanger> #topic Actions from last meeting
19:02:41 <pabelanger> #link http://eavesdrop.openstack.org/meetings/infra/2017/infra.2017-04-04-19.03.html
19:02:47 <pabelanger> fungi put forth proposal to flatten git namespaces
19:02:58 <pabelanger> I took a look, and didn't see anything
19:03:16 <pabelanger> and since fungi isn't here today, we can likely action again for next week
19:03:22 <AJaeger> agreed
19:03:28 <pabelanger> #action fungi put forth proposal to flatten git namespaces
19:03:33 <pabelanger> pabelanger Open an Ubuntu SRU for bug 1251495
19:03:35 <openstack> bug 1251495 in mailman (Ubuntu Trusty) "Lists with topics enabled can throw unexpected keyword argument 'Delete' exception." [High,Triaged] https://launchpad.net/bugs/1251495
19:03:50 <pabelanger> I started looking into this, but have not created a bug yet. I will reaction and do so for next week
19:04:02 <pabelanger> #action pabelanger Open an Ubuntu SRU for bug 1251495
19:04:11 <pabelanger> and that was it
19:04:22 <pabelanger> #topic Specs approval
19:04:29 <pabelanger> Zuulv3 Executor Security Enhancement
19:04:31 <pabelanger> #link https://review.openstack.org/444495
19:04:40 <pabelanger> jeblair asked to put this on the meeting today. Is this something we are ready to move forward for a vote, or do we want to hold off until next week?
19:04:55 <pabelanger> SpamapS: ^
19:06:11 <clarkb> I think SpamapS is also in the afk boat in michigan
19:06:19 <pabelanger> think so too
19:06:48 <clarkb> I read through it, I think its well put together. But personally prefer the alternative listed as its somethign we currently do with success and not much pain
19:07:42 <pabelanger> Yes, I think it has some good options listed.
19:07:51 <clarkb> I'm not going to object strongly enough to move forward with it as proposed, just more comfortable when it comes to security being a little conservative and using a known good solution
19:07:56 <pabelanger> I haven't been able to get bublewrap working locally yet myself
19:08:21 <clarkb> *er not objecting strongly enough that we can't move forward
19:09:15 <pabelanger> so, if we want to open voting, I was thinking keeping it open until next tuesday. This just people that are away time to cast votes
19:09:28 <pabelanger> other wise, I'm happy to defer to next week
19:09:29 <clarkb> seems reasonable
19:09:52 <pabelanger> k, lets start voting
19:10:02 <pabelanger> #info Infra Council voting is open for the "Zuulv3 Executor Security Enhancement" spec until 19:00 UTC on Tuesday, April 18
19:10:32 <pabelanger> if nothing else, onwards to the next topic
19:10:44 <pabelanger> #topic Priority Efforts
19:10:57 <pabelanger> Seems to be the status quo for now
19:11:18 <pabelanger> clarkb: did you want to add anything for gerrit upgrades?
19:12:11 <clarkb> uh I need to work with zaro to write up a manual upgrade plan since we require an offline index that is expected to take many hours, then perform that on review-dev to make sure it works. Then we test new gerrit on review-dev and then we upgrade prod
19:12:19 <pabelanger> as for zuulv3, I believe zuulv3-dev.o.o is still offline pending a security fix
19:12:30 <clarkb> I started an etherpad, but its pretty bare bones let me find it
19:12:35 <clarkb> https://etherpad.openstack.org/p/gerrit-2.13.-upgrade-steps
19:12:53 <pabelanger> #link https://etherpad.openstack.org/p/gerrit-2.13.-upgrade-steps
19:13:07 <clarkb> I am hoping to work on that more this week and hopefully have review-dev upgraded soon
19:13:18 <pabelanger> ack
19:13:33 <mordred> ohai
19:13:33 <pabelanger> are we aiming for an upgrade for summit? or after
19:14:54 <clarkb> my guess is after. I don't expect we'll have all the testing done in the next couple weeks
19:15:09 <clarkb> just based on all the toehr things being juggled including the summit
19:15:33 <pabelanger> ya, I wasn't sure if we picked a date yet or not.
19:15:37 <pabelanger> works for me
19:16:16 <pabelanger> and we move on to the next topic
19:16:20 <pabelanger> #topic General topics
19:16:44 <pabelanger> nothing on the wiki today, if anybody has something they want to add now, we have the time to talk. Otherwise, onto open discussion
19:16:44 <clarkb> oh it might be nice to have a second infra root on that just so more than one person is familiar with the process
19:17:29 <clarkb> pabelanger: any idea if/how the caching proxies are helping things that use rdo or docker hub?
19:17:46 * mordred also curious
19:17:59 <pabelanger> clarkb: my understanding they are helping a lot. I don't think they have had a network issue since we added them
19:18:32 <pabelanger> I am not sure about docker registry, patches are still in process for that
19:18:34 <clarkb> ya the rdo issues on e-r have definitely fallen off
19:18:46 <ianw> i haven't got around to an email, but i plan to restart the dib meeting in earnest.  there was a bit of confusion as to who was running it, and we got slack, but i'll start doing it regularly after easter
19:19:09 <pabelanger> #topic Open discussion
19:19:14 <clarkb> ianw: by getting slack you mean like a rope not like the irc alternative?
19:19:28 <pabelanger> all the topics now!
19:19:37 <jlvillal> Review request: https://review.openstack.org/448786  Highlight POST_FAILURE same as FAILURE on Gerrit page
19:19:51 <cmurphy> clarkb: lol
19:19:54 <ianw> oh, yes, i mean we skipped it, not random web chat clients :)
19:20:09 <clarkb> on the citycloud front I've been told to make accounts then tell them what they are so they can comp them and edit quotas. So uh I just need to sit down and do that.
19:20:12 <pabelanger> clarkb: I did want to talk do you about moving apache cache to afs, was curious what you meant about that.  Currently osic-cloud only has 40GB root drive, our smallest
19:20:32 <clarkb> jlvillal: I'll try to review that today
19:20:38 <jlvillal> clarkb, Thanks :)
19:20:52 <clarkb> pabelanger: basically we mount a cinder volume in most places for the afs cache but the entire volume is mounted at just the afs cache location
19:21:00 <pabelanger> we also landed some of the work cmurphy has been doing to depuppet DIB images, so yay for that
19:21:15 <clarkb> pabelanger: I was thinking maybe we could either create two filesystems and mount one for apache or mount it a level above the apache and afs caches so they can share it
19:22:21 <pabelanger> clarkb: interesting. Okay, happy to talk a more about that. I suspect docker registry we may need more then 2GB of cache
19:22:40 <clarkb> ya 2GB was a conservative limit to make sure we didn't break anything
19:22:46 <clarkb> so definitely open to raising that as we go
19:22:57 <pabelanger> ++
19:23:27 <pabelanger> okay, unless anybody else wants to continue talking. I think we can wrap up early today
19:23:52 <clarkb> oh please bug me to do the citycloud thing. I keep putting it off because it requires things like web forms and credit cards
19:24:11 <pabelanger> should we action?
19:24:16 <clarkb> yes
19:24:47 <pabelanger> #action clarkb to add citycloud to nodepool
19:25:38 <pabelanger> with that, lets end our meeting for today
19:25:43 <pabelanger> thanks everybody
19:25:47 <pabelanger> #endmeeting